EAP-AKA and EAP-SIM Parameters
All requests for value assignment from the various number spaces below
require "Specification Required". Requests must be specified in sufficient
detail so that interoperability between independent implementations is
possible. Possible forms of documentation include, but are not limited to,
RFCs, the products of another standards body (e.g. 3GPP), or permanently
and readily available vendor design notes.
Subtypes
- RFC 4187: Extensible Authentication Protocol Method for 3rd Generation Authentication and Key Agreement (EAP-AKA)
Attribute Types (Non-Skippable Attributes 0-127)
- RFC 4187: Extensible Authentication Protocol Method for 3rd Generation Authentication and Key Agreement (EAP-AKA)
Attribute Types (Skippable Attributes 128-255)
- RFC 4187: Extensible Authentication Protocol Method for 3rd Generation Authentication and Key Agreement (EAP-AKA)
AT_NOTIFICATION (12) Attribute - Notification Code Values
- RFC 4187: Extensible Authentication Protocol Method for 3rd Generation Authentication and Key Agreement (EAP-AKA)
AT_VERSION_LIST (15) and AT_SELECTED_VERSION (16) Attributes - EAP method version numbers
- RFC 4187: Extensible Authentication Protocol Method for 3rd Generation Authentication and Key Agreement (EAP-AKA)
AT_CLIENT_ERROR_CODE (22) Attribute - Client Error Code Values
- RFC 4187: Extensible Authentication Protocol Method for 3rd Generation Authentication and Key Agreement (EAP-AKA)
| Value |
Description |
Reference |
| 0 |
"unable to process packet": a general error code |
RFC 4187; RFC 4186 |
| 1 |
"unsupported version": the peer does not support
any of the versions listed in AT_VERSION_LIST |
RFC 4187; RFC 4186 |
| 2 |
"insufficient number of challenges": the peer's
policy requires more triplets than the server
included in AT_RAND |
RFC 4187; RFC 4186 |
| 3 |
"RANDs are not fresh": the peer believes that the
RAND challenges included in AT_RAND were not fresh |
RFC 4187; RFC 4186 |
| 4-65535 |
Unassigned |
RFC 4187 |
EAP-AKA' AT_KDF Key Derivation Function Values
- RFC 9048: Improved Extensible Authentication Protocol Method for 3GPP Mobile Network Authentication and Key Agreement (EAP-AKA')
| Value |
Description |
Reference |
| 0 |
Reserved |
RFC 9048 |
| 1 |
EAP-AKA' with CK'/IK' |
RFC 9048 |
| 2-65535 |
Unassigned |
|
Trusted Non-3GPP Access EAP Parameters
- RFC 7458: Extensible Authentication Protocol (EAP) Attributes for Wi-Fi Integration with the Evolved Packet Core
Virt-Net-Req Type
- RFC 7458: Extensible Authentication Protocol (EAP) Attributes for Wi-Fi Integration with the Evolved Packet Core
| Value |
Description |
Reference |
| 0 |
Reserved |
RFC 7458 |
| 1 |
Single PDN connection |
RFC 7458 |
| 2 |
Multiple PDN connection. Can request Non-Seamless Wi-
Fi Offload or EPC connectivity (see the Connectivity Type
attribute below) |
RFC 7458 |
| 3-127 |
Unassigned |
|
Virt-Net-Req Sub Type
- RFC 7458: Extensible Authentication Protocol (EAP) Attributes for Wi-Fi Integration with the Evolved Packet Core
Connectivity Type
- RFC 7458: Extensible Authentication Protocol (EAP) Attributes for Wi-Fi Integration with the Evolved Packet Core
| Value |
Description |
Reference |
| 0 |
Reserved |
RFC 7458 |
| 1 |
Non-Seamless WLAN Offload (NSWO) |
RFC 7458 |
| 2 |
EPC PDN connectivity |
RFC 7458 |
| 3-127 |
Unassigned |
|
Access Technology
- RFC 7458: Extensible Authentication Protocol (EAP) Attributes for Wi-Fi Integration with the Evolved Packet Core
Serial ID Type
- RFC 7458: Extensible Authentication Protocol (EAP) Attributes for Wi-Fi Integration with the Evolved Packet Core
EAP-AKA' AT_KDF_FS Key Derivation Function Values
- RFC 9678: Forward Secrecy Extension to the Improved Extensible Authentication Protocol Method for Authentication and Key Agreement (EAP-AKA' FS)
| Value |
Description |
Reference |
| 0 |
Reserved |
RFC 9678 |
| 1 |
EAP-AKA' with ECDHE and X25519 |
RFC 9678 |
| 2 |
EAP-AKA' with ECDHE and P-256 |
RFC 9678 |
| 3-65535 |
Unassigned |
|
Contact Information
| Name |
Contact URI |
Last Updated |
| Dongwook Kim |
info&3gpp.org |
2026-10-20 |