Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About EAP-AKA and EAP-SIM Parameters Created 2005-05-02 Last Updated 2026-10-20 Note All requests for value assignment from the various number spaces below require "Specification Required". Requests must be specified in sufficient detail so that interoperability between independent implementations is possible. Possible forms of documentation include, but are not limited to, RFCs, the products of another standards body (e.g. 3GPP), or permanently and readily available vendor design notes. Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • Subtypes • Attribute Types (Non-Skippable Attributes 0-127) • Attribute Types (Skippable Attributes 128-255) • AT_NOTIFICATION (12) Attribute - Notification Code Values • AT_VERSION_LIST (15) and AT_SELECTED_VERSION (16) Attributes - EAP method version numbers • AT_CLIENT_ERROR_CODE (22) Attribute - Client Error Code Values • EAP-AKA' AT_KDF Key Derivation Function Values • Trusted Non-3GPP Access EAP Parameters • Virt-Net-Req Type • Virt-Net-Req Sub Type • Connectivity Type • Access Technology • Serial ID Type • EAP-AKA' AT_KDF_FS Key Derivation Function Values Subtypes Registration Procedure(s) Specification Required Expert(s) Vesa Lehtovirta Reference [RFC 4187] Available Formats [IMG] CSV Value Description Reference 0 Reserved 1 AKA-Challenge [RFC 4187]; [RFC 4186] 2 AKA-Authentication-Reject [RFC 4187]; [RFC 4186] 3 Unassigned 4 AKA-Synchronization-Failure [RFC 4187]; [RFC 4186] 5 AKA-Identity [RFC 4187]; [RFC 4186] 6-9 Unassigned 10 SIM-Start [RFC 4187]; [RFC 4186] 11 SIM-Challenge [RFC 4187]; [RFC 4186] 12 AKA-Notification and SIM-Notification [RFC 4187]; [RFC 4186] 13 AKA-Reauthentication and SIM-Reauthentication [RFC 4187]; [RFC 4186] 14 AKA-Client-Error and SIM-Client-Error [RFC 4187]; [RFC 4186] 15-255 Unassigned [RFC 4187] Attribute Types (Non-Skippable Attributes 0-127) Registration Procedure(s) Specification Required Expert(s) Vesa Lehtovirta Reference [RFC 4187] Available Formats [IMG] CSV Value Description Reference 0 Reserved 1 AT_RAND [RFC 4187]; [RFC 4186] 2 AT_AUTN [RFC 4187]; [RFC 4186] 3 AT_RES [RFC 4187]; [RFC 4186] 4 AT_AUTS [RFC 4187]; [RFC 4186] 5 Unassigned 6 AT_PADDING [RFC 4187]; [RFC 4186] 7 AT_NONCE_MT [RFC 4187]; [RFC 4186] 8-9 Unassigned 10 AT_PERMANENT_ID_REQ [RFC 4187]; [RFC 4186] 11 AT_MAC [RFC 4187]; [RFC 4186] 12 AT_NOTIFICATION [RFC 4187]; [RFC 4186] 13 AT_ANY_ID_REQ [RFC 4187]; [RFC 4186] 14 AT_IDENTITY [RFC 4187]; [RFC 4186] 15 AT_VERSION_LIST [RFC 4187]; [RFC 4186] 16 AT_SELECTED_VERSION [RFC 4187]; [RFC 4186] 17 AT_FULLAUTH_ID_REQ [RFC 4187]; [RFC 4186] 18 Unassigned 19 AT_COUNTER [RFC 4187]; [RFC 4186] 20 AT_COUNTER_TOO_SMALL [RFC 4187]; [RFC 4186] 21 AT_NONCE_S [RFC 4187]; [RFC 4186] 22 AT_CLIENT_ERROR_CODE [RFC 4187]; [RFC 4186] 23 AT_KDF_INPUT [RFC 9048] 24 AT_KDF [RFC 9048] 25-127 Unassigned Attribute Types (Skippable Attributes 128-255) Registration Procedure(s) Specification Required Expert(s) Vesa Lehtovirta Reference [RFC 4187] Available Formats [IMG] CSV Value Description Reference 128 Unassigned 129 AT_IV [RFC 4187]; [RFC 4186] 130 AT_ENCR_DATA [RFC 4187]; [RFC 4186] 131 Unassigned 132 AT_NEXT_PSEUDONYM [RFC 4187]; [RFC 4186] 133 AT_NEXT_REAUTH_ID [RFC 4187]; [RFC 4186] 134 AT_CHECKCODE [RFC 4187]; [RFC 4186] 135 AT_RESULT_IND [RFC 4187]; [RFC 4186] 136 AT_BIDDING [RFC 9048] 137 AT_IPMS_IND [3GPP TS 24.302]; [Dongwook_Kim] 138 AT_IPMS_RES [3GPP TS 24.302]; [Dongwook_Kim] 139 AT_TRUST_IND [3GPP TS 24.302]; [Dongwook_Kim] 140 AT_SHORT_NAME_FOR_NETWORK [3GPP TS 24.302]; [Dongwook_Kim] 141 AT_FULL_NAME_FOR_NETWORK [3GPP TS 24.302]; [Dongwook_Kim] 142 AT_RQSI_IND [3GPP TS 24.139]; [Dongwook_Kim] 143 AT_ RQSI_RES [3GPP TS 24.139]; [Dongwook_Kim] 144 AT_TWAN_CONN_MODE [3GPP TS 24.302 12.6.0]; [Dongwook_Kim] 145 AT_VIRTUAL_NETWORK_ID [RFC 7458] 146 AT_VIRTUAL_NETWORK_REQ [RFC 7458] 147 AT_CONNECTIVITY_TYPE [RFC 7458] 148 AT_HANDOVER_INDICATION [RFC 7458] 149 AT_HANDOVER_SESSION_ID [RFC 7458] 150 AT_MN_SERIAL_ID [RFC 7458] 151 AT_DEVICE_IDENTITY [3GPP TS 24.302]; [Dongwook_Kim] 152 AT_PUB_ECDHE [RFC 9678] 153 AT_KDF_FS [RFC 9678] 154-255 Unassigned AT_NOTIFICATION (12) Attribute - Notification Code Values Registration Procedure(s) Specification Required Expert(s) Vesa Lehtovirta Reference [RFC 4187] Available Formats [IMG] CSV Value Description Reference 0 General failure after authentication [RFC 4187]; [RFC 4186] 1-1025 Unassigned [RFC 4187] 1026 User has been temporarily denied access [RFC 4187]; [RFC 4186] 1027-1030 Unassigned [RFC 4187] 1031 User has not subscribed to the requested service [RFC 4187]; [RFC 4186] 1032-16383 Unassigned [RFC 4187] 16384 General failure [RFC 4187]; [RFC 4186] 16385 Certificate Replacement Required [WBA IMSI Privacy Protection for Wi-Fi - Technical Specification v1.0] 16386-32767 Unassigned [RFC 4187] 32768 Success [RFC 4187]; [RFC 4186] 32769-65535 Unassigned [RFC 4187] AT_VERSION_LIST (15) and AT_SELECTED_VERSION (16) Attributes - EAP method version numbers Registration Procedure(s) Specification Required Expert(s) Vesa Lehtovirta Reference [RFC 4187] Available Formats [IMG] CSV Value Description Reference 0 Unassigned 1 EAP-SIM Version 1 [RFC 4187]; [RFC 4186] 2-65535 Unassigned [RFC 4187] AT_CLIENT_ERROR_CODE (22) Attribute - Client Error Code Values Registration Procedure(s) Specification Required Expert(s) Vesa Lehtovirta Reference [RFC 4187] Available Formats [IMG] CSV Value Description Reference 0 "unable to process packet": a general error code [RFC 4187]; [RFC 4186] 1 "unsupported version": the peer does not support any of the versions listed in AT_VERSION_LIST [RFC 4187]; [RFC 4186] 2 "insufficient number of challenges": the peer's policy requires more triplets than the server included in AT_RAND [RFC 4187]; [RFC 4186] 3 "RANDs are not fresh": the peer believes that the RAND challenges included in AT_RAND were not fresh [RFC 4187]; [RFC 4186] 4-65535 Unassigned [RFC 4187] EAP-AKA' AT_KDF Key Derivation Function Values Registration Procedure(s) Specification Required Expert(s) Vesa Lehtovirta Reference [RFC 9048] Available Formats [IMG] CSV Value Description Reference 0 Reserved [RFC 9048] 1 EAP-AKA' with CK'/IK' [RFC 9048] 2-65535 Unassigned Trusted Non-3GPP Access EAP Parameters Registration Procedure(s) Specification Required Expert(s) Jouni Korhonen Reference [RFC 7458] Available Formats [IMG] CSV Value Description Reference 0 Reserved [RFC 7458] 1 Virt-Net-Req Type [RFC 7458] 2 Virt-Net-Req Sub type [RFC 7458] 3 Connectivity Type [RFC 7458] 4 Access Technology [RFC 7458] 5 Serial ID Type [RFC 7458] 6-127 Unassigned Virt-Net-Req Type Registration Procedure(s) Specification Required Expert(s) Jouni Korhonen Reference [RFC 7458] Available Formats [IMG] CSV Value Description Reference 0 Reserved [RFC 7458] 1 Single PDN connection [RFC 7458] 2 Multiple PDN connection. Can request Non-Seamless Wi- Fi Offload or EPC connectivity (see the Connectivity Type attribute below) [RFC 7458] 3-127 Unassigned Virt-Net-Req Sub Type Registration Procedure(s) Specification Required Expert(s) Jouni Korhonen Reference [RFC 7458] Available Formats [IMG] CSV Value Description Reference 0 Reserved [RFC 7458] 1 PDN Type: IPv4 [RFC 7458] 2 PDN Type: IPv6 [RFC 7458] 3 PDN Type: IPv4v6 [RFC 7458] 4-127 Unassigned Connectivity Type Registration Procedure(s) Specification Required Expert(s) Jouni Korhonen Reference [RFC 7458] Available Formats [IMG] CSV Value Description Reference 0 Reserved [RFC 7458] 1 Non-Seamless WLAN Offload (NSWO) [RFC 7458] 2 EPC PDN connectivity [RFC 7458] 3-127 Unassigned Access Technology Registration Procedure(s) Specification Required Expert(s) Jouni Korhonen Reference [RFC 7458] Available Formats [IMG] CSV Value Description Reference 0 Reserved [RFC 7458] 1 UTRAN [RFC 7458] 2 E-UTRAN [RFC 7458] 3-127 Unassigned Serial ID Type Registration Procedure(s) Specification Required Expert(s) Jouni Korhonen Reference [RFC 7458] Available Formats [IMG] CSV Value Description Reference 0 Reserved [RFC 7458] 1 IMEI [RFC 7458] 2 IMEISV [RFC 7458] 3-127 Unassigned EAP-AKA' AT_KDF_FS Key Derivation Function Values Registration Procedure(s) Specification Required Expert(s) Jari Arkko, Peter Yee Reference [RFC 9678] Available Formats [IMG] CSV Value Description Reference 0 Reserved [RFC 9678] 1 EAP-AKA' with ECDHE and X25519 [RFC 9678] 2 EAP-AKA' with ECDHE and P-256 [RFC 9678] 3-65535 Unassigned Contact Information ID Name Contact URI Last Updated [Dongwook_Kim] Dongwook Kim mailto:info&3gpp.org 2026-10-20 Licensing Terms