Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About YANG Parameters Created 2010-06-10 Last Updated 2026-10-16 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registry Included Below • YANG Module Names YANG Module Names Registration Procedure(s) RFC Required Reference [RFC 6020][RFC 9907][RFC 9890] Note YANG modules are additionally available for bulk retrieval by Rsync (rsync.iana.org::assignments/yang-parameters/) or FTP (ftp://ftp.iana.org/assignments/yang-parameters/). Available Formats [IMG] CSV Name File Maintained Namespace (Modules Only) Prefix (Modules Module (Submodules Only) Reference Notes by IANA? Only) BFD Diagnostic Codes and BFD Authentication Types must not be added directly to the iana-bfd-types YANG iana-bfd-types iana-bfd-types@2026-07-02.yang Y urn:ietf:params:xml:ns:yang:iana-bfd-types iana-bfd-types [RFC 9127] module. They must first be added to [Bidirectional Forwarding Detection (BFD) Parameters], which it mirrors. BGP Layer 2 encapsulation types must not be directly iana-bgp-l2-encaps iana-bgp-l2-encaps@2022-09-20.yang Y urn:ietf:params:xml:ns:yang:iana-bgp-l2-encaps iana-bgp-l2-encaps [RFC 9291] added to the "iana-bgp-l2-encaps" YANG module. They must instead be added to the [BGP Layer 2 Encapsulation Types] registry. iana-crypt-hash iana-crypt-hash@2014-08-06.yang Y urn:ietf:params:xml:ns:yang:iana-crypt-hash ianach [RFC 7317] Registration procedure: Expert Review, as described in [RFC 8126]. Expert(s): Kent Watsen. Classes and types of DNS resource records must not be directly added to the "iana-dns-class-rr-type" YANG iana-dns-class-rr-type iana-dns-class-rr-type@2026-10-16.yang Y urn:ietf:params:xml:ns:yang:iana-dns-class-rr-type dnsct [RFC 9108] module. They must instead be added to the "DNS CLASSes" and "Resource Record (RR) TYPEs" [registries], respectively. Status, conflict status, conflict cause, and attack status values must not be directly added to the iana-dots-signal-channel YANG module. They must iana-dots-signal-channel iana-dots-signal-channel@2021-09-02.yang Y urn:ietf:params:xml:ns:yang:iana-dots-signal-channel iana-dots-signal [RFC 9132] instead be respectively added to the "DOTS Status Codes", "DOTS Conflict Status Codes", "DOTS Conflict Cause Codes", and "DOTS Attack Status Codes" [registries]. The "iana-hardware" YANG module is intended to reflect the [IANA-ENTITY-MIB] MIB module so that if a new iana-hardware iana-hardware@2018-03-13.yang Y urn:ietf:params:xml:ns:yang:iana-hardware ianahw [RFC 8348] enumeration is added to the "IANAPhysicalClass" textual convention, the same class is added as an identity derived from "ianahw:hardware-class". [RFC-ietf-netconf-http-client-server-31]'s module file will be posted upon the document's publication as an RFC. iana-http-versions Y urn:ietf:params:xml:ns:yang:iana-http-versions httpv [RFC-ietf-netconf-http-client-server-31] New values must not be directly added to the "iana-http-versions" YANG module. They must instead be added to the [TLS Application-Layer Protocol Negotiation (ALPN) Protocol IDs] registry. New values must not be directly added to the iana-icmpv4-types iana-icmpv4-types@2025-12-22.yang Y urn:ietf:params:xml:ns:yang:iana-icmpv4-types iana-icmpv4-types [RFC 9899] iana-icmpv4-types YANG module. They must instead be added to the [ICMP Type Numbers] registry. New values must not be directly added to the iana-icmpv6-types iana-icmpv6-types@2025-12-22.yang Y urn:ietf:params:xml:ns:yang:iana-icmpv6-types iana-icmpv6-types [RFC 9899] iana-icmpv6-types YANG module. They must instead be added to the [ICMPv6 "type" Numbers] registry. Interface types must not be directly added to the iana-if-type iana-if-type@2026-03-17.yang Y urn:ietf:params:xml:ns:yang:iana-if-type ianaift [RFC 7224] iana-if-type YANG module. They must instead be added to the [Interface Types (ifType)] registry. [RFC-ietf-lsr-ospf-flex-algo-yang-16]'s module file will be posted upon the document's publication as an RFC. iana-igp-algo-types Y urn:ietf:params:xml:ns:yang:iana-igp-algo-types iana-algo-types [RFC-ietf-lsr-ospf-flex-algo-yang-16] New values must not be directly added to the "iana-igp-algo-types" YANG module. They must instead be added to the [IGP Algorithm Types] registry. [RFC-ietf-lsr-ospf-flex-algo-yang-16]'s module file will be posted upon the document's publication as an RFC. iana-igp-link-attr-apps Y urn:ietf:params:xml:ns:yang:iana-igp-link-attr-apps iana-link-attr-apps [RFC-ietf-lsr-ospf-flex-algo-yang-16] New values must not be directly added to the "iana-igp-link-attr-apps" YANG module. They must instead be added to the [Link Attribute Application Identifiers] registry. [RFC-ietf-lsr-ospf-flex-algo-yang-16]'s module file will be posted upon the document's publication as an RFC. iana-igp-metric-types Y urn:ietf:params:xml:ns:yang:iana-igp-metric-types iana-metric-types [RFC-ietf-lsr-ospf-flex-algo-yang-16] New values must not be directly added to the "iana-igp-metric-types" YANG module. They must instead be added to the [IGP Metric-Type] registry. [RFC-ietf-ippm-ioam-integrity-yang-08]'s module file will be posted upon the document's publication as an RFC. iana-ioam-integrity-protection-methods Y urn:ietf:params:xml:ns:yang:iana-ioam-integrity-protection-methods iana-ioam-ipm [RFC-ietf-ippm-ioam-integrity-yang-08] New values must not be directly added to the "iana-ioam-integrity-protection-methods" YANG module. They must instead be added to the [IOAM Integrity Protection Methods] registry. New values must not be directly added to the iana-ipv6-ext-types iana-ipv6-ext-types@2025-12-22.yang Y urn:ietf:params:xml:ns:yang:iana-ipv6-ext-types iana-ipv6-ext-types [RFC 9899] iana-ipv6-ext-types YANG module. They must instead be added to the [IPv6 Extension Header Types] registry. New values must not be directly added to the iana-msd-types iana-msd-types@2026-09-18.yang Y urn:ietf:params:xml:ns:yang:iana-msd-types iana-msd-types [RFC 9702] "iana-msd-types" YANG module. They must instead be added to the "IGP MSD-Types" registry in the [Interior Gateway Protocol (IGP) Parameters] registry group. New values must not be directly added to the "iana-ospf-functional-cap-bits" YANG module. They must iana-ospf-functional-cap-bits iana-ospf-functional-cap-bits@2026-01-28.yang Y urn:ietf:params:xml:ns:yang:iana-ospf-functional-cap-bits iana-ospf-fc-bits [RFC 10041] instead be added to the "OSPF Router Functional Capability Bits" registry in the [Open Shortest Path First (OSPF) Parameters] registry group. MPLS pseudowire types must not be directly added to iana-pseudowire-types iana-pseudowire-types@2022-09-20.yang Y urn:ietf:params:xml:ns:yang:iana-pseudowire-types iana-pw-types [RFC 9291] the "iana-pseudowire-types" YANG module. They must instead be added to the [MPLS Pseudowire Types] registry. Address Families and Subsequent Address Families must not be directly added to the iana-routing-types YANG iana-routing-types iana-routing-types@2025-09-03.yang Y urn:ietf:params:xml:ns:yang:iana-routing-types iana-rt-types [RFC 8294] module. They must instead be respectively added to the [Address Family Numbers] and [Subsequent Address Family Identifiers (SAFI) Parameters] registries. New values must not be directly added to the iana-sip-option-tags iana-sip-option-tags@2026-08-17.yang Y urn:ietf:params:xml:ns:yang:iana-sip-option-tags sip-option-tags [RFC 10006] "iana-sip-option-tags" YANG module. They must instead be added to the [Option Tags] registry. New values must not be directly added to the "iana-ssh-encryption-algs" YANG module. They must iana-ssh-encryption-algs iana-ssh-encryption-algs@2024-10-16.yang Y urn:ietf:params:xml:ns:yang:iana-ssh-encryption-algs sshea [RFC 9644] instead be added to the "Encryption Algorithm Names" registry in the [Secure Shell (SSH) Protocol Parameters] registry group. New values must not be directly added to the "iana-ssh-key-exchange-algs" YANG module. They must iana-ssh-key-exchange-algs iana-ssh-key-exchange-algs@2024-10-16.yang Y urn:ietf:params:xml:ns:yang:iana-ssh-key-exchange-algs sshkea [RFC 9644] instead be added to the "Key Exchange Method Names" registry in the [Secure Shell (SSH) Protocol Parameters] registry group. New values must not be directly added to the "iana-ssh-mac-algs" YANG module. They must instead be iana-ssh-mac-algs iana-ssh-mac-algs@2024-10-16.yang Y urn:ietf:params:xml:ns:yang:iana-ssh-mac-algs sshma [RFC 9644] added to the "MAC Algorithm Names" registry in the [Secure Shell (SSH) Protocol Parameters] registry group. New values must not be directly added to the "iana-ssh-public-key-algs" YANG module. They must iana-ssh-public-key-algs iana-ssh-public-key-algs@2026-09-08.yang Y urn:ietf:params:xml:ns:yang:iana-ssh-public-key-algs sshpka [RFC 9644] instead be added to the "Public Key Algorithm Names" registry in the [Secure Shell (SSH) Protocol Parameters] registry group. iana-template iana-template@2023-12-08.yang N urn:ietf:params:xml:ns:yang:iana-template iana-foo [RFC 9907] New values must not be directly added to the "iana-tls-cipher-suite-algs" YANG module. They must iana-tls-cipher-suite-algs iana-tls-cipher-suite-algs@2024-10-16.yang Y urn:ietf:params:xml:ns:yang:iana-tls-cipher-suite-algs tlscsa [RFC 9645] instead be added to the "TLS Cipher Suites" registry in the [Transport Layer Security (TLS) Parameters] registry group. tls-version and dtls-version values must not be directly added to the iana-tls-profile YANG module. They must instead be respectively added to the "ACL TLS Version Codes" and "ACL DTLS Version Codes" [registries], provided the new (D)TLS version has been standardized by the IETF. It allows new (D)TLS version iana-tls-profile iana-tls-profile@2025-04-18.yang Y urn:ietf:params:xml:ns:yang:iana-tls-profile ianatp [RFC 9761] to be added to the "iana-tls-profile" YANG Module. (D)TLS parameters must not be directly added to the iana-tls-profile YANG module. They must instead be added to the [ACL (D)TLS Parameters] registry if the new (D)TLS parameters can be used by a middlebox to identify a MUD non-compliant (D)TLS behavior. It allows new (D)TLS parameters to be added to the "iana-tls-profile" YANG Module. Tunnel type values must not be directly added to the iana-tunnel-type iana-tunnel-type@2021-04-23.yang Y urn:ietf:params:xml:ns:yang:iana-tunnel-type iana-tunnel-type [RFC 8675] iana-tunnel-type YANG module. They must instead be added to the [Tunnel Types (tunnelType)] subregistry (under the "Interface Types (ifType)" registry). ietf-ac-common ietf-ac-common@2025-09-29.yang N urn:ietf:params:xml:ns:yang:ietf-ac-common ac-common [RFC 9833] ietf-ac-glue ietf-ac-glue@2025-09-29.yang N urn:ietf:params:xml:ns:yang:ietf-ac-glue ac-glue [RFC 9836] ietf-ac-ntw ietf-ac-ntw@2025-09-29.yang N urn:ietf:params:xml:ns:yang:ietf-ac-ntw ac-ntw [RFC 9835] ietf-ac-svc ietf-ac-svc@2025-09-29.yang N urn:ietf:params:xml:ns:yang:ietf-ac-svc ac-svc [RFC 9834] ietf-access-control-list ietf-access-control-list@2019-03-04.yang N urn:ietf:params:xml:ns:yang:ietf-access-control-list acl [RFC 8519] ietf-acl-enh ietf-acl-enh@2025-12-22.yang N urn:ietf:params:xml:ns:yang:ietf-acl-enh acl-enh [RFC 9899] ietf-acl-tls ietf-acl-tls@2025-04-18.yang N urn:ietf:params:xml:ns:yang:ietf-acl-tls ietf-acl-tls [RFC 9761] ietf-acldns ietf-acldns@2019-01-28.yang N urn:ietf:params:xml:ns:yang:ietf-acldns ietf-acldns [RFC 8520] [RFC-ietf-netconf-adaptive-subscription-18]'s module ietf-adaptive-subscription N urn:ietf:params:xml:ns:yang:ietf-adaptive-subscription adaps [RFC-ietf-netconf-adaptive-subscription-18] file will be posted upon the document's publication as an RFC. ietf-alarms ietf-alarms@2022-06-06.yang N urn:ietf:params:xml:ns:yang:ietf-alarms al [RFC 8632]; [RFC Errata 6866] ietf-alarms-x733 ietf-alarms-x733@2019-09-11.yang N urn:ietf:params:xml:ns:yang:ietf-alarms-x733 x733 [RFC 8632] ietf-alto N urn:ietf:params:xml:ns:yang:ietf-alto alto [RFC-ietf-alto-oam-yang-17] [RFC-ietf-alto-oam-yang-17]'s module file will be posted upon the document's publication as an RFC. ietf-alto-stats N urn:ietf:params:xml:ns:yang:ietf-alto-stats alto-stats [RFC-ietf-alto-oam-yang-17] [RFC-ietf-alto-oam-yang-17]'s module file will be posted upon the document's publication as an RFC. ietf-amt N urn:ietf:params:xml:ns:yang:ietf-amt amt [RFC-ietf-mboned-amt-yang-09] [RFC-ietf-mboned-amt-yang-09]'s module file will be posted upon the document's publication as an RFC. ietf-babel ietf-babel@2024-10-10.yang N urn:ietf:params:xml:ns:yang:ietf-babel babel [RFC 9647] ietf-bearer-svc ietf-bearer-svc@2025-09-29.yang N urn:ietf:params:xml:ns:yang:ietf-bearer-svc bearer-svc [RFC 9834] ietf-bfd ietf-bfd@2021-10-21.yang N urn:ietf:params:xml:ns:yang:ietf-bfd bfd [RFC 9127] ietf-bfd ietf-bfd@2022-09-22.yang N urn:ietf:params:xml:ns:yang:ietf-bfd bfd [RFC 9314] ietf-bfd-ip-mh ietf-bfd-ip-mh@2021-10-21.yang N urn:ietf:params:xml:ns:yang:ietf-bfd-ip-mh bfd-ip-mh [RFC 9127] ietf-bfd-ip-mh ietf-bfd-ip-mh@2022-09-22.yang N urn:ietf:params:xml:ns:yang:ietf-bfd-ip-mh bfd-ip-mh [RFC 9314] ietf-bfd-ip-sh ietf-bfd-ip-sh@2021-10-21.yang N urn:ietf:params:xml:ns:yang:ietf-bfd-ip-sh bfd-ip-sh [RFC 9127] ietf-bfd-ip-sh ietf-bfd-ip-sh@2022-09-22.yang N urn:ietf:params:xml:ns:yang:ietf-bfd-ip-sh bfd-ip-sh [RFC 9314] ietf-bfd-lag ietf-bfd-lag@2021-10-21.yang N urn:ietf:params:xml:ns:yang:ietf-bfd-lag bfd-lag [RFC 9127] ietf-bfd-lag ietf-bfd-lag@2022-09-22.yang N urn:ietf:params:xml:ns:yang:ietf-bfd-lag bfd-lag [RFC 9314] ietf-bfd-large ietf-bfd-large@2025-04-04.yang N urn:ietf:params:xml:ns:yang:ietf-bfd-large bfdl [RFC 9764] ietf-bfd-met-keyed-isaac ietf-bfd-met-keyed-isaac@2026-06-19.yang N urn:ietf:params:xml:ns:yang:ietf-bfd-met-keyed-isaac bfd-mki [RFC 9986] ietf-bfd-mpls ietf-bfd-mpls@2021-10-21.yang N urn:ietf:params:xml:ns:yang:ietf-bfd-mpls bfd-mpls [RFC 9127] ietf-bfd-mpls ietf-bfd-mpls@2022-09-22.yang N urn:ietf:params:xml:ns:yang:ietf-bfd-mpls bfd-mpls [RFC 9314] ietf-bfd-opt-auth ietf-bfd-opt-auth@2026-06-19.yang N urn:ietf:params:xml:ns:yang:ietf-bfd-opt-auth bfd-oa [RFC 9985] ietf-bfd-stability ietf-bfd-stability@2026-06-29.yang N urn:ietf:params:xml:ns:yang:ietf-bfd-stability bfd-s [RFC 9978] ietf-bfd-types ietf-bfd-types@2021-10-21.yang N urn:ietf:params:xml:ns:yang:ietf-bfd-types bfd-types [RFC 9127] ietf-bfd-types ietf-bfd-types@2022-09-22.yang N urn:ietf:params:xml:ns:yang:ietf-bfd-types bfd-types [RFC 9314] ietf-bfd-unsolicited ietf-bfd-unsolicited@2023-08-31.yang N urn:ietf:params:xml:ns:yang:ietf-bfd-unsolicited bfd-unsol [RFC 9468] ietf-complex-types ietf-complex-types@2011-03-15.yang N urn:ietf:params:xml:ns:yang:ietf-complex-types ct [RFC 6095] ietf-connection-oriented-oam ietf-connection-oriented-oam@2019-04-16.yang N urn:ietf:params:xml:ns:yang:ietf-connection-oriented-oam co-oam [RFC 8531] ietf-connectionless-oam ietf-connectionless-oam@2019-04-16.yang N urn:ietf:params:xml:ns:yang:ietf-connectionless-oam cl-oam [RFC 8532] ietf-connectionless-oam-methods ietf-connectionless-oam-methods@2019-04-16.yang N urn:ietf:params:xml:ns:yang:ietf-connectionless-oam-methods cloam-methods [RFC 8533] ietf-crypto-types ietf-crypto-types@2024-10-10.yang N urn:ietf:params:xml:ns:yang:ietf-crypto-types ct [RFC 9640] ietf-datastores ietf-datastores@2018-02-14.yang N urn:ietf:params:xml:ns:yang:ietf-datastores ds [RFC 8342] ietf-dc-fabric-topology ietf-dc-fabric-topology@2019-02-25.yang N urn:ietf:params:xml:ns:yang:ietf-dc-fabric-topology fabric [RFC 8542] ietf-dc-fabric-topology-state ietf-dc-fabric-topology-state@2019-02-25.yang N urn:ietf:params:xml:ns:yang:ietf-dc-fabric-topology-state sfabric [RFC 8542] ietf-dc-fabric-types ietf-dc-fabric-types@2019-02-25.yang N urn:ietf:params:xml:ns:yang:ietf-dc-fabric-types fabrictypes [RFC 8542] ietf-detnet ietf-detnet@2024-10-28.yang N urn:ietf:params:xml:ns:yang:ietf-detnet dnet [RFC 9633] ietf-dhcpv6-client ietf-dhcpv6-client@2022-06-20.yang N urn:ietf:params:xml:ns:yang:ietf-dhcpv6-client dhc6-clnt [RFC 9243] ietf-dhcpv6-common ietf-dhcpv6-common@2022-06-20.yang N urn:ietf:params:xml:ns:yang:ietf-dhcpv6-common dhc6 [RFC 9243] ietf-dhcpv6-relay ietf-dhcpv6-relay@2022-06-20.yang N urn:ietf:params:xml:ns:yang:ietf-dhcpv6-relay dhc6-rly [RFC 9243] ietf-dhcpv6-server ietf-dhcpv6-server@2022-06-20.yang N urn:ietf:params:xml:ns:yang:ietf-dhcpv6-server dhc6-srv [RFC 9243] ietf-dots-call-home ietf-dots-call-home@2021-12-09.yang N urn:ietf:params:xml:ns:yang:ietf-dots-call-home dots-call-home [RFC 9066] ietf-dots-data-channel ietf-dots-data-channel@2020-05-28.yang N urn:ietf:params:xml:ns:yang:ietf-dots-data-channel data-channel [RFC 8783] ietf-dots-mapping ietf-dots-mapping@2022-06-20.yang N urn:ietf:params:xml:ns:yang:ietf-dots-mapping dots-mapping [RFC 9244] ietf-dots-robust-trans ietf-dots-robust-trans@2023-02-28.yang N urn:ietf:params:xml:ns:yang:ietf-dots-robust-trans dots-robust [RFC 9362] ietf-dots-signal-channel ietf-dots-signal-channel@2020-05-28.yang N urn:ietf:params:xml:ns:yang:ietf-dots-signal-channel signal [RFC 8782] ietf-dots-signal-channel ietf-dots-signal-channel@2021-09-02.yang N urn:ietf:params:xml:ns:yang:ietf-dots-signal-channel dots-signal [RFC 9132] ietf-dots-signal-control ietf-dots-signal-control@2021-09-02.yang N urn:ietf:params:xml:ns:yang:ietf-dots-signal-control dots-control [RFC 9133] ietf-dots-telemetry ietf-dots-telemetry@2022-06-20.yang N urn:ietf:params:xml:ns:yang:ietf-dots-telemetry dots-telemetry [RFC 9244] ietf-dslite ietf-dslite@2019-01-10.yang N urn:ietf:params:xml:ns:yang:ietf-dslite dslite [RFC 8513] ietf-ethernet-segment ietf-ethernet-segment@2022-09-20.yang N urn:ietf:params:xml:ns:yang:ietf-ethernet-segment l2vpn-es [RFC 9291] ietf-ethertypes ietf-ethertypes@2019-03-04.yang N urn:ietf:params:xml:ns:yang:ietf-ethertypes ethertypes [RFC 8519] ietf-factory-default ietf-factory-default@2020-08-31.yang N urn:ietf:params:xml:ns:yang:ietf-factory-default fd [RFC 8808] ietf-geo-location ietf-geo-location@2022-02-11.yang N urn:ietf:params:xml:ns:yang:ietf-geo-location geo [RFC 9179] ietf-hardware ietf-hardware@2018-03-13.yang N urn:ietf:params:xml:ns:yang:ietf-hardware hw [RFC 8348] ietf-hardware-state ietf-hardware-state@2018-03-13.yang N urn:ietf:params:xml:ns:yang:ietf-hardware-state hw-state [RFC 8348] [RFC-ietf-netconf-http-client-server-31]'s module file ietf-http-client N urn:ietf:params:xml:ns:yang:ietf-http-client httpc [RFC-ietf-netconf-http-client-server-31] will be posted upon the document's publication as an RFC. [RFC-ietf-netconf-http-client-server-31]'s module file ietf-http-server N urn:ietf:params:xml:ns:yang:ietf-http-server https [RFC-ietf-netconf-http-client-server-31] will be posted upon the document's publication as an RFC. [RFC-ietf-i2nsf-capability-data-model-32]'s module ietf-i2nsf-capability N urn:ietf:params:xml:ns:yang:ietf-i2nsf-capability i2nsfcap [RFC-ietf-i2nsf-capability-data-model-32] file will be posted upon the document's publication as an RFC. [RFC-ietf-i2nsf-consumer-facing-interface-dm-31]'s ietf-i2nsf-cons-facing-interface N urn:ietf:params:xml:ns:yang:ietf-i2nsf-cons-facing-interface i2nsfcfi [RFC-ietf-i2nsf-consumer-facing-interface-dm-31] module file will be posted upon the document's publication as an RFC. ietf-i2nsf-ike ietf-i2nsf-ike@2021-07-14.yang N urn:ietf:params:xml:ns:yang:ietf-i2nsf-ike nsfike [RFC 9061] ietf-i2nsf-ikec ietf-i2nsf-ikec@2021-07-14.yang N urn:ietf:params:xml:ns:yang:ietf-i2nsf-ikec nsfikec [RFC 9061] ietf-i2nsf-ikeless ietf-i2nsf-ikeless@2021-07-14.yang N urn:ietf:params:xml:ns:yang:ietf-i2nsf-ikeless nsfikels [RFC 9061] [RFC-ietf-i2nsf-nsf-monitoring-data-model-19]'s module ietf-i2nsf-monitoring-interface N urn:ietf:params:xml:ns:yang:ietf-i2nsf-monitoring-interface i2nsfmi [RFC-ietf-i2nsf-nsf-monitoring-data-model-19] file will be posted upon the document's publication as an RFC. [RFC-ietf-i2nsf-nsf-facing-interface-dm-28]'s module ietf-i2nsf-nsf-facing-interface N urn:ietf:params:xml:ns:yang:ietf-i2nsf-nsf-facing-interface i2nsfnfi [RFC-ietf-i2nsf-nsf-facing-interface-dm-28] file will be posted upon the document's publication as an RFC. [RFC-ietf-i2nsf-registration-interface-dm-26]'s module ietf-i2nsf-registration-interface N urn:ietf:params:xml:ns:yang:ietf-i2nsf-registration-interface i2nsfri [RFC-ietf-i2nsf-registration-interface-dm-26] file will be posted upon the document's publication as an RFC. ietf-i2rs-rib ietf-i2rs-rib@2018-09-13.yang N urn:ietf:params:xml:ns:yang:ietf-i2rs-rib iir [RFC 8431] ietf-igmp-mld ietf-igmp-mld@2019-11-01.yang N urn:ietf:params:xml:ns:yang:ietf-igmp-mld igmp-mld [RFC 8652] ietf-igmp-mld-proxy ietf-igmp-mld-proxy@2023-05-30.yang N urn:ietf:params:xml:ns:yang:ietf-igmp-mld-proxy igmp-mld-proxy [RFC 9398] ietf-igmp-mld-snooping ietf-igmp-mld-snooping@2022-01-31.yang N urn:ietf:params:xml:ns:yang:ietf-igmp-mld-snooping ims [RFC 9166] ietf-immutable-annotation N urn:ietf:params:xml:ns:yang:ietf-immutable-annotation imma [RFC-ietf-netmod-immutable-flag-14] ietf-inet-types ietf-inet-types@2010-09-24.yang N urn:ietf:params:xml:ns:yang:ietf-inet-types inet [RFC 6021] ietf-inet-types ietf-inet-types@2013-07-15.yang N urn:ietf:params:xml:ns:yang:ietf-inet-types inet [RFC 6991] ietf-inet-types ietf-inet-types@2025-12-22.yang N urn:ietf:params:xml:ns:yang:ietf-inet-types inet [RFC 9911] ietf-interface-protection ietf-interface-protection@2019-06-19.yang N urn:ietf:params:xml:ns:yang:ietf-interface-protection ifprot [RFC 8561] ietf-interfaces ietf-interfaces@2014-05-08.yang N urn:ietf:params:xml:ns:yang:ietf-interfaces if [RFC 7223] ietf-interfaces ietf-interfaces@2018-02-20.yang N urn:ietf:params:xml:ns:yang:ietf-interfaces if [RFC 8343] ietf-ioam ietf-ioam@2024-08-27.yang N urn:ietf:params:xml:ns:yang:ietf-ioam ioam [RFC 9617] [RFC-ietf-ippm-ioam-integrity-yang-08]'s module file ietf-ioam-integrity N urn:ietf:params:xml:ns:yang:ietf-ioam-integrity ioam-int [RFC-ietf-ippm-ioam-integrity-yang-08] will be posted upon the document's publication as an RFC. ietf-ip ietf-ip@2014-06-16.yang N urn:ietf:params:xml:ns:yang:ietf-ip ip [RFC 7277] ietf-ip ietf-ip@2018-02-22.yang N urn:ietf:params:xml:ns:yang:ietf-ip ip [RFC 8344] ietf-ipfix-psamp ietf-ipfix-psamp@2012-09-05.yang N urn:ietf:params:xml:ns:yang:ietf-ipfix-psamp ipfix [RFC 6728] ietf-ipsec-iptfs ietf-ipsec-iptfs@2023-01-31.yang N urn:ietf:params:xml:ns:yang:ietf-ipsec-iptfs iptfs [RFC 9348] ietf-ipv4-unicast-routing ietf-ipv4-unicast-routing@2016-11-04.yang N urn:ietf:params:xml:ns:yang:ietf-ipv4-unicast-routing v4ur [RFC 8022] ietf-ipv4-unicast-routing ietf-ipv4-unicast-routing@2018-03-13.yang N urn:ietf:params:xml:ns:yang:ietf-ipv4-unicast-routing v4ur [RFC 8349] ietf-ipv6-router-advertisements ietf-ipv6-router-advertisements@2016-11-04.yang N ietf-ipv6-unicast-routing [RFC 8022] ietf-ipv6-router-advertisements ietf-ipv6-router-advertisements@2018-03-13.yang N ietf-ipv6-unicast-routing [RFC 8349] ietf-ipv6-unicast-routing ietf-ipv6-unicast-routing@2016-11-04.yang N urn:ietf:params:xml:ns:yang:ietf-ipv6-unicast-routing v6ur [RFC 8022] ietf-ipv6-unicast-routing ietf-ipv6-unicast-routing@2018-03-13.yang N urn:ietf:params:xml:ns:yang:ietf-ipv6-unicast-routing v6ur [RFC 8349] ietf-isis ietf-isis@2022-10-19.yang N urn:ietf:params:xml:ns:yang:ietf-isis isis [RFC 9130] [RFC-ietf-lsr-isis-flex-algo-yang-21]'s module file ietf-isis-flex-algo N urn:ietf:params:xml:ns:yang:ietf-isis-flex-algo isis-flex-algo [RFC-ietf-lsr-isis-flex-algo-yang-21] will be posted upon the document's publication as an RFC. [RFC-ietf-lsr-isis-flex-algo-yang-21]'s module file ietf-isis-link-attr N urn:ietf:params:xml:ns:yang:ietf-isis-link-attr isis-link-attr [RFC-ietf-lsr-isis-flex-algo-yang-21] will be posted upon the document's publication as an RFC. ietf-isis-reverse-metric ietf-isis-reverse-metric@2022-10-19.yang N urn:ietf:params:xml:ns:yang:ietf-isis-reverse-metric isis-rmetric [RFC 9194] ietf-isis-sr-mpls ietf-isis-sr-mpls@2025-12-09.yang N urn:ietf:params:xml:ns:yang:ietf-isis-sr-mpls isis-sr-mpls [RFC 9902] ietf-key-chain ietf-key-chain@2017-06-15.yang N urn:ietf:params:xml:ns:yang:ietf-key-chain key-chain [RFC 8177] ietf-keystore ietf-keystore@2024-10-10.yang N urn:ietf:params:xml:ns:yang:ietf-keystore ks [RFC 9642] ietf-l1csm N urn:ietf:params:xml:ns:yang:ietf-l1csm l1csm [RFC-ietf-ccamp-l1csm-yang-26] [RFC-ietf-ccamp-l1csm-yang-26]'s module file will be posted upon the document's publication as an RFC. ietf-l2-topology ietf-l2-topology@2020-11-15.yang N urn:ietf:params:xml:ns:yang:ietf-l2-topology l2t [RFC 8944] ietf-l2-topology-state ietf-l2-topology-state@2020-11-15.yang N urn:ietf:params:xml:ns:yang:ietf-l2-topology-state l2t-s [RFC 8944] ietf-l2vpn-ntw ietf-l2vpn-ntw@2022-09-20.yang N urn:ietf:params:xml:ns:yang:ietf-l2vpn-ntw l2vpn-ntw [RFC 9291] ietf-l2vpn-svc ietf-l2vpn-svc@2018-10-09.yang N urn:ietf:params:xml:ns:yang:ietf-l2vpn-svc l2vpn-svc [RFC 8466] ietf-l3-unicast-topology ietf-l3-unicast-topology@2018-02-26.yang N urn:ietf:params:xml:ns:yang:ietf-l3-unicast-topology l3t [RFC 8346] ietf-l3-unicast-topology-state ietf-l3-unicast-topology-state@2018-02-26.yang N urn:ietf:params:xml:ns:yang:ietf-l3-unicast-topology-state l3t-s [RFC 8346] ietf-l3vpn-ntw ietf-l3vpn-ntw@2022-02-14.yang N urn:ietf:params:xml:ns:yang:ietf-l3vpn-ntw l3nm [RFC 9182] ietf-l3vpn-svc ietf-l3vpn-svc@2018-01-19.yang N urn:ietf:params:xml:ns:yang:ietf-l3vpn-svc l3vpn-svc [RFC 8299] ietf-layer0-types ietf-layer0-types@2021-08-13.yang N urn:ietf:params:xml:ns:yang:ietf-layer0-types l0-types [RFC 9093] ietf-layer0-types N urn:ietf:params:xml:ns:yang:ietf-layer0-types l0-types [RFC-ietf-ccamp-rfc9093-bis-18] [RFC-ietf-ccamp-rfc9093-bis-18]'s module file will be posted upon the document's publication as an RFC. ietf-layer1-types N urn:ietf:params:xml:ns:yang:ietf-layer1-types l1-types [RFC-ietf-ccamp-layer1-types-18] [RFC-ietf-ccamp-layer1-types-18]'s module file will be posted upon the document's publication as an RFC. ietf-lime-time-types ietf-lime-time-types@2019-04-16.yang N urn:ietf:params:xml:ns:yang:ietf-lime-time-types lime [RFC 8532] ietf-lmap-common ietf-lmap-common@2017-08-08.yang N urn:ietf:params:xml:ns:yang:ietf-lmap-common lmap [RFC 8194] ietf-lmap-control ietf-lmap-control@2017-08-08.yang N urn:ietf:params:xml:ns:yang:ietf-lmap-control lmapc [RFC 8194] ietf-lmap-report ietf-lmap-report@2017-08-08.yang N urn:ietf:params:xml:ns:yang:ietf-lmap-report lmapr [RFC 8194] ietf-logical-network-element ietf-logical-network-element@2019-01-25.yang N urn:ietf:params:xml:ns:yang:ietf-logical-network-element lne [RFC 8530] ietf-microwave-radio-link ietf-microwave-radio-link@2019-06-19.yang N urn:ietf:params:xml:ns:yang:ietf-microwave-radio-link mrl [RFC 8561] ietf-microwave-topology ietf-microwave-topology@2024-09-30.yang N urn:ietf:params:xml:ns:yang:ietf-microwave-topology mwt [RFC 9656] ietf-microwave-types ietf-microwave-types@2019-06-19.yang N urn:ietf:params:xml:ns:yang:ietf-microwave-types mw-types [RFC 8561] ietf-module-tags ietf-module-tags@2021-01-04.yang N urn:ietf:params:xml:ns:yang:ietf-module-tags tags [RFC 8819] ietf-module-tags-state ietf-module-tags-state@2021-01-04.yang N urn:ietf:params:xml:ns:yang:ietf-module-tags-state tags-s [RFC 8819] ietf-mpls ietf-mpls@2020-12-18.yang N urn:ietf:params:xml:ns:yang:ietf-mpls mpls [RFC 8960] ietf-mpls-ldp ietf-mpls-ldp@2022-03-14.yang N urn:ietf:params:xml:ns:yang:ietf-mpls-ldp ldp [RFC 9070] ietf-mpls-ldp-extended ietf-mpls-ldp-extended@2022-03-14.yang N urn:ietf:params:xml:ns:yang:ietf-mpls-ldp-extended ldp-ext [RFC 9070] ietf-mpls-msd ietf-mpls-msd@2025-01-10.yang N urn:ietf:params:xml:ns:yang:ietf-mpls-msd mpls-msd [RFC 9702] ietf-msdp ietf-msdp@2020-10-31.yang N urn:ietf:params:xml:ns:yang:ietf-msdp msdp [RFC 8916] ietf-mud ietf-mud@2019-01-28.yang N urn:ietf:params:xml:ns:yang:ietf-mud ietf-mud [RFC 8520] ietf-mud-tls ietf-mud-tls@2025-04-18.yang N urn:ietf:params:xml:ns:yang:ietf-mud-tls ietf-mud-tls [RFC 9761] ietf-mud-transparency ietf-mud-transparency@2023-10-10.yang N urn:ietf:params:xml:ns:yang:ietf-mud-transparency mudtx [RFC 9472] ietf-nat ietf-nat@2019-01-10.yang N urn:ietf:params:xml:ns:yang:ietf-nat nat [RFC 8512] ietf-netconf ietf-netconf@2011-06-01.yang N urn:ietf:params:xml:ns:netconf:base:1.0 nc [RFC 6241] ietf-netconf-acm ietf-netconf-acm@2012-02-22.yang N urn:ietf:params:xml:ns:yang:ietf-netconf-acm nacm [RFC 6536] ietf-netconf-acm ietf-netconf-acm@2018-02-14.yang N urn:ietf:params:xml:ns:yang:ietf-netconf-acm nacm [RFC 8341] [RFC-ietf-netconf-netconf-client-server-41]'s module ietf-netconf-client N urn:ietf:params:xml:ns:yang:ietf-netconf-client ncc [RFC-ietf-netconf-netconf-client-server-41] file will be posted upon the document's publication as an RFC. ietf-netconf-monitoring ietf-netconf-monitoring@2010-10-04.yang N urn:ietf:params:xml:ns:yang:ietf-netconf-monitoring ncm [RFC 6022] ietf-netconf-nmda ietf-netconf-nmda@2019-01-07.yang N urn:ietf:params:xml:ns:yang:ietf-netconf-nmda ncds [RFC 8526] ietf-netconf-notifications ietf-netconf-notifications@2012-02-06.yang N urn:ietf:params:xml:ns:yang:ietf-netconf-notifications ncn [RFC 6470] ietf-netconf-partial-lock ietf-netconf-partial-lock@2009-10-19.yang N urn:ietf:params:xml:ns:netconf:partial-lock:1.0 pl [RFC 5717] [RFC-ietf-netconf-netconf-client-server-41]'s module ietf-netconf-server N urn:ietf:params:xml:ns:yang:ietf-netconf-server ncs [RFC-ietf-netconf-netconf-client-server-41] file will be posted upon the document's publication as an RFC. ietf-netconf-time ietf-netconf-time@2016-01-26.yang N urn:ietf:params:xml:ns:yang:ietf-netconf-time nct [RFC 7758] ietf-netconf-with-defaults ietf-netconf-with-defaults@2011-06-01.yang N urn:ietf:params:xml:ns:yang:ietf-netconf-with-defaults ncwd [RFC 6243] ietf-network ietf-network@2018-02-26.yang N urn:ietf:params:xml:ns:yang:ietf-network nw [RFC 8345] ietf-network-instance ietf-network-instance@2019-01-21.yang N urn:ietf:params:xml:ns:yang:ietf-network-instance ni [RFC 8529] [RFC-ietf-teas-ietf-network-slice-nbi-yang-25]'s ietf-network-slice-service N urn:ietf:params:xml:ns:yang:ietf-network-slice-service ietf-nss [RFC-ietf-teas-ietf-network-slice-nbi-yang-25] module file will be posted upon the document's publication as an RFC. ietf-network-state ietf-network-state@2018-02-26.yang N urn:ietf:params:xml:ns:yang:ietf-network-state nw-s [RFC 8345] ietf-network-topology ietf-network-topology@2018-02-26.yang N urn:ietf:params:xml:ns:yang:ietf-network-topology nt [RFC 8345] ietf-network-topology-state ietf-network-topology-state@2018-02-26.yang N urn:ietf:params:xml:ns:yang:ietf-network-topology-state nt-s [RFC 8345] ietf-network-vpn-pm ietf-network-vpn-pm@2023-03-20.yang N urn:ietf:params:xml:ns:yang:ietf-network-vpn-pm nvp [RFC 9375] ietf-nmda-compare ietf-nmda-compare@2021-12-10.yang N urn:ietf:params:xml:ns:yang:ietf-nmda-compare cmp [RFC 9144] ietf-notification-capabilities ietf-notification-capabilities@2022-02-17.yang N urn:ietf:params:xml:ns:yang:ietf-notification-capabilities notc [RFC 9196] ietf-ntp ietf-ntp@2022-07-05.yang N urn:ietf:params:xml:ns:yang:ietf-ntp ntp [RFC 9249] [RFC-ietf-ccamp-optical-impairment-topology-yang-23]'s ietf-optical-impairment-topology N urn:ietf:params:xml:ns:yang:ietf-optical-impairment-topology oit [RFC-ietf-ccamp-optical-impairment-topology-yang-23] module file will be posted upon the document's publication as an RFC. ietf-origin ietf-origin@2018-02-14.yang N urn:ietf:params:xml:ns:yang:ietf-origin or [RFC 8342] ietf-ospf ietf-ospf@2022-10-19.yang N urn:ietf:params:xml:ns:yang:ietf-ospf ospf [RFC 9129] ietf-ospf-admin-tags ietf-ospf-admin-tags@2025-07-31.yang N urn:ietf:params:xml:ns:yang:ietf-ospf-admin-tags ospf-admin-tags [RFC 9825] ietf-ospf-anycast-flag ietf-ospf-anycast-flag@2026-05-19.yang N urn:ietf:params:xml:ns:yang:ietf-ospf-anycast-flag ospf-anycast-flag [RFC 9983] [RFC-ietf-lsr-ospf-flex-algo-yang-16]'s module file ietf-ospf-flex-algo N urn:ietf:params:xml:ns:yang:ietf-ospf-flex-algo ospf-flex-algo [RFC-ietf-lsr-ospf-flex-algo-yang-16] will be posted upon the document's publication as an RFC. ietf-ospf-functional-capability ietf-ospf-functional-capability@2026-09-16.yang N urn:ietf:params:xml:ns:yang:ietf-ospf-functional-capability ospf-fc [RFC 10041] [RFC-ietf-lsr-ospf-flex-algo-yang-16]'s module file ietf-ospf-link-attr N urn:ietf:params:xml:ns:yang:ietf-ospf-link-attr ospf-link-attr [RFC-ietf-lsr-ospf-flex-algo-yang-16] will be posted upon the document's publication as an RFC. ietf-ospf-sr-mpls ietf-ospf-sr-mpls@2025-12-09.yang N urn:ietf:params:xml:ns:yang:ietf-ospf-sr-mpls ospf-sr-mpls [RFC 9903] ietf-ospf-unreachable-links ietf-ospf-unreachable-links@2026-09-16.yang N urn:ietf:params:xml:ns:yang:ietf-ospf-unreachable-links ospf-unreach-link [RFC 10041] ietf-ospfv3-extended-lsa ietf-ospfv3-extended-lsa@2024-06-07.yang N urn:ietf:params:xml:ns:yang:ietf-ospfv3-extended-lsa ospfv3-e-lsa [RFC 9587] ietf-otn-topology N urn:ietf:params:xml:ns:yang:ietf-otn-topology otnt [RFC-ietf-ccamp-otn-topo-yang-20] [RFC-ietf-ccamp-otn-topo-yang-20]'s module file will be posted upon the document's publication as an RFC. ietf-packet-discard-reporting N urn:ietf:params:xml:ns:yang:ietf-packet-discard-reporting pdr [RFC-ietf-opsawg-discardmodel-16] [RFC-ietf-opsawg-discardmodel-16]'s module file will be posted upon the document's publication as an RFC. ietf-packet-discard-reporting-common N urn:ietf:params:xml:ns:yang:ietf-packet-discard-reporting-common pdr-common [RFC-ietf-opsawg-discardmodel-16] [RFC-ietf-opsawg-discardmodel-16]'s module file will be posted upon the document's publication as an RFC. ietf-packet-discard-reporting-sx N urn:ietf:params:xml:ns:yang:ietf-packet-discard-reporting-sx pdr-sx [RFC-ietf-opsawg-discardmodel-16] [RFC-ietf-opsawg-discardmodel-16]'s module file will be posted upon the document's publication as an RFC. ietf-packet-fields ietf-packet-fields@2019-03-04.yang N urn:ietf:params:xml:ns:yang:ietf-packet-fields packet-fields [RFC 8519] ietf-pcep ietf-pcep@2025-09-12.yang N urn:ietf:params:xml:ns:yang:ietf-pcep pcep [RFC 9826] ietf-pcep-stats ietf-pcep-stats@2025-09-12.yang N urn:ietf:params:xml:ns:yang:ietf-pcep-stats pcep-stats [RFC 9826] ietf-pim-base ietf-pim-base@2022-10-19.yang N urn:ietf:params:xml:ns:yang:ietf-pim-base pim-base [RFC 9128] ietf-pim-bidir ietf-pim-bidir@2022-10-19.yang N urn:ietf:params:xml:ns:yang:ietf-pim-bidir pim-bidir [RFC 9128] ietf-pim-dm ietf-pim-dm@2022-10-19.yang N urn:ietf:params:xml:ns:yang:ietf-pim-dm pim-dm [RFC 9128] ietf-pim-rp ietf-pim-rp@2022-10-19.yang N urn:ietf:params:xml:ns:yang:ietf-pim-rp pim-rp [RFC 9128] ietf-pim-sm ietf-pim-sm@2022-10-19.yang N urn:ietf:params:xml:ns:yang:ietf-pim-sm pim-sm [RFC 9128] ietf-ptp ietf-ptp@2019-05-07.yang N urn:ietf:params:xml:ns:yang:ietf-ptp ptp [RFC 8575] ietf-restconf ietf-restconf@2017-01-26.yang N urn:ietf:params:xml:ns:yang:ietf-restconf rc [RFC 8040] [RFC-ietf-netconf-restconf-client-server-45]'s module ietf-restconf-client N urn:ietf:params:xml:ns:yang:ietf-restconf-client rcc [RFC-ietf-netconf-restconf-client-server-45] file will be posted upon the document's publication as an RFC. ietf-restconf-monitoring ietf-restconf-monitoring@2017-01-26.yang N urn:ietf:params:xml:ns:yang:ietf-restconf-monitoring rcmon [RFC 8040] [RFC-ietf-netconf-restconf-client-server-45]'s module ietf-restconf-server N urn:ietf:params:xml:ns:yang:ietf-restconf-server rcs [RFC-ietf-netconf-restconf-client-server-45] file will be posted upon the document's publication as an RFC. ietf-restconf-subscribed-notifications ietf-restconf-subscribed-notifications@2019-11-17.yang N urn:ietf:params:xml:ns:yang:ietf-restconf-subscribed-notifications rsn [RFC 8650] ietf-rib-extension ietf-rib-extension@2023-11-20.yang N urn:ietf:params:xml:ns:yang:ietf-rib-extension rib-ext [RFC 9403] ietf-rift ietf-rift@2025-04-04.yang N urn:ietf:params:xml:ns:yang:ietf-rift rift [RFC 9719] ietf-rip ietf-rip@2020-02-20.yang N urn:ietf:params:xml:ns:yang:ietf-rip rip [RFC 8695] ietf-routing ietf-routing@2016-11-04.yang N urn:ietf:params:xml:ns:yang:ietf-routing rt [RFC 8022] ietf-routing ietf-routing@2018-03-13.yang N urn:ietf:params:xml:ns:yang:ietf-routing rt [RFC 8349] ietf-routing-policy ietf-routing-policy@2021-10-11.yang N urn:ietf:params:xml:ns:yang:ietf-routing-policy rt-pol [RFC 9067] ietf-routing-types ietf-routing-types@2017-12-04.yang N urn:ietf:params:xml:ns:yang:ietf-routing-types rt-types [RFC 8294] ietf-sap-ntw ietf-sap-ntw@2023-06-20.yang N urn:ietf:params:xml:ns:yang:ietf-sap-ntw sap [RFC 9408] ietf-schc ietf-schc@2023-03-01.yang N urn:ietf:params:xml:ns:yang:ietf-schc schc [RFC 9363] ietf-schc-compound-ack ietf-schc-compound-ack@2023-07-26.yang N urn:ietf:params:xml:ns:yang:ietf-schc-compound-ack schc-compound-ack [RFC 9441] ietf-schedule ietf-schedule@2026-03-10.yang N urn:ietf:params:xml:ns:yang:ietf-schedule schedule [RFC 9922] ietf-segment-routing ietf-segment-routing@2021-05-26.yang N urn:ietf:params:xml:ns:yang:ietf-segment-routing sr [RFC 9020] ietf-segment-routing-common ietf-segment-routing-common@2021-05-26.yang N urn:ietf:params:xml:ns:yang:ietf-segment-routing-common sr-cmn [RFC 9020] ietf-segment-routing-mpls ietf-segment-routing-mpls@2021-05-26.yang N urn:ietf:params:xml:ns:yang:ietf-segment-routing-mpls sr-mpls [RFC 9020] ietf-service-assurance ietf-service-assurance@2023-07-11.yang N urn:ietf:params:xml:ns:yang:ietf-service-assurance sain [RFC 9418] ietf-service-assurance-device ietf-service-assurance-device@2023-07-11.yang N urn:ietf:params:xml:ns:yang:ietf-service-assurance-device sain-device [RFC 9418] ietf-service-assurance-interface ietf-service-assurance-interface@2023-07-11.yang N urn:ietf:params:xml:ns:yang:ietf-service-assurance-interface sain-interface [RFC 9418] ietf-sid-file ietf-sid-file@2024-07-31.yang N urn:ietf:params:xml:ns:yang:ietf-sid-file sid [RFC 9595] ietf-sip-auto-peering ietf-sip-auto-peering@2026-06-15.yang N urn:ietf:params:xml:ns:yang:ietf-sip-auto-peering sipap [RFC 10006] ietf-snmp ietf-snmp@2014-12-10.yang N urn:ietf:params:xml:ns:yang:ietf-snmp snmp [RFC 7407] ietf-snmp-common ietf-snmp-common@2014-12-10.yang N ietf-snmp [RFC 7407] ietf-snmp-community ietf-snmp-community@2014-12-10.yang N ietf-snmp [RFC 7407] ietf-snmp-engine ietf-snmp-engine@2014-12-10.yang N ietf-snmp [RFC 7407] ietf-snmp-notification ietf-snmp-notification@2014-12-10.yang N ietf-snmp [RFC 7407] ietf-snmp-proxy ietf-snmp-proxy@2014-12-10.yang N ietf-snmp [RFC 7407] ietf-snmp-ssh ietf-snmp-ssh@2014-12-10.yang N ietf-snmp [RFC 7407] ietf-snmp-target ietf-snmp-target@2014-12-10.yang N ietf-snmp [RFC 7407] ietf-snmp-tls ietf-snmp-tls@2014-12-10.yang N ietf-snmp [RFC 7407] ietf-snmp-tsm ietf-snmp-tsm@2014-12-10.yang N ietf-snmp [RFC 7407] ietf-snmp-usm ietf-snmp-usm@2014-12-10.yang N ietf-snmp [RFC 7407] ietf-snmp-vacm ietf-snmp-vacm@2014-12-10.yang N ietf-snmp [RFC 7407] ietf-softwire-br ietf-softwire-br@2019-11-16.yang N urn:ietf:params:xml:ns:yang:ietf-softwire-br softwire-br [RFC 8676] ietf-softwire-ce ietf-softwire-ce@2019-11-16.yang N urn:ietf:params:xml:ns:yang:ietf-softwire-ce softwire-ce [RFC 8676] ietf-softwire-common ietf-softwire-common@2019-11-16.yang N urn:ietf:params:xml:ns:yang:ietf-softwire-common softwire-common [RFC 8676] ietf-ssh-client ietf-ssh-client@2024-10-10.yang N urn:ietf:params:xml:ns:yang:ietf-ssh-client sshc [RFC 9644] ietf-ssh-common ietf-ssh-common@2024-10-10.yang N urn:ietf:params:xml:ns:yang:ietf-ssh-common sshcmn [RFC 9644] ietf-ssh-server ietf-ssh-server@2024-10-10.yang N urn:ietf:params:xml:ns:yang:ietf-ssh-server sshs [RFC 9644] ietf-subscribed-notifications ietf-subscribed-notifications@2019-09-09.yang N urn:ietf:params:xml:ns:yang:ietf-subscribed-notifications sn [RFC 8639] ietf-syslog ietf-syslog@2025-04-30.yang N urn:ietf:params:xml:ns:yang:ietf-syslog syslog [RFC 9742] ietf-system ietf-system@2014-08-06.yang N urn:ietf:params:xml:ns:yang:ietf-system sys [RFC 7317] ietf-system-capabilities ietf-system-capabilities@2022-02-17.yang N urn:ietf:params:xml:ns:yang:ietf-system-capabilities sysc [RFC 9196] ietf-system-datastore ietf-system-datastore@2026-09-16.yang N urn:ietf:params:xml:ns:yang:ietf-system-datastore sysds [RFC 10016] ietf-system-tacacs-plus ietf-system-tacacs-plus@2021-08-05.yang N urn:ietf:params:xml:ns:yang:ietf-system-tacacs-plus sys-tcs-plus [RFC 9105] ietf-system-tacacs-plus ietf-system-tacacs-plus@2026-03-31.yang N urn:ietf:params:xml:ns:yang:ietf-system-tacacs-plus sys-tcs-plus [RFC 9950] ietf-sztp-bootstrap-server ietf-sztp-bootstrap-server@2019-04-30.yang N urn:ietf:params:xml:ns:yang:ietf-sztp-bootstrap-server sztp-svr [RFC 8572] ietf-sztp-conveyed-info ietf-sztp-conveyed-info@2019-04-30.yang N urn:ietf:params:xml:ns:yang:ietf-sztp-conveyed-info sztp-info [RFC 8572] ietf-sztp-csr ietf-sztp-csr@2024-10-10.yang N urn:ietf:params:xml:ns:yang:ietf-sztp-csr sztp-csr [RFC 9646] ietf-tcg-algs ietf-tcg-algs@2024-12-05.yang N urn:ietf:params:xml:ns:yang:ietf-tcg-algs taa [RFC 9684] ietf-tcp ietf-tcp@2024-10-10.yang N urn:ietf:params:xml:ns:yang:ietf-tcp tcp [RFC 9648] ietf-tcp-client ietf-tcp-client@2024-10-10.yang N urn:ietf:params:xml:ns:yang:ietf-tcp-client tcpc [RFC 9643] ietf-tcp-common ietf-tcp-common@2024-10-10.yang N urn:ietf:params:xml:ns:yang:ietf-tcp-common tcpcmn [RFC 9643] ietf-tcp-server ietf-tcp-server@2024-10-10.yang N urn:ietf:params:xml:ns:yang:ietf-tcp-server tcps [RFC 9643] ietf-te N urn:ietf:params:xml:ns:yang:ietf-te te [RFC-ietf-teas-yang-te-44] [RFC-ietf-teas-yang-te-44]'s module file will be posted upon the document's publication as an RFC. ietf-te-device N urn:ietf:params:xml:ns:yang:ietf-te-device te-device [RFC-ietf-teas-yang-te-44] [RFC-ietf-teas-yang-te-44]'s module file will be posted upon the document's publication as an RFC. ietf-te-packet-types ietf-te-packet-types@2020-06-10.yang N urn:ietf:params:xml:ns:yang:ietf-te-packet-types te-packet-types [RFC 8776] ietf-te-packet-types N urn:ietf:params:xml:ns:yang:ietf-te-packet-types te-packet-types [RFC-ietf-teas-rfc8776-update-23] [RFC-ietf-teas-rfc8776-update-23]'s module file will be posted upon the document's publication as an RFC. ietf-te-topology ietf-te-topology@2020-08-06.yang N urn:ietf:params:xml:ns:yang:ietf-te-topology tet [RFC 8795] ietf-te-topology-state ietf-te-topology-state@2020-08-06.yang N urn:ietf:params:xml:ns:yang:ietf-te-topology-state tet-s [RFC 8795] ietf-te-types ietf-te-types@2020-06-10.yang N urn:ietf:params:xml:ns:yang:ietf-te-types te-types [RFC 8776] ietf-te-types N urn:ietf:params:xml:ns:yang:ietf-te-types te-types [RFC-ietf-teas-rfc8776-update-23] [RFC-ietf-teas-rfc8776-update-23]'s module file will be posted upon the document's publication as an RFC. ietf-template ietf-template@2010-05-18.yang N urn:ietf:params:xml:ns:yang:ietf-template temp [RFC 6087] ietf-template ietf-template@2016-03-20.yang N urn:ietf:params:xml:ns:yang:ietf-template temp [RFC 8407] ietf-template ietf-template@2023-07-26.yang N urn:ietf:params:xml:ns:yang:ietf-template temp [RFC 9907] ietf-tls-client ietf-tls-client@2024-10-10.yang N urn:ietf:params:xml:ns:yang:ietf-tls-client tlsc [RFC 9645] ietf-tls-common ietf-tls-common@2024-10-10.yang N urn:ietf:params:xml:ns:yang:ietf-tls-common tlscmn [RFC 9645] ietf-tls-server ietf-tls-server@2024-10-10.yang N urn:ietf:params:xml:ns:yang:ietf-tls-server tlss [RFC 9645] ietf-tpm-remote-attestation ietf-tpm-remote-attestation@2024-12-05.yang N urn:ietf:params:xml:ns:yang:ietf-tpm-remote-attestation tpm [RFC 9684] [RFC-ietf-bmwg-network-tester-cfg-17]'s module file ietf-traffic-analyzer N urn:ietf:params:xml:ns:yang:ietf-traffic-analyzer ntta [RFC-ietf-bmwg-network-tester-cfg-17] will be posted upon the document's publication as an RFC. [RFC-ietf-bmwg-network-tester-cfg-17]'s module file ietf-traffic-generator N urn:ietf:params:xml:ns:yang:ietf-traffic-generator nttg [RFC-ietf-bmwg-network-tester-cfg-17] will be posted upon the document's publication as an RFC. ietf-truststore ietf-truststore@2024-10-10.yang N urn:ietf:params:xml:ns:yang:ietf-truststore ts [RFC 9641] ietf-tvr-node N urn:ietf:params:xml:ns:yang:ietf-tvr-node tvr-node [RFC-ietf-tvr-schedule-yang-12] [RFC-ietf-tvr-schedule-yang-12]'s module file will be posted upon the document's publication as an RFC. ietf-tvr-schedule N urn:ietf:params:xml:ns:yang:ietf-tvr-schedule tvr-schd [RFC-ietf-tvr-schedule-yang-12] [RFC-ietf-tvr-schedule-yang-12]'s module file will be posted upon the document's publication as an RFC. ietf-tvr-topology N urn:ietf:params:xml:ns:yang:ietf-tvr-topology tvr-topo [RFC-ietf-tvr-schedule-yang-12] [RFC-ietf-tvr-schedule-yang-12]'s module file will be posted upon the document's publication as an RFC. ietf-twamp ietf-twamp@2021-11-17.yang N urn:ietf:params:xml:ns:yang:ietf-twamp twamp [RFC 8913] ietf-ucl-acl ietf-ucl-acl@2026-10-07.yang N urn:ietf:params:xml:ns:yang:ietf-ucl-acl ucl [RFC 10065] ietf-udp-client ietf-udp-client@2026-06-15.yang N urn:ietf:params:xml:ns:yang:ietf-udp-client udpc [RFC 9984] ietf-udp-server ietf-udp-server@2026-06-15.yang N urn:ietf:params:xml:ns:yang:ietf-udp-server udps [RFC 9984] ietf-vn ietf-vn@2025-03-27.yang N urn:ietf:params:xml:ns:yang:ietf-vn vn [RFC 9731] ietf-voucher ietf-voucher@2018-05-09.yang N urn:ietf:params:xml:ns:yang:ietf-voucher vch [RFC 8366] ietf-voucher-request ietf-voucher-request@2021-05-20.yang N urn:ietf:params:xml:ns:yang:ietf-voucher-request vch [RFC 8995] ietf-vpn-common ietf-vpn-common@2022-02-11.yang N urn:ietf:params:xml:ns:yang:ietf-vpn-common vpn-common [RFC 9181] ietf-vrrp ietf-vrrp@2018-03-13.yang N urn:ietf:params:xml:ns:yang:ietf-vrrp vrrp [RFC 8347] ietf-vrrp N urn:ietf:params:xml:ns:yang:ietf-vrrp vrrp [RFC-ietf-rtgwg-vrrp-rfc8347bis-23] [RFC-ietf-rtgwg-vrrp-rfc8347bis-23]'s module file will be posted upon the document's publication as an RFC. ietf-wson-topology ietf-wson-topology@2021-08-13.yang N urn:ietf:params:xml:ns:yang:ietf-wson-topology wsont [RFC 9094] ietf-x509-cert-to-name ietf-x509-cert-to-name@2014-12-10.yang N urn:ietf:params:xml:ns:yang:ietf-x509-cert-to-name x509c2n [RFC 7407] ietf-yang-instance-data ietf-yang-instance-data@2022-02-17.yang N urn:ietf:params:xml:ns:yang:ietf-yang-instance-data yid [RFC 9195] ietf-yang-library ietf-yang-library@2016-06-21.yang N urn:ietf:params:xml:ns:yang:ietf-yang-library yanglib [RFC 7895] ietf-yang-library ietf-yang-library@2019-01-04.yang N urn:ietf:params:xml:ns:yang:ietf-yang-library yanglib [RFC 8525] ietf-yang-library-augmentedby ietf-yang-library-augmentedby@2026-08-26.yang N urn:ietf:params:xml:ns:yang:ietf-yang-library-augmentedby yanglib-aug [RFC 10035] ietf-yang-library-semver N urn:ietf:params:xml:ns:yang:ietf-yang-library-semver yl-semver [RFC-ietf-netmod-yang-semver-28] [RFC-ietf-netmod-yang-semver-28]'s module file will be posted upon the document's publication as an RFC. [RFC-ietf-netmod-yang-module-versioning-17]'s module ietf-yang-library-status N urn:ietf:params:xml:ns:yang:ietf-yang-library-status yls [RFC-ietf-netmod-yang-module-versioning-17] file will be posted upon the document's publication as an RFC. ietf-yang-metadata ietf-yang-metadata@2016-08-05.yang N urn:ietf:params:xml:ns:yang:ietf-yang-metadata md [RFC 7952] ietf-yang-patch ietf-yang-patch@2017-02-22.yang N urn:ietf:params:xml:ns:yang:ietf-yang-patch ypatch [RFC 8072] ietf-yang-push ietf-yang-push@2019-09-09.yang N urn:ietf:params:xml:ns:yang:ietf-yang-push yp [RFC 8641] [RFC-ietf-netmod-yang-module-versioning-17]'s module ietf-yang-revisions N urn:ietf:params:xml:ns:yang:ietf-yang-revisions rev [RFC-ietf-netmod-yang-module-versioning-17] file will be posted upon the document's publication as an RFC. ietf-yang-schema-mount ietf-yang-schema-mount@2019-01-14.yang N urn:ietf:params:xml:ns:yang:ietf-yang-schema-mount yangmnt [RFC 8528] ietf-yang-semver N urn:ietf:params:xml:ns:yang:ietf-yang-semver ysv [RFC-ietf-netmod-yang-semver-28] [RFC-ietf-netmod-yang-semver-28]'s module file will be posted upon the document's publication as an RFC. ietf-yang-smiv2 ietf-yang-smiv2@2012-06-22.yang N urn:ietf:params:xml:ns:yang:ietf-yang-smiv2 smiv2 [RFC 6643] ietf-yang-structure-ext ietf-yang-structure-ext@2020-06-17.yang N urn:ietf:params:xml:ns:yang:ietf-yang-structure-ext sx [RFC 8791] ietf-yang-types ietf-yang-types@2010-09-24.yang N urn:ietf:params:xml:ns:yang:ietf-yang-types yang [RFC 6021] ietf-yang-types ietf-yang-types@2013-07-15.yang N urn:ietf:params:xml:ns:yang:ietf-yang-types yang [RFC 6991] ietf-yang-types ietf-yang-types@2025-12-22.yang N urn:ietf:params:xml:ns:yang:ietf-yang-types yang [RFC 9911] ietf-ztp-types ietf-ztp-types@2024-10-10.yang N urn:ietf:params:xml:ns:yang:ietf-ztp-types ztp-types [RFC 9646] Licensing Terms