Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About Transparent Interconnection of Lots of Links (TRILL) Parameters Created 2010-03-26 Last Updated 2024-09-02 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • TRILL Nicknames • TRILL Multicast Addresses • TRILL Ethertypes • TRILL Extended Header Flags • RBridge Channel Protocols • TRILL Address Flush TLV Types • Extended RBridge Channel Payload Types • Extended RBridge Channel Security Types • RBridge Channel Header Flags • RBridge Channel Error Codes • RBridge Channel SubError Codes • Vendor RBridge Channel Error Codes • TRILL-VER Sub-TLV Capability Flags • PORT-TRILL-VER Sub-TLV Capability Flags • TRILL Neighbor TLV NEIGHBOR RECORD Flags • Interested VLANs Flag Bits • Interested Labels Flag Bits • TRILL APPsub-TLV Types under IS-IS TLV 251 Application Identifier 1 • ESADI-Parameter APPsub-TLV Flag Bits • NickFlags Bits • Interface Addresses APPsub-TLV Sub-sub-TLVs • Extended RBridge Capabilities • TRILL OAM Return Codes • Sub-codes for TRILL OAM Return Code 0 • Sub-codes for TRILL OAM Return Code 1 • TRILL Pull Directory Query Types (QTYPEs) • TRILL Pull Directory Errors • Sub-codes for TRILL Pull Directory Errors 1 and 3 • Sub-codes for TRILL Pull Directory Errors 128 and 131 TRILL Nicknames Registration Procedure(s) RFC Required (single value) or IETF Review (single or multiple values) Reference [RFC 6325] Available Formats [IMG] CSV Name Description Reference 0x0000 Reserved to indicate no nickname specified [RFC 6325] 0x0001-0xFFBF Dynamically allocated by the RBridges within each RBridge campus [RFC 6325] 0xFFC0 Any-RBridge [RFC 7178] 0xFFC1 OOMF (Overload Originated Multi-destination Frame) [RFC 7780] 0xFFC2-0xFFD7 Unassigned 0xFFD8-0xFFDF For use in documentation examples [RFC 7780] 0xFFE0-0xFFFE Unassigned 0xFFFF Permanently reserved [RFC 6325] TRILL Multicast Addresses Registration Procedure(s) IETF Review Reference [RFC 6325] Available Formats [IMG] CSV Address Description Reference 01-80-C2-00-00-40 All-RBridges [RFC 6325] 01-80-C2-00-00-41 All-IS-IS-RBridges [RFC 6325] 01-80-C2-00-00-42 All-ESADI-RBridges/All-Egress-RBridges [RFC 6325]; [RFC 7178] 01-80-C2-00-00-43 to 01-80-C2-00-00-44 Unassigned 01-80-C2-00-00-45 TRILL-End-Stations [RFC 7178] 01-80-C2-00-00-46 All-Edge-RBridges [RFC 7178] 01-80-C2-00-00-47 TRILL-ES-IS [RFC 8171] 01-80-C2-00-00-48 to 01-80-C2-00-00-4F Unassigned TRILL Ethertypes Registration Procedure(s) Ethertypes are assigned by the IEEE Registration Authority. Updates to this registry are coordinated with the designated expert. Expert(s) Donald Eastlake (primary), Sue Hares (secondary) Reference [RFC 8377] Note This registry provides centralized documentation of Ethertypes that were assigned by the IEEE for initial use with TRILL. In some cases, particularly L2-IS-IS and MT, they may be used with other protocols. Available Formats [IMG] CSV Value Mnemonic Explanation Reference 0x22F3 TRILL TRILL data [RFC 6325] 0x22F4 L2-IS-IS IS-IS [RFC 6325] 0x893B FGL Fine Grained Labeling [RFC 7172] 0x8946 - TRILL RBridge Channel [RFC 7178] 0x9A22 MT Multi-Topology [RFC 8377] TRILL Extended Header Flags Registration Procedure(s) IETF Review Reference [RFC 7179] Available Formats [IMG] CSV Bits Purpose Reference 0-2 Critical Summary Bits [RFC 7179] 3-6 available critical hop-by-hop flags [RFC 7179] 7 Critical Channel Alert Flag [RFC 7179] 8 Non-critical Channel Alert Flag [RFC 7179] 9-11 available non-critical hop-by-hop flags [RFC 7179] 12-13 TRILL-ECN (Explicit Congestion Notification) [RFC 9600] 14-16 Extended Hop Count [RFC 7780] 17-20 available non-critical reserved flags [RFC 7179] 21-25 available critical ingress-to-egress flags [RFC 7179] 26 Critical Congestion Experienced (CCE) [RFC 9600] 27-28 Extended Color [RFC 7780] 29-31 available non-critical ingress-to-egress flags [RFC 7179]; [RFC 7780] RBridge Channel Protocols Reference [RFC 7178] Available Formats [IMG] CSV Range Registration Procedures Note 0x002-0x0FF Standards Action 0x100-0xFF7 RFC Required allocation of a single value 0x100-0xFF7 IESG Approval allocation of multiple values Protocol Description Reference 0x000 Reserved [RFC 7178] 0x001 RBridge Channel Error [RFC 7178] 0x002 BFD Control [RFC 7175] 0x003 BFD Echo [RFC 7175] 0x004 RBridge Channel Extension [RFC 7978] 0x005 Pull Directory Services [RFC 8171] 0x006 Port-Shutdown [RFC 8139] 0x007 P2MP BFD Control [RFC 8564] 0x008 Vendor-Specific RBridge Channel [RFC 8381] 0x009 Address Flush [RFC 8383] 0x00A-0xFF7 Unassigned 0xFF8-0xFFE Reserved for Private Use [RFC 7178] 0xFFF Reserved [RFC 7178] TRILL Address Flush TLV Types Registration Procedure(s) IETF Review Reference [RFC 8383] Available Formats [IMG] CSV Protocol Description Reference 0 Reserved [RFC 8383] 1 Blocks of VLANs [RFC 8383] 2 Bit Map of VLANs [RFC 8383] 3 Blocks of FGLs [RFC 8383] 4 List of FGLs [RFC 8383] 5 Bit Map of FGLs [RFC 8383] 6 All Data Labels [RFC 8383] 7 MAC Address List [RFC 8383] 8 MAC Address Blocks [RFC 8383] 9-254 Unassigned 255 Reserved [RFC 8383] Extended RBridge Channel Payload Types Registration Procedure(s) IETF Review Reference [RFC 7978] Available Formats [IMG] CSV PType Description Reference 0 Reserved [RFC 7978] 1 Null [RFC 7978, Section 3.1] 2 Ethertyped Payload [RFC 7978, Section 3.2] 3 Ethernet Frame [RFC 7978, Section 3.3] 4-14 Unassigned 15 Reserved [RFC 7978] Extended RBridge Channel Security Types Registration Procedure(s) IETF Review Reference [RFC 7978] Available Formats [IMG] CSV SType Description Reference 0 None [RFC 7978, Section 4.2] 1 IS-IS CRYPTO_AUTH-Based Authentication [RFC 7978, Section 4.3] 2 DTLS Pairwise Security [RFC 7978, Section 4.4] 3 Composite Security [RFC 7978, Section 4.5] 4-14 Unassigned 15 Reserved [RFC 7978] RBridge Channel Header Flags Registration Procedure(s) IETF Review Reference [RFC 7178] Available Formats [IMG] CSV Flag Bit Mnemonic Allocation Reference 0 SL Silent [RFC 7178] 1 MH Multi-hop [RFC 7178] 2 NA Native [RFC 7178] 3-11 Unassigned RBridge Channel Error Codes Registration Procedure(s) Standards Action Reference [RFC 7178] Note Value 15 is intended to be allocated by Standards Action for an error code expansion feature when it appears likely that all other available error codes are being allocated. Available Formats [IMG] CSV Value RBridge Channel Error Code Meaning Reference 0 No error [RFC 7178] 1 Frame too short (truncated Ethertype or Channel Header) [RFC 7178] 2 Unrecognized Ethertype [RFC 7178] 3 Unimplemented value of CHV [RFC 7178] 4 Wrong value of NA flag [RFC 7178] 5 Channel Protocol is reserved or unimplemented [RFC 7178] 6 Unknown or unsupported field value [RFC 7978] 7 Authentication failure [RFC 7978] 8 Error in nested RBridge Channel message [RFC 7978] 9-14 Unassigned 15 Reserved (see Note) [RFC 7178] RBridge Channel SubError Codes Registration Procedure(s) IETF Review Reference [RFC 7978] Available Formats [IMG] CSV Err SubERR Meaning Reference 0 No Error, suberrors not allowed [RFC 7978] 1-5 (no suberrors assigned) [RFC 7978] 6 0 Reserved [RFC 7978] 6 1 Non-zero RESV4 nibble [RFC 7978] 6 2 Unsupported SType [RFC 7978] 6 3 Unsupported PType [RFC 7978] 6 4 Unknown Key ID [RFC 7978] 6 5 Unsupported Ethertype with PType = 2 [RFC 7978] 6 6 Unsupported authentication algorithm for SType = 1 [RFC 7978] 6 7 Non-zero SubERR with zero ERR field [RFC 7978] 6 8-15 Unassigned 7-14 (no suberrors assigned) [RFC 7978] 15 Reserved [RFC 7978] Vendor RBridge Channel Error Codes Registration Procedure(s) Standards Action Reference [RFC 8381] Available Formats [IMG] CSV Code Description Reference 0x00 No error [RFC 8381] 0x01 Message too short [RFC 8381] 0x02 Unknown OUI/CID [RFC 8381] 0x03 Unknown Sub-Protocol [RFC 8381] 0x04 Unknown Sub-Version [RFC 8381] 0x05-0x0F Unassigned 0x10-0xFE Reserved for vendor use [RFC 8381] 0xFF Reserved [RFC 8381] TRILL-VER Sub-TLV Capability Flags Registration Procedure(s) IETF Review Reference [RFC 7176] Available Formats [IMG] CSV Bit Description Reference 0 Affinity sub-TLV support [RFC 7783] 1 FGL-safe [RFC 7172] 2 OAM capable [RFC 7455] 3 Backwards-compatible OAM [RFC 7455] 4 E-L1FS FS-LSP support [RFC 7780]; [RFC 7356] 5 Able to handle the NickBlockFlags APPsub-TLV [RFC 8397] 6-13 Unassigned 14 Extended Hop Count support [RFC 7780] 15-16 Unassigned 17-20 available non-critical reserved flags [RFC 7179] 21-26 available critical ingress-to-egress flags [RFC 7179] 27-28 Extended Color support [RFC 7780] 29-31 Extended header flag support [RFC 7179]; [RFC 7780] PORT-TRILL-VER Sub-TLV Capability Flags Registration Procedure(s) IETF Review Reference [RFC 7176] Available Formats [IMG] CSV Bit Description Reference 0 Hello reduction support. [RFC 8139] 1-2 Unassigned 3-13 Hop-by-hop extended flag support. [RFC 7179] 14-15 Topology labeling support. [RFC 8377] 16-31 Unassigned TRILL Neighbor TLV NEIGHBOR RECORD Flags Registration Procedure(s) Standards Action Reference [RFC 7176] Available Formats [IMG] CSV Bit Short Name Description Reference 0 Fail Failed MTU test [RFC 6325]; [RFC 7176]; [RFC 7177] 1 OOMF Offering OOMF service [RFC 7780] 2-7 Unassigned Interested VLANs Flag Bits Registration Procedure(s) IETF Review Reference [RFC 7176][RFC 7357] Note These bits appear in the Interested VLANs record within the Interested VLANs and Spanning Tree Roots Sub-TLV (INT-VLAN) specified in [RFC 7176]. Available Formats [IMG] CSV Bit Mnemonic Description Reference 0 M4 IPv4 Multicast Router Attached [RFC 7176] 1 M6 IPv6 Multicast Router Attached [RFC 7176] 2 Unassigned 3 ES ESADI Participation [RFC 7357] 4-15 (used for a VLAN ID) [RFC 7176] 16 AA VLANs for Active-Active [RFC 7782] 17 Unassigned 18 PUL Pull Directory [RFC 8171] 19 NOD No Data [RFC 8171] 20-31 (used for a VLAN ID) [RFC 7176] Interested Labels Flag Bits Registration Procedure(s) IETF Review Reference [RFC 7176][RFC 7357] Note These bits appear in the Interested Labels record within the Interested Labels and Spanning Tree Roots Sub-TLV (INT-LABEL) specified in [RFC 7176]. Available Formats [IMG] CSV Bit Mnemonic Description Reference 0 M4 IPv4 Multicast Router Attached [RFC 7176] 1 M6 IPv6 Multicast Router Attached [RFC 7176] 2 BM Bit Map [RFC 7176] 3 ES ESADI Participation [RFC 7357] 4 AA FGLs for Active-Active [RFC 7782] 5 Unassigned 6 PUL Pull Directory [RFC 8171] 7 NOD No Data [RFC 8171] TRILL APPsub-TLV Types under IS-IS TLV 251 Application Identifier 1 Registration Procedure(s) IETF Review with additional requirements on the documentation of the use being registered as specified in [Section 7.2 of RFC 7357]. Reference [RFC 7357] Note Types greater than 255 are only usable in contexts permitting a type larger than one byte, such as extended TLVs [RFC 7356]. Note Also see [Application Identifiers for TLV 251] Available Formats [IMG] CSV Type Name Reference 0 Reserved [RFC 7357] 1 ESADI-PARAM [RFC 7357]; [RFC 8171] 2 PN-LAALP-Membership [RFC 7781] 3 PN-RBv [RFC 7781] 4 PN-MAC-RI-LAALP-INFO-START [RFC 7781] 5 PN-MAC-RI-LAALP-INFO-END [RFC 7781] 6 NICKFLAGS [RFC 7780] 7 TENANT-GWMAC-LABEL [RFC 7956] 8 IPV4-PREFIX [RFC 7956] 9 IPV6-PREFIX [RFC 7956] 10 IA [RFC 7961] 11 Tree and VLANs [RFC 7968] 12 Tree and VLANs Used [RFC 7968] 13 Tree and FGLs [RFC 7968] 14 Tree and FGLs Used [RFC 7968] 15 Tree and Groups [RFC 7968] 16 Tree and Groups Used [RFC 7968] 17 AppointmentBitmap [RFC 8139] 18 AppointmentList [RFC 8139] 19 FGL-VLAN-Bitmap [RFC 8139] 20 FGL-VLAN-Pairs [RFC 8139] 21 originatingSNPBufferSize [RFC 8249] 22 Smart-Parameters [RFC 8384] 23 Smart-MAC [RFC 8384] 24 NickBlockFlags [RFC 8397] 25-251 Unassigned 252 AA-LAALP-GROUP-RBRIDGES [RFC 7782] 253 AA-LAALP-GROUP-MAC [RFC 7782] 254 EXTENDED-RBRIDGE-CAP [RFC 7782] 255 Reserved [RFC 7357] 256 L1-BORDER-RBRIDGE [RFC 9183] 257 L1-BORDER-RB-GROUP [RFC 9183] 258-65534 Unassigned 65535 Reserved [RFC 7357] ESADI-Parameter APPsub-TLV Flag Bits Registration Procedure(s) Standards Action Reference [RFC 7357][RFC 8171] Available Formats [IMG] CSV Bit Mnemonic Description Reference 0 UN Supports Unicast ESADI [RFC 7357] 1-2 PDSS Push Directory Server Status [RFC 8171] 3-7 Unassigned NickFlags Bits Registration Procedure(s) IETF Review Reference [RFC 7780] Available Formats [IMG] CSV Bit Mnemonic Description Reference 0 IN Used as ingress [RFC 7780] 1 SE Inter-Subnet Egress [RFC 7956] 2 R Replication Nickname [RFC 8361] 3 C Special RPF Check [RFC 8361] 4-15 Unassigned Interface Addresses APPsub-TLV Sub-sub-TLVs Registration Procedure(s) Expert Review Expert(s) Unassigned Reference [RFC 7961] Note Types greater than 255 are not usable in some contexts. Available Formats [IMG] CSV Type Description Reference 0 Reserved [RFC 7961] 1 AFN Size [RFC 7961] 2 Fixed Address [RFC 7961] 3 Data Label [RFC 7961] 4 Topology [RFC 7961] 5-254 Unassigned 255 Reserved [RFC 7961] 256-65534 Unassigned 65535 Reserved [RFC 7961] Extended RBridge Capabilities Registration Procedure(s) Expert Review Expert(s) Unassigned Reference [RFC 7782] Available Formats [IMG] CSV Bit Mnemonic Description Reference 0 E Option B Support [RFC 7782] 1 H Option A Support [RFC 7782] 2-63 Unassigned TRILL OAM Return Codes Registration Procedure(s) Standards Action Reference [RFC 7455] Available Formats [IMG] CSV Return Code Assignment Reference 0 Request message [RFC 7455] 1 Reply message [RFC 7455] 2-255 Unassigned Sub-codes for TRILL OAM Return Code 0 Registration Procedure(s) Standards Action Reference [RFC 7455] Available Formats [IMG] CSV Sub Code Assignment Reference 0 Valid request [RFC 7455] 1-255 Unassigned Sub-codes for TRILL OAM Return Code 1 Registration Procedure(s) Standards Action Reference [RFC 7455] Available Formats [IMG] CSV Sub Code Assignment Reference 0 Valid response [RFC 7455] 1 Fragment limit exceeded [RFC 7455] 2 Intermediate RBridge [RFC 7455] 3-255 Unassigned TRILL Pull Directory Query Types (QTYPEs) Registration Procedure(s) IETF Review Reference [RFC 8171] Available Formats [IMG] CSV QTYPE Description Reference 0 Reserved [RFC 8171] 1 Address query [RFC 8171] 2 Frame query [RFC 8171] 3-4 Unassigned 5 Unknown unicast MAC query frame [RFC 8171] 6-14 Unassigned 15 Reserved [RFC 8171] TRILL Pull Directory Errors Registration Procedure(s) IETF Review Reference [RFC 8171] Available Formats [IMG] CSV Err Level Meaning Reference 0 No Error [RFC 8171] 1 Message Unknown or reserved Query Message field value [RFC 8171] 2 Message Request Message/data too short [RFC 8171] 3 Message Unknown or reserved Update Message field value [RFC 8171] 4 Message Update Message/data too short [RFC 8171] 5-126 Message Unassigned 127 Reserved [RFC 8171] 128 Record Unknown or reserved QUERY Record field value [RFC 8171] 129 Record QUERY Record truncated [RFC 8171] 130 Record Address not found [RFC 8171] 131 Record Unknown or reserved RESPONSE Record field value [RFC 8171] 132 Record RESPONSE Record truncated [RFC 8171] 133-254 Record Unassigned 255 Reserved [RFC 8171] Sub-codes for TRILL Pull Directory Errors 1 and 3 Registration Procedure(s) Expert Review Expert(s) Unassigned Reference [RFC 8171] Available Formats [IMG] CSV SubErr Field with Error Reference 0 Unspecified [RFC 8171] 1 Version not understood (see [Section 3.1.1 of RFC 8171]) [RFC 8171] 2 Unknown Type field value [RFC 8171] 3 Specified Data Label not being served [RFC 8171] 4-254 Unassigned 255 Reserved [RFC 8171] Sub-codes for TRILL Pull Directory Errors 128 and 131 Registration Procedure(s) Expert Review Expert(s) Unassigned Reference [RFC 8171] Available Formats [IMG] CSV SubErr Field with Error Reference 0 Unspecified [RFC 8171] 1 Unknown AFN field value [RFC 8171] 2 Unknown or Reserved QTYPE field value [RFC 8171] 3 Invalid or inconsistent SIZE field value [RFC 8171] 4 Invalid frame for QTYPE 2 (other than SEND) [RFC 8171] 5 SEND frame sent as QTYPE 2 [RFC 8171] 6 Invalid frame for QTYPE 5 (such as multicast MacDA) [RFC 8171] 7-254 Unassigned 255 Reserved [RFC 8171] Licensing Terms