Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About syslog Parameters Created 2001-08-21 Last Updated 2016-04-26 Note The syslog protocol utilizes numerical facility and severity values. Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • syslog Message Facilities • syslog Message Severities • syslog Version Values • syslog Structured Data ID Values • syslog-sign Protocol Version Values • syslog-sign Hash Algorithm Values • syslog-sign Signature Scheme Values • syslog-sign SG Field Values • syslog-sign Key Blob Type Values syslog Message Facilities Registration Procedure(s) IETF Review Reference [RFC 5424] Available Formats [IMG] CSV Numerical Code Facility Reference 0 kernel messages [RFC 5424] 1 user-level messages [RFC 5424] 2 mail system [RFC 5424] 3 system daemons [RFC 5424] 4 security/authorization messages [1] [RFC 5424] 5 messages generated internally by syslogd [RFC 5424] 6 line printer subsystem [RFC 5424] 7 network news subsystem [RFC 5424] 8 UUCP subsystem [RFC 5424] 9 clock daemon [2] [RFC 5424] 10 security/authorization messages [1] [RFC 5424] 11 FTP daemon [RFC 5424] 12 NTP subsystem [RFC 5424] 13 log audit [1] [RFC 5424] 14 log alert [1] [RFC 5424] 15 clock daemon [2] [RFC 5424] 16 local use 0 (local0) [RFC 5424] 17 local use 1 (local1) [RFC 5424] 18 local use 2 (local2) [RFC 5424] 19 local use 3 (local3) [RFC 5424] 20 local use 4 (local4) [RFC 5424] 21 local use 5 (local5) [RFC 5424] 22 local use 6 (local6) [RFC 5424] 23 local use 7 (local7) [RFC 5424] syslog Message Severities Registration Procedure(s) IETF Review Reference [RFC 5424] Note REGISTRY FULL Available Formats [IMG] CSV Numerical Code Severity Reference 0 Emergency: system is unusable [RFC 5424] 1 Alert: action must be taken immediately [RFC 5424] 2 Critical: critical conditions [RFC 5424] 3 Error: error conditions [RFC 5424] 4 Warning: warning conditions [RFC 5424] 5 Notice: normal but significant condition [RFC 5424] 6 Informational: informational messages [RFC 5424] 7 Debug: debug-level messages [RFC 5424] syslog Version Values Registration Procedure(s) Standards Action Reference [RFC 5424] Available Formats [IMG] CSV Version Format Reference 1 Defined in [RFC 5424] [RFC 5424] syslog Structured Data ID Values Registration Procedure(s) IETF Review Reference [RFC 5424] Note The registration rules for this registry will be that new Structured Data ID values and new Parameter Name values must be registered via IETF Review. In addition, once SD-IDs and SD-PARAMs are defined, the syntax and semantics of these registrations must not be altered. In the event that modifications of existing registry items are required, a new SD-ID or SD-PARAM must be created, leaving the older one unchanged. Finally, the IANA does not register, and will not control SD-IDs or SD-PARAMs \with an "@" sign (ABNF %d64) in them. Available Formats [IMG] CSV Structured Data ID Structured Data Parameter Mandatory or Optional Reference timeQuality OPTIONAL [RFC 5424] tzKnown OPTIONAL [RFC 5424] isSynced OPTIONAL [RFC 5424] syncAccuracy OPTIONAL [RFC 5424] origin OPTIONAL [RFC 5424] ip OPTIONAL [RFC 5424] enterpriseId OPTIONAL [RFC 5424] software OPTIONAL [RFC 5424] swVersion OPTIONAL [RFC 5424] meta OPTIONAL [RFC 5424] sequenceId OPTIONAL [RFC 5424] sysUpTime OPTIONAL [RFC 5424] language OPTIONAL [RFC 5424] snmp OPTIONAL [RFC 5675] ctxEngine OPTIONAL [RFC 5675] ctxName OPTIONAL [RFC 5675] v OPTIONAL [RFC 5675] l OPTIONAL [RFC 5675] o OPTIONAL [RFC 5675] x OPTIONAL [RFC 5675] c OPTIONAL [RFC 5675] C OPTIONAL [RFC 5675] u OPTIONAL [RFC 5675] d OPTIONAL [RFC 5675] i OPTIONAL [RFC 5675] n OPTIONAL [RFC 5675] p OPTIONAL [RFC 5675] t OPTIONAL [RFC 5675] a OPTIONAL [RFC 5675] alarm OPTIONAL [RFC 5674] resource MANDATORY [RFC 5674] probableCause MANDATORY [RFC 5674] perceivedSeverity MANDATORY [RFC 5674] eventType OPTIONAL [RFC 5674] trendIndication OPTIONAL [RFC 5674] resourceURI OPTIONAL [RFC 5674] ssign MANDATORY [RFC 5848] VER MANDATORY [RFC 5848] RSID MANDATORY [RFC 5848] SG MANDATORY [RFC 5848] SPRI MANDATORY [RFC 5848] GBC MANDATORY [RFC 5848] FMN MANDATORY [RFC 5848] CNT MANDATORY [RFC 5848] HB MANDATORY [RFC 5848] SIGN MANDATORY [RFC 5848] ssign-cert MANDATORY [RFC 5848] VER MANDATORY [RFC 5848] RSID MANDATORY [RFC 5848] SG MANDATORY [RFC 5848] SPRI MANDATORY [RFC 5848] TPBL MANDATORY [RFC 5848] INDEX MANDATORY [RFC 5848] FLEN MANDATORY [RFC 5848] FRAG MANDATORY [RFC 5848] SIGN MANDATORY [RFC 5848] PCNNode OPTIONAL [RFC 6661] ID MANDATORY [RFC 6661] Rtyp MANDATORY [RFC 6661] PCNTerm OPTIONAL [RFC 6661] IngrID MANDATORY [RFC 6661] EgrID MANDATORY [RFC 6661] TermRate MANDATORY [RFC 6661] FCnt MANDATORY [RFC 6661] syslog-sign Protocol Version Values Registration Procedure(s) IETF Review Reference [RFC 5848] Available Formats [IMG] CSV Value Protocol Version Reference 00 Reserved [RFC 5848] 01 Defined in [RFC 5848] [RFC 5848] 02-50 Unassigned 51-99 Reserved for Private Use [RFC 5848] syslog-sign Hash Algorithm Values Registration Procedure(s) IETF Review Reference [RFC 5848] Note New values are assigned incrementally from 0-9, then from a-z, then from A-Z. Available Formats [IMG] CSV Value Protocol Version Hash Algorithm Reference 0 01 Reserved [RFC 5848] 1 01 SHA1 [RFC 5848] 2 01 SHA256 [RFC 5848] syslog-sign Signature Scheme Values Registration Procedure(s) IETF Review Reference [RFC 5848] Note The range for values is 0-9. Available Formats [IMG] CSV Value Protocol Version Signature Scheme Reference 0 01 Reserved [RFC 5848] 1 01 OpenPGP DSA [RFC 5848] syslog-sign SG Field Values Registration Procedure(s) IETF Review Reference [RFC 5848] Available Formats [IMG] CSV Value Meaning Reference 0 There is only one Signature Group. [RFC 5848] 1 Each PRI value is associated with its own Signature Group. [RFC 5848] 2 Each Signature Group contains a range of PRI Values. [RFC 5848] 3 Signature Groups are not assigned with any of the above relationships to PRI values of the syslog messages they sign. [RFC 5848] 4-7 Unassigned 8-9 Reserved for Private Use [RFC 5848] syslog-sign Key Blob Type Values Registration Procedure(s) IETF Review Reference [RFC 5848] Note Upper-case letters are assigned by IANA. Lower-case letters are vendor-specific. Available Formats [IMG] CSV Value Key Blob Type Reference C a PKIX certificate [RFC 5848] P an OpenPGP certificate [RFC 5848] K the public key whose corresponding private key is used to sign the messages [RFC 5848] N no key information sent, key is pre-distributed [RFC 5848] U installation-specific key exchange information [RFC 5848] Footnotes [1] Various operating systems have been found to utilize Facilities 4, 10, 13 and 14 for security/authorization, audit, and alert messages which seem to be similar. [2] Various operating systems have been found to utilize both Facilities 9 and 15 for clock (cron/at) messages. Licensing Terms