Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About Secure Shell (SSH) Protocol Parameters Created 2005-06-02 Last Updated 2026-09-08 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • Message Numbers • Disconnection Messages Reason Codes and Descriptions • Channel Connection Failure Reason Codes and Descriptions • Extended Channel Data Transfer data_type_code and Data • Pseudo-Terminal Encoded Terminal Modes • Service Names • Authentication Method Names • Connection Protocol Channel Types • Connection Protocol Global Request Names • Connection Protocol Channel Request Names • Signal Names • Connection Protocol Subsystem Names • Key Exchange Method Names • Encryption Algorithm Names • MAC Algorithm Names • Public Key Algorithm Names • Compression Algorithm Names • SSH Public-Key File Header Tags • Publickey Subsystem Request Names • Publickey Subsystem Response Names • Publickey Subsystem Attributes • Publickey Subsystem Status Codes • Extension Names • SSH Agent Protocol Message Type Numbers • SSH Agent Key Constraint Numbers • SSH Agent Key Constraint Extension Names • SSH Agent Signature Flags • SSH Agent Extension Request Names Message Numbers Registration Procedure(s) Standards Action Reference [RFC 4250] Available Formats [IMG] CSV Value Message ID Reference 0 Reserved 1 SSH_MSG_DISCONNECT [RFC 4253] 2 SSH_MSG_IGNORE [RFC 4253] 3 SSH_MSG_UNIMPLEMENTED [RFC 4253] 4 SSH_MSG_DEBUG [RFC 4253] 5 SSH_MSG_SERVICE_REQUEST [RFC 4253] 6 SSH_MSG_SERVICE_ACCEPT [RFC 4253] 7 SSH_MSG_EXT_INFO [RFC 8308] 8 SSH_MSG_NEWCOMPRESS [RFC 8308] 9-19 Unassigned (Transport layer generic) 20 SSH_MSG_KEXINIT [RFC 4253] 21 SSH_MSG_NEWKEYS [RFC 4253] 22-29 Unassigned (Algorithm negotiation) 30-49 Reserved (key exchange method specific) [RFC 4251] 50 SSH_MSG_USERAUTH_REQUEST [RFC 4252] 51 SSH_MSG_USERAUTH_FAILURE [RFC 4252] 52 SSH_MSG_USERAUTH_SUCCESS [RFC 4252] 53 SSH_MSG_USERAUTH_BANNER [RFC 4252] 54-59 Unassigned (User authentication generic) 60 SSH_MSG_USERAUTH_INFO_REQUEST [RFC 4256] 61 SSH_MSG_USERAUTH_INFO_RESPONSE [RFC 4256] 62-79 Reserved (User authentication method specific) [RFC 4251] 80 SSH_MSG_GLOBAL_REQUEST [RFC 4254] 81 SSH_MSG_REQUEST_SUCCESS [RFC 4254] 82 SSH_MSG_REQUEST_FAILURE [RFC 4254] 83-89 Unassigned (Connection protocol generic) 90 SSH_MSG_CHANNEL_OPEN [RFC 4254] 91 SSH_MSG_CHANNEL_OPEN_CONFIRMATION [RFC 4254] 92 SSH_MSG_CHANNEL_OPEN_FAILURE [RFC 4254] 93 SSH_MSG_CHANNEL_WINDOW_ADJUST [RFC 4254] 94 SSH_MSG_CHANNEL_DATA [RFC 4254] 95 SSH_MSG_CHANNEL_EXTENDED_DATA [RFC 4254] 96 SSH_MSG_CHANNEL_EOF [RFC 4254] 97 SSH_MSG_CHANNEL_CLOSE [RFC 4254] 98 SSH_MSG_CHANNEL_REQUEST [RFC 4254] 99 SSH_MSG_CHANNEL_SUCCESS [RFC 4254] 100 SSH_MSG_CHANNEL_FAILURE [RFC 4254] 101-127 Unassigned (Channel related messages) 128-191 Reserved (for client protocols) 192-255 Reserved for Private Use (local extensions) Disconnection Messages Reason Codes and Descriptions Expert(s) Peter Yee, Markus Stenberg Reference [RFC 4250][RFC 9519] Note SSH_MSG_DISCONNECT 'description' and 'reason code' values Note Registration requests should be sent to the mailing list described in [RFC 9519]. If approved, designated experts should notify IANA within three weeks. For assistance, please contact iana@iana.org. Available Formats [IMG] CSV Range Registration Procedures 0x00000001-0xFDFFFFFF Expert Review 0xFE000000-0xFFFFFFFF Reserved for Private Use Reason Code Symbolic Name Reference 0x00000000 Reserved 0x00000001 SSH_DISCONNECT_HOST_NOT_ALLOWED_TO_CONNECT [RFC 4253] 0x00000002 SSH_DISCONNECT_PROTOCOL_ERROR [RFC 4253] 0x00000003 SSH_DISCONNECT_KEY_EXCHANGE_FAILED [RFC 4253] 0x00000004 SSH_DISCONNECT_RESERVED [RFC 4253] 0x00000005 SSH_DISCONNECT_MAC_ERROR [RFC 4253] 0x00000006 SSH_DISCONNECT_COMPRESSION_ERROR [RFC 4253] 0x00000007 SSH_DISCONNECT_SERVICE_NOT_AVAILABLE [RFC 4253] 0x00000008 SSH_DISCONNECT_PROTOCOL_VERSION_NOT_SUPPORTED [RFC 4253] 0x00000009 SSH_DISCONNECT_HOST_KEY_NOT_VERIFIABLE [RFC 4253] 0x0000000A SSH_DISCONNECT_CONNECTION_LOST [RFC 4253] 0x0000000B SSH_DISCONNECT_BY_APPLICATION [RFC 4253] 0x0000000C SSH_DISCONNECT_TOO_MANY_CONNECTIONS [RFC 4253] 0x0000000D SSH_DISCONNECT_AUTH_CANCELLED_BY_USER [RFC 4253] 0x0000000E SSH_DISCONNECT_NO_MORE_AUTH_METHODS_AVAILABLE [RFC 4253] 0x0000000F SSH_DISCONNECT_ILLEGAL_USER_NAME [RFC 4253] 0x00000010-0xFDFFFFFF Unassigned 0xFE000000-0xFFFFFFFF Reserved for Private Use Channel Connection Failure Reason Codes and Descriptions Expert(s) Peter Yee, Markus Stenberg Reference [RFC 4250][RFC 9519] Note 'reason code' values and 'description' values Note Registration requests should be sent to the mailing list described in [RFC 9519]. If approved, designated experts should notify IANA within three weeks. For assistance, please contact iana@iana.org. Available Formats [IMG] CSV Range Registration Procedures 0x00000001-0xFDFFFFFF Expert Review 0xFE000000-0xFFFFFFFF Reserved for Private Use Reason Code Symbolic Name Reference 0x00000000 Reserved 0x00000001 SSH_OPEN_ADMINISTRATIVELY_PROHIBITED [RFC 4254] 0x00000002 SSH_OPEN_CONNECT_FAILED [RFC 4254] 0x00000003 SSH_OPEN_UNKNOWN_CHANNEL_TYPE [RFC 4254] 0x00000004 SSH_OPEN_RESOURCE_SHORTAGE [RFC 4254] 0x00000005-0xFDFFFFFF Unassigned 0xFE000000-0xFFFFFFFF Reserved for Private Use Extended Channel Data Transfer data_type_code and Data Expert(s) Peter Yee, Markus Stenberg Reference [RFC 4250][RFC 9519] Note 'data_type_code' values and 'data' values Note Registration requests should be sent to the mailing list described in [RFC 9519]. If approved, designated experts should notify IANA within three weeks. For assistance, please contact iana@iana.org. Available Formats [IMG] CSV Range Registration Procedures 0x00000001-0xFDFFFFFF Expert Review 0xFE000000-0xFFFFFFFF Reserved for Private Use data_type_code Symbolic Name Reference 0x00000000 Reserved 0x00000001 SSH_EXTENDED_DATA_STDERR [RFC 4254] 0x00000002-0xFDFFFFFF Unassigned 0xFE000000-0xFFFFFFFF Reserved for Private Use Pseudo-Terminal Encoded Terminal Modes Registration Procedure(s) Expert Review Expert(s) Peter Yee, Markus Stenberg Reference [RFC 4250][RFC 9519] Note opcode and argument values which make up the "encoded terminal modes" values Note Registration requests should be sent to the mailing list described in [RFC 9519]. If approved, designated experts should notify IANA within three weeks. For assistance, please contact iana@iana.org. Available Formats [IMG] CSV Opcode Argument Description Reference Note 0 TTY_OP_END Indicates end of options. [RFC 4250] 1 VINTR Interrupt character; 255 if none. Similarly for the other characters. Not all of these characters are [RFC 4254] Section 8 supported on all systems. 2 VQUIT The quit character (sends SIGQUIT signal on POSIX systems). [RFC 4254] Section 8 3 VERASE Erase the character to left of the cursor. [RFC 4254] Section 8 4 VKILL Kill the current input line. [RFC 4254] Section 8 5 VEOF End-of-file character (sends EOF from the terminal). [RFC 4254] Section 8 6 VEOL End-of-line character in addition to carriage return and/or linefeed. [RFC 4254] Section 8 7 VEOL2 Additional end-of-line character. [RFC 4254] Section 8 8 VSTART Continues paused output (normally control-Q). [RFC 4254] Section 8 9 VSTOP Pauses output (normally control-S). [RFC 4254] Section 8 10 VSUSP Suspends the current program. [RFC 4254] Section 8 11 VDSUSP Another suspend character. [RFC 4254] Section 8 12 VREPRINT Reprints the current input line. [RFC 4254] Section 8 13 VWERASE Erases a word left of cursor. [RFC 4254] Section 8 14 VLNEXT Enter the next character typed literally, even if it is a special character [RFC 4254] Section 8 15 VFLUSH Character to flush output. [RFC 4254] Section 8 16 VSWTCH Switch to a different shell layer. [RFC 4254] Section 8 17 VSTATUS Prints system status line (load, command, pid, etc). [RFC 4254] Section 8 18 VDISCARD Toggles the flushing of terminal output. [RFC 4254] Section 8 19-29 Unassigned 30 IGNPAR The ignore parity flag. The parameter SHOULD be 0 if this flag is FALSE, and 1 if it is TRUE. [RFC 4254] Section 8 31 PARMRK Mark parity and framing errors. [RFC 4254] Section 8 32 INPCK Enable checking of parity errors. [RFC 4254] Section 8 33 ISTRIP Strip 8th bit off characters. [RFC 4254] Section 8 34 INLCR Map NL into CR on input. [RFC 4254] Section 8 35 IGNCR Ignore CR on input. [RFC 4254] Section 8 36 ICRNL Map CR to NL on input. [RFC 4254] Section 8 37 IUCLC Translate uppercase characters to lowercase. [RFC 4254] Section 8 38 IXON Enable output flow control. [RFC 4254] Section 8 39 IXANY Any char will restart after stop. [RFC 4254] Section 8 40 IXOFF Enable input flow control. [RFC 4254] Section 8 41 IMAXBEL Ring bell on input queue full. [RFC 4254] Section 8 42 IUTF8 Terminal input and output is assumed to be encoded in UTF-8. [RFC 8160] 43-49 Unassigned 50 ISIG Enable signals INTR, QUIT, [D]SUSP. [RFC 4254] Section 8 51 ICANON Canonicalize input lines. [RFC 4254] Section 8 52 XCASE Enable input and output of uppercase characters by preceding their lowercase equivalents with "\". [RFC 4254] Section 8 53 ECHO Enable echoing. [RFC 4254] Section 8 54 ECHOE Visually erase chars. [RFC 4254] Section 8 55 ECHOK Kill character discards current line. [RFC 4254] Section 8 56 ECHONL Echo NL even if ECHO is off. [RFC 4254] Section 8 57 NOFLSH Don't flush after interrupt. [RFC 4254] Section 8 58 TOSTOP Stop background jobs from output. [RFC 4254] Section 8 59 IEXTEN Enable extensions. [RFC 4254] Section 8 60 ECHOCTL Echo control characters as ^(Char). [RFC 4254] Section 8 61 ECHOKE Visual erase for line kill. [RFC 4254] Section 8 62 PENDIN Retype pending input. [RFC 4254] Section 8 63-69 Unassigned 70 OPOST Enable output processing. [RFC 4254] Section 8 71 OLCUC Convert lowercase to uppercase. [RFC 4254] Section 8 72 ONLCR Map NL to CR-NL. [RFC 4254] Section 8 73 OCRNL Translate carriage return to newline (output). [RFC 4254] Section 8 74 ONOCR Translate newline to carriage return-newline (output). [RFC 4254] Section 8 75 ONLRET Newline performs a carriage return (output). [RFC 4254] Section 8 76-89 Unassigned 90 CS7 7 bit mode. [RFC 4254] Section 8 91 CS8 8 bit mode. [RFC 4254] Section 8 92 PARENB Parity enable. [RFC 4254] Section 8 93 PARODD Odd parity, else even. [RFC 4254] Section 8 94-127 Unassigned 128 TTY_OP_ISPEED Specifies the input baud rate in bits per second. [RFC 4254] Section 8 129 TTY_OP_OSPEED Specifies the output baud rate in bits per second. [RFC 4254] Section 8 130-255 Unassigned Service Names Registration Procedure(s) Expert Review Expert(s) Peter Yee, Markus Stenberg Reference [RFC 4250][RFC 9519] Note Registration requests should be sent to the mailing list described in [RFC 9519]. If approved, designated experts should notify IANA within three weeks. For assistance, please contact iana@iana.org. Available Formats [IMG] CSV Service Name Reference ssh-userauth [RFC 4252] ssh-connection [RFC 4254] Authentication Method Names Registration Procedure(s) Expert Review Expert(s) Peter Yee, Markus Stenberg Reference [RFC 4250][RFC 9519] Note Registration requests should be sent to the mailing list described in [RFC 9519]. If approved, designated experts should notify IANA within three weeks. For assistance, please contact iana@iana.org. Available Formats [IMG] CSV Method Name Reference Note publickey [RFC 4252] Section 7 password [RFC 4252] Section 8 hostbased [RFC 4252] Section 9 none [RFC 4252] Section 5.2 keyboard-interactive [RFC 4256] gssapi-with-mic [RFC 4462] gssapi-keyex [RFC 4462] gssapi [RFC 4462] external-keyx [RFC 4462] Connection Protocol Channel Types Registration Procedure(s) Expert Review Expert(s) Peter Yee, Markus Stenberg Reference [RFC 4250][RFC 9519] Note Registration requests should be sent to the mailing list described in [RFC 9519]. If approved, designated experts should notify IANA within three weeks. For assistance, please contact iana@iana.org. Available Formats [IMG] CSV Channel Type Reference Note session [RFC 4254] Section 6.1 x11 [RFC 4254] Section 6.3.2 forwarded-tcpip [RFC 4254] Section 7.2 direct-tcpip [RFC 4254] Section 7.2 agent-connect [RFC 9987] Section 7.3 Connection Protocol Global Request Names Registration Procedure(s) Expert Review Expert(s) Peter Yee, Markus Stenberg Reference [RFC 4250][RFC 9519] Note Registration requests should be sent to the mailing list described in [RFC 9519]. If approved, designated experts should notify IANA within three weeks. For assistance, please contact iana@iana.org. Available Formats [IMG] CSV Request Type Reference Note tcpip-forward [RFC 4254] Section 7.1 cancel-tcpip-forward [RFC 4254] Section 7.1 Connection Protocol Channel Request Names Registration Procedure(s) Expert Review Expert(s) Peter Yee, Markus Stenberg Reference [RFC 4250][RFC 9519] Note Registration requests should be sent to the mailing list described in [RFC 9519]. If approved, designated experts should notify IANA within three weeks. For assistance, please contact iana@iana.org. Available Formats [IMG] CSV Request Type Reference Note pty-req [RFC 4254] Section 6.2 x11-req [RFC 4254] Section 6.3.1 env [RFC 4254] Section 6.4 shell [RFC 4254] Section 6.5 exec [RFC 4254] Section 6.5 subsystem [RFC 4254] Section 6.5 window-change [RFC 4254] Section 6.7 xon-xoff [RFC 4254] Section 6.8 signal [RFC 4254] Section 6.9 exit-status [RFC 4254] Section 6.10 exit-signal [RFC 4254] Section 6.10 break [RFC 4335] agent-req [RFC 9987] Section 7.2 Signal Names Registration Procedure(s) Expert Review Expert(s) Peter Yee, Markus Stenberg Reference [RFC 4250][RFC 9519] Note Registration requests should be sent to the mailing list described in [RFC 9519]. If approved, designated experts should notify IANA within three weeks. For assistance, please contact iana@iana.org. Available Formats [IMG] CSV Signal Reference ABRT [RFC 4254] ALRM [RFC 4254] FPE [RFC 4254] HUP [RFC 4254] ILL [RFC 4254] INT [RFC 4254] KILL [RFC 4254] PIPE [RFC 4254] QUIT [RFC 4254] SEGV [RFC 4254] TERM [RFC 4254] USR1 [RFC 4254] USR2 [RFC 4254] Connection Protocol Subsystem Names Registration Procedure(s) Expert Review Expert(s) Peter Yee, Markus Stenberg Reference [RFC 4250][RFC 9519] Note Registration requests should be sent to the mailing list described in [RFC 9519]. If approved, designated experts should notify IANA within three weeks. For assistance, please contact iana@iana.org. Available Formats [IMG] CSV Subsystem Name Reference publickey [RFC 4819] snmp [RFC 5592] netconf [RFC 6242] rpki-rtr [RFC 6810] Key Exchange Method Names Registration Procedure(s) Expert Review Expert(s) Peter Yee, Markus Stenberg Reference [RFC 4250][RFC 9142][RFC 9519] Note *All values beginning with the specified string and not containing "@". Note “OK to Implement” guidance entries for registrations that pre-date [RFC 9142] are found in Table 12 in [Section 4 of RFC 9142]. Note When this registry is modified, the YANG module "iana-ssh-key-exchange-algs" [YANG Parameters] must be updated as defined in [RFC 9644]. Note Registration requests should be sent to the mailing list described in [RFC 9519]. If approved, designated experts should notify IANA within three weeks. For assistance, please contact iana@iana.org. Available Formats [IMG] CSV Method Name Reference Note OK to Implement diffie-hellman-group-exchange-sha1 [RFC 4419]; [RFC 8270] Section 4.1 SHOULD NOT diffie-hellman-group-exchange-sha256 [RFC 4419]; [RFC 8270] Section 4.2 MAY diffie-hellman-group1-sha1 [RFC 4253] Section 8.1 SHOULD NOT diffie-hellman-group14-sha1 [RFC 4253] Section 8.2 MAY diffie-hellman-group14-sha256 [RFC 8268] MUST diffie-hellman-group15-sha512 [RFC 8268] MAY diffie-hellman-group16-sha512 [RFC 8268] SHOULD diffie-hellman-group17-sha512 [RFC 8268] MAY diffie-hellman-group18-sha512 [RFC 8268] MAY ecdh-sha2-* [RFC 5656] MAY ecmqv-sha2 [RFC 5656] MAY gss-group1-sha1-* [RFC 4462]; [RFC 8732] SHOULD NOT gss-group14-sha1-* [RFC 4462]; [RFC 8732] SHOULD NOT gss-gex-sha1-* [RFC 4462]; [RFC 8732] SHOULD NOT gss- [RFC 4462] Section 2.6 reserved rsa1024-sha1 [RFC 4432] MUST NOT rsa2048-sha256 [RFC 4432] MAY ext-info-s [RFC 8308] Section 2 SHOULD ext-info-c [RFC 8308] Section 2 SHOULD gss-group14-sha256-* [RFC 8732] SHOULD gss-group15-sha512-* [RFC 8732] MAY gss-group16-sha512-* [RFC 8732] MAY gss-group17-sha512-* [RFC 8732] MAY gss-group18-sha512-* [RFC 8732] MAY gss-nistp256-sha256-* [RFC 8732] SHOULD gss-nistp384-sha384-* [RFC 8732] SHOULD gss-nistp521-sha512-* [RFC 8732] SHOULD gss-curve25519-sha256-* [RFC 8732] SHOULD gss-curve448-sha512-* [RFC 8732] MAY curve25519-sha256 [RFC 8731] SHOULD curve448-sha512 [RFC 8731] MAY ecdh-sha2-nistp256 [RFC 5656] SHOULD ecdh-sha2-nistp384 [RFC 5656] SHOULD ecdh-sha2-nistp521 [RFC 5656] SHOULD sntrup761x25519-sha512 [RFC 9941] SHOULD mlkem768nistp256-sha256 [RFC 10042] SHOULD mlkem1024nistp384-sha384 [RFC 10042] SHOULD mlkem768x25519-sha256 [RFC 10042] SHOULD mlkem512-sha256 [draft-harrison-mlkem-ssh-01] MAY mlkem768-sha256 [draft-harrison-mlkem-ssh-01] MAY mlkem1024-sha384 [draft-harrison-mlkem-ssh-01] MAY Encryption Algorithm Names Registration Procedure(s) Expert Review Expert(s) Peter Yee, Markus Stenberg Reference [RFC 4250][RFC 9519] Note When this registry is modified, the YANG module "iana-ssh-encryption-algs" [YANG Parameters] must be updated as defined in [RFC 9644]. Note Registration requests should be sent to the mailing list described in [RFC 9519]. If approved, designated experts should notify IANA within three weeks. For assistance, please contact iana@iana.org. Available Formats [IMG] CSV Encryption Algorithm Name Reference Note 3des-cbc [RFC 4253] Section 6.3 blowfish-cbc [RFC 4253] Section 6.3 twofish256-cbc [RFC 4253] Section 6.3 twofish-cbc [RFC 4253] Section 6.3 twofish192-cbc [RFC 4253] Section 6.3 twofish128-cbc [RFC 4253] Section 6.3 aes256-cbc [RFC 4253] Section 6.3 aes192-cbc [RFC 4253] Section 6.3 aes128-cbc [RFC 4253] Section 6.3 serpent256-cbc [RFC 4253] Section 6.3 serpent192-cbc [RFC 4253] Section 6.3 serpent128-cbc [RFC 4253] Section 6.3 arcfour [RFC 8758] HISTORIC idea-cbc [RFC 4253] Section 6.3 cast128-cbc [RFC 4253] Section 6.3 none [RFC 4253] Section 6.3 des-cbc [FIPS-46-3] HISTORIC, See page 4 arcfour128 [RFC 8758] HISTORIC arcfour256 [RFC 8758] HISTORIC aes128-ctr [RFC 4344] aes192-ctr [RFC 4344] aes256-ctr [RFC 4344] 3des-ctr [RFC 4344] blowfish-ctr [RFC 4344] twofish128-ctr [RFC 4344] twofish192-ctr [RFC 4344] twofish256-ctr [RFC 4344] serpent128-ctr [RFC 4344] serpent192-ctr [RFC 4344] serpent256-ctr [RFC 4344] idea-ctr [RFC 4344] cast128-ctr [RFC 4344] AEAD_AES_128_GCM [RFC 5647] Section 6.1 AEAD_AES_256_GCM [RFC 5647] Section 6.2 chacha20-poly1305 [draft-josefsson-ssh-chacha20-poly1305-openssh-01] MAC Algorithm Names Registration Procedure(s) Expert Review Expert(s) Peter Yee, Markus Stenberg Reference [RFC 4250][RFC 9519] Note When this registry is modified, the YANG module "iana-ssh-mac-algs" [YANG Parameters] must be updated as defined in [RFC 9644]. Note Registration requests should be sent to the mailing list described in [RFC 9519]. If approved, designated experts should notify IANA within three weeks. For assistance, please contact iana@iana.org. Available Formats [IMG] CSV MAC Algorithm Name Reference Note hmac-sha1 [RFC 4253] Section 6.4 hmac-sha1-96 [RFC 4253] Section 6.4 hmac-md5 [RFC 4253] Section 6.4 hmac-md5-96 [RFC 4253] Section 6.4 none [RFC 4253] Section 6.4 AEAD_AES_128_GCM [RFC 5647] Section 6.1 AEAD_AES_256_GCM [RFC 5647] Section 6.2 hmac-sha2-256 [RFC 6668] Section 2 hmac-sha2-512 [RFC 6668] Section 2 Public Key Algorithm Names Registration Procedure(s) Expert Review Expert(s) Peter Yee, Markus Stenberg Reference [RFC 4250][RFC 9519] Note *All values beginning with the specified string and not containing "@". Note When this registry is modified, the YANG module "iana-ssh-public-key-algs" [YANG Parameters] must be updated as defined in [RFC 9644]. Note Registration requests should be sent to the mailing list described in [RFC 9519]. If approved, designated experts should notify IANA within three weeks. For assistance, please contact iana@iana.org. Available Formats [IMG] CSV Public Key Algorithm Name Public Key Format Reference Note ssh-dss ssh-dss [RFC 4253] Section 6.6 ssh-rsa ssh-rsa [RFC 4253] Section 6.6 rsa-sha2-256 ssh-rsa [RFC 8332] Section 3 rsa-sha2-512 ssh-rsa [RFC 8332] Section 3 spki-sign-rsa spki-sign-rsa [RFC 4253] Section 6.6 spki-sign-dss spki-sign-dss [RFC 4253] Section 6.6 pgp-sign-rsa pgp-sign-rsa [RFC 4253] Section 6.6 pgp-sign-dss pgp-sign-dss [RFC 4253] Section 6.6 null null [RFC 4462] Section 5 ecdsa-sha2-* ecdsa-sha2-* [RFC 5656] x509v3-ssh-dss x509v3-ssh-dss [RFC 6187] x509v3-ssh-rsa x509v3-ssh-rsa [RFC 6187] x509v3-rsa2048-sha256 x509v3-rsa2048-sha256 [RFC 6187] x509v3-ecdsa-sha2-* x509v3-ecdsa-sha2-* [RFC 6187] ssh-ed25519 ssh-ed25519 [RFC 8709] ssh-ed448 ssh-ed448 [RFC 8709] ssh-mldsa-44 ssh-mldsa-44 [draft-sfluhrer-ssh-mldsa-08] ssh-mldsa-65 ssh-mldsa-65 [draft-sfluhrer-ssh-mldsa-08] ssh-mldsa-87 ssh-mldsa-87 [draft-sfluhrer-ssh-mldsa-08] ssh-mldsa44-ed25519 ssh-mldsa44-ed25519 [draft-ietf-sshm-composite-sigs-00] ssh-mldsa87-p384 ssh-mldsa87-p384 [draft-ietf-sshm-composite-sigs-00] Compression Algorithm Names Registration Procedure(s) Expert Review Expert(s) Peter Yee, Markus Stenberg Reference [RFC 4250][RFC 9519] Note Registration requests should be sent to the mailing list described in [RFC 9519]. If approved, designated experts should notify IANA within three weeks. For assistance, please contact iana@iana.org. Available Formats [IMG] CSV Compression Algorithm Name Reference Note none [RFC 4253] Section 6.2 zlib [RFC 4253] Section 6.2 SSH Public-Key File Header Tags Registration Procedure(s) Expert Review Expert(s) Peter Yee, Markus Stenberg Reference [RFC 4716][RFC 9519] Note Tags beginning with x- Reserved for Private Use Note Registration requests should be sent to the mailing list described in [RFC 9519]. If approved, designated experts should notify IANA within three weeks. For assistance, please contact iana@iana.org. Available Formats [IMG] CSV Header Tag Reference Note subject [RFC 4716] Section 3.3.1 comment [RFC 4716] Section 3.3.2 Publickey Subsystem Request Names Registration Procedure(s) Expert Review Expert(s) Peter Yee, Markus Stenberg Reference [RFC 4819][RFC 9519] Note Registration requests should be sent to the mailing list described in [RFC 9519]. If approved, designated experts should notify IANA within three weeks. For assistance, please contact iana@iana.org. Available Formats [IMG] CSV Request Name Reference version [RFC 4819] add [RFC 4819] remove [RFC 4819] list [RFC 4819] listattributes [RFC 4819] Publickey Subsystem Response Names Registration Procedure(s) Expert Review Expert(s) Peter Yee, Markus Stenberg Reference [RFC 4819][RFC 9519] Note Registration requests should be sent to the mailing list described in [RFC 9519]. If approved, designated experts should notify IANA within three weeks. For assistance, please contact iana@iana.org. Available Formats [IMG] CSV Response Name Reference version [RFC 4819] status [RFC 4819] publickey [RFC 4819] attribute [RFC 4819] Publickey Subsystem Attributes Registration Procedure(s) Expert Review Expert(s) Peter Yee, Markus Stenberg Reference [RFC 4819][RFC 9519] Note Registration requests should be sent to the mailing list described in [RFC 9519]. If approved, designated experts should notify IANA within three weeks. For assistance, please contact iana@iana.org. Available Formats [IMG] CSV Attribute Name Reference comment [RFC 4819] comment-language [RFC 4819] command-override [RFC 4819] subsystem [RFC 4819] x11 [RFC 4819] shell [RFC 4819] exec [RFC 4819] agent [RFC 4819] env [RFC 4819] from [RFC 4819] port-forward [RFC 4819] reverse-forward [RFC 4819] Publickey Subsystem Status Codes Reference [RFC 4819] Available Formats [IMG] CSV Range Registration Procedures 0-191 Standards Action 192-255 Reserved for Private Use Value Status Code Reference 0 SSH_PUBLICKEY_SUCCESS [RFC 4819] 1 SSH_PUBLICKEY_ACCESS_DENIED [RFC 4819] 2 SSH_PUBLICKEY_STORAGE_EXCEEDED [RFC 4819] 3 SSH_PUBLICKEY_VERSION_NOT_SUPPORTED [RFC 4819] 4 SSH_PUBLICKEY_KEY_NOT_FOUND [RFC 4819] 5 SSH_PUBLICKEY_KEY_NOT_SUPPORTED [RFC 4819] 6 SSH_PUBLICKEY_KEY_ALREADY_PRESENT [RFC 4819] 7 SSH_PUBLICKEY_GENERAL_FAILURE [RFC 4819] 8 SSH_PUBLICKEY_REQUEST_NOT_SUPPORTED [RFC 4819] 9 SSH_PUBLICKEY_ATTRIBUTE_NOT_SUPPORTED [RFC 4819] 10-191 Standards Action 192-255 Reserved Extension Names Registration Procedure(s) Expert Review Expert(s) Peter Yee, Markus Stenberg Reference [RFC 8308][RFC 9519] Note Names in the Extension Names table MUST follow the Conventions for Names defined in [RFC 4250, Section 4.6.1]. Note Registration requests should be sent to the mailing list described in [RFC 9519]. If approved, designated experts should notify IANA within three weeks. For assistance, please contact iana@iana.org. Available Formats [IMG] CSV Extension Name Reference Note server-sig-algs [RFC 8308] Section 3.1 delay-compression [RFC 8308] Section 3.2 no-flow-control [RFC 8308] Section 3.3 elevation [RFC 8308] Section 3.4 agent-forward [RFC 9987] Section 7.1 SSH Agent Protocol Message Type Numbers Expert(s) Damien Miller, Markus Friedl Reference [RFC 9987] Available Formats [IMG] CSV Range Registration Procedures 0-239 Expert Review 240-255 Private Use Number Identifier Reference 0 Reserved [RFC 9987, Section 8.1.1] 1 Reserved [RFC 9987, Section 8.1.1] 2 Reserved [RFC 9987, Section 8.1.1] 3 Reserved [RFC 9987, Section 8.1.1] 4 Reserved [RFC 9987, Section 8.1.1] 5 SSH_AGENT_FAILURE [RFC 9987, Section 5.1, 8.1] 6 SSH_AGENT_SUCCESS [RFC 9987, Section 5.1, 8.1] 7 Reserved [RFC 9987, Section 8.1.1] 8 Reserved [RFC 9987, Section 8.1.1] 9 Reserved [RFC 9987, Section 8.1.1] 10 Reserved [RFC 9987, Section 8.1.1] 11 SSH_AGENTC_REQUEST_IDENTITIES [RFC 9987, Section 5.5, 8.1] 12 SSH_AGENT_IDENTITIES_ANSWER [RFC 9987, Section 5.5, 8.1] 13 SSH_AGENTC_SIGN_REQUEST [RFC 9987, Section 5.6, 8.1] 14 SSH_AGENT_SIGN_RESPONSE [RFC 9987, Section 5.6, 8.1] 15 Reserved [RFC 9987, Section 8.1.1] 16 Reserved [RFC 9987, Section 8.1.1] 17 SSH_AGENTC_ADD_IDENTITY [RFC 9987, Section 5.2, 8.1] 18 SSH_AGENTC_REMOVE_IDENTITY [RFC 9987, Section 5.4, 8.1] 19 SSH_AGENTC_REMOVE_ALL_IDENTITIES [RFC 9987, Section 5.4, 8.1] 20 SSH_AGENTC_ADD_SMARTCARD_KEY [RFC 9987, Section 5.2.6, 8.1] 21 SSH_AGENTC_REMOVE_SMARTCARD_KEY [RFC 9987, Section 5.4, 8.1] 22 SSH_AGENTC_LOCK [RFC 9987, Section 5.7, 8.1] 23 SSH_AGENTC_UNLOCK [RFC 9987, Section 5.7, 8.1] 24 Reserved [RFC 9987, Section 8.1.1] 25 SSH_AGENTC_ADD_ID_CONSTRAINED [RFC 9987, Section 5.2, 8.1] 26 SSH_AGENTC_ADD_SMARTCARD_KEY_CONSTRAINED [RFC 9987, Section 5.2.6, 8.1] 27 SSH_AGENTC_EXTENSION [RFC 9987, Section 5.8, 8.1] 28 SSH_AGENT_EXTENSION_FAILURE [RFC 9987, Section 5.8, 8.1] 29 SSH_AGENT_EXTENSION_RESPONSE [RFC 9987, Section 5.8, 8.1] 30-239 Unassigned 240-255 Reserved for Private Use [RFC 9987, Section 8.1] SSH Agent Key Constraint Numbers Registration Procedure(s) Expert Review Expert(s) Damien Miller, Markus Friedl Reference [RFC 9987] Available Formats [IMG] CSV Number Identifier Reference 0 Reserved [RFC 9987, Section 8.2] 1 SSH_AGENT_CONSTRAIN_LIFETIME [RFC 9987, Section 8.2] 2 SSH_AGENT_CONSTRAIN_CONFIRM [RFC 9987, Section 8.2] 3-254 Unassigned 255 SSH_AGENT_CONSTRAIN_EXTENSION [RFC 9987, Section 8.2] SSH Agent Key Constraint Extension Names Registration Procedure(s) Expert Review Expert(s) Damien Miller, Markus Friedl Reference [RFC 9987] Number Identifier Reference No registrations at this time. SSH Agent Signature Flags Registration Procedure(s) Expert Review Expert(s) Damien Miller, Markus Friedl Reference [RFC 9987] Available Formats [IMG] CSV Number Identifier Reference 0x01 Reserved [RFC 9987, Section 8.3] 0x02 SSH_AGENT_RSA_SHA2_256 [RFC 9987, Section 8.3] 0x04 SSH_AGENT_RSA_SHA2_512 [RFC 9987, Section 8.3] SSH Agent Extension Request Names Registration Procedure(s) Expert Review Expert(s) Damien Miller, Markus Friedl Reference [RFC 9987] Available Formats [IMG] CSV Extension Name Reference query [RFC 9987, Section 5.8.1] Licensing Terms