Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About Simple Network Management Protocol (SNMP) Number Spaces Last Updated 2016-05-03 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • Security Models • Message Processing Models • SnmpEngineID Formats • SnmpAuthProtocols • SnmpPrivProtocols • SNMP Transport Domains Security Models Registration Procedure(s) Standards Action Reference [RFC 3411] Note The SnmpSecurityModel TEXTUAL-CONVENTION values managed by IANA are in the range from 0 to 255 inclusive, and are reserved for standards- track Security Models. If this range should in the future prove insufficient, an enterprise number can be allocated to obtain an additional 255 possible values. There are several values of securityModel defined for use with SNMP or reserved for use with supporting MIB objects. They are as follows: Available Formats [IMG] CSV Value Description Reference 0 reserved for 'any' [RFC 3411] 1 reserved for SNMPv1 [RFC 3411] 2 reserved for SNMPv2c [RFC 3411] 3 User-Based Security Model (USM) [RFC 3411] 4 Transport Security Model (TSM) [RFC 5591] 5-255 Unassigned Message Processing Models Registration Procedure(s) Standards Action Reference [RFC 3411] Note The SnmpMessageProcessingModel TEXTUAL-CONVENTION values managed by IANA are in the range 0 to 255, inclusive. Each value uniquely identifies a standards-track Message Processing Model of the Message Processing Subsystem within a SNMP Management Architecture. Should this range prove insufficient in the future, an enterprise number may be obtained for the standards committee to get an additional 256 possible values. Available Formats [IMG] CSV Value Description Reference 0 reserved for SNMPv1 [RFC 3411] 1 reserved for SNMPv2c [RFC 3411] 2 reserved for SNMPv2u and SNMPv2* [RFC 3411] 3 reserved for SNMPv3 [RFC 3411] 4-255 Unassigned SnmpEngineID Formats Expert(s) Unassigned Reference [RFC 3411][RFC 5343] Available Formats [IMG] CSV Range Registration Procedures Note 1-127 Specification Required 128-255 Enterprise-specific IANA does not assign Format Description Reference 0 Reserved [RFC 3411] 1 IPv4 address [RFC 3411] 2 IPv6 address [RFC 3411] 3 MAC address [RFC 3411] 4 administratively assigned text [RFC 3411] 5 administratively assigned octets [RFC 3411] 6 local engine [RFC 5343] 7-127 Unassigned 128-255 Enterprise-specific [RFC 3411] SnmpAuthProtocols Registration Procedure(s) Standards Action Reference [RFC 3411] Note IETF standard protocols for SNMPv3 authentication and privacy The MIB module defined in [RFC 3411] defines this OBJECT-IDENTITY as registration points. Available Formats [IMG] CSV Value Description Reference 0 Reserved [RFC 3411] 1 usmNoAuthProtocol - no authentication [RFC 3414] 2 usmHMACMD5AuthProtocol - HMAC-MD5-96 [RFC 3414] 3 usmHMACSHAAuthProtocol - HMAC-SHA-96 [RFC 3414] 4 usmHMAC128SHA224AuthProtocol [RFC 7860] 5 usmHMAC192SHA256AuthProtocol [RFC 7860] 6 usmHMAC256SHA384AuthProtocol [RFC 7860] 7 usmHMAC384SHA512AuthProtocol [RFC 7860] SnmpPrivProtocols Registration Procedure(s) Standards Action Reference [RFC 3411] Note IETF standard protocols for SNMPv3 authentication and privacy The MIB module defined in [RFC 3411] defines this OBJECT-IDENTITY as registration points. Available Formats [IMG] CSV Value Description Reference 0 Reserved [RFC 3411] 1 usmNoPrivProtocol - no privacy [RFC 3414] 2 usmDESPrivProtocol - CBC-DES [RFC 3414] 3 Reserved 4 usmAesCfb128Protocol - AES-CFB-128 [RFC 3826] SNMP Transport Domains Registration Procedure(s) Specification Required Expert(s) Unassigned Reference [RFC 2578][RFC 3417][RFC 5590] Note Each domain is assigned a MIB-defined OID under snmpDomains. Available Formats [IMG] CSV Prefix SnmpDomains Reference udp snmpUDPDomain [RFC 3417]; [RFC 5590] clns snmpCLNSDomain [RFC 3417]; [RFC 5590] cons snmpCONSDomain [RFC 3417]; [RFC 5590] ddp snmpDDPDomain [RFC 3417]; [RFC 5590] ipx snmpIPXDomain [RFC 3417]; [RFC 5590] prxy rfc1157Domain [RFC 3417]; [RFC 5590] ssh snmpSSHDomain [RFC 5592] tls snmpTLSTCPDomain [RFC 6353] dtls snmpDTLSUDPDomain [RFC 6353] Licensing Terms