Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About Signaling User Adaptation Layer Assignments Created 2002-08-12 Last Updated 2011-12-01 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • Message Classes • Message Types - Management (MGMT) Message (Value 0) • Message Types - Transfer Messages (Value 1) • Message Types - SS7 Signalling Network Management (SSNM) Messages (Value 2) • Message Types - ASP State Maintenance (ASPSM) Messages (Value 3) • Message Types - ASP Traffic Maintenance (ASPTM) Messages (Value 4) • Message Types - Q.921/Q.931 Boundary Primitives Transport (QPTM) Messages (Value 5) • Message Types - MTP2 User Adaptation (MAUP) Messages (Value 6) • Message Types - Connectionless Messages (Value 7) • Message Types - Connection-Oriented Messages (Value 8) • Message Types - Routing Key Management (RKM) Messages (Value 9) • Message Types - Interface Identifier Management (IIM) Messages (Value 10) • Message Types - M2PA Messages (Value 11) • Message Types - Security Messages (Value 12) • Message Types - DPNSS/DASS2 Boundary Primitives Transport Messages (Value 13) • Message Types - V5 Boundary Primitives Transport (V5PTM) Messages (Value 14) • Message Parameters Message Classes Registration Procedure(s) IETF Review Reference [RFC 3057][RFC 4233] Available Formats [IMG] CSV Value Description Reference 0 Management (MGMT) Message [RFC 4233]; [RFC 3331]; [RFC 4666]; [RFC 3868]; [RFC 4129]; [RFC 3057] 1 Transfer Messages [RFC 4666] 2 SS7 Signalling Network Management (SSNM) Messages [RFC 4666]; [RFC 3868] 3 ASP State Maintenance (ASPSM) Messages [RFC 4233]; [RFC 3331]; [RFC 4666]; [RFC 3868]; [RFC 4129]; [RFC 3057] 4 ASP Traffic Maintenance (ASPTM) Messages [RFC 4233]; [RFC 3331]; [RFC 4666]; [RFC 3868]; [RFC 4129]; [RFC 3057] 5 Q.921/Q.931 Boundary Primitives Transport (QPTM) Messages [RFC 4233] 6 MTP2 User Adaptation (MAUP) Messages [RFC 3331] 7 Connectionless Messages [RFC 3868] 8 Connection-Oriented Messages [RFC 3868] 9 Routing Key Management (RKM) Messages [RFC 4666] 10 Interface Identifier Management (IIM) Messages [RFC 3331] 11 M2PA Messages [RFC 4165] 12 Security Messages [RFC 3788] 13 DPNSS/DASS2 Boundary Primitives Transport Messages [RFC 4129] 14 V5 Boundary Primitives Transport Messages (V5PTM) [RFC 3807] 15-127 Unassigned 128-255 Reserved for IETF-Defined Message Class extensions Message Types - Management (MGMT) Message (Value 0) Registration Procedure(s) IETF Review Reference [RFC 4233][RFC 3331][RFC 4666][RFC 3868][RFC 4129][RFC 3057] Available Formats [IMG] CSV Value Description Reference 0 Error (ERR) [RFC 4233]; [RFC 3331]; [RFC 4666]; [RFC 3868]; [RFC 4129]; [RFC 3057] 1 Notify (NTFY) [RFC 4233]; [RFC 3331]; [RFC 4666]; [RFC 3868]; [RFC 4129]; [RFC 3057] 2 TEI Status Request [RFC 4233]; [RFC 3057] 3 TEI Status Confirm [RFC 4233]; [RFC 3057] 4 TEI Status Indication [RFC 4233]; [RFC 3057] 5 DLC Status Request [RFC 4129] 6 DLC Status Confirm [RFC 4129] 7 DLC Status Indication [RFC 4129] 8 TEI Query Request [RFC 5133]; [RFC 4233] 9-127 Unassigned 128-255 Reserved for IETF-Defined MGMT extensions Message Types - Transfer Messages (Value 1) Registration Procedure(s) IETF Review Reference [RFC 4666] Available Formats [IMG] CSV Value Description Reference 0 Reserved [RFC 4666] 1 Payload Data (DATA) [RFC 4666] 2-127 Unassigned 128-255 Reserved for IETF-Defined Transfer extensions Message Types - SS7 Signalling Network Management (SSNM) Messages (Value 2) Registration Procedure(s) IETF Review Reference [RFC 4666][RFC 3868] Available Formats [IMG] CSV Value Description Reference 0 Reserved [RFC 4666]; [RFC 3868] 1 Destination Unavailable (DUNA) [RFC 4666]; [RFC 3868] 2 Destination Available (DAVA) [RFC 4666]; [RFC 3868] 3 Destination State Audit (DAUD) [RFC 4666]; [RFC 3868] 4 Signalling Congestion (SCON) [RFC 4666]; [RFC 3868] 5 Destination User Part Unavailable (DPU) [RFC 4666]; [RFC 3868] 6 Destination Restricted (DRST) [RFC 4666]; [RFC 3868] 7-127 Reserved by the IETF 128-255 Reserved for IETF-Defined SSNM extensions Message Types - ASP State Maintenance (ASPSM) Messages (Value 3) Registration Procedure(s) IETF Review Reference [RFC 4233][RFC 3331][RFC 4666][RFC 3868][RFC 4129][RFC 3057] Available Formats [IMG] CSV Value Description Reference 0 Reserved [RFC 4233]; [RFC 3331]; [RFC 4666]; [RFC 3868]; [RFC 4129]; [RFC 3057] 1 ASP Up (UP) [RFC 4233]; [RFC 3331]; [RFC 4666]; [RFC 3868]; [RFC 4129]; [RFC 3057] 2 ASP Down (DOWN) [RFC 4233]; [RFC 3331]; [RFC 4666]; [RFC 3868]; [RFC 4129]; [RFC 3057] 3 Heartbeat (BEAT) [RFC 4233]; [RFC 3331]; [RFC 4666]; [RFC 3868]; [RFC 4129]; [RFC 3057] 4 ASP Up Ack (UP ACK) [RFC 4233]; [RFC 3331]; [RFC 4666]; [RFC 3868]; [RFC 4129]; [RFC 3057] 5 ASP Down Ack (DOWN ACK) [RFC 4233]; [RFC 3331]; [RFC 4666]; [RFC 3868]; [RFC 4129]; [RFC 3057] 6 Heartbeat Ack (BEAT ACK) [RFC 4233]; [RFC 3331]; [RFC 4666]; [RFC 3868]; [RFC 4129]; [RFC 3057] 7-127 Unassigned 128-255 Reserved for IETF-Defined ASPSM extensions Message Types - ASP Traffic Maintenance (ASPTM) Messages (Value 4) Registration Procedure(s) IETF Review Reference [RFC 4233][RFC 3331][RFC 4666][RFC 3868][RFC 4129][RFC 3057] Available Formats [IMG] CSV Value Description Reference 0 Reserved [RFC 4233]; [RFC 3331]; [RFC 4666]; [RFC 3868]; [RFC 4129]; [RFC 3057] 1 ASP Active (ACTIVE) [RFC 4233]; [RFC 3331]; [RFC 4666]; [RFC 3868]; [RFC 4129]; [RFC 3057] 2 ASP Inactive (INACTIVE) [RFC 4233]; [RFC 3331]; [RFC 4666]; [RFC 3868]; [RFC 4129]; [RFC 3057] 3 ASP Active Ack (ACTIVE ACK) [RFC 4233]; [RFC 3331]; [RFC 4666]; [RFC 3868]; [RFC 4129]; [RFC 3057] 4 ASP Inactive Ack (INACTIVE ACK) [RFC 4233]; [RFC 3331]; [RFC 4666]; [RFC 3868]; [RFC 4129]; [RFC 3057] 5-127 Unassigned 128-255 Reserved for IETF-Defined ASPTM extensions Message Types - Q.921/Q.931 Boundary Primitives Transport (QPTM) Messages (Value 5) Registration Procedure(s) IETF Review Reference [RFC 4233] Available Formats [IMG] CSV Value Description Reference 0 Reserved [RFC 4233] 1 Data Request Message [RFC 4233] 2 Data Indication Message [RFC 4233] 3 Unit Data Request Message [RFC 4233] 4 Unit Data Indication Message [RFC 4233] 5 Establish Request [RFC 4233] 6 Establish Confirm [RFC 4233] 7 Establish Indication [RFC 4233] 8 Release Request [RFC 4233] 9 Release Confirm [RFC 4233] 10 Release Indication [RFC 4233] 11-127 Unassigned 128-255 Reserved for IETF-Defined QPTM extensions Message Types - MTP2 User Adaptation (MAUP) Messages (Value 6) Registration Procedure(s) IETF Review Reference [RFC 3331] Available Formats [IMG] CSV Value Description Reference 0 Reserved [RFC 3331] 1 Data [RFC 3331] 2 Establish Request [RFC 3331] 3 Establish Confirm [RFC 3331] 4 Release Request [RFC 3331] 5 Release Confirm [RFC 3331] 6 Release Indication [RFC 3331] 7 State Request [RFC 3331] 8 State Confirm [RFC 3331] 9 State Indication [RFC 3331] 10 Data Retrieval Request [RFC 3331] 11 Data Retrieval Confirm [RFC 3331] 12 Data Retrieval Indication [RFC 3331] 13 Data Retrieval Complete Indication [RFC 3331] 14 Congestion Indication [RFC 3331] 15 Data Acknowledge [RFC 3331] 16-127 Unassigned 128-255 Reserved for IETF-Defined MAUP extensions Message Types - Connectionless Messages (Value 7) Registration Procedure(s) IETF Review Reference [RFC 3868] Available Formats [IMG] CSV Value Description Reference 0 Reserved [RFC 3868] 1 Connectionless Data Transfer (CLDT) [RFC 3868] 2 Connectionless Data Response (CLDR) [RFC 3868] 3-127 Unassigned 128-255 Reserved for IETF-Defined Message Class Extensions Message Types - Connection-Oriented Messages (Value 8) Registration Procedure(s) IETF Review Reference [RFC 3868] Available Formats [IMG] CSV Value Description Reference 0 Reserved [RFC 3868] 1 Connection Request (CORE) [RFC 3868] 2 Connection Acknowledge (COAK) [RFC 3868] 3 Connection Refused (COREF) [RFC 3868] 4 Release Request (RELRE) [RFC 3868] 5 Release Complete (RELCO) [RFC 3868] 6 Reset Confirm (RESCO) [RFC 3868] 7 Reset Request (RESRE) [RFC 3868] 8 Connection Oriented Data Transfer (CODT) [RFC 3868] 9 Connection Oriented Data Acknowledge (CODA) [RFC 3868] 10 Connection Oriented Error (COERR) [RFC 3868] 11 Inactivity Test (COIT) [RFC 3868] 12-127 Unassigned 128-255 Reserved for IETF-Defined Message Class Extensions Message Types - Routing Key Management (RKM) Messages (Value 9) Registration Procedure(s) IETF Review Reference [RFC 4666] Available Formats [IMG] CSV Value Description Reference 0 Reserved [RFC 4666]; [RFC 3868] 1 Registration Request (REG REQ) [RFC 4666]; [RFC 3868] 2 Registration Response (REG RSP) [RFC 4666]; [RFC 3868] 3 Deregistration Request (DEREG REQ) [RFC 4666]; [RFC 3868] 4 Deregistration Response (DEREG RSP) [RFC 4666]; [RFC 3868] 5-127 Unassigned 128-255 Reserved for IETF-Defined RKM extensions Message Types - Interface Identifier Management (IIM) Messages (Value 10) Registration Procedure(s) IETF Review Reference [RFC 3331] Available Formats [IMG] CSV Value Description Reference 0 Reserved [RFC 3331] 1 Registration Request (REG REQ) [RFC 3331] 2 Registration Response (REG RSP) [RFC 3331] 3 Deregistration Request (DEREG REQ) [RFC 3331] 4 Deregistration Response (DEREG RSP) [RFC 3331] 5-127 Unassigned 128-255 Reserved for IETF-Defined IIM extensions Message Types - M2PA Messages (Value 11) Registration Procedure(s) IETF Review Reference [RFC 4165] Available Formats [IMG] CSV Value Description Reference 1 User Data [RFC 4165] 2 Link Status [RFC 4165] Message Types - Security Messages (Value 12) Registration Procedure(s) IETF Review Reference [RFC 3788] Available Formats [IMG] CSV Value Description Reference 1 STARTTLS message [RFC 3788] 2 STARTTLS_ACK message [RFC 3788] Message Types - DPNSS/DASS2 Boundary Primitives Transport Messages (Value 13) Registration Procedure(s) IETF Review Reference [RFC 4129] Available Formats [IMG] CSV Value Description Reference 0 Reserved [RFC 4129] 1 Data Request Message [RFC 4129] 2 Data Indication Message [RFC 4129] 3 Unit Data Request Message [RFC 4129] 4 Unit Data Indication Message [RFC 4129] 5 Establish Request [RFC 4129] 6 Establish Confirm [RFC 4129] 7 Establish Indication [RFC 4129] 8 Release Request [RFC 4129] 9 Release Confirm [RFC 4129] 10 Release Indication [RFC 4129] Message Types - V5 Boundary Primitives Transport (V5PTM) Messages (Value 14) Registration Procedure(s) IETF Review Reference [RFC 3807] Available Formats [IMG] CSV Value Description Reference 1 Data Request Message [RFC 3807] 2 Data Indication Message [RFC 3807] 3 Unit Data Request Message [RFC 3807] 4 Unit Data Indication Message [RFC 3807] 5 Establish Request [RFC 3807] 6 Establish Confirm [RFC 3807] 7 Establish Indication [RFC 3807] 8 Release Request [RFC 3807] 9 Release Confirm [RFC 3807] 10 Release Indication [RFC 3807] 11 Link Status Start Reporting [RFC 3807] 12 Link Status Stop Reporting [RFC 3807] 13 Link Status Indication [RFC 3807] 14 Sa-Bit Set Request [RFC 3807] 15 Sa-Bit Set Confirm [RFC 3807] 16 Sa-Bit Status Request [RFC 3807] 17 Sa-Bit Status Indication [RFC 3807] 18 Error Indication [RFC 3807] Message Parameters Registration Procedure(s) IETF Review Reference [RFC 3331][RFC 4233][RFC 4666] Available Formats [IMG] CSV Value Description Reference 0 Reserved [RFC 4233]; [RFC 3868]; [RFC 3331] 1 Interface Identifier (Integer) [RFC 4233]; [RFC 3331]; [RFC 4129]; [RFC 3807] 2 Reserved [RFC 4233] 3 Interface Identifier (Text) [RFC 4233]; [RFC 3331]; [RFC 4129]; [RFC 3807] 4 Info String [RFC 4233]; [RFC 3331]; [RFC 4666]; [RFC 3868]; [RFC 4129]; [RFC 3807] 5 DLCI [RFC 4233]; [RFC 4129] 6 Routing Context [RFC 4666]; [RFC 3868] 7 Diagnostic Information [RFC 4233]; [RFC 3331]; [RFC 4666]; [RFC 3868]; [RFC 4129]; [RFC 3807] 8 Interface Identifier (Integer Range) [RFC 4233]; [RFC 3331]; [RFC 4129]; [RFC 3807] 9 Heartbeat Data [RFC 4233]; [RFC 3331]; [RFC 4666]; [RFC 3868]; [RFC 4129]; [RFC 3807] 10 Reason [RFC 4129]; [RFC 3807] 11 Traffic Mode Type [RFC 4233]; [RFC 3331]; [RFC 4666]; [RFC 3868]; [RFC 4129]; [RFC 3807] 12 Error Code [RFC 4233]; [RFC 3331]; [RFC 4666]; [RFC 3868]; [RFC 4129]; [RFC 3807] 13 Status Type/Information [RFC 4233]; [RFC 3331]; [RFC 4666]; [RFC 3868]; [RFC 4129]; [RFC 3807] 14 Protocol Data [RFC 4233]; [RFC 4129]; [RFC 3807] 15 Release Reason [RFC 4233]; [RFC 4129]; [RFC 3807] 16 Status [RFC 4233]; [RFC 4129]; [RFC 3807] 17 ASP Identifier [RFC 3331]; [RFC 4666]; [RFC 3868] 18 Affected Point Code [RFC 4666]; [RFC 3868] 19 Correlation Id [RFC 3331]; [RFC 4666]; [RFC 3868] 20 Registration Result [RFC 3868] 21 Deregistration Result [RFC 3868] 22 Registration Status [RFC 3868] 23 Deregistration Status [RFC 3868] 24 Local Routing Key Identifier [RFC 3868] 25-128 Unassigned 129 DLCI/EFA [RFC 3807] 130 Link Status [RFC 3807] 131 Bit ID/Bit Value [RFC 3807] 132 Error Reason [RFC 3807] 133-255 Unassigned 256 Unassigned 257 SS7 Hop Counter [RFC 3868] 258 Source Address [RFC 3868] 259 Destination Address [RFC 3868] 260 Source Reference Number [RFC 3868] 261 Destination Reference Number [RFC 3868] 262 SCCP Cause [RFC 3868] 263 Sequence Number [RFC 3868] 264 Receive Sequence Number [RFC 3868] 265 ASP Capabilities [RFC 3868] 266 Credit [RFC 3868] 267 Data [RFC 3868] 268 Cause / User [RFC 3868] 269 Network Appearance [RFC 3868] 270 Routing Key [RFC 3868] 271 DRN Label [RFC 3868] 272 TID Label [RFC 3868] 273 Address Range [RFC 3868] 274 SMI [RFC 3868] 275 Importance [RFC 3868] 276 Message Priority [RFC 3868] 277 Protocol Class [RFC 3868] 278 Sequence Control [RFC 3868] 279 Segmentation [RFC 3868] 280 Congestion Level [RFC 3868] 281-511 Unassigned 512 Network Appearance [RFC 4666] 513 Reserved [RFC 4666] 514 Reserved [RFC 4666] 515 Reserved [RFC 4666] 516 User/Cause [RFC 4666] 517 Congestion Indications [RFC 4666] 518 Concerned Destination [RFC 4666] 519 Routing Key [RFC 4666] 520 Registration Result [RFC 4666] 521 Deregistration Result [RFC 4666] 522 Local_Routing Key Identifier [RFC 4666] 523 Destination Point Code [RFC 4666] 524 Service Indicators [RFC 4666] 525 Reserved [RFC 4666] 526 Originating Point Code List [RFC 4666] 527 Circuit Range [RFC 4666] 528 Protocol Data [RFC 4666] 529 Reserved [RFC 4666] 530 Registration Status [RFC 4666] 531 Deregistration Status [RFC 4666] 532-767 Unassigned 768 Protocol Data 1 [RFC 3331] 769 Protocol Data 2 (TTC) [RFC 3331] 770 State Request [RFC 3331] 771 State Event [RFC 3331] 772 Congestion Status [RFC 3331] 773 Discard Status [RFC 3331] 774 Action [RFC 3331] 775 Sequence Number [RFC 3331] 776 Retrieval Result [RFC 3331] 777 Link Key [RFC 3331] 778 Local-LK-Identifier [RFC 3331] 779 Signalling Data Terminal (SDT) Identifier [RFC 3331] 780 Signalling Data Link (SDL) Identifier [RFC 3331] 781 Registration Result [RFC 3331] 782 Registration Status [RFC 3331] 783 De-Registration Result [RFC 3331] 784 De-Registration Status [RFC 3331] 785-32768 Unassigned 32769 Global Title [RFC 3868] 32770 Point Code [RFC 3868] 32771 Subsystem Number [RFC 3868] 32772 IPv4 Address [RFC 3868] 32773 Hostname [RFC 3868] 32774 IPv6 Addresses [RFC 3868] 32775-65534 Unassigned 65535 Reserved [RFC 4233] Licensing Terms