Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About SIG (0) Algorithm Numbers Last Updated 2003-11-03 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registry Included Below • SIG (0) Algorithm Numbers SIG (0) Algorithm Numbers Registration Procedure(s) Standards Action Reference [RFC 3755] Note DNS KEY and SIG RRs [RFC 2535] use an 8-bit number used to identify the security algorithm being used listed below. Available Formats [IMG] CSV Number Description References Note 0 Reserved 1 RSA/MD5 [RFC 2537]; [RFC 1321] deprecated, see 5 2 Diffie-Hellman [RFC 2539] [RFC 2536]; [Federal Information Processing Standards Publication (FIPS PUB) 186, Digital 3 DSA/SHA1 Signature Standard, 18 May 1994.]; [Federal Information Processing Standards Publication (FIPS PUB) 180-1, Secure Hash Standard, 17 April 1995. (Supersedes FIPS PUB 180 dated 11 May 1993.)] 4 Reserved for Elliptic Curve Crypto 5 RSA/SHA-1 [RFC 3110] 6-251 Unassigned 252 Reserved for indirect keys [RFC 2535] 253 Private algorithms - domain name [RFC 2535] 254 Private algorithms - OID [RFC 2535] 255 Reserved Licensing Terms