Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About Sieve Extensions Created 2000-11 Last Updated 2024-10-15 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • Sieve Extensions • Sieve URN Parameters • Sieve Actions Sieve Extensions Reference [RFC 5228] Available Formats [IMG] CSV Range Registration Procedures vendor-controlled (name begins with "vnd.") First Come First Served IETF-controlled (no "vnd." prefix) Standards track or IESG-approved experimental RFC Capability name Description RFC number Contact address Registration date body Provides a test for matching against the the body [RFC 5173] [Sieve_discussion_list] of the message being processed comparator-* (anything adds the indicated comparator for use with the [RFC 4790]; [RFC 5228] (Sieve base starting with :comparator argument spec) [Sieve_discussion_list] "comparator-") adds a new Sieve test and action that enable Sieve convert scripts to perform data conversions on the message [RFC 6558] [Sieve_discussion_list] being delivered. copy [RFC 3894] [Jutta_Degener] date The "date" extension gives Sieve the ability to [RFC 5260] [Sieve_discussion_list] test date and time values. Adds test 'duplicate' that can be used to test duplicate whether a particular message is a duplicate, i.e., [RFC 7352] [Sieve_discussion_list] 2014-06-30 whether a copy of it was seen before by the delivery agent that is executing the Sieve script. editheader Adds actions 'addheader' and 'deleteheader' that [RFC 5293] [Sieve_discussion_list] modify the header of the message being processed enclose adds the "enclose" action for enclosing a message [RFC 5703] [Sieve_discussion_list] with a wrapper. changes the interpretation of strings to allow encoded-character arbitrary octets and Unicode characters to be [RFC 5228] (Sieve base spec) [Sieve_discussion_list] represented using US-ASCII adds the 'notify' action for notifying user about the received message. It also provides two new enotify tests: valid_notify_method checks notification URIs [RFC 5435] [Sieve_discussion_list] for validity; notify_method_capability can check recipients capabilities. envelope adds the 'envelope' test for testing the message [RFC 5228] (Sieve base spec) [Sieve_discussion_list] transport sender and recipient address The "envelope-deliverby" extension extends the envelope-deliverby envelope test to allow checking of information [RFC 6009] [Sieve_discussion_list] associated with the Deliver-By ESMTP extension defined in [RFC 2852]. The "envelope-dsn" extension extends the envelope envelope-dsn test to allow checking of information associated [RFC 6009] [Sieve_discussion_list] with the DSN ESMTP extension defined in [RFC 3461]. The "environment" extension provides a new environment test that can be used to implement environment scripts that behave differently when moved from one [RFC 5183] [Sieve_discussion_list] system to another or otherwise operated in different contexts. adds the 'ereject' action for refusing delivery of a message. The refusal should happen as early as ereject possible (e.g. at the protocol level) and might not [RFC 5429] [Sieve_discussion_list] preserve the exact reason for refusal if it contains non-US-ASCII text. Adds the ":list" match type to certain Sieve tests, and the ":list" argument to the "redirect" action. The ":list" match type changes tests to match extlists values against values stored in one or more [RFC 6134] [Sieve_discussion_list] externally stored lists. The ":list" argument to the redirect action changes the redirect action to forward the message to email addresses stored in the externally stored list. extracttext adds the "extracttext" action for extracting text [RFC 5703] [Sieve_discussion_list] from a MIME body part. fcc Adds the ":fcc" parameter to Sieve action commands [RFC 8580] [Sieve_discussion_list] 2019-01-29 that generate additional messages. adds the 'fileinto' action for delivering to a [RFC 5228] (Sieve base spec), [RFC fileinto mailbox other than the default 5490] (:create), [RFC 3894] (:copy), [Sieve_discussion_list] [RFC 5232] (:flags) foreverypart adds the "foreverypart" and "break" actions for [RFC 5703] [Sieve_discussion_list] iterating through MIME parts of a message. The "ihave" extension provides a means to write ihave scripts that make use of other extensions only when [RFC 5463] [Sieve_discussion_list] they are actually available. imapsieve Add Sieve processing for IMAP events. [RFC 6785] [Sieve_discussion_list] imap4flags Adds actions and tests for manipulating IMAP flags [RFC 5232] [Sieve_discussion_list] adds the "include" command to execute other Sieve scripts, the "return" action from an included include script, and the "global" command and "global" [RFC 6609] [Sieve_discussion_list] variables namespace to access variables shared among included scripts. The "index" extension provides a means to limit index header and address tests to specific instances when [RFC 5260] [Sieve_discussion_list] more than one field of a given type is present. adds test for checking for mailbox existence and a mailbox new optional argument to fileinto for creating a [RFC 5490] [Sieve_discussion_list] mailbox before attempting mail delivery. adds a test for checking mailbox existence by mailboxid OBJECTID, and new optional arguments to fileinto [RFC 9042] [EXTRA_discussion_list] 2021-03-30 and :fcc that allow selecting the destination mailbox by OBJECTID. adds tests for checking for mailbox metadata item mboxmetadata existence and for retrieving of a mailbox metadata [RFC 5490] [Sieve_discussion_list] value. adds the ":mime" and ":anychild" tagged arguments to the "header", "address", and "exists" tests. mime Adds the ":type", ":subtype", ":contenttype", and [RFC 5703] [Sieve_discussion_list] ":param" options when ":mime" is used with the "header" test. processcalendar Adds the "processcalendar" action command to add [RFC 9671] [Sieve_discussion_list] 2024-08-16 and update items on a user's calendars. The "redirect-deliverby" extension extends the redirect-deliverby redirect action to allow specification of the BY [RFC 6009] [Sieve_discussion_list] ESMTP parameter associated with the Deliver-By SMTP extension defined in [RFC 2852]. The "redirect-dsn" extension extends the redirect redirect-dsn action to allow specification of the NOTIFY and RET [RFC 6009] [Sieve_discussion_list] ESMTP parameters associated with the DSN SMTP extension defined in [RFC 3461]. regex [draft-murchison-sieve-regex-07] [Kenneth_Murchison] adds the "reject" action for refusing delivery of a reject message. The exact reason for refusal is conveyed [RFC 5429] [Sieve_discussion_list] back to the client. relational Extends existing conditional tests in Sieve [RFC 5231] [Sieve_discussion_list] language to allow relational operators replace adds the "replace" action for replacing a MIME body [RFC 5703] [Sieve_discussion_list] part of a message. adds tests for checking for server metadata item servermetadata existence and for retrieving of a server metadata [RFC 5490] [Sieve_discussion_list] value. spamtest Provides a test to check for varying likelihood of [RFC 5235] [Sieve_discussion_list] an email message being spam. Provides a test to check for varying likelihood of spamtestplus an email message being spam, possibly using a [RFC 5235] [Sieve_discussion_list] percentage range. adds a test for checking whether an IMAP special-use attribute is assigned for a particular special-use mailbox or any mailbox, and it adds the ability to [RFC 8579] [Sieve_discussion_list] 2019-01-29 file messages into a mailbox identified solely by a special-use attribute. subaddress adds the ':user' and ':detail' address parts for [RFC 5233] [Sieve_discussion_list] use with the address and envelope tests adds an action for generating an auto-reply saying vacation that the original message will not be read or [RFC 5230] [Sieve_discussion_list] answered immediately adds the ":seconds" parameter to the Sieve Vacation vacation-seconds extension. Implementations that support this MUST [RFC 6131] [Sieve_discussion_list] also support "vacation". variables Adds support for variables to the Sieve filtering [RFC 5229] [Sieve_discussion_list] language. virustest Provides a test to check for varying likelihood of [RFC 5235] [Sieve_discussion_list] there being malicious content in an email message. vnd.cyrus.* (anything Extends the Sieve language with vendor-defined starting with functionality specific to the Cyrus IMAP server Not applicable [Kenneth_Murchison] 2020-05-05 "vnd.cyrus.") ([http://www.cyrusimap.org]). vnd.dovecot.* (anything Extends the Sieve language with vendor-defined [Stephan_Bosch]; starting with functionality specific to the Dovecot Secure IMAP Not applicable [Timo_Sirainen] 2008-07-28 "vnd.dovecot.") server ([http://www.dovecot.org]). vnd.stalwart.* (anything Extends the Sieve language with vendor-defined starting with functionality specific to the Stalwart JMAP server Not applicable [Mauro_De_Gennaro] 2022-11-02 "vnd.stalwart.") [http://www.stalw.art]. Sieve URN Parameters Registration Procedure(s) Specification Required Expert(s) Unassigned Reference [RFC 6134] Available Formats [IMG] CSV URN Parameter Name Reference addrbook [RFC 6134, Section 2.6] Sieve Actions Registration Procedure(s) Expert Review Expert(s) Alexey Melnikov, Ken Murchison Reference [RFC 9122] Available Formats [IMG] CSV Cancels Can Use With Name Description References Capabilities Action Interactions Implicit IMAP Events? Comments Keep? Add a header field to All subsequent tests and actions addheader the existing message [RFC 5293] "editheader" apply to the altered message No Yes header Add IMAP flags to a list of IMAP flags that [RFC 5232]; [RFC addflag would be set on the 5229] "imap4flags", "variables" No Yes message if it gets delivered to a mailbox Convert body parts from All subsequent tests and actions convert one MIME type to [RFC 6558] "convert" apply to the altered message No Yes another Remove a header field All subsequent tests and actions deleteheader from the existing [RFC 5293] "editheader" apply to the altered message No Yes message header discard Silently throw away the [RFC 5228] Yes Yes message Enclose a message as an All subsequent tests and actions enclose attachment to a new [RFC 5703] "enclose" except "redirect" apply to the No Yes message altered message This action is incompatible with the "vacation" action. Typically ereject Refuse delivery of the [RFC 5429] "ereject" is not permitted with actions Yes No message that cause mail delivery, such as "keep", "fileinto", and "redirect" extracttext Store text of a MIME [RFC 5703]; [RFC "extracttext", "variables" No Yes part into a variable 5229] Deliver the message [RFC 5228]; [RFC "fileinto", "copy", fileinto into the specified 3894]; [RFC 5232]; "imap4flags", "mailbox", Use of :copy suppresses Yes Yes mailbox [RFC 5490]; [RFC "mailboxid", "special-use" cancellation of implicit keep 9042]; [RFC 8579] keep File the message into [RFC 5228]; [RFC "imap4flags" Yes Yes the user's main mailbox 5232] notify Send a notification to [RFC 5435]; [RFC "enotify", "fcc" No Yes a user 8580] Add and update items on [RFC 9671]; [RFC "processcalendar", This action is incompatible with processcalendar a user's calendars 5229]; [RFC 6134] "variables", "extlists" the "reject" and "ereject" No No actions. Send (forward) the [RFC 5228]; [RFC "copy", "redirect-dsn", Use of :copy suppresses redirect message to another user 3894]; [RFC 6009]; "redirect-deliverby", cancellation of implicit keep Yes Yes [RFC 6134] "extlists" This action is incompatible with the "vacation" action. Typically reject Refuse delivery of the [RFC 5429] "reject" is not permitted with actions Yes No message that cause mail delivery, such as "keep", "fileinto", and "redirect" Remove IMAP flags from a list of IMAP flags [RFC 5232]; [RFC removeflag that would be set on 5229] "imap4flags", "variables" No Yes the message if it gets delivered to a mailbox All subsequent tests and actions replace Replace a MIME part [RFC 5703] "replace" except "redirect" apply to the No Yes altered message set Store a value in a [RFC 5229] "variables" No Yes variable Set IMAP system flags or keywords that would [RFC 5232]; [RFC setflag be set on the message 5229] "imap4flags", "variables" No Yes if it gets delivered to a mailbox Implement a vacation [RFC 5230]; [RFC "vacation", This action is incompatible with vacation autoresponder 6131]; [RFC 8580] "vacation-seconds", "fcc" the "reject" and "ereject" No No actions. Contact Information ID Name Organization Contact URI Last Updated [EXTRA_discussion_list] EXTRA discussion list mailto:extra&ietf.org [Jutta_Degener] Jutta Degener Sendmail, Inc. 6425 Christie Ave, 4th Floor Emeryville, CA mailto:jutta&sendmail.com 94608 [Kenneth_Murchison] Kenneth Murchison mailto:sieve&cyrusimap.org 2020-05-05 [Mauro_De_Gennaro] Mauro De Gennaro mailto:mauro&stalw.art 2022-11-02 [Sieve_discussion_list] Sieve discussion list mailto:sieve&ietf.org [Stephan_Bosch] Stephan Bosch mailto:stephan&rename-it.nl [Timo_Sirainen] Timo Sirainen mailto:tss&iki.fi Licensing Terms