Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About Service Function Chaining Service Function Types Last Updated 2026-09-10 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registry Included Below • Service Function Chaining Service Function Types Service Function Chaining Service Function Types Reference [RFC 9015] Available Formats [IMG] CSV Range Registration Procedures Note 1-31 Standards Action Special Purpose SFT values 32-64495 First Come First Served 64496-65534 Private Use Value Name Reference Registration Date 0 Reserved [RFC 9015] 1 Change Sequence [RFC 9015] 2020-09-02 2-31 Unassigned 32 Classifier [RFC 9015]; [draft-dawra-idr-bgp-ls-sr-service-segments-04] 2020-09-02 33 Firewall [RFC 9015]; [draft-dawra-idr-bgp-ls-sr-service-segments-04] 2020-09-02 34 Load balancer [RFC 9015]; [draft-dawra-idr-bgp-ls-sr-service-segments-04] 2020-09-02 35 Deep packet inspection engine [RFC 9015]; [draft-dawra-idr-bgp-ls-sr-service-segments-04] 2020-09-02 36 Penalty box [RFC 8300]; [RFC 9015] 2020-09-02 37 WAN accelerator [RFC 7665]; [RFC 8300]; [RFC 9015] 2020-09-02 38 Application accelerator [RFC 7665]; [RFC 9015] 2020-09-02 39 TCP optimizer [RFC 7665]; [RFC 9015] 2020-09-02 40 Network Address Translator [RFC 7665]; [RFC 9015] 2020-09-02 41 NAT44 [RFC 3022]; [RFC 7665]; [RFC 9015] 2020-09-02 42 NAT64 [RFC-ietf-v6ops-rfc6146-bis-16]; [RFC 7665]; [RFC 9015] 2020-09-02 43 NPTv6 [RFC 6296]; [RFC 7665]; [RFC 9015] 2020-09-02 44 Lawful intercept [RFC 7665]; [RFC 9015] 2020-09-02 45 HOST_ID injection [RFC 7665]; [RFC 9015] 2020-09-02 46 HTTP header enrichment [RFC 7665]; [RFC 9015] 2020-09-02 47 Caching engine [RFC 7665]; [RFC 9015] 2020-09-02 48-64495 Unassigned 64496-65534 Reserved for Private Use [RFC 9015] 65535 Reserved [RFC 9015] Licensing Terms