Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About Subsequent Address Family Identifiers (SAFI) Parameters Created 2000-07 Last Updated 2026-03-19 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registry Included Below • SAFI Values SAFI Values Reference [RFC 4760] Note When this registry is modified, the YANG module [iana-routing-types] must be updated as defined in [RFC 8294]. Available Formats [IMG] CSV Range Registration Procedures Note 1-63 Standards Action 64-127 First Come First Served 128-240 Some recognized assignments below, others Reserved 241-254 Reserved for Private Use Not to be assigned Value Description Reference 0 Reserved [RFC 4760] 1 Network Layer Reachability Information used for [RFC 4760] unicast forwarding 2 Network Layer Reachability Information used for [RFC 4760] multicast forwarding 3 Reserved [RFC 4760] 4 Network Layer Reachability Information (NLRI) with [RFC 8277] MPLS Labels 5 MCAST-VPN [RFC 6514] 6 Network Layer Reachability Information used for [RFC 7267] Dynamic Placement of Multi-Segment Pseudowires 7 Encapsulation SAFI (OBSOLETE) [RFC 9012] 8 MCAST-VPLS [RFC 7117] 9 BGP SFC [RFC 9015] 10-63 Unassigned 64 Tunnel SAFI [Gargi_Nalawade]; [draft-nalawade-kapoor-tunnel-safi-01] 65 Virtual Private LAN Service (VPLS) [RFC 4761]; [RFC 6074] 66 BGP MDT SAFI [RFC 6037] 67 BGP 4over6 SAFI [RFC 5747] 68 BGP 6over4 SAFI [Yong_Cui] 69 Layer-1 VPN auto-discovery information [RFC 5195] 70 BGP EVPNs [RFC 7432] 71 BGP-LS [RFC 9552] 72 BGP-LS-VPN [RFC 9552] 73 SR Policy SAFI [RFC 9830] 74 SD-WAN Capabilities [draft-ietf-idr-sdwan-edge-discovery-03] 75 Routing Policy SAFI [draft-ietf-idr-rpd-02] 76 Classful Transport (CT) [RFC 9832] 77 Tunneled Traffic Flowspec [draft-ietf-idr-flowspec-nvo3-10] 78 MCAST-TREE [draft-ietf-bess-bgp-multicast-03] 79 BGP-DPS (Dynamic Path Selection) [https://eos.arista.com/eos-4-26-2f/dps-vpn-scaling-using-bgp]; [Venkit_Kasiviswanathan] 80 BGP-LS-SPF [RFC 9815] 81 Unreachability Information SAFI [Jeff_Tantsura]; [draft-tantsura-idr-unreachability-safi-01] 82 Unassigned 83 BGP CAR [RFC 9871] 84 BGP VPN CAR [RFC 9871] 85 BGP-MUP SAFI [draft-mpmz-bess-mup-safi-00] 86-127 Unassigned 128 MPLS-labeled VPN address [RFC 4364]; [RFC 8277]; [RFC 9252] 129 Multicast for BGP/MPLS IP Virtual Private Networks [RFC 6513]; [RFC 6514] (VPNs) 130-131 Reserved [RFC 4760] 132 Route Target constrains [RFC 4684] 133 Dissemination of Flow Specification rules [RFC 8955] 134 L3VPN Dissemination of Flow Specification rules [RFC 8955] 135-139 Reserved [RFC 4760] 140 VPN auto-discovery [draft-ietf-l3vpn-bgpvpn-auto-08] 141-240 Reserved [RFC 4760] 241-254 Reserved for Private Use [RFC 4760] 255 Reserved [RFC 4760] Contact Information ID Name Contact URI Last Updated [Gargi_Nalawade] Gargi Nalawade mailto:gargi&cisco.com 2004-01 [Jeff_Tantsura] Jeff Tantsura mailto:jefftant.ietf&gmail.com 2026-03-19 [Venkit_Kasiviswanathan] Venkit Kasiviswanathan mailto:venkit&arista.com 2021-09-08 [Yong_Cui] Yong Cui mailto:cuiyong&tsinghua.edu.cn 2006-09-20 Licensing Terms