Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About Real Time Streaming Protocol (RTSP)/1.0 Parameters Created 2005-10-11 Last Updated 2019-02-19 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • RTSP/1.0 Methods • RTSP/1.0 Headers • RTSP/1.0 Status Codes • RTSP/1.0 Option Tags RTSP/1.0 Methods Registration Procedure(s) Standards Action Reference [RFC 2326] Available Formats [IMG] CSV Method Name Reference DESCRIBE [RFC 2326] ANNOUNCE [RFC 2326] GET_PARAMETER [RFC 2326] OPTIONS [RFC 2326] PAUSE [RFC 2326] PLAY [RFC 2326] RECORD [RFC 2326] REDIRECT [RFC 2326] SETUP [RFC 2326] SET_PARAMETER [RFC 2326] TEARDOWN [RFC 2326] RTSP/1.0 Headers Registration Procedure(s) Standards Document, preferably an IETF RFC Reference [RFC 2326] Available Formats [IMG] CSV Header Name Reference 3GPP-Adaptation [3GPP TS 26.234]; [RFC 6064] 3GPP-Freshness-Token [3GPP TS 26.234]; [RFC 6064] 3GPP-Link-Char [3GPP TS 26.234]; [RFC 6064] 3GPP-QoE-Feedback [3GPP TS 26.234]; [RFC 6064] 3GPP-QoE-Metrics [3GPP TS 26.234]; [RFC 6064] 3gpp-videopostdecbufsize [3GPP TS 26.234]; [RFC 6064] Accept [RFC 2326] Accept-Encoding [RFC 2326] Accept-Language [RFC 2326] Allow [RFC 2326] Authorization [RFC 2326] Bandwidth [RFC 2326] Blocksize [RFC 2326] Cache-Control [RFC 2326] Conference [RFC 2326] Connection [RFC 2326] Content-Base [RFC 2326] Content-Encoding [RFC 2326] Content-Encoding [RFC 2326] Content-Language [RFC 2326] Content-Length [RFC 2326] Content-Length [RFC 2326] Content-Location [RFC 2326] Content-Type [RFC 2326] Content-Type [RFC 2326] CSeq [RFC 2326] Date [RFC 2326] Expires [RFC 2326] From [RFC 2326] If-Modified-Since [RFC 2326] keymgmt [1] [RFC 4567] Last-Modified [RFC 2326] Pipelined-Requests [3GPP TS 26.234]; [RFC 6064] Proxy-Authenticate [RFC 2326] Proxy-Require [RFC 2326] Public [RFC 2326] Range [RFC 2326] Range [RFC 2326] Referer [RFC 2326] Require [RFC 2326] Retry-After [RFC 2326] RTP-Info [RFC 2326] Scale [RFC 2326] SDP-Requested [3GPP TS 26.234]; [RFC 6064] Session [RFC 2326] Server [RFC 2326] Speed [RFC 2326] Supported [3GPP TS 26.234]; [RFC 6064] Switch-Stream [3GPP TS 26.234]; [RFC 6064] Transport [RFC 2326] Unsupported [RFC 2326] User-Agent [RFC 2326] Via [RFC 2326] WWW-Authenticate [RFC 2326] x-initpostdecbufperiod [3GPP TS 26.234]; [RFC 6064] x-initpredecbufperiod [3GPP TS 26.234]; [RFC 6064] x-predecbufsize [3GPP TS 26.234]; [RFC 6064] RTSP/1.0 Status Codes Registration Procedure(s) Standards Action Reference [RFC 2326] Available Formats [IMG] CSV Value Description Reference 100 Continue [RFC 2326] 200 OK [RFC 2326] 201 Created [RFC 2326] 250 Low on Storage Space [RFC 2326] 300 Multiple Choices [RFC 2326] 301 Moved Permanently [RFC 2326] 302 Moved Temporarily [RFC 2326] 303 See Other [RFC 2326] 304 Not Modified [RFC 2326] 305 Use Proxy [RFC 2326] 400 Bad Request [RFC 2326] 401 Unauthorized [RFC 2326] 402 Payment Required [RFC 2326] 403 Forbidden [RFC 2326] 404 Not Found [RFC 2326] 405 Method Not Allowed [RFC 2326] 406 Not Acceptable [RFC 2326] 407 Proxy Authentication Required [RFC 2326] 408 Request Time-out [RFC 2326] 410 Gone [RFC 2326] 411 Length Required [RFC 2326] 412 Precondition Failed [RFC 2326] 413 Request Entity Too Large [RFC 2326] 414 Request-URI Too Large [RFC 2326] 415 Unsupported Media Type [RFC 2326] 451 Parameter Not Understood [RFC 2326] 452 Conference Not Found [RFC 2326] 453 Not Enough Bandwidth [RFC 2326] 454 Session Not Found [RFC 2326] 455 Method Not Valid in This State [RFC 2326] 456 Header Field Not Valid for Resource [RFC 2326] 457 Invalid Range [RFC 2326] 458 Parameter Is Read-Only [RFC 2326] 459 Aggregate operation not allowed [RFC 2326] 460 Only aggregate operation allowed [RFC 2326] 461 Unsupported transport [RFC 2326] 462 Destination unreachable [RFC 2326] 463 Key management Failure [RFC 4567] 500 Internal Server Error [RFC 2326] 501 Not Implemented [RFC 2326] 502 Bad Gateway [RFC 2326] 503 Service Unavailable [RFC 2326] 504 Gateway Time-out [RFC 2326] 505 RTSP Version not supported [RFC 2326] 551 Option not supported [RFC 2326] RTSP/1.0 Option Tags Registration Procedure(s) Specification Required Expert(s) Unassigned Reference [RFC 2326] Available Formats [IMG] CSV Option Tag Reference 3gpp-pipelined [3GPP TS 26.234]; [RFC 6064] 3gpp-switch [3GPP TS 26.234]; [RFC 6064] 3gpp-switch-req-sdp [3GPP TS 26.234]; [RFC 6064] 3gpp-switch-stream [3GPP TS 26.234]; [RFC 6064] FEC-protection-needed [RFC 6695] Footnote [1] The key management protocol identifier, KMPID, used by this header has a name space that is shared between the SDP "key-mgmt" attribute and RTSP header "keymgmt". This name space is maintained in the registry named "SDP/RTSP key management protocol identifiers", available here: [SDP/RTSP key management protocol identifiers]. Licensing Terms