Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About Reliable Multicast Transport (RMT) FEC Encoding IDs and FEC Instance IDs Created 2002-11-07 Last Updated 2020-01-16 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • ietf:rmt:fec:encoding - Fully-Specified FEC schemes (0-127) • ietf:rmt:fec:encoding - Under-Specified FEC schemes (128-255) • ietf:rmt:fec:encoding:instance:128 • ietf:rmt:fec:encoding:instance:129 • ietf:rmt:fec:encoding:instance:130 • FEC Framework (FECFRAME) FEC Encoding IDs ietf:rmt:fec:encoding - Fully-Specified FEC schemes (0-127) Registration Procedure(s) IETF Review Reference [RFC 5052] Available Formats [IMG] CSV Value Description Reference 0 Compact No-Code [RFC 5445] 1 Raptor [RFC 5053] 2 Reed-Solomon Codes over GF(2^^m) [RFC 5510] 3 LDPC Staircase Codes [RFC 5170] 4 LDPC Triangle Codes [RFC 5170] 5 Reed-Solomon Codes over GF(2^^8) [RFC 5510] 6 RaptorQ Code [RFC 6330] 7-127 Unassigned ietf:rmt:fec:encoding - Under-Specified FEC schemes (128-255) Registration Procedure(s) IETF Review Reference [RFC 5052] Available Formats [IMG] CSV Value Description Reference 128 Small Block, Large Block and Expandable FEC Codes [RFC 5445] 129 Small Block Systematic FEC Codes [RFC 5445] 130 Compact FEC [RFC 5445] 131-255 Unassigned ietf:rmt:fec:encoding:instance:128 Registration Procedure(s) First Come First Served Reference [RFC 5445][RFC 5052] Note ietf:rmt:fec:encoding = 128 (Small Block, Large Block and ...) Available Formats [IMG] CSV Value Description Reference Registration Date 0 Digital Fountain LT Code [Michael_Luby] 2003-01 1-65535 Unassigned ietf:rmt:fec:encoding:instance:129 Registration Procedure(s) First Come First Served Reference [RFC 5445][RFC 5052] Note ietf:rmt:fec:encoding = 129 (Small Block Systematic FEC Codes) Available Formats [IMG] CSV Value Description Reference 0 Reed-Solomon Codes over GF(2^^8) [RFC 5510] 1-65535 Unassigned ietf:rmt:fec:encoding:instance:130 Registration Procedure(s) First Come First Served Reference [RFC 5445][RFC 5052] Note ietf:rmt:fec:encoding = 130 (Compact FEC) Available Formats [IMG] CSV Value Description Reference 0-65535 Unassigned FEC Framework (FECFRAME) FEC Encoding IDs Registration Procedure(s) IETF Review Reference [RFC 6363] Available Formats [IMG] CSV Value Description Reference 0 Reserved [RFC 6363] 1 Raptor FEC Scheme for Arbitrary Packet Flows [RFC 6681, Section 6], using [RFC 5053]. 2 RaptorQ FEC Scheme for Arbitrary Packet Flows [RFC 6681, Section 6], using [RFC 6330]. 3 Raptor FEC Scheme Optimised for Arbitrary Packet Flows [RFC 6681, Section 7], using [RFC 5053]. 4 RaptorQ FEC Scheme Optimised for Arbitrary Packet Flows [RFC 6681, Section 7], using [RFC 6330]. 5 Raptor FEC Scheme for a Single Sequence Flow [RFC 6681, Section 8], using [RFC 5053]. 6 RaptorQ FEC Scheme for a Single Sequence Flow [RFC 6681, Section 8], using [RFC 6330]. 7 Simple LDPC-Staircase FEC Scheme for Arbitrary Packet Flows [RFC 6816, Section 5] 8 Simple Reed-Solomon FEC Scheme over GF(2^^m) for Arbitrary Packet Flows [RFC 6865] 9 Sliding Window Random Linear Codes (RLC) over GF(2) FEC Scheme for Arbitrary Packet Flows [RFC 8681, Section 5] 10 Sliding Window Random Linear Codes (RLC) over GF(2^^8) FEC Scheme for Arbitrary Packet Flows [RFC 8681, Section 4] 11-254 Unassigned 255 Reserved Contact Information ID Name Contact URI Last Updated [Michael_Luby] Michael Luby mailto:luby&qualcomm.com Licensing Terms