Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About Routing Information Protocol (RIP) Parameters Last Updated 2018-06-12 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • RIP Commands • RIP Update Headers • RIP Address Family Identifiers • RIP Authentication Type • RIPNG Commands • RIPNG Update Headers RIP Commands Registration Procedure(s) Not defined Reference [RFC 1723] Available Formats [IMG] CSV Value Description Reference Notes 0 Invalid 1 Request [RFC 1058] 2 Response [RFC 1058] 3 TraceOn [RFC 1058] 4 TraceOff [RFC 1058] 5 Reserved [RFC 1058] 6 Triggered Request [RFC 1582] There are widely deployed implementations that don't support Triggered UDP that use value 6 = "Poll Entry" (undocumented) 7 Triggered Response [RFC 1582] 8 Triggered Acknowledgement [RFC 1582] 9 Update Request [RFC 2091] 10 Update Response [RFC 2091] 11 Update Acknowledge [RFC 2091] 12-254 Unassigned RIP Update Headers Registration Procedure(s) Not Defined Reference [RFC 1058] Available Formats [IMG] CSV Value Description Reference Notes 0 must be discarded [RFC 1058] 1 version 1 [RFC 1058] 2 version 2 [RFC 2453] 3-254 Unassigned RIP Address Family Identifiers Registration Procedure(s) Not defined Reference [RFC 1058] Available Formats [IMG] CSV Value Description Reference Notes 0 assigned but, unspecified. Associated full route table exchange [RFC 1058] 1 Unassigned 2 IP [RFC 1058] 3-65534 Unassigned 65535 Authentication present [RFC 1388] This is represented in hex as 0xFFFF in Section 3.1 RIP Authentication Type Registration Procedure(s) Not defined Reference [RFC 1388] Available Formats [IMG] CSV Value Description Reference Notes 0 none 1 Authentication Trailer [RFC 4822] Only used with Cryptographic Hash Function 2 Plain-text password [RFC 1388] 3 Cryptographic Hash Function [RFC 4822] Requires Authentication Trailer 4-65534 Unassigned RIPNG Commands Registration Procedure(s) Not defined Reference [RFC 2080] Available Formats [IMG] CSV Value Description Reference Notes 1 Request [RFC 2080] 2 Response [RFC 2080] 3-255 Unassigned RIPNG Update Headers Registration Procedure(s) Not defined Reference [RFC 2080] Available Formats [IMG] CSV Value Description Reference Notes 0 Unassigned Must be discarded 1 Version 1 [RFC 2080] 2-254 Unassigned Licensing Terms