Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About RDAP JSON Values Created 2015-01-12 Last Updated 2025-06-04 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registry Included Below • RDAP JSON Values RDAP JSON Values Registration Procedure(s) Expert Review Expert(s) Jasdip Singh, Scott Hollenbeck Reference [RFC 9083][RFC 9537] Available Formats [IMG] CSV Value Type Description Registrant Reference result set notice and The list of results does not contain all results due to lack of authorization. This truncated due to remark type may indicate to some clients that proper authorization will yield a longer result [IESG] [RFC 9083] authorization set. result set notice and The list of results does not contain all results due to an excessively heavy load on truncated due to remark type the server. This may indicate to some clients that requerying at a later time will [IESG] [RFC 9083] excessive load yield a longer result set. result set The list of results does not contain all results for an unexplainable reason. This truncated due to notice and may indicate to some clients that requerying for any reason will not yield a longer [IESG] [RFC 9083] unexplainable remark type result set. reasons object truncated notice and due to remark type The object does not contain all data due to lack of authorization. [IESG] [RFC 9083] authorization object truncated notice and The object does not contain all data due to an excessively heavy load on the server. due to excessive remark type This may indicate to some clients that requerying at a later time will yield all data [IESG] [RFC 9083] load of the object. object truncated due to notice and The object does not contain all data for an unexplainable reason. [IESG] [RFC 9083] unexplainable remark type reasons Signifies that the data of the object instance has been found to be accurate. This validated status type of status is usually found on entity object instances to note the validity of [IESG] [RFC 9083] identifying contact information. renew prohibited status Renewal or reregistration of the object instance is forbidden. [IESG] [RFC 9083] update prohibited status Updates to the object instance are forbidden. [IESG] [RFC 9083] transfer status Transfers of the registration from one registrar to another are forbidden. This type [IESG] [RFC 9083] prohibited of status normally applies to DNR domain names. delete prohibited status Deletion of the registration of the object instance is forbidden. This type of status [IESG] [RFC 9083] normally applies to DNR domain names. proxy status The registration of the object instance has been performed by a third party. This is [IESG] [RFC 9083] most commonly applied to entities. private status The information of the object instance is not designated for public consumption. This [IESG] [RFC 9083] is most commonly applied to entities. removed status Some of the information of the object instance has not been made available and has [IESG] [RFC 9083] been removed. This is most commonly applied to entities. Some of the information of the object instance has been altered for the purposes of obscured status not readily revealing the actual information of the object instance. This is most [IESG] [RFC 9083] commonly applied to entities. The object instance is associated with other object instances in the registry. This associated status is most commonly used to signify that a nameserver is associated with a domain or [IESG] [RFC 9083] that an entity is associated with a network resource or domain. The object instance is in use. For domain names, it signifies that the domain name is active status published in DNS. For network and autnum registrations, it signifies that they are [IESG] [RFC 9083] allocated or assigned for use in operational networks. This maps to the "OK" status of the Extensible Provisioning Protocol (EPP) [RFC 5730]. inactive status The object instance is not in use. See "active". [IESG] [RFC 9083] locked status Changes to the object instance cannot be made, including the association of other [IESG] [RFC 9083] object instances. pending create status A request has been received for the creation of the object instance, but this action [IESG] [RFC 9083] is not yet complete. pending renew status A request has been received for the renewal of the object instance, but this action [IESG] [RFC 9083] is not yet complete. pending transfer status A request has been received for the transfer of the object instance, but this action [IESG] [RFC 9083] is not yet complete. pending update status A request has been received for the update or modification of the object instance, [IESG] [RFC 9083] but this action is not yet complete. A request has been received for the deletion or removal of the object instance, but pending delete status this action is not yet complete. For domains, this might mean that the name is no [IESG] [RFC 9083] longer published in DNS but has not yet been purged from the registry database. This grace period is provided after the initial registration of the object. If the object is deleted by the client during this period, the server provides a credit to add period status the client for the cost of the registration. This maps to the Domain Registry Grace [IESG] [RFC 8056] Period Mapping for the Extensible Provisioning Protocol (EPP) [RFC 3915] 'addPeriod' status. This grace period is provided after an object registration period expires and is extended (renewed) automatically by the server. If the object is deleted by the auto renew period status client during this period, the server provides a credit to the client for the cost of [IESG] [RFC 8056] the auto renewal. This maps to the Domain Registry Grace Period Mapping for the Extensible Provisioning Protocol (EPP) [RFC 3915] 'autoRenewPeriod' status. The client requested that requests to delete the object MUST be rejected. This maps client delete to the Extensible Provisioning Protocol (EPP) Domain Name Mapping [RFC 5731], prohibited status Extensible Provisioning Protocol (EPP) Host Mapping [RFC 5732], and Extensible [IESG] [RFC 8056] Provisioning Protocol (EPP) Contact Mapping [RFC 5733] 'clientDeleteProhibited' status. The client requested that the DNS delegation information MUST NOT be published for client hold status the object. This maps to the Extensible Provisioning Protocol (EPP) Domain Name [IESG] [RFC 8056] Mapping [RFC 5731] 'clientHold' status. client renew The client requested that requests to renew the object MUST be rejected. This maps to prohibited status the Extensible Provisioning Protocol (EPP) Domain Name Mapping [RFC 5731] [IESG] [RFC 8056] 'clientRenewProhibited' status. The client requested that requests to transfer the object MUST be rejected. This maps client transfer status to the Extensible Provisioning Protocol (EPP) Domain Name Mapping [RFC 5731] and [IESG] [RFC 8056] prohibited Extensible Provisioning Protocol (EPP) Contact Mapping [RFC 5733] 'clientTransferProhibited' status. The client requested that requests to update the object (other than to remove this client update status) MUST be rejected. This maps to the Extensible Provisioning Protocol (EPP) prohibited status Domain Name Mapping [RFC 5731], Extensible Provisioning Protocol (EPP) Host Mapping [IESG] [RFC 8056] [RFC 5732], and Extensible Provisioning Protocol (EPP) Contact Mapping [RFC 5733] 'clientUpdateProhibited' status. An object is in the process of being restored after being in the redemption period pending restore status state. This maps to the Domain Registry Grace Period Mapping for the Extensible [IESG] [RFC 8056] Provisioning Protocol (EPP) [RFC 3915] 'pendingRestore' status. A delete has been received, but the object has not yet been purged because an redemption period status opportunity exists to restore the object and abort the deletion process. This maps to [IESG] [RFC 8056] the Domain Registry Grace Period Mapping for the Extensible Provisioning Protocol (EPP) [RFC 3915] 'redemptionPeriod' status. This grace period is provided after an object registration period is explicitly extended (renewed) by the client. If the object is deleted by the client during this renew period status period, the server provides a credit to the client for the cost of the renewal. This [IESG] [RFC 8056] maps to the Domain Registry Grace Period Mapping for the Extensible Provisioning Protocol (EPP) [RFC 3915] 'renewPeriod' status. The server set the status so that requests to delete the object MUST be rejected. server delete This maps to the Extensible Provisioning Protocol (EPP) Domain Name Mapping [RFC prohibited status 5731], Extensible Provisioning Protocol (EPP) Host Mapping [RFC 5732], and Extensible [IESG] [RFC 8056] Provisioning Protocol (EPP) Contact Mapping [RFC 5733] 'serverDeleteProhibited' status. server renew The server set the status so that requests to renew the object MUST be rejected. This prohibited status maps to the Extensible Provisioning Protocol (EPP) Domain Name Mapping [RFC 5731] [IESG] [RFC 8056] 'serverRenewProhibited' status. The server set the status so that requests to transfer the object MUST be rejected. server transfer status This maps to the Extensible Provisioning Protocol (EPP) Domain Name Mapping [RFC [IESG] [RFC 8056] prohibited 5731] and Extensible Provisioning Protocol (EPP) Contact Mapping [RFC 5733] 'serverTransferProhibited' status. The server set the status so that requests to update the object (other than to remove server update this status) MUST be rejected. This maps to the Extensible Provisioning Protocol prohibited status (EPP) Domain Name Mapping [RFC 5731], Extensible Provisioning Protocol (EPP) Host [IESG] [RFC 8056] Mapping [RFC 5732], and Extensible Provisioning Protocol (EPP) Contact Mapping [RFC 5733] 'serverUpdateProhibited' status. The server set the status so that DNS delegation information MUST NOT be published server hold status for the object. This maps to the Extensible Provisioning Protocol (EPP) Domain Name [IESG] [RFC 8056] Mapping [RFC 5731] 'serverHold' status. This grace period is provided after the successful transfer of object registration sponsorship from one client to another client. If the object is deleted by the client transfer period status during this period, the server provides a credit to the client for the cost of the [IESG] [RFC 8056] transfer. This maps to the Domain Registry Grace Period Mapping for the Extensible Provisioning Protocol (EPP) [RFC 3915] 'transferPeriod' status. registration event action The object instance was initially registered. [IESG] [RFC 9083] reregistration event action The object instance was registered subsequently to initial registration. [IESG] [RFC 9083] last changed event action An action noting when the information in the object instance was last changed. [IESG] [RFC 9083] expiration event action The object instance has been removed or will be removed at a predetermined date and [IESG] [RFC 9083] time from the registry. deletion event action The object instance was removed from the registry at a point in time that was not [IESG] [RFC 9083] predetermined. reinstantiation event action The object instance was reregistered after having been removed from the registry. [IESG] [RFC 9083] transfer event action The object instance was transferred from one registrar to another. [IESG] [RFC 9083] locked event action The object instance was locked (see the "locked" status). [IESG] [RFC 9083] unlocked event action The object instance was unlocked (see the "locked" status). [IESG] [RFC 9083] registrant role The entity object instance is the registrant of the registration. In some registries, [IESG] [RFC 9083] this is known as a maintainer. technical role The entity object instance is a technical contact for the registration. [IESG] [RFC 9083] administrative role The entity object instance is an administrative contact for the registration. [IESG] [RFC 9083] abuse role The entity object instance handles network abuse issues on behalf of the registrant [IESG] [RFC 9083] of the registration. billing role The entity object instance handles payment and billing issues on behalf of the [IESG] [RFC 9083] registrant of the registration. registrar role The entity object instance represents the authority responsible for the registration [IESG] [RFC 9083] in the registry. reseller role The entity object instance represents a third party through which the registration [IESG] [RFC 9083] was conducted (i.e., not the registry or registrar). sponsor role The entity object instance represents a domain policy sponsor, such as an [IESG] [RFC 9083] ICANN-approved sponsor. proxy role The entity object instance represents a proxy for another entity object, such as a [IESG] [RFC 9083] registrant. notifications role An entity object instance designated to receive notifications about association [IESG] [RFC 9083] object instances. noc role The entity object instance handles communications related to a network operations [IESG] [RFC 9083] center (NOC). domain registered variant The variant names are registered in the registry. [IESG] [RFC 9083] relation domain unregistered variant The variant names are not found in the registry. [IESG] [RFC 9083] relation registration domain Registration of the variant names is restricted to certain parties or within certain restricted variant rules. [IESG] [RFC 9083] relation domain open registration variant Registration of the variant names is available to generally qualified registrants. [IESG] [RFC 9083] relation domain Registration of the variant names occurs automatically with the registration of the conjoined variant containing domain registration. [IESG] [RFC 9083] relation last update of event action An action noting when the information in the object instance in the RDAP database was [ICANN] RDAP database last synchronized from the authoritative database (e.g. registry database). registrar event action An action noting the expiration date of the object in the registrar system. [ICANN] expiration enum validation event action Association of phone number represented by this ENUM domain to registrant has expired [CZ.NIC_z._s._p._o.] expiration or will expire at a predetermined date and time. object redacted notice and due to remark type The object contains redacted data due to lack of authorization. [ICANN] authorization administrative status The object instance has been allocated administratively (i.e., not for use by the [NRO] recipient in their own right in operational networks). reserved status The object instance has been allocated to an IANA special-purpose address registry. [NRO] redacted jsonpath expression JSON path expression language, as defined in [RFC 9535]. [IETF] [RFC 9537] language [ICANN gTLD Registry Domain ID redacted Redacted domain object class “handle” member. The “removal” redacted “path” member [ICANN] RDAP name JSONPath for Figure “Unredacted RDAP Lookup Response” of [RFC 9537] is “$.handle”. Response Profile] Redacted entity object class, with “registrant” role, “handle” member. The “removal” [ICANN gTLD Registry redacted redacted “path” member JSONPath for Figure “Unredacted RDAP Lookup Response” of [RFC [ICANN] RDAP Registrant ID name 9537] is “$.entities[?(@.roles[0]=='registrant')].handle”. Response Profile] Redacted entity object class, with “registrant” role, name property. When using [ICANN gTLD Registrant Name redacted jCard, redacting the “vcard” “fn” property. The “emptyValue” redacted “path” member [ICANN] RDAP name JSONPath for Figure “Unredacted RDAP Lookup Response” of [RFC 9537] is Response “$.entities[?(@.roles[0]=='registrant')].vcardArray[1][?(@[0]=='fn')][3]”. Profile] Redacted entity object class, with “registrant” role, organization property. When [ICANN gTLD Registrant redacted using jCard, redacting the “vcard” “org” property. The “removal” redacted “path” [ICANN] RDAP Organization name member JSONPath for Figure “Unredacted RDAP Lookup Response” of [RFC 9537] is Response “$.entities[?(@.roles[0]=='registrant')].vcardArray[1][?(@[0]=='org')]”. Profile] Redacted entity object class, with “registrant” role, street properties. When using [ICANN gTLD redacted jCard, the “vcard” “adr” street properties (vCard “ADR-component-pobox”, RDAP Registrant Street name “ADR-component-ext”, and “ADR-component-street”). The “emptyValue” redacted “path” [ICANN] Response member JSONPath for Figure “Unredacted RDAP Lookup Response” of [RFC 9537] is Profile] “$.entities[?(@.roles[0]=='registrant')].vcardArray[1][?(@[0]=='adr')][3][:3]”. Redacted entity object class, with “registrant” role, city property. When using [ICANN gTLD redacted jCard, the “vcard” “adr” locality property (vCard “ADR-component-locality”). The RDAP Registrant City name “emptyValue” redacted “path” member JSONPath for Figure “Unredacted RDAP Lookup [ICANN] Response Response” of [RFC 9537] is Profile] “$.entities[?(@.roles[0]=='registrant')].vcardArray[1][?(@[0]=='adr')][3][3]”. Redacted entity object class, with “registrant” role, postal code property. When [ICANN gTLD Registrant Postal redacted using jCard, the “vcard” “adr” code property (vCard “ADR-component-code”). The RDAP Code name “emptyValue” redacted “path” member JSONPath for Figure “Unredacted RDAP Lookup [ICANN] Response Response” of [RFC 9537] is Profile] “$.entities[?(@.roles[0]=='registrant')].vcardArray[1][?(@[0]=='adr')][3][5]”. Redacted entity object class, with “registrant” role, voice phone property. When [ICANN gTLD Registrant Phone redacted using jCard, the “vcard” “tel” property with type “voice”. The “removal” redacted [ICANN] RDAP name “path” member JSONPath for Figure “Unredacted RDAP Lookup Response” of [RFC 9537] is Response “$.entities[?(@.roles[0]=='registrant')].vcardArray[1][?(@[1].type=='voice')]”. Profile] Redacted entity object class, with “registrant” role, voice phone extension property. [ICANN gTLD Registrant Phone redacted When using jCard, the “vcard” “tel” property extension value with type “voice”. The RDAP Ext name “removal” redacted “path” member JSONPath for Figure “Unredacted RDAP Lookup [ICANN] Response Response” of [RFC 9537] is Profile] “$.entities[?(@.roles[0]=='registrant')].vcardArray[1][?(@[1].type=='voice')]”. Redacted entity object class, with “registrant” role, fax phone property. When using [ICANN gTLD Registrant Fax redacted jCard, the “vcard” “tel” property with type “fax”. The “removal” redacted “path” [ICANN] RDAP name member JSONPath for Figure “Unredacted RDAP Lookup Response” of [RFC 9537] is Response “$.entities[?(@.roles[0]=='registrant')].vcardArray[1][?(@[1].type=='fax')]”. Profile] Radacted entity object class, with “registrant” role, fax phone extension property. [ICANN gTLD Registrant Fax Ext redacted When using jCard, the “vcard” “tel” property with type “fax”. The “removal” redacted [ICANN] RDAP name “path” member JSONPath for Figure “Unredacted RDAP Lookup Response” of [RFC 9537] is Response “$.entities[?(@.roles[0]=='registrant')].vcardArray[1][?(@[1].type=='fax')]”. Profile] Redacted entity object class, with “registrant” role, email property. When using jCard, the “vcard” “email” property. The “removal” redacted “path” member JSONPath for Figure “Unredacted RDAP Lookup Response” of [RFC 9537] is [ICANN gTLD Registrant Email redacted “$.entities[?(@.roles[0]=='registrant')].vcardArray[1][?(@[0]=='email')]”. The [ICANN] RDAP name “replacementValue” redacted “path” member JSONPath for Figure “Unredacted RDAP Lookup Response Response” of [RFC 9537] is Profile] “$.entities[?(@.roles[0]=='registrant')].vcardArray[1][?(@[0]=='email')][3]” or using the “replacementPath” to the “vcard” “contact-uri” property. Redacted entity object class, with “technical” role, “handle” member. The “removal” [ICANN gTLD Registry Tech ID redacted redacted “path” member JSONPath for Figure “Unredacted RDAP Lookup Response” of [RFC [ICANN] RDAP name 9537] is “$.entities[?(@.roles[0]==’technical’)].handle”. Response Profile] Redacted entity object class, with “technical” role, name property. When using jCard, [ICANN gTLD Tech Name redacted redacting the “vcard” “fn” property. The “emptyValue” redacted “path” member JSONPath [ICANN] RDAP name for Figure “Unredacted RDAP Lookup Response” of [RFC 9537] is Response “$.entities[?(@.roles[0]==’technical’)].vcardArray[1][?(@[0]=='fn')][3]”. Profile] Radacted entity object class, with “technical” role, voice phone property. When using [ICANN gTLD Tech Phone redacted jCard, the “vcard” “tel” property with type “voice”. The “removal” redacted “path” [ICANN] RDAP name member JSONPath for Figure “Unredacted RDAP Lookup Response” of [RFC 9537] is Response “$.entities[?(@.roles[0]=='technical')].vcardArray[1][?(@[1].type=='voice')]”. Profile] Redacted entity object class, with “technical” role, voice phone extension property. [ICANN gTLD redacted When using jCard, the “vcard” “tel” property extension value with type “voice”. The RDAP Tech Phone Ext name “removal” redacted “path” member JSONPath for Figure “Unredacted RDAP Lookup [ICANN] Response Response” of [RFC 9537] is Profile] “$.entities[?(@.roles[0]=='technical')].vcardArray[1][?(@[1].type=='voice')]”. Redacted entity object class, with “technical” role, email property. When using jCard, the “vcard” “email” property. The “removal” redacted “path” member JSONPath for Figure “Unredacted RDAP Lookup Response” of [RFC 9537] is [ICANN gTLD Tech Email redacted “$.entities[?(@.roles[0]=='technical')].vcardArray[1][?(@[0]=='email')]”. The [ICANN] RDAP name “replacementValue” redacted “path” member JSONPath for Figure “Unredacted RDAP Lookup Response Response” of [RFC 9537] is Profile] “$.entities[?(@.roles[0]=='technical')].vcardArray[1][?(@[0]=='email')][3]” or using the “replacementPath” to the “vcard” “contact-uri” property. Contact Information ID Name Contact URI Last Updated [CZ.NIC_z._s._p._o.] CZ.NIC, z. s. p. o. mailto:tech&nic.cz 2016-03-30 [ICANN] ICANN mailto:globalsupport&icann.org 2019-08-02 [IESG] IESG mailto:iesg&ietf.org [IETF] IETF mailto:iesg&ietf.org [NRO] NRO mailto:secretariat&nro.net 2021-01-27 Licensing Terms