Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About QoS NSIS Signal Layering Protocol (NSLP) QSPEC Parameters Created 2010-02-24 Last Updated 2010-10-06 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • Object Types • QSPEC Version • QSPEC Type • QSPEC Procedure • Parameter ID • Y.2171 Admission Priority Parameter • Excess Treatment Parameter • Y.1541 QoS Class Parameter • Restoration Priority Field • Time to Restore Field • Extent of Restoration Field Object Types Registration Procedure(s) Specification Required Expert(s) Unassigned Reference [RFC 5975] Available Formats [IMG] CSV Value Description Reference 0 QoS Desired [RFC 5975] 1 QoS Available [RFC 5975] 2 QoS Reserved [RFC 5975] 3 Minimum QoS [RFC 5975] 4-63 Unassigned 64-67 Reserved for Private/Experimental Use [RFC 5975] 68-4095 Reserved [RFC 5975] QSPEC Version Registration Procedure(s) Specification Required Expert(s) Unassigned Reference [RFC 5975] Available Formats [IMG] CSV Value Description Reference 0 Version 0 QSPEC [RFC 5975] 1-15 Unassigned QSPEC Type Registration Procedure(s) Specification Required Expert(s) Unassigned Reference [RFC 5975] Available Formats [IMG] CSV Value Description Reference 0 Default [RFC 5975] 1 Y.1541-QOSM [RFC 5975] 2 RMD-QOSM [RFC 5975] 3-12 Unassigned 13-16 Reserved for Local/Experimental Use [RFC 5975] 17-31 Reserved [RFC 5975] QSPEC Procedure Registration Procedure(s) Specification Required Expert(s) Unassigned Reference [RFC 5975] Available Formats [IMG] CSV Message Sequence Value Object Combination Value Description Reference 0 0 QSPEC objects as specified in [RFC 5975] [RFC 5975] 0 1 QSPEC objects as specified in [RFC 5975] [RFC 5975] 0 2 QSPEC objects as specified in [RFC 5975] [RFC 5975] 0 3-15 Unassigned 1 0 QSPEC objects as specified in [RFC 5975] [RFC 5975] 1 1 QSPEC objects as specified in [RFC 5975] [RFC 5975] 1 2 QSPEC objects as specified in [RFC 5975] [RFC 5975] 1 3-15 Unassigned 2 0 QSPEC objects as specified in [RFC 5975] [RFC 5975] 2 1-15 Unassigned 3-15 0-15 Unassigned Parameter ID Registration Procedure(s) Specification Required Expert(s) Unassigned Reference [RFC 5975] Available Formats [IMG] CSV Value Description Reference 1 TMOD-1 [RFC 5975] 2 TMOD-2 [RFC 5975] 3 Path Latency [RFC 5975] 4 Path Jitter [RFC 5975] 5 Path PLR [RFC 5975] 6 Path PER [RFC 5975] 7 Slack Term [RFC 5975] 8 Preemption Priority & Defending Priority [RFC 5975] 9 Admission Priority [RFC 5975] 10 RPH Priority [RFC 5975] 11 Excess Treatment [RFC 5975] 12 PHB Class [RFC 5975] 13 DSTE Class Type [RFC 5975] 14 Y.1541 QoS Class [RFC 5975] 15 TMOD Extension [RFC 5976] 16 Restoration Priority [RFC 5976] 17 PHR_Resource_Request [RFC 5977] 18 PHR_Release_Request [RFC 5977] 19 PHR_Refresh_Update [RFC 5977] 20 PDR_Reservation_Request [RFC 5977] 21 PDR_Refresh_Request [RFC 5977] 22 PDR_Release_Request [RFC 5977] 23 PDR_Reservation_Report [RFC 5977] 24 PDR_Refresh_Report [RFC 5977] 25 PDR_Release_Report [RFC 5977] 26 PDR_Congestion_Report [RFC 5977] 27-255 Unassigned 256-259 Reserved for Private/Experimental Use [RFC 5975] 260-4095 Reserved [RFC 5975] Y.2171 Admission Priority Parameter Registration Procedure(s) Specification Required Expert(s) Unassigned Reference [RFC 5975] Available Formats [IMG] CSV Value Description Reference 0 best-effort priority flow [RFC 5975] 1 normal priority flow [RFC 5975] 2 high priority flow [RFC 5975] 3-63 Unassigned 64-255 Reserved [RFC 5975] Excess Treatment Parameter Registration Procedure(s) Specification Required Expert(s) Unassigned Reference [RFC 5975] Available Formats [IMG] CSV Value Description Reference 0 drop [RFC 5975] 1 shape [RFC 5975] 2 re-mark [RFC 5975] 3 no metering or policing is permitted [RFC 5975] 4-63 Unassigned 64-255 Reserved [RFC 5975] Y.1541 QoS Class Parameter Registration Procedure(s) Specification Required Expert(s) Unassigned Reference [RFC 5975] Available Formats [IMG] CSV Value Description Reference 0 Y.1541 QoS Class 0 [RFC 5975] 1 Y.1541 QoS Class 1 [RFC 5975] 2 Y.1541 QoS Class 2 [RFC 5975] 3 Y.1541 QoS Class 3 [RFC 5975] 4 Y.1541 QoS Class 4 [RFC 5975] 5 Y.1541 QoS Class 5 [RFC 5975] 6 Y.1541 QoS Class 6 [RFC 5975] 7 Y.1541 QoS Class 7 [RFC 5975] 8-63 Unassigned 64-255 Reserved [RFC 5975] Restoration Priority Field Registration Procedure(s) Specification Required Expert(s) Unassigned Reference [RFC 5976] Available Formats [IMG] CSV Value Description Reference 0 best-effort priority [RFC 5976] 1 normal priority [RFC 5976] 2 high priority [RFC 5976] 3-255 Unassigned Time to Restore Field Registration Procedure(s) Specification Required Expert(s) Unassigned Reference [RFC 5976] Available Formats [IMG] CSV Value Description Reference 0 Unspecified Time-to-Restore [RFC 5976] 1 Best Time-to-Restore: less than or equal to 200 ms [RFC 5976] 2 Normal Time-to-Restore: less than or equal to 2 s [RFC 5976] 3-15 Unassigned Extent of Restoration Field Registration Procedure(s) Specification Required Expert(s) Unassigned Reference [RFC 5976] Available Formats [IMG] CSV Value Description Reference 0 unspecified EOR [RFC 5976] 1 high priority restored at 100%; medium priority restored at 100% [RFC 5976] 2 high priority restored at 100%; medium priority restored at 80% [RFC 5976] 3 high priority restored >= 80%; medium priority restored >= 80% [RFC 5976] 4 high priority restored >= 80%; medium priority restored >= 60% [RFC 5976] 5 high priority restored >= 60%; medium priority restored >= 60% [RFC 5976] 6-15 Unassigned Licensing Terms