Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About Point-to-Point (PPP) Protocol Field Assignments Last Updated 2026-04-24 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • PPP DLL Protocol Numbers • PPP Link Control Protocol (LCP) and Internet Protocol Control Protocol (IPCP) Codes • PPP LCP Configuration Option Types • PPP TNCP Configuration Option Types • PPP ECP Configuration Option Types • PPP CCP Configuration Option Types • PPP SDCP Configuration Options • PPP Authentication Algorithms • PPP LCP FCS-Alternatives • PPP Multilink Endpoint Discriminator Class • PPP LCP Callback Operation Fields • PPP ATCP Configuration Option Types • PPP OSINLCP Configuration Option Types • PPP Banyan Vines Configuration Option Types • PPP Bridging Configuration Option Types • PPP Bridging MAC Types • PPP Bridging Spanning Tree • PPP (IPXCP) Configuration Options • IPX Compression Protocol Values (Value 3) • IPX Routing Protocol Options (Value 4) • NetBIOS Frames Control Protocol (NBFCP) Configuration Options • NBFCP Configuration Options - Name-Projection 'Added' field (value 1) • NBFCP Configuration Options - Peer-Information (value 2) • PPP EAP Request/Response Types • PPP Vendor Specific OUI Options • PPP IPCP Configuration Option Types • PPP IPv6CP Configuration Options • IP-Compression-Protocol Types • IPv6-Compression-Protocol Types • IP Header Compression Configuration Option Suboption Types • ROHC Configuration Option Suboption Identifier Values • PPP Over Ethernet Versions PPP DLL Protocol Numbers Reference [RFC 1661][RFC 3818] Note The Point-to-Point Protocol (PPP) Data Link Layer [RFC 1331]; [RFC 1332]; [RFC 1353] contains a 16 bit Protocol field to identify the the encapsulated protocol. The Protocol field is consistent with the ISO 3309 (HDLC) extension mechanism for Address fields. All Protocols MUST be assigned such that the least significant bit of the most significant octet equals "0", and the least significant bit of the least significant octet equals "1". It is recommended that values in the "02xx" to "1exx" and "xx01" to "xx1f" ranges not be assigned, as they are compression inefficient. Available Formats [IMG] CSV Range Registration Procedures Note 0xxx-3xxx IETF Review Network Layer Protocols 4xxx-7xxx IETF Review Low volume traffic without NCP 8xxx-bxxx IETF Review Network Control Protocols cxxx-fxxx IETF Review Link-layer Control Protocols Value (in hex) Protocol Name Reference 0001 Padding Protocol [RFC 1661] 0003 ROHC small-CID [RFC 3095] 0005 ROHC large-CID [RFC 3095] 0007-001f Reserved (transparency inefficient) [RFC 1661] 0021 Internet Protocol version 4 [RFC 1332] 0023 OSI Network Layer [RFC 1377] 0025 Xerox NS IDP [RFC 1764] 0027 DECnet Phase IV [RFC 1762] 0029 Appletalk [RFC 1378] 002b Novell IPX [RFC 1552] 002d Van Jacobson Compressed TCP/IP [RFC 1332] 002f Van Jacobson Uncompressed TCP/IP [RFC 1332] 0031 Bridging PDU [RFC 3518] 0033 Stream Protocol (ST-II) 0035 Banyan Vines [RFC 1763] 0037 Unassigned 0039 AppleTalk EDDP 003b AppleTalk SmartBuffered 003d Multi-Link [RFC 1990] 003f NETBIOS Framing [RFC 2097] 0041 Cisco Systems 0043 Ascom Timeplex 0045 Fujitsu Link Backup and Load Balancing (LBLB) 0047 DCA Remote Lan 0049 Serial Data Transport Protocol (PPP-SDTP) [RFC 1963] 004b SNA over 802.2 [RFC 2043] 004d SNA [RFC 2043] 004f IPv6 Header Compression 0051 KNX Bridging Data [ianp_knxunix_knx_co] 0053 Encryption [RFC 1968] 0055 Individual Link Encryption [RFC 1968] 0057 Internet Protocol version 6 [RFC 5072] 0059 PPP Muxing [RFC 3153] 005b Vendor-Specific Network Protocol (VSNP) [RFC 3772] 005d TRILL Network Protocol (TNP) [RFC 6361] 0061 RTP IPHC Full Header [RFC 3544] 0063 RTP IPHC Compressed TCP [RFC 3544] 0065 RTP IPHC Compressed Non TCP [RFC 3544] 0067 RTP IPHC Compressed UDP 8 [RFC 3544] 0069 RTP IPHC Compressed RTP 8 [RFC 3544] 006f Stampede Bridging 0071 Reserved [Karl_Fox] 0073 MP+ Protocol [RFC 1934] 007d Reserved (Control Escape) [RFC 1661] 007f Reserved (compression inefficient) [RFC 1662] 0081 Unassigned 0083 Unassigned 00c1 NTCITS IPI [Alan_Ungar] 00cf Reserved (PPP NLPID) [RFC 1661] 00fb Single link compression in multilink [RFC 1962] 00fd Compressed datagram [RFC 1962] 00ff Reserved (compression inefficient) [RFC 1661] 0201 802.1d Hello Packets [RFC 3518] 0203 IBM Source Routing BPDU [RFC 3518] 0205 DEC LANBridge100 Spanning Tree [RFC 3518] 0207 Cisco Discovery Protocol [Arun_Sastry] 0209 Netcs Twin Routing [Oliver_Korfmacher] 020b STP - Scheduled Transfer Protocol [Ben_Segal] 020d EDP - Extreme Discovery Protocol [Don_Grosser] 0211 Optical Supervisory Channel Protocol (OSCP) [Sharat_C_Prasad] 0213 Optical Supervisory Channel Protocol (OSCP) [Sharat_C_Prasad] 0231 Luxcom 0233 Sigma Network Systems 0235 Apple Client Server Protocol [Howard_Ridenour] 0281 MPLS Unicast [RFC 3032] 0283 MPLS Multicast [RFC 3032] 0285 IEEE p1284.4 standard - data packets [Brian_Batchelder] 0287 ETSI TETRA Network Protocol Type 1 [Seppo_Nieminen] 0289 Multichannel Flow Treatment Protocol [Pete_McCann] 028b-1exx Reserved for compression inefficient 2063 RTP IPHC Compressed TCP No Delta [RFC 3544] 2065 RTP IPHC Context State [RFC 3544] 2067 RTP IPHC Compressed UDP 16 [RFC 3544] 2069 RTP IPHC Compressed RTP 16 [RFC 3544] 4001 Cray Communications Control Protocol [Erling_B_Stage] 4003 CDPD Mobile Network Registration Protocol [Frank_Quick] 4005 Expand accelerator protocol [Ilan_Rachmani] 4007 ODSICP NCP [K_Arvind] 4009 DOCSIS DLL [Jason_Gaedtke] 400B Cetacean Network Detection Protocol [Curtis_A_Siller_Jr] 4021 Stacker LZS [RFC 1974] 4023 RefTek Protocol [Robert_Banfill] 4025 Fibre Channel [Murali_Rajagopal] 4027 OpenDOF [Bryant_Eastham] 405b Vendor-Specific Protocol (VSP) [RFC 3772] 405d TRILL Link State Protocol (TLSP) [RFC 6361] 8001-801f Not Used - reserved [RFC 1661] 8021 Internet Protocol Control Protocol [RFC 1332] 8023 OSI Network Layer Control Protocol [RFC 1377] 8025 Xerox NS IDP Control Protocol [RFC 1764] 8027 DECnet Phase IV Control Protocol [RFC 1762] 8029 Appletalk Control Protocol [RFC 1378] 802b Novell IPX Control Protocol [RFC 1552] 802d Reserved 802f Reserved 8031 Bridging NCP [RFC 3518] 8033 Stream Protocol Control Protocol 8035 Banyan Vines Control Protocol [RFC 1763] 8037 Unassigned 8039 Reserved 803b Reserved 803d Multi-Link Control Protocol [RFC 1990] 803f NETBIOS Framing Control Protocol [RFC 2097] 8041 Cisco Systems Control Protocol 8043 Ascom Timeplex 8045 Fujitsu LBLB Control Protocol 8047 DCA Remote Lan Network Control Protocol (RLNCP) 8049 Serial Data Control Protocol (PPP-SDCP) [RFC 1963] 804b SNA over 802.2 Control Protocol [RFC 2043] 804d SNA Control Protocol [RFC 2043] 804f IP6 Header Compression Control Protocol 8051 KNX Bridging Control Protocol [ianp_knxunix_knx_co] 8053 Encryption Control Protocol [RFC 1968] 8055 Individual Link Encryption Control Protocol [RFC 1968] 8057 IPv6 Control Protocol [RFC 5072] 8059 PPP Muxing Control Protocol [RFC 3153] 805b Vendor-Specific Network Control Protocol (VSNCP) [RFC 3772] 805d TRILL Network Control Protocol (TNCP) [RFC 6361] 806f Stampede Bridging Control Protocol 8073 MP+ Control Protocol [RFC 1934] 8071 Reserved [Karl_Fox] 807d Not Used - reserved [RFC 1661] 8081 Unassigned 8083 Unassigned 80c1 NTCITS IPI Control Protocol [Alan_Ungar] 80cf Not Used - reserved [RFC 1661] 80fb single link compression in multilink control [RFC 1962] 80fd Compression Control Protocol [RFC 1962] 80ff Not Used - reserved [RFC 1661] 8207 Cisco Discovery Protocol Control [Arun_Sastry] 8209 Netcs Twin Routing [Oliver_Korfmacher] 820b STP - Control Protocol [Ben_Segal] 820d EDPCP - Extreme Discovery Protocol Ctrl Prtcl [Don_Grosser] 8235 Apple Client Server Protocol Control [Howard_Ridenour] 8281 MPLSCP [RFC 3032] 8285 IEEE p1284.4 standard - Protocol Control [Brian_Batchelder] 8287 ETSI TETRA TNP1 Control Protocol [Seppo_Nieminen] 8289 Multichannel Flow Treatment Protocol [Pete_McCann] c021 Link Control Protocol [RFC 1661] c023 Password Authentication Protocol [RFC 1661] c025 Link Quality Report [RFC 1661] c027 Shiva Password Authentication Protocol c029 CallBack Control Protocol (CBCP) c02b BACP Bandwidth Allocation Control Protocol [RFC 2125] c02d BAP [RFC 2125] c05b Vendor-Specific Authentication Protocol (VSAP) [RFC 3772] c081 Container Control Protocol [Ken_funk_com] c223 Challenge Handshake Authentication Protocol [RFC 1661] c225 RSA Authentication Protocol [Badari_Narayana] c227 Extensible Authentication Protocol [RFC 3748] c229 Mitsubishi Security Info Exch Ptcl (SIEP) [Shoichiro_Seno] c26f Stampede Bridging Authorization Protocol c281 Proprietary Authentication Protocol [Ken_funk_com] c283 Proprietary Authentication Protocol [Wayne_Tackabury] c481 Proprietary Node ID Authentication Protocol [Ken_funk_com] PPP Link Control Protocol (LCP) and Internet Protocol Control Protocol (IPCP) Codes Registration Procedure(s) IETF Review Reference [RFC 1661][RFC 3818] Note The Point-to-Point Protocol (PPP) Link Control Protocol (LCP), the Compression Control Protocol (CCP), Internet Protocol Control Protocol (IPCP), and other control protocols, contain an 8 bit Code field which identifies the type of packet. Available Formats [IMG] CSV Code Packet Type Reference Note 0 Vendor Specific [RFC 2153] 1 Configure-Request [RFC 1661] 2 Configure-Ack [RFC 1661] 3 Configure-Nak [RFC 1661] 4 Configure-Reject [RFC 1661] 5 Terminate-Request [RFC 1661] 6 Terminate-Ack [RFC 1661] 7 Code-Reject [RFC 1661] 8 Protocol-Reject [RFC 1661] LCP Only 9 Echo-Request [RFC 1661] LCP Only 10 Echo-Reply [RFC 1661] LCP Only 11 Discard-Request [RFC 1661] LCP Only 12 Identification [RFC 1570] LCP Only 13 Time-Remaining [RFC 1570] LCP Only 14 Reset-Request [RFC 1962] CCP Only 15 Reset-Reply [RFC 1962] CCP Only PPP LCP Configuration Option Types Registration Procedure(s) IETF Review Reference [RFC 1661][RFC 3818] Note The Point-to-Point Protocol (PPP) Link Control Protocol (LCP) specifies a number of Configuration Options which are distinguished by an 8 bit Type field. Available Formats [IMG] CSV Type Configuration Option Reference 0 Vendor Specific [RFC 2153] 1 Maximum-Receive-Unit [RFC 1661] 2 Async-Control-Character-Map 3 Authentication-Protocol [RFC 1661] 4 Quality-Protocol [RFC 1661] 5 Magic-Number [RFC 1661] 6 DEPRECATED (Quality-Protocol) 7 Protocol-Field-Compression [RFC 1661] 8 Address-and-Control-Field-Compression [RFC 1661] 9 FCS-Alternatives [RFC 1570] 10 Self-Describing-Pad [RFC 1570] 11 Numbered-Mode [RFC 1663] 12 DEPRECATED (Multi-Link-Procedure) 13 Callback [RFC 1570] 14 DEPRECATED (Connect-Time) 15 DEPRECATED (Compound-Frames) 16 DEPRECATED (Nominal-Data-Encapsulation) 17 Multilink-MRRU [RFC 1990] 18 Multilink-Short-Sequence-Number-Header [RFC 1990] 19 Multilink-Endpoint-Discriminator [RFC 1990] 20 Proprietary [Ken_funk_com] 21 DCE-Identifier [Warning: option type in the RFC is incorrect.] [RFC 1976] 22 Multi-Link-Plus-Procedure [RFC 1934] 23 Link Discriminator for BACP [RFC 2125] 24 LCP-Authentication-Option [Ken_Culbert] 25 Consistent Overhead Byte Stuffing (COBS) [James_Carlson] 26 Prefix elision [RFC 2686]; [RFC 2687] 27 Multilink header format [RFC 2686]; [RFC 2687] 28 Internationalization [RFC 2484] 29 Simple Data Link on SONET/SDH [RFC 2823] 30 Unassigned PPP TNCP Configuration Option Types Registration Procedure(s) IETF Review Reference [RFC 6361] Available Formats [IMG] CSV Type Configuration Option Reference 0 Vendor Specific [RFC 2153] PPP ECP Configuration Option Types Registration Procedure(s) Expert Review Expert(s) James Carlson Reference [RFC 1968] Note A one octet field is used in the Encryption Control Protocol (ECP) to indicate the configuration option type [RFC 1968]. Available Formats [IMG] CSV ECP Option Configuration Type Reference 0 OUI [RFC 1968] 1 Deprecated (DESE) [Karl_Fox] 2 3DESE [RFC 2420] 3 DESE-bis [RFC 2419] 4-255 Unassigned PPP CCP Configuration Option Types Registration Procedure(s) IETF Review Reference [RFC 1962][RFC 3818] Note A one octet field is used in the Compression Control Protocol (CCP) to indicate the configuration option type [RFC 1962]. The unassigned values 4-15 are intended to be assigned to other freely available compression algorithms that have no license fees. Available Formats [IMG] CSV CCP Option Configuration Type Reference 0 OUI [RFC 1962] 1 Predictor type 1 [RFC 1962] 2 Predictor type 2 [RFC 1962] 3 Puddle Jumper [RFC 1962] 4-15 Unassigned 16 Hewlett-Packard PPC [RFC 1962] 17 Stac Electronics LZS [RFC 1974] 18 Microsoft PPC [RFC 2118] 19 Gandalf FZA [RFC 1993] 20 V.42bis compression [RFC 1962] 21 BSD Compress [RFC 1977] 22 Unassigned 23 LZS-DCP [RFC 1967] 24 MVRCA (Magnalink) [RFC 1975] 25 Unassigned 26 Deflate [RFC 1979] 27 V.44/LZJH Compression Protocol [Jeff_Heath] 28-254 Unassigned 255 Reserved [RFC 1962] PPP SDCP Configuration Options Registration Procedure(s) Expert Review Expert(s) James Carlson Reference [RFC 1963] Note A one octet field is used in the PPP Serial Data Transport Protocol (SDTP) to indicate the option type [RFC 1963]. Note that Option Types 5-8 are specific to a single port and require port numbers in their format. Option Types 6-8 are specific to the HDLC-Synchronous Transport-Mode. Available Formats [IMG] CSV SDCP Option Configuration Element Reference 1 Packet-Format [RFC 1963] 2 Header-Type [RFC 1963] 3 Length-Field-Present [RFC 1963] 4 Multi-Port [RFC 1963] 5 Transport-Mode [RFC 1963] 6 Maximum-Frame-Size [RFC 1963] 7 Allow-Odd-Frames [RFC 1963] 8 FCS-Type [RFC 1963] 9 Flow-Expiration-Time [RFC 1963] PPP Authentication Algorithms Registration Procedure(s) Expert Review Expert(s) James Carlson Reference [RFC 1994] Note A one octet field is used in the Challenge-Handshake Authentication Protocol (CHAP) to indicate which algorithm is in use [RFC 1994]. Available Formats [IMG] CSV Number Name Reference 0 Reserved [RFC 1994] 1 Reserved [RFC 1994] 2 Reserved [RFC 1994] 3 Reserved [RFC 1994] 4 Reserved [RFC 1994] 5 CHAP with MD5 [RFC 1994] 6 CHAP with SHA-1 [David_Black] 7 CHAP with SHA-256 [David_Black] 8 CHAP with SHA3-256 [David_Black] 9 CHAP with SHA-384 [David_Black] 10 CHAP with SHA3-384 [David_Black] 11 CHAP with SHA-512 [David_Black] 12 CHAP with SHA3-512 [David_Black] 13-127 Unassigned 128 MS-CHAP [RFC 2433] 129 MS-CHAP-2 [RFC 2759] PPP LCP FCS-Alternatives Registration Procedure(s) IETF Review Reference [RFC 1570][RFC 3818] Note The Point-to-Point Protocol (PPP) Link Control Protocol (LCP) FCS-Alternatives Configuration Option contains an 8-bit Options field which identifies the FCS used. These are assigned as follows. Available Formats [IMG] CSV Bit FCS Reference 1 Null FCS [RFC 1570] 2 CCITT 16-Bit FCS [RFC 1570] 3 Unassigned 4 CCITT 32-bit FCS [RFC 1570] PPP Multilink Endpoint Discriminator Class Registration Procedure(s) IETF Review Reference [RFC 1990][RFC 3818] Note The Point-to-Point Protocol (PPP) Link Control Protocol (LCP) Multilink Endpoint Discriminator Option includes a Class field which identifies the address class. Available Formats [IMG] CSV Class Description Reference 0 Null Class [RFC 1990] 1 Locally Assigned [RFC 1990] 2 Internet Protocol (IPv4) [RFC 1990] 3 IEEE 802.1 global MAC address [RFC 1990] 4 PPP Magic Number Block [RFC 1990] 5 Public Switched Network Director Number [RFC 1990] 6 Internet Protocol (Ipv6) Address [RFC 3790] PPP LCP Callback Operation Fields Registration Procedure(s) IETF Review Reference [RFC 1570][RFC 3818] Note The Point-to-Point Protocol (PPP) Link Control Protocol (LCP) Callback Configuration Option contains an 8-bit Operations field which identifies the format of the Message. Available Formats [IMG] CSV Operation Description Reference 0 Location determined by user authentication [RFC 1570] 1 Dialing string [RFC 1570] 2 Location identifier [RFC 1570] 3 E.164 number [RFC 1570] 4 X.500 distinguished name [RFC 1570] 5 Unassigned 6 Location is determined during CBCP negotiation PPP ATCP Configuration Option Types Registration Procedure(s) Expert Review Expert(s) James Carlson Reference [RFC 1378] Note The Point-to-Point Protocol (PPP) Apple Talk Control Protocol (ATCP) specifies a number of Configuration Options [RFC 1378] which are distinguished by an 8 bit Type field. Available Formats [IMG] CSV Type Configuration Option Reference 1 AppleTalk-Address [RFC 1378] 2 Routing-Protocol [RFC 1378] 3 Suppress-Broadcasts [RFC 1378] 4 AT-Compression-Protocol [RFC 1378] 5 Reserved [RFC 1378] 6 Server-information [RFC 1378] 7 Zone-information [RFC 1378] 8 Default-Router-Address [RFC 1378] PPP OSINLCP Configuration Option Types Registration Procedure(s) Expert Review Expert(s) James Carlson Reference [RFC 1377] Note The Point-to-Point Protocol (PPP) OSI Network Layer Control Protocol (OSINLCP) specifies a number of Configuration Options [RFC 1377] which are distinguished by an 8 bit Type field. Available Formats [IMG] CSV Type Configuration Option Reference 1 Align-NPDU [RFC 1377] PPP Banyan Vines Configuration Option Types Registration Procedure(s) Expert Review Expert(s) James Carlson Reference [RFC 1763] Note The Point-to-Point Protocol (PPP) Banyan Vines Control Protocol (BVCP) specifies a number of Configuration Options [RFC 1763] which are distinguished by an 8 bit Type field. Available Formats [IMG] CSV Type Configuration Option Reference 1 BV-NS-RTP-Link-Type [RFC 1763] 2 BV-FRP [RFC 1763] 3 BV-RTP [RFC 1763] 4 BV-Suppress-Broadcast [RFC 1763] PPP Bridging Configuration Option Types Registration Procedure(s) IETF Review Reference [RFC 3518][RFC 3818] Note The Point-to-Point Protocol (PPP) Bridging Control Protocol (BCP) specifies a number of Configuration Options which are distinguished by an 8 bit Type field. Available Formats [IMG] CSV Type Configuration Option Reference 1 Bridge-Identification [RFC 3518] 2 Line-Identification [RFC 3518] 3 MAC-Support [RFC 3518] 4 Tinygram-Compression [RFC 3518] 5 LAN-Identification (obsoleted) [RFC 3518] 6 MAC-Address [RFC 3518] 7 Spanning-Tree-Protocol (old formatted) [RFC 3518] 8 IEEE-802-Tagged-Frame [RFC 3518] 9 Management-Inline [RFC 3518] 10 Bridge-Control-Packet-Indicator [RFC 3518] PPP Bridging MAC Types Registration Procedure(s) IETF Review Reference [RFC 3518][RFC 3818] Note The Point-to-Point Protocol (PPP) Bridging Control Protocol (BCP) contains an 8 bit MAC Type field which identifies the MAC encapsulated. Available Formats [IMG] CSV Type MAC Address Format Reference 0 Reserved [RFC 3518] 1 IEEE 802.3/Ethernet Canonical addresses [RFC 3518] 2 IEEE 802.4 Canonical addresses [RFC 3518] 3 IEEE 802.5 Non-canonical addresses [RFC 3518] 4 FDDI Non-canonical addresses [RFC 3518] 5-10 Reserved 11 IEEE 802.5 Canonical addresses [RFC 3518] 12 FDDI Canonical addresses [RFC 3518] PPP Bridging Spanning Tree Registration Procedure(s) IETF Review Reference [RFC 3518][RFC 3818] Note The Point-to-Point Protocol (PPP) Bridging Control Protocol (BCP) Spanning Tree Configuration Option contains an 8-bit Protocol field which identifies the spanning tree used. These are assigned as follows: Available Formats [IMG] CSV Protocol Spanning Tree Reference 0 Null - no spanning tree protocol supported [RFC 3518] 1 IEEE 802.1D spanning tree protocol [RFC 3518] 2 IEEE 802.1G extended spanning tree protocol [RFC 3518] 3 IBM source route spanning tree protocol [RFC 3518] 4 DEC LANbridge 100 spanning tree protocol [RFC 3518] PPP (IPXCP) Configuration Options Registration Procedure(s) Expert Review Expert(s) James Carlson Reference [RFC 1552] Available Formats [IMG] CSV Option Description Reference 1 IPX-Network-Number [RFC 1552] 2 IPX-Node-Number [RFC 1552] 3 IPX-Compression-Protocol [RFC 1552] 4 IPX-Routing-Protocol [RFC 1552] 5 IPX-Router-Name [RFC 1552] 6 IPX-Configuration-Complete [RFC 1552] IPX Compression Protocol Values (Value 3) Registration Procedure(s) Expert Review Expert(s) James Carlson Reference [RFC 1552] Available Formats [IMG] CSV Value (in hex) Protocol Reference 0000-0001 Unassigned 0002 Telebit Compressed IPX [RFC 1552] 0002-0234 Unassigned 0235 Shiva Compressed NCP/IPX [RFC 1552] IPX Routing Protocol Options (Value 4) Registration Procedure(s) Expert Review Expert(s) James Carlson Reference [RFC 1552] Available Formats [IMG] CSV Value Protocol Reference 0 No routing protocol required [RFC 1552] 1 Reserved [RFC 1552] 2 Novell RIP/SAP required [RFC 1552] 3 Unassigned 4 Novell NLSP required [RFC 1552] 5 Novell Demand RIP required [RFC 1582] 6 Novell Demand SAP required [RFC 1582] 7 Novell Triggered RIP required [Richard_Edmonstone] 8 Novell Triggered SAP required [Richard_Edmonstone] NetBIOS Frames Control Protocol (NBFCP) Configuration Options Registration Procedure(s) Expert Review Expert(s) James Carlson Reference [RFC 2097] Note NBFCP Configuration Options [RFC 2097] allow modifications to the standard characteristics of the network-layer protocol to be negotiated. If a Configuration Option is not included in a Configure-Request packet, the default value for that Configuration Option is assumed. NBFCP uses the same Configuration Option format defined for LCP, with a separate set of Options. Available Formats [IMG] CSV Value Option Reference 0 Reserved [RFC 2153] 1 Name-Projection [RFC 2097] 2 Peer-Information [RFC 2097] 3 Multicast-Filtering [RFC 2097] 4 IEEE-MAC-Address-Required [RFC 2097] 5-255 Unassigned NBFCP Configuration Options - Name-Projection 'Added' field (value 1) Registration Procedure(s) IANA does not allocate Reference [RFC 2097] Note The Name-Projection 'Added' field is not defined by IETF or allocated through IANA and thus no new values should be allocated. Available Formats [IMG] CSV Value (Hex) Result Codes for Added field Reference 00 Name successfully added. [RFC 2097] 0D Duplicate name in local name table. [RFC 2097] 0E Name table full. [RFC 2097] 15 Name not found or cannot specify "*" or null. [RFC 2097] 16 Name in use on remote NetBIOS. [RFC 2097] 19 Name conflict detected. [RFC 2097] 30 Name defined by another environment. [RFC 2097] 35 Required system resources exhausted. [RFC 2097] 36-FF Undefined NBFCP Configuration Options - Peer-Information (value 2) Registration Procedure(s) Expert Review Reference [RFC 2097] Available Formats [IMG] CSV Value Peer-Class Reference 1 Reserved for legacy implementations. [RFC 2097] 2 PPP NetBIOS Gateway Server. [RFC 2097] 3 Reserved for legacy implementations. [RFC 2097] 4 PPP Local Access Only Server. [RFC 2097] 5 Reserved for legacy implementations. [RFC 2097] 6 PPP NBF Bridge. [RFC 2097] 7 Reserved for legacy implementations. [RFC 2097] 8 PPP End-System. [RFC 2097] 9-255 Unassigned PPP EAP Request/Response Types Registration Procedure(s) Expert Review Reference [RFC 3748] Note A one octet field is used in the Extensible Authentication Protocol (EAP) to indicate the function and structure of EAP Request and Response packets [RFC 3748]. This registry has been replaced. See the "Method Types" registry at [Extensible Authentication Protocol (EAP) Registry] for a current list of the assigned types. PPP Vendor Specific OUI Options Registration Procedure(s) Registry closed by [RFC 5342] Reference [RFC 5342] Note PPP Vendor Extensions [RFC 2153] uses IEEE standard OUIs (Organizationally Unique Identifiers) to indicate vendor-specific features. See [RFC 1700] for details on contacting the IEEE. Vendors that desire to use their IEEE 802 OUI for PPP Vendor Extensions should register their OUI with IANA. Vendors that do not otherwise need an IEEE assigned OUI can request a PPP specific OUI from IANA out of the 'CF0000' range, which has both the "locally-assigned" and "broadcast/multicast" bits set to one. See [RFC 2153] for details. Available Formats [IMG] CSV OUI (in hex) Organization Reference CF0001 NTT Mobile Communications Network CF0001 Data Comm for Business [1] [John_McCain] CF0002 3GPP2 Vendor specific packet ID [Trevor_Plestid] CF0003 Trafficmaster, Plc [David_Fernandez] CF0004-CFFFFF Reserved: Registry closed PPP IPCP Configuration Option Types Registration Procedure(s) IETF Review Reference [RFC 1332][RFC 3818] Note The Point-to-Point Protocol (PPP) Internet Protocol Control Protocol (IPCP) specifies a number of Configuration Options which are distinguished by an 8 bit Type field. Available Formats [IMG] CSV Type Configuration Option Reference 1 IP-Addresses (deprecated) [RFC 1332] 2 IP-Compression-Protocol [RFC 1332] 3 IP-Address [RFC 1332] 4 Mobile-IPv4 [RFC 2290] 5-128 Unassigned 129 Primary DNS Server Address [RFC 1877] 130 Primary NBNS Server Address [RFC 1877] 131 Secondary DNS Server Address [RFC 1877] 132 Secondary NBNS Server Address [RFC 1877] PPP IPv6CP Configuration Options Registration Procedure(s) IETF Review Reference [RFC 5072][RFC 3818] Note IPV6CP Configuration Options allow negotiation of desirable IPv6 parameters. IPV6CP uses the same Configuration Option format defined for LCP, with a separate set of Options. If a Configuration Option is not included in a Configure-Request packet, the default value for that Configuration Option is assumed. Available Formats [IMG] CSV Type Configuration Option Reference 1 Interface-Identifier [RFC 5072] 2 IPv6-Compression-Protocol [RFC 5172] IP-Compression-Protocol Types Registration Procedure(s) IETF Review Reference [RFC 1332] Available Formats [IMG] CSV Value (hex) Description Reference 002d Van Jacobson Compressed TCP/IP [RFC 1144]; [RFC 1332] 0003 Robust Header Compression (ROHC) [RFC 3241] 0061 IP Header Compression [RFC 2507]; [RFC 3544] IPv6-Compression-Protocol Types Registration Procedure(s) IETF Review Reference [RFC 5172] Available Formats [IMG] CSV Value (hex) Description Reference 0003 Robust Header Compression (ROHC) [RFC 3241] 004f Historical; do not use -- see RFC2023 0061 IP Header Compression [RFC 2507]; [RFC 3544] IP Header Compression Configuration Option Suboption Types Registration Procedure(s) Standards Action Reference [RFC 3544] Available Formats [IMG] CSV Value Description Reference 1 RTP Header Compression [RFC 2508]; [RFC 3544] 2 Enhanced RTP-Compression [RFC 3544] 3 TCP or non-TCP Compression Disable [RFC 3544] ROHC Configuration Option Suboption Identifier Values Reference [RFC 3241] Note Please see [RObust Header Compression (ROHC) Suboption Identifier Values] PPP Over Ethernet Versions Registration Procedure(s) Specification Required Expert(s) Donald Eastlake Reference [RFC 2516][RFC 8822] Available Formats [IMG] CSV VER Description Reference 0 Reserved [RFC 8822] 1 PPPoE [RFC 2516] 2 5G WWC User Plane Encapsulation [RFC 8822] 3-15 Unassigned Contact Information ID Name Contact URI Last Updated [Alan_Ungar] Alan Ungar mailto:AUngar&farradyne.com 1995-04 [Arun_Sastry] Arun Sastry mailto:asastry&cisco.com 1995-04 [Badari_Narayana] Badari Narayana mailto:badari&ca.sjf.novell.com [Ben_Segal] Ben Segal mailto:b.segal&cern.ch 2000-08 [Brian_Batchelder] Brian Batchelder mailto:brianb&vcd.hp.com 1999-01 [Bryant_Eastham] Bryant Eastham mailto:protocol&opendof.org 2015-04-23 [Curtis_A_Siller_Jr] Curtis A. Siller Jr. mailto:csiller&cetacean.com 2003-01 [David_Fernandez] David Fernandez mailto:david.fernandez&trafficmaster.co.uk 2007-04-18 [David_Black] David Black mailto:david.black&dell.com 2026-04-16 [Don_Grosser] Don Grosser mailto:dgrosser&extremenetworks.com 2000-10 [Erling_B_Stage] Erling B. Stage mailto:ebs&craycom.dk 1994-10 [Frank_Quick] Frank Quick mailto:fquick&qualcomm.com [Howard_Ridenour] Howard Ridenour mailto:RIDENOUR1&applelink.apple.com 1995-02 [Ilan_Rachmani] Ilan Rachmani mailto:standards&expand.com 1999-10 [James_Carlson] James Carlson mailto:carlsonj&workingcode.com 2026-04-24 [Jason_Gaedtke] Jason Gaedtke mailto:j.gaedtke&cablelabs.com 2002-04 [Jeff_Heath] Jeff Heath mailto:jheath&hns.com 2002-04 [John_McCain] John McCain mailto:jmccain&dcbnet.com 1997-07 [K_Arvind] K. Arvind mailto:arvind&tenornetworks.com 2000-11 [Karl_Fox] Karl Fox mailto:karl&ascend.con 1997-01 [Ken_Culbert] Ken Culbert mailto:ken&funk.com 1996-10 [Murali_Rajagopal] Murali Rajagopal mailto:murali&gadzoox.com 2000-05 [Oliver_Korfmacher] Oliver Korfmacher mailto:okorf&netcs.com 1995-04 [Pete_McCann] Pete McCann mailto:mccap&research.bell-labs.com 2001-03 [Richard_Edmonstone] Richard Edmonstone mailto:richarde&spider.co.uk 1996-07 [Robert_Banfill] Robert Banfill mailto:r_banfill&reftek.com 1997-07 [Seppo_Nieminen] Seppo Nieminen mailto:seppo.niemimen&ntc.nokia.com 1999-07 [Sharat_C_Prasad] Sharat C. Prasad mailto:shprasad&cisco.com 2001-10 [Shoichiro_Seno] Shoichiro Seno mailto:senos&kousoku.isl.melco.co.jp 1995-04 [Trevor_Plestid] Trevor Plestid mailto:tplestid&rim.net 2003-06 [Wayne_Tackabury] Wayne Tackabury mailto:wayne&cayman.cayman.com 1995-01 [ianp_knxunix_knx_co] mailto:ianp&knxunix.knx.co.uk 1994-11 [Ken_funk_com] mailto:ken&funk.com Footnote [1] The duplicate assignment of CF0001 was inadvertent. As per Expert Donald Eastlake, this assignment has been moved to here from the ethernet-numbers registry. Licensing Terms