Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About Performance Metrics Created 2020-03-19 Last Updated 2026-05-08 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • Performance Metrics Registry • Performance Metric Name Elements - Metric Type • Performance Metric Name Elements - Method • Performance Metric Name Elements - SubTypeMethod • Performance Metric Name Elements - Spec • Performance Metric Name Elements - Units • Performance Metric Name Elements - Output Performance Metrics Registry Registration Procedure(s) Specification Required Expert(s) Greg Mirsky, Michael Scharf Reference [RFC 8911] Note Summary category shown. Complete registry entries available in the URIs of each row. Available Formats [IMG] CSV Identifier Name URI Description Reference Change Version Controller 0 Reserved [RFC IETF 8912] This metric assesses the delay of a stream of packets exchanged between two hosts (which are the two measurement points). The 1 RTDelay_Active_IP-UDP-Periodic_RFC8912sec4_Seconds_95Percentile RTDelay_Active_IP-UDP-Periodic_RFC8912sec4_Seconds_95Percentile output is the [RFC IETF 1.0 round-trip 8912] delay for all successfully exchanged packets expressed as the 95th percentile of their conditional delay distribution. This metric assesses the loss ratio of a stream of packets exchanged between two hosts (which [RFC are the two 8912]; 2 RTLoss_Active_IP-UDP-Periodic_RFC8912sec4_Percent_LossRatio RTLoss_Active_IP-UDP-Periodic_RFC8912sec4_Percent_LossRatio measurement [RFC IETF 1.0 points). The Errata output is the 6758] round-trip loss ratio for all successfully exchanged packets expressed as a percentage. This metric assesses packet delay variation with respect to the minimum delay observed on 3 OWPDV_Active_IP-UDP-Periodic_RFC8912sec5_Seconds_95Percentile OWPDV_Active_IP-UDP-Periodic_RFC8912sec5_Seconds_95Percentile the periodic [RFC IETF 1.0 stream. The 8912] output is expressed as the 95th percentile of the packet delay variation distribution. This is a metric for DNS Response performance from a network user's perspective, for a specific named resource. The metric can be 4 RTDNS_Active_IP-UDP-Poisson_RFC8912sec6_Seconds_Raw RTDNS_Active_IP-UDP-Poisson_RFC8912sec6_Seconds_Raw measured [RFC IETF 1.0 repeatedly 8912] using different resource names. This metric assesses the response time, the interval from the query transmission to the response. This is a metric for DNS Response performance from a network user's perspective, for a specific named resource. The metric can be measured 5 RLDNS_Active_IP-UDP-Poisson_RFC8912sec6_Logical_Raw RLDNS_Active_IP-UDP-Poisson_RFC8912sec6_Logical_Raw repeatedly [RFC IETF 1.0 using 8912] different resource names. This metric indicates that the response was deemed lost. In other words, the response time exceeded the maximum waiting time. This metric assesses the delay of a stream of packets exchanged between two hosts (or measurement points) and [RFC 6 OWDelay_Active_IP-UDP-Poisson-Payload250B_RFC8912sec7_Seconds_95Percentile OWDelay_Active_IP-UDP-Poisson-Payload250B_RFC8912sec7_Seconds_95Percentile reports the 8912] IETF 1.0 95Percentile of one-way delay for all successfully exchanged packets based on their conditional delay distribution. This metric assesses the delay of a stream of packets exchanged between two hosts (or measurement points) and [RFC 7 OWDelay_Active_IP-UDP-Poisson-Payload250B_RFC8912sec7_Seconds_Mean OWDelay_Active_IP-UDP-Poisson-Payload250B_RFC8912sec7_Seconds_Mean reports the 8912] IETF 1.0 Mean of one-way delay for all successfully exchanged packets based on their conditional delay distribution. This metric assesses the delay of a stream of packets exchanged between two hosts (or measurement points) and [RFC 8 OWDelay_Active_IP-UDP-Poisson-Payload250B_RFC8912sec7_Seconds_Min OWDelay_Active_IP-UDP-Poisson-Payload250B_RFC8912sec7_Seconds_Min reports the 8912] IETF 1.0 Min of one-way delay for all successfully exchanged packets based on their conditional delay distribution. This metric assesses the delay of a stream of packets exchanged between two hosts (or measurement points) and [RFC 9 OWDelay_Active_IP-UDP-Poisson-Payload250B_RFC8912sec7_Seconds_Max OWDelay_Active_IP-UDP-Poisson-Payload250B_RFC8912sec7_Seconds_Max reports the 8912] IETF 1.0 Max of one-way delay for all successfully exchanged packets based on their conditional delay distribution. This metric assesses the delay of a stream of packets exchanged between two hosts (or measurement points) and [RFC 10 OWDelay_Active_IP-UDP-Poisson-Payload250B_RFC8912sec7_Seconds_StdDev OWDelay_Active_IP-UDP-Poisson-Payload250B_RFC8912sec7_Seconds_StdDev reports the 8912] IETF 1.0 StdDev of one-way delay for all successfully exchanged packets based on their conditional delay distribution. This metric assesses the loss ratio of a stream of packets exchanged between two [RFC hosts (which 8912]; 11 OWLoss_Active_IP-UDP-Poisson-Payload250B_RFC8912sec7_Percent_LossRatio OWLoss_Active_IP-UDP-Poisson-Payload250B_RFC8912sec7_Percent_LossRatio are the two [RFC IETF 1.0 measurement Errata points). The 6758] output is the one-way loss ratio for all transmitted packets expressed as a percentage. This metric assesses the delay of a stream of packets exchanged between two hosts (or measurement points) and [RFC 12 OWDelay_Active_IP-UDP-Periodic20m-Payload142B_RFC8912sec8_Seconds_95Percentile OWDelay_Active_IP-UDP-Periodic20m-Payload142B_RFC8912sec8_Seconds_95Percentile reports the 8912] IETF 1.0 95Percentile one-way delay for all successfully exchanged packets based on their conditional delay distribution. This metric assesses the delay of a stream of packets exchanged between two hosts (or measurement 13 OWDelay_Active_IP-UDP-Periodic20m-Payload142B_RFC8912sec8_Seconds_Mean OWDelay_Active_IP-UDP-Periodic20m-Payload142B_RFC8912sec8_Seconds_Mean points) and [RFC IETF 1.0 reports the 8912] Mean one-way delay for all successfully exchanged packets based on their conditional delay distribution. This metric assesses the delay of a stream of packets exchanged between two hosts (or measurement 14 OWDelay_Active_IP-UDP-Periodic20m-Payload142B_RFC8912sec8_Seconds_Min OWDelay_Active_IP-UDP-Periodic20m-Payload142B_RFC8912sec8_Seconds_Min points) and [RFC IETF 1.0 reports the 8912] Min one-way delay for all successfully exchanged packets based on their conditional delay distribution. This metric assesses the delay of a stream of packets exchanged between two hosts (or measurement 15 OWDelay_Active_IP-UDP-Periodic20m-Payload142B_RFC8912sec8_Seconds_Max OWDelay_Active_IP-UDP-Periodic20m-Payload142B_RFC8912sec8_Seconds_Max points) and [RFC IETF 1.0 reports the 8912] Max one-way delay for all successfully exchanged packets based on their conditional delay distribution. This metric assesses the delay of a stream of packets exchanged between two hosts (or measurement points) and [RFC 16 OWDelay_Active_IP-UDP-Periodic20m-Payload142B_RFC8912sec8_Seconds_StdDev OWDelay_Active_IP-UDP-Periodic20m-Payload142B_RFC8912sec8_Seconds_StdDev reports the 8912] IETF 1.0 StdDev one-way delay for all successfully exchanged packets based on their conditional delay distribution. This metric assesses the loss ratio of a stream of packets exchanged between two [RFC hosts (which 8912]; 17 OWLoss_Active_IP-UDP-Periodic20m-Payload142B_RFC8912sec8_Percent_LossRatio OWLoss_Active_IP-UDP-Periodic20m-Payload142B_RFC8912sec8_Percent_LossRatio are the two [RFC IETF 1.0 measurement Errata points). The 6758] output is the one-way loss ratio for all transmitted packets expressed as a percentage. This metric assesses the delay of a stream of ICMP packets exchanged between two hosts (which are the two measurement points). The [RFC 18 RTDelay_Active_IP-ICMP-SendOnRcv_RFC8912sec9_Seconds_Mean RTDelay_Active_IP-ICMP-SendOnRcv_RFC8912sec9_Seconds_Mean output is the 8912] IETF 1.0 round-trip delay for all successfully exchanged packets expressed as the Mean of their conditional delay distribution. This metric assesses the delay of a stream of ICMP packets exchanged between two hosts (which are the two measurement points). The [RFC 19 RTDelay_Active_IP-ICMP-SendOnRcv_RFC8912sec9_Seconds_Min RTDelay_Active_IP-ICMP-SendOnRcv_RFC8912sec9_Seconds_Min output is the 8912] IETF 1.0 round-trip delay for all successfully exchanged packets expressed as the Min of their conditional delay distribution. This metric assesses the delay of a stream of ICMP packets exchanged between two hosts (which are the two measurement points). The [RFC 20 RTDelay_Active_IP-ICMP-SendOnRcv_RFC8912sec9_Seconds_Max RTDelay_Active_IP-ICMP-SendOnRcv_RFC8912sec9_Seconds_Max output is the 8912] IETF 1.0 round-trip delay for all successfully exchanged packets expressed as the Max of their conditional delay distribution. This metric assesses the loss ratio of a stream of ICMP packets exchanged between two hosts (which [RFC are the two 8912]; 21 RTLoss_Active_IP-ICMP-SendOnRcv_RFC8912sec9_Percent_LossRatio RTLoss_Active_IP-ICMP-SendOnRcv_RFC8912sec9_Percent_LossRatio measurement [RFC IETF 1.0 points). The Errata output is the 6758] round-trip loss ratio for all transmitted packets expressed as a percentage. This metric assesses the round-trip delay of TCP packets constituting a single connection, exchanged between two hosts. We consider the measurement of round-trip delay based on a single 22 RTDelay_Passive_IP-TCP_RFC8912sec10_Seconds_Mean RTDelay_Passive_IP-TCP_RFC8912sec10_Seconds_Mean Observation [RFC IETF 1.0 Point (OP) 8912] [RFC 7011] somewhere in the network. The output is the round-trip delay for all successfully exchanged packets expressed as the Mean of their conditional delay distribution. This metric assesses the round-trip delay of TCP packets constituting a single connection, exchanged between two hosts. We consider the measurement of round-trip delay based on a single 23 RTDelay_Passive_IP-TCP_RFC8912sec10_Seconds_Min RTDelay_Passive_IP-TCP_RFC8912sec10_Seconds_Min Observation [RFC IETF 1.0 Point (OP) 8912] [RFC 7011] somewhere in the network. The output is the round-trip delay for all successfully exchanged packets expressed as the Min of their conditional delay distribution. This metric assesses the round-trip delay of TCP packets constituting a single connection, exchanged between two hosts. We consider the measurement of round-trip delay based on a single 24 RTDelay_Passive_IP-TCP_RFC8912sec10_Seconds_Max RTDelay_Passive_IP-TCP_RFC8912sec10_Seconds_Max Observation [RFC IETF 1.0 Point (OP) 8912] [RFC 7011] somewhere in the network. The output is the round-trip delay for all successfully exchanged packets expressed as the Max of their conditional delay distribution. RTDelay Singleton: This metric assesses the round-trip delay of TCP packets initiating a single connection (or 3-way handshake), exchanged between two hosts. We [RFC 25 RTDelay_Passive_IP-TCP-HS_RFC8912sec10_Seconds_Singleton RTDelay_Passive_IP-TCP-HS_RFC8912sec10_Seconds_Singleton consider the 8912] IETF 1.0 measurement of round-trip delay based on a single Observation Point (OP) [RFC 7011] somewhere in the network. The output is a single measurement of Round-trip delay, or Singleton. This metric assesses the estimated loss count for TCP packets constituting a single connection, exchanged between two hosts. We consider the 26 RTLoss_Passive_IP-TCP_RFC8912sec10_Packet_Count RTLoss_Passive_IP-TCP_RFC8912sec10_Packet_Count measurement [RFC IETF 1.0 of round-trip 8912] delay based on a single Observation Point (OP) [RFC 7011] somewhere in the network. The output is the estimated loss count for the measurement interval. This metric assesses the mean of one-way delays of all successfully forwarded IP packets constituting a single [RFC 27 OWDelay_HybridType1_IP_RFC9951_Seconds_Mean OWDelay_HybridType1_IP_RFC9951_Seconds_Mean Flow. The 9951] IETF 1.0 measurement of one-sway delay is based on a single Observation Point [RFC 7011] somewhere in the network. This metric assesses the minimum of one-way delays of all successfully forwarded IP packets constituting a single [RFC 28 OWDelay_HybridType1_IP_RFC9951_Seconds_Min OWDelay_HybridType1_IP_RFC9951_Seconds_Min Flow. The 9951] IETF 1.0 measurement of one-way delay is based on a single Observation Point [RFC 7011] somewhere in the network. This metric assesses the maximum of one-way delays of all successfully forwarded IP packets constituting a single [RFC 29 OWDelay_HybridType1_IP_RFC9951_Seconds_Max OWDelay_HybridType1_IP_RFC9951_Seconds_Max Flow. The 9951] IETF 1.0 measurement of one-way delay is based on a single Observation Point [RFC 7011] somewhere in the network. This metric assesses the maximum of one-way delays of all successfully forwarded IP packets constituting a single [RFC 30 OWDelay_HybridType1_IP_RFC9951_Seconds_Sum OWDelay_HybridType1_IP_RFC9951_Seconds_Sum Flow. The 9951] IETF 1.0 measurement of one-way delay is based on a single Observation Point [RFC 7011] somewhere in the network. Performance Metric Name Elements - Metric Type Registration Procedure(s) Specification Required Expert(s) Greg Mirsky, Michael Scharf Reference [RFC 8911] Available Formats [IMG] CSV Identifier Name Description Reference Change Controller MetricType RTDelay Round-Trip Delay [RFC 8911] IETF MetricType RTDNS Response Time Domain Name Service [RFC 8911] IETF MetricType RLDNS Response Loss Domain Name Service [RFC 8911] IETF MetricType OWDelay One-Way Delay [RFC 8911] IETF MetricType RTLoss Round-Trip Loss [RFC 8911] IETF MetricType OWLoss One-Way Loss [RFC 8911] IETF MetricType OWPDV One-Way Packet Delay Variation [RFC 8911] IETF MetricType OWIPDV One-Way Inter-Packet Delay Variation [RFC 8911] IETF MetricType OWReorder One-Way Packet Reordering [RFC 8911] IETF MetricType OWDuplic One-Way Packet Duplication [RFC 8911] IETF MetricType OWBTC One-Way Bulk Transport Capacity [RFC 8911] IETF MetricType OWMBM One-Way Model-Based Metric [RFC 8911] IETF MetricType SPMonitor Single-Point Monitor [RFC 8911] IETF MetricType MPMonitor Multi-Point Monitor [RFC 8911] IETF Performance Metric Name Elements - Method Registration Procedure(s) Specification Required Expert(s) Greg Mirsky, Michael Scharf Reference [RFC 8911] Available Formats [IMG] CSV Identifier Name Description Reference Change Controller Method Active depends on a dedicated measurement packet stream and observations of the stream as described in [RFC 8911] IETF [RFC 7799] Method Passive depends *solely* on observation of one or more existing packet streams as described in [RFC [RFC 8911] IETF 7799] Method Hybrid Type 1 Hybrid Type I obervations on one stream that combine both Active Methods and Passive Methods as [RFC 8911] IETF described in [RFC 7799] Method Hybrid Type 2 Hybrid Type II obervations on two or more streams that combine both Active Methods and Passive [RFC 8911] IETF Methods as described in [RFC 7799] Method Spatial spatial metric as described in [RFC 5644] [RFC 8911] IETF Performance Metric Name Elements - SubTypeMethod Registration Procedure(s) Specification Required Expert(s) Greg Mirsky, Michael Scharf Reference [RFC 8911] Available Formats [IMG] CSV Identifier Name Description Reference Change Controller SubTypeMethod ICMP Internet Control Message Protocol [RFC 8911] IETF SubTypeMethod IP Internet Protocol [RFC 8911] IETF SubTypeMethod DSCPxx where xx is replaced by a Diffserv code point [RFC 8911] IETF SubTypeMethod UDP User Datagram Protocol [RFC 8911] IETF SubTypeMethod TCP Transport Control Protocol [RFC 8911] IETF SubTypeMethod QUIC QUIC transport protocol [RFC 8911] IETF SubTypeMethod HS Hand-Shake, such as TCP's 3-way HS [RFC 8911] IETF SubTypeMethod Poisson packet generation using Poisson distribution [RFC 8911] IETF SubTypeMethod Periodic periodic packet generation [RFC 8911] IETF SubTypeMethod SendOnRcv Sender keeps one packet in transit by sending when previous packet arrives [RFC 8911] IETF SubTypeMethod PayloadxxxxB where xxxx is replaced by an integer, the number of octets or 8-bit Bytes in the Payload [RFC 8911] IETF SubTypeMethod SustaninedBurst capacity test, worst case [RFC 8911] IETF SubTypeMethod StandingQueue test of bottleneck queue behavior [RFC 8911] IETF Performance Metric Name Elements - Spec Registration Procedure(s) Specification Required Expert(s) Greg Mirsky, Michael Scharf Reference [RFC 8911] Note Spec contains an immutable document identifier combined with a document section identifier for the specifying document. See [Section 7.1.2 of RFC 8911]. Available Formats [IMG] CSV Identifier Reference Spec [RFC 8911] Performance Metric Name Elements - Units Registration Procedure(s) Specification Required Expert(s) Greg Mirsky, Michael Scharf Reference [RFC 8911] Available Formats [IMG] CSV Identifier Name Description Reference Change Controller Units Seconds [RFC 8911] IETF Units Ratio unitless [RFC 8911] IETF Units Percent value multiplied by 100% [RFC 8911] IETF Units Logical 1 or 0 [RFC 8911] IETF Units Packets [RFC 8911] IETF Units BPS bits per second [RFC 8911] IETF Units PPS packets per second [RFC 8911] IETF Units EventTotal for unitless counts [RFC 8911] IETF Units Multiple more than one type of unit [RFC 8911] IETF Units Enumerated a list of outcomes [RFC 8911] IETF Units Unitless [RFC 8911] IETF Performance Metric Name Elements - Output Registration Procedure(s) Specification Required Expert(s) Greg Mirsky, Michael Scharf Reference [RFC 8911] Available Formats [IMG] CSV Identifier Name Description Reference Change Controller Output Singleton [RFC 8911] IETF Output Raw multiple singletons [RFC 8911] IETF Output Count [RFC 8911] IETF Output Minimum [RFC 8911] IETF Output Maximum [RFC 8911] IETF Output Median [RFC 8911] IETF Output Mean [RFC 8911] IETF Output 95Percentile 95th Percentile [RFC 8911] IETF Output 99Percentile 99th Percentile [RFC 8911] IETF Output StdDev standard deviation [RFC 8911] IETF Output Variance [RFC 8911] IETF Output PFI pass, fail, inconclusive [RFC 8911] IETF Output FlowRecords descriptions of flows observed [RFC 8911] IETF Output LossRatio lost packets to total packets, <=1 [RFC 8911] IETF Licensing Terms