Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About Posture Broker (PB) Protocol Compatible with Trusted Network Connect (TNC) Parameters Created 2009-12-18 Last Updated 2018-07-09 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • PB-TNC Message Types • PA Subtypes • PB-TNC Remediation Parameters Types • PB-TNC Error Codes PB-TNC Message Types Registration Procedure(s) Specification Required Expert(s) Steve Hanna, Jessica Fitzgerald-McKay, Charles Schmidt Reference [RFC 5793] Available Formats [IMG] CSV PEN Integer Name Reference 0 0 PB-Experimental [RFC 5793] 0 1 PB-PA [RFC 5793] 0 2 PB-Assessment-Result [RFC 5793] 0 3 PB-Access-Recommendation [RFC 5793] 0 4 PB-Remediation-Parameters [RFC 5793] 0 5 PB-Error [RFC 5793] 0 6 PB-Language-Preference [RFC 5793] 0 7 PB-Reason-String [RFC 5793] 0 0xffffffff Reserved [RFC 5793] PA Subtypes Registration Procedure(s) Specification Required Expert(s) Steve Hanna, Jessica Fitzgerald-McKay, Charles Schmidt Reference [RFC 5793] Available Formats [IMG] CSV PEN Integer Name Reference 0 0 Testing [RFC 5792] 0 1 Operating System [RFC 5792] 0 2 Anti-Virus [RFC 5792] 0 3 Anti-Spyware [RFC 5792] 0 4 Anti-Malware [RFC 5792] 0 5 Firewall [RFC 5792] 0 6 IDPS [RFC 5792] 0 7 VPN [RFC 5792] 0 8 NEA Client [RFC 5792] 0 9 SWIMA Attributes [RFC 8412] PB-TNC Remediation Parameters Types Registration Procedure(s) Specification Required Expert(s) Steve Hanna, Jessica Fitzgerald-McKay, Charles Schmidt Reference [RFC 5793] Available Formats [IMG] CSV PEN Integer Name Reference 0 1 Remediation-URI [RFC 5793] 0 2 Remediation-String [RFC 5793] PB-TNC Error Codes Registration Procedure(s) Specification Required Expert(s) Steve Hanna, Jessica Fitzgerald-McKay, Charles Schmidt Reference [RFC 5793] Available Formats [IMG] CSV PEN Integer Name Reference 0 0 Unexpected Batch Type [RFC 5793] 0 1 Invalid Parameter [RFC 5793] 0 2 Local Error [RFC 5793] 0 3 Unsupported Mandatory Message [RFC 5793] 0 4 Version Not Supported [RFC 5793] Licensing Terms