Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About Open Shortest Path First (OSPF) Opaque Link-State Advertisements (LSA) Option Types Last Updated 2026-05-19 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • Opaque Link-State Advertisements (LSA) Option Types • OSPFv2 TTZ LSA TLVs Opaque Link-State Advertisements (LSA) Option Types Reference [RFC 5250] Available Formats [IMG] CSV Range Registration Procedures 0-127 IETF Review 128-255 Private Use Value Opaque Type Reference 1 Traffic Engineering LSA [RFC 3630] 2 Sycamore Optical Topology Descriptions [John_Moy] 3 grace-LSA [RFC 3623] 4 Router Information (RI) [RFC 7770] 5 L1VPN LSA [RFC 5252] 6 Inter-AS-TE-v2 LSA [RFC 5392] 7 OSPFv2 Extended Prefix Opaque LSA [RFC 7684] 8 OSPFv2 Extended Link Opaque LSA [RFC 7684] 9 TTZ LSA [RFC 8099] 10 OSPFv2 Dynamic Flooding Opaque LSA [RFC 9667] 11 OSPFv2 Extended Inter-Area ASBR (EIA-ASBR) LSA [RFC 9350, Section 10.1] 12-127 Unassigned 128-255 Reserved for Private Use [RFC 5250] OSPFv2 TTZ LSA TLVs Registration Procedure(s) IETF Review Reference [RFC 8099] Available Formats [IMG] CSV Value OSPFv2 TTZ LSA TLV Name Reference 0 Reserved [RFC 8099] 1 TTZ ID TLV [RFC 8099, Section 6.2] 2 TTZ Router TLV [RFC 8099, Section 6.3] 3 TTZ Options TLV [RFC 8099, Section 6.4] 4-32767 Unassigned 32768-65535 Reserved [RFC 8099] Contact Information ID Name Contact URI Last Updated [John_Moy] John Moy mailto:John.Moy&sycamorenet.com 2001-05 Licensing Terms