Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About Message Session Relay Protocol (MSRP) Parameters Created 2007-04-27 Last Updated 2015-12-18 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • Methods • Header Fields • Status Codes Methods Registration Procedure(s) RFC Required Reference [RFC 4975] Available Formats [IMG] CSV Description Reference SEND [RFC 4975] REPORT [RFC 4975] AUTH [RFC 4976] NICKNAME [RFC 7701] Header Fields Registration Procedure(s) RFC Required Reference [RFC 4975] Available Formats [IMG] CSV Description Reference To-Path [RFC 4975] From-Path [RFC 4975] Message-ID [RFC 4975] Success-Report [RFC 4975] Failure-Report [RFC 4975] Byte-Range [RFC 4975] Status [RFC 4975] Expires [RFC 4976] Min-Expires [RFC 4976] Max-Expires [RFC 4976] Use-Path [RFC 4976] WWW-Authenticate [RFC 4976] Authorization [RFC 4976] Authentication-Info [RFC 4976] Use-Nickname [RFC 7701] Status Codes Registration Procedure(s) RFC Required Reference [RFC 4975] Available Formats [IMG] CSV Value Description Reference 200 Success [RFC 4975] 400 Unintelligible [RFC 4975] 401 Unauthorized [RFC 4976] 403 Action-not-allowed [RFC 4975] 404 Failure to resolve recipient's URI [RFC 7701] 408 Transaction-did-not-complete-in-allotted-time [RFC 4975] 413 Stop-sending-message [RFC 4975] 415 MIME-not-understood [RFC 4975] 423 Parameter-out-of-bounds [RFC 4975] 424 Malformed nickname [RFC 7701] 425 Nickname reserved or already in use [RFC 7701] 428 Private messages not supported [RFC 7701] 481 Session-does-not-exist [RFC 4975] 501 Request-method-not-understood [RFC 4975] 506 Session-already-in-use [RFC 4975] Licensing Terms