Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About Media Feature Tags - iso.org.dod.internet.features (1.3.6.1.8) Last Updated 2026-10-20 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • iso.org.dod.internet.features.ietf-tree (1.3.6.1.8.1) • iso.org.dod.internet.features.global-tree (1.3.6.1.8.2) • iso.org.dod.internet.features.uri-tree (1.3.6.1.8.3) • iso.org.dod.internet.features.sip-tree (1.3.6.1.8.4) iso.org.dod.internet.features.ietf-tree (1.3.6.1.8.1) Registration Procedure(s) IETF Review Reference [RFC 2506][RFC 2534] Available Formats [IMG] CSV Decimal Name Description Reference 1 pix-x horizontal pixels [RFC 2534] 2 pix-y vertical pixels [RFC 2534] 3 dpi dots-per-inch [RFC 2534] 4 ua-media ua-media [RFC 2534] 5 paper-size paper-size [RFC 2534] 6 color color [RFC 2534] 7 size-x size-x [RFC 2879] 8 size-y size-y [RFC 2879] 9 dpi-xyratio dpi-xyratio [RFC 2879] 10 color-levels color-levels [RFC 2879] 11 color-space color-space [RFC 2879] 12 CIELAB-L-depth CIELAB-L-depth [RFC 2879] 13 CIELAB-A-depth CIELAB-A-depth [RFC 2879] 14 CIELAB-B-depth CIELAB-B-depth [RFC 2879] 15 CIELAB-L-min CIELAB-L-min [RFC 2879] 16 CIELAB-L-max CIELAB-L-max [RFC 2879] 17 CIELAB-a-min CIELAB-a-min [RFC 2879] 18 CIELAB-a-max CIELAB-a-max [RFC 2879] 19 CIELAB-b-min CIELAB-b-min [RFC 2879] 20 CIELAB-b-max CIELAB-b-max [RFC 2879] 21 image-file-structure image-file-structure [RFC 2879] 22 image-coding image-coding [RFC 2879] 23 image-coding-constraint image-coding-constraint [RFC 2879] 24 JBIG-stripe-size JBIG-stripe-size [RFC 2879] 25 image-interleave image-interleave [RFC 2879] 26 color-subsampling color-subsampling [RFC 2879] 27 MRC-mode MRC-mode [RFC 2879] 28 MRC-max-stripe-size MRC-max-stripe-size [RFC 2879] 29 color-illuminant color-illuminant [RFC 2879] 30 type type [RFC 2913] 31 charset charset [RFC 2987] 32 language language [RFC 2987] 33 unknown-character-replacement unknown-character-replacement [RFC 5259] iso.org.dod.internet.features.global-tree (1.3.6.1.8.2) Registration Procedure(s) Expert Review Expert(s) Paul Kyzivat Reference [RFC 2506] Note Registration requests can be sent directly to iana@iana.org or submitted via IANA's [general request form]. IANA will forward requests to the [Media Feature Tags mailing list] and the IESG-designated expert(s), who will notify IANA if the request is approved. IANA does not monitor the list. Available Formats [IMG] CSV Decimal Name Description Reference 1 g.3gpp.cs-voice This feature-tag indicates that the device supports circuit switched voice [ETSI TS 124 279]; when combining circuit switched calls and IM sessions. [Dongwook_Kim] 2 g.3gpp.cs-video This feature-tag indicates that the device supports circuit switched video [ETSI TS 124 279]; when combining circuit switched video calls and IM sessions. [Dongwook_Kim] 3 g.3gpp.smsip This feature-tag indicates that the device is capable of accepting SMS [ETSI TS 124 341]; messages via SIP as specified by ETSI TS 124 341. [Dongwook_Kim] Each value of the Service Reference media feature-tag indicates the software applications supported by the agent. The values for this tag equal the IMS communication Service Identifier (ICSI) values supported by the agent. The [3GPP TS 24.229]; 4 g.3gpp.icsi-ref Service Reference media feature tag is defined to fulfil the requirements for [Dongwook_Kim] forking to an appropriate UE when multiple UEs are registered and dispatch to an appropriate application within the UE based upon the IMS communication Service Identifier (ICSI) values as stated in 3GPP TS 23.228. Each value of the Application Reference media feature-tag indicates the software applications supported by the agent. The values for this tag equal IMS Application Reference Identifier (IARI) values supported by the agent The [3GPP TS 24.229]; 5 g.3gpp.iari-ref Application Reference media feature tag is defined to fulfil the requirements [Dongwook_Kim] for forking to an appropriate UE when multiple UEs are registered and dispatch to an appropriate application within the UE based upon and IMS Application Reference Identifier (IARI) values as stated in 3GPP TS 23.228. This feature-tag when used in a SIP REGISTER request indicates that the 6 g.3gpp.ics function is ICS capability and may operate in ICS mode. This feature-tag when [3GPP TS 24.292]; used is a none SIP REGISTER method indicates that the function wants to [Dongwook_Kim] invoke ICS functionality. This feature-tag when used in a SIP REGISTER request indicates access network [3GPP TS 24.292]; 7 g.3gpp.accesstype technology used by the device and the particular registration flow that the [Dongwook_Kim] device is using to register over. 8 g.3gpp.pne-id This media feature-tag when used in a SIP request or a SIP response indicates [3GPP TS 24.259]; the identifier of a PNE other than a UE. [Dongwook_Kim] This media feature-tag when used in a SIP request or a SIP response indicates 9 g.3gpp.iut-controller that the function sending the SIP message supports the IUT Controller [3GPP TS 24.337]; functionality.This media feature tag does not imply that the controller UE [Dongwook_Kim] capabilities are handled in the same protocol manner. This media feature-tag when used in a Contact header field or a 10 g.3gpp.iut-focus Accept-Contact header field of a SIP request or a SIP response indicates that [3GPP TS 24.337]; the function sending the SIP message supports anchoring a IUT session and/or [Dongwook_Kim] the SIP message is an inter-UE transfer operation. This media feature-tag when used in a Contact header field of SIP request or 11 g.3gpp.current-iut-controller SIP response indicates that the UA is the currently active IUT controller for [3GPP TS 24.337]; the collaborative session or is a controllee in the collaborative. The values [Dongwook_Kim] of the feature tag are "active" and "passive". This feature-tag when used in a SIP request or a SIP response indicates that [3GPP TS 24.237]; 12 g.3gpp.mid-call the function sending the SIP message supports the MSC server assisted [Dongwook_Kim] mid-call feature. This media feature-tag when used in a Contact header field of a SIP request 13 g.3gpp.srvcc-alerting or a SIP response indicates that the functional entity sending the SIP [3GPP TS 24.237]; message supports SRVCC access transfer for calls in alerting phase, i.e. for [Dongwook_Kim] calls whith early dialog. This media feature-tag when used in a Contact header field of a SIP request [3GPP TS 24.237 11.10.0]; 14 g.3gpp.cs2ps-srvcc-alerting or a SIP response indicates that the functional entity sending the SIP [Dongwook_Kim] message supports CS to PS SRVCC access transfer for calls in alerting phase. This media feature tag when used in a Contact header field in SIP REGISTER 15 g.3gpp.path request or SIP response to the SIP REGISTER request indicates capability of [3GPP TS 24.237 11.10.0]; identifying the registration path and binding SRVCC related information to [Dongwook_Kim] it. This media feature tag when included in Contact header field indicates [3GPP TS 24.237 11.10.0]; 16 g.3gpp.cs2ps-srvcc support of the CS to PS single radio voice call continuity as specified in [Dongwook_Kim] 3GPP TS 24.237. This media feature-tag when used in a Contact header field of a SIP request [3GPP TS 24.237 11.10.0]; 17 g.3gpp.pstops-sti or a SIP response indicates that the functional entity sending the SIP [Dongwook_Kim] message supports the use of the PS to PS STI URI. This media feature tag when used in a Contact header field as specified in 18 g.3gpp.ti IETF RFC 3840 in SIP INVITE request or SIP response to the SIP INVITE request [3GPP TS 24.237 11.10.0]; indicates the capability of associating a CS call with dialog created by the [Dongwook_Kim] SIP INVITE request. This media feature-tag when used in a Contact header field of a SIP request 19 g.3gpp.drvcc-alerting or a SIP response indicates that the functional entity sending the SIP [3GPP TS 24.237 12.8.0]; message supports the PS to CS dual radio access transfer for calls in [Dongwook_Kim] alerting phase. This media feature-tag when used in a Contact header field of a SIP request [3GPP TS 24.237 12.8.0]; 20 g.3gpp.dynamic-stn or a SIP response indicates that the functional entity sending the SIP [Dongwook_Kim] message supports the use of dynamic STN. This media feature-tag when used in a Contact header field of a SIP request 21 g.3gpp.ps2cs-drvcc-orig-pre-alerting or a SIP response indicates that the functional entity sending the SIP [3GPP TS 24.237 12.8.0]; message supports the PS to CS dual radio access transfer for originating [Dongwook_Kim] calls in pre-alerting phase. This media feature tag when used in a Contact header field of a SIP request 22 g.3gpp.ps2cs-srvcc-orig-pre-alerting or a SIP response indicates that the functional entity sending the SIP [3GPP TS 24.237 12.8.0]; message supports the PS to CS SRVCC for originating calls in pre-alerting [Dongwook_Kim] phase. This media feature-tag, when used in a Contact header field of a SIP request 23 g.3gpp.cs2ps-drvcc-alerting or a SIP response, indicates that the functional entity sending the SIP [3GPP TS 24.237 v12.9.0]; message supports the CS to PS dual radio access transfer for calls in [Dongwook_Kim] alerting phase. This media feature-tag when used in a Contact header field of a SIP request 24 g.3gpp.cs2ps-drvcc-orig-pre-alerting or a SIP response indicates that the functional entity sending the SIP [3GPP TS 24.237 v12.9.0]; message supports the CS to PS dual radio access transfer for originating [Dongwook_Kim] calls in pre-alerting phase. This media feature-tag when used in a Contact header field of a SIP request [3GPP TS 24.341 v12.6.0]; 25 g.3gpp.smsip-msisdn-less or a SIP response indicates that the functional entity sending the SIP [Dongwook_Kim] message supports MSISDN less operation of SMS via SIP MESSAGE request. 26 g.3gpp.nw-init-ussi This feature-tag indicates support of user equipment procedures for the [3GPP TS 24.390 v12.6.0]; network initiated USSD over IMS. [Dongwook_Kim] This media feature tag, when included in a third party SIP REGISTER request, indicates the support of using a token to identify the registration used for [3GPP TS 24.229 v12.16.0]; 27 g.3gpp.registration-token the request. The mediafeature tag is assigned a value that can be used by the [Dongwook_Kim] receiving AS to later identify the used registration for initial requests from an originating user or dialog forming responses from a terminating user. This media feature tag when used in a SIP request or a SIP response indicates [3GPP TS 24.379 v13.5.0]; 28 g.3gpp.mcptt that the function sending the SIP message supports Mission Critical Push To [Dongwook_Kim] Talk (MCPTT) communication. This media feature tag when used in a SIP request or a SIP response indicates [3GPP TS 24.282 14.3.0]; 29 g.3gpp.mcdata.sds that the function sending the SIP message supports Mission Critical Data [Dongwook_Kim] (MCData) communications Short Data Service (SDS). This media feature tag when used in a SIP request or a SIP response indicates [3GPP TS 24.282 14.3.0]; 30 g.3gpp.mcdata.fd that the function sending the SIP message supports Mission Critical Data [Dongwook_Kim] (MCData) communications File Distribution (FD). This media feature tag when used in a SIP request or a SIP response indicates [3GPP TS 24.281 Rel-14]; 31 g.3gpp.mcvideo that the function sending the SIP message supports Mission Critical Video [Dongwook_Kim] (MCVideo) communication. This media feature-tag when used in a Contact header field of a SIP request [3GPP TS 24.237]; 32 g.3gpp.dynamic-e-stn-drvcc or a SIP response indicates that the functional entity sending the SIP [Dongwook_Kim] message supports the use of dynamic-e-stn-drvcc. This media feature-tag, when used in a Contact header field of a SIP request or a SIP response, indicates that the functional entity sending the SIP 33 g.3gpp.ps2cs-srvcc-mid-call-emergency message supports the PS to CS SRVCC for emergency session in early dialog [3GPP TS 24.237]; state with active speech media component when both the emergency session in [Dongwook_Kim] early dialog state with active speech media component and a non-emergency call in confirmed dialog state with inactive speech media component exists. This media feature tag when used in a Contact header field of a SIP request 34 g.3gpp.ps2cs-srvcc-term-pre-alerting or a SIP response indicates that the functional entity sending the SIP [3GPP TS 24.237]; message supports the PS to CS SRVCC for terminating calls in pre-alerting [Dongwook_Kim] phase. This media feature tag when included in a Contact header field in a REGISTER request indicates the status of the 3GPP PS data off for the registration 35 g.3gpp.ps-data-off time. This media feature tag, when included in the Contact header field in a [3GPP TS 24.229]; REGISTER request indicates that the UE supports the 3GPP PS data off. The [Dongwook_Kim] g.3gpp.ps-data-off media feature tag can take a value that indicates whether the 3GPP PS data off has been activated or deactivated by the user at the UE. This media feature tag when used in a SIP request or a SIP response indicates [3GPP TS 24.282]; 36 g.3gpp.mcdata.ipconn that the function sending the SIP message supports Mission Critical Data [Kiran_Kapale] (MCData) communications IP Connectivity (IPCONN). 37 g.3gpp.rlos This feature-tag when used in a SIP REGISTER request indicates that the [3GPP TS 24.229] function sending the SIP message supports restricted local operator service. Support of multiplexing multiple IMS application data channels from different data channel applications on a single SDP media description, resulting in use 38 g.3gpp.dc-mux of multiple a=3gpp-req-app SDP attributes with different application-id tag [3GPP TS 26.114] values. Also, support of multiplexing IMS bootstrap data channels from both local network and remote network bootstrap content sources on a single SDP media description. iso.org.dod.internet.features.uri-tree (1.3.6.1.8.3) Registration Procedure(s) Unregistered (formed from uri) Reference [RFC 2506] Decimal Name Description Reference No registrations at this time. iso.org.dod.internet.features.sip-tree (1.3.6.1.8.4) Registration Procedure(s) IETF Review Reference [RFC 3840] Available Formats [IMG] CSV Decimal Name Description Reference 1 sip.audio This feature tag indicates that the device supports audio as a streaming media type. [RFC 3840] This feature tag indicates that the device supports application as a streaming media type. This feature tag exists 2 sip.application primarily for completeness. Since so many MIME types are underneath application, indicating the ability to support [RFC 3840] applications provides little useful information. 3 sip.data This feature tag indicates that the device supports data as a streaming media type. [RFC 3840] 4 sip.control This feature tag indicates that the device supports control as a streaming media type. [RFC 3840] 5 sip.video This feature tag indicates that the device supports video as a streaming media type. [RFC 3840] 6 sip.text This feature tag indicates that the device supports text as a streaming media type. [RFC 3840] 7 sip.automata The sip.automata feature tag is a boolean value that indicates whether the UA represents an automata (such as a [RFC 3840] voicemail server, conference server, IVR, or recording device) or a human. 8 sip.class This feature tag indicates the setting, business or personal, in which a communications device is used. [RFC 3840] The sip.duplex media feature tag indicates whether a communications device can simultaneously send and receive 9 sip.duplex media ("full"), alternate between sending and receiving ("half"), can only receive ("receive-only") or only send [RFC 3840] ("send-only"). The sip.mobility feature tag indicates whether the device is fixed (meaning that it is associated with a fixed 10 sip.mobility point of contact with the network), or mobile (meaning that it is not associated with a fixed point of contact). [RFC 3840] Note that cordless phones are fixed, not mobile, based on this definition. 11 sip.description The sip.description feature tag provides a textual description of the device. [RFC 3840] 12 sip.events Each feature tag value indicates a SIP event package supported by a SIP UA. The values for this tag equal the event [RFC 3840] package names that are registered by each event package. The sip.priority feature tag indicates the call priorities the device is willing to handle. A value of X means that 13 sip.priority the device is willing to take requests with priority X and higher. This does not imply that a phone has to reject [RFC 3840] calls of lower priority. As always, the decision on handling of such calls is a matter of local policy. Each value of the sip.methods (note the plurality) feature tag indicates a SIP method supported by this UA. In this 14 sip.methods case, "supported" means that the UA can receive requests with this method. In that sense, it has the same [RFC 3840] connotation as the Allow header field. Each value of the sip.extensions feature tag is a SIP extension (each of which is defined by an option-tag 15 sip.extensions registered with IANA) that is understood by the UA. Understood, in this context, means that the option tag would be [RFC 3840] included in a Supported header field in a request. Each value of the sip.schemes (note the plurality) media feature tag indicates a URI scheme that is supported by a 16 sip.schemes UA. Supported implies, for example, that the UA would know how to handle a URI of that scheme in the Contact header [RFC 3840] field of a redirect response. 17 sip.actor This feature tag indicates the type of entity that is available at this URI. [RFC 3840] 18 sip.isfocus This feature tag indicates that the UA is a conference server, also known as a focus, and will mix together the [RFC 3840] media for all calls to the same URI. 19 sip.byeless The feature tag is a boolean flag. When set it indicates that the device is incapable of terminating a session [RFC 4235] autonomously. This feature tag contains one of three tokens indicating if the device is rendering any media from the current 20 sip.rendering session ("yes"), none of the media from the current session ("no"), or if this status is not known to the device [RFC 4235] ("unknown"). 21 sip.message This feature tag indicates that the device supports message as a streaming media type. [RFC 4569] 22 sip.ice This feature tag indicates that the device supports Interactive Connectivity Establishment (ICE). [RFC 5768] This feature tag contains a string containing a URN that indicates a unique identifier associated with the UA instance registering the Contact. Values appropriate for use with this feature tag: String (equality relationship). 23 sip.instance The feature tag is intended primarily for use in the following applications, protocols, services, or negotiation [RFC 5626] mechanisms: This feature tag is most useful in a communications application, for describing the capabilities of a device, such as a phone or PDA. 24 sip.app-subtype This feature tag indicates the MIME application sub-types supported by the agent for purposes of streaming media. [RFC 5688] 25 sip.fax This feature tag indicates whether a communications device supports the ITU-T T.38 fax protocol ("t38") or the [RFC 6913] passthrough method of fax transmission using the ITU-T G.711 audio codec ("passthrough"). 26 sip.uui-isdn This media feature tag when used in a Contact header field of a SIP request or a SIP response indicates that the [RFC 7434] entity sending the SIP message supports the package "uui-isdn". 27 sip.src This feature tag indicates that the UA is a Session Recording Client for the purpose of an RS. [RFC 7866] 28 sip.srs This feature tag indicates that the UA is a Session Recording Server for the purpose of an RS. [RFC 7866] This media feature tag, when inserted in the Contact header field of a SIP REGISTER request, conveys that the SIP 29 sip.pnsreg UA associated with the tag is able to send binding-refresh REGISTER requests associated with the registration [RFC 8599] without being awakened by push notifications. This feature tag indicates that the device supports CLUE-controlled media. Values appropriate for use with this 30 sip.clue feature tag: Boolean. The feature tag is intended primarily for use in the following applications, protocols, [RFC 8848] services, or negotiation mechanisms: This feature tag is most useful in a communications application for describing the capabilities of a device to use the CLUE control protocol to negotiate the use of multiple media streams. Contact Information ID Name Contact URI Last Updated [Kiran_Kapale] Kiran Kapale mailto:kiran.kapale&samsung.com 2023-02-27 [Dongwook_Kim] Dongwook Kim mailto:info&3gpp.org 2026-10-20 Licensing Terms