Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About JSON Meta Application Protocol (JMAP) Created 2019-03-28 Last Updated 2025-05-02 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • JMAP Capabilities • JMAP Error Codes • JMAP Data Types JMAP Capabilities Expert(s) Neil Jenkins, Chris Newman, Arnt Gulbrandsen, Joris Baum Reference [RFC 8620] Available Formats [IMG] CSV Range Registration Procedures intended use field is “common" or “placeholder” Specification Required all other values Expert Review Capability Name Intended Use Change Controller Security and Privacy Considerations Reference urn:ietf:params:jmap:core common IETF [RFC 8620, Section 8] [RFC 8620, Section 2] urn:ietf:params:jmap:error: placeholder IETF [RFC 8620, Section 8] [RFC 8620, Section 9.5] urn:ietf:params:jmap:mail common IETF [RFC 8621, Section 9] [RFC 8621] urn:ietf:params:jmap:mdn common IETF [RFC 9007, Section 5] [RFC 9007] urn:ietf:params:jmap:smimeverify common IETF [RFC 9219, Section 6] [RFC 9219] urn:ietf:params:jmap:submission common IETF [RFC 8621, Section 9] [RFC 8621] urn:ietf:params:jmap:vacationresponse common IETF [RFC 8621, Section 9] [RFC 8621] urn:ietf:params:jmap:blob common IETF [RFC 9404, Section 5] [RFC 9404] urn:ietf:params:jmap:quota common IETF [RFC 9425, Section 7] [RFC 9425] urn:ietf:params:jmap:sieve common IETF [RFC 9661, Section 5] [RFC 9661] urn:ietf:params:jmap:principals common IETF [RFC 9670, Section 6] [RFC 9670] urn:ietf:params:jmap:principals:owner common IETF [RFC 9670, Section 6] [RFC 9670] urn:ietf:params:jmap:contacts common IETF [RFC 9610, Section 6] [RFC 9610] urn:ietf:params:jmap:calendars common IETF [RFC-ietf-jmap-calendars-22, Section 1.5.1] [RFC-ietf-jmap-calendars-22] urn:ietf:params:jmap:principals:availability common IETF [RFC-ietf-jmap-calendars-22, Section 1.5.2] [RFC-ietf-jmap-calendars-22] urn:ietf:params:jmap:webpush-vapid common IETF [RFC 9749, Section 6] [RFC 9749] JMAP Error Codes Registration Procedure(s) Expert Review Expert(s) Neil Jenkins, Chris Newman, Arnt Gulbrandsen, Joris Baum Reference [RFC 8620] Available Formats [IMG] CSV JMAP Error Code Intended Use Change Description Reference Controller accountNotFound common IETF The accountId does not correspond to a valid account. [RFC 8620, Section 3.6.2] accountNotSupportedByMethod common IETF The accountId given corresponds to a valid account, but [RFC 8620, Section 3.6.2] the account does not support this method or data type. This method modifies state, but the account is read-only accountReadOnly common IETF (as returned on the corresponding Account object in the [RFC 8620, Section 3.6.2] JMAP Session resource). anchorNotFound common IETF An anchor argument was supplied, but it cannot be found [RFC 8620, Section 5.5] in the results of the query. The server forbids duplicates, and the record already alreadyExists common IETF exists in the target account. An existingId property of [RFC 8620, Section 5.4] type Id MUST be included on the SetError object with the id of the existing record. cannotCalculateChanges common IETF The server cannot calculate the changes from the state [RFC 8620, Section 5.2, 5.6] string given by the client. forbidden common IETF The action would violate an ACL or other permissions [RFC 8620, Section 3.6.2, 5.3, policy. 7.2.1] fromAccountNotFound common IETF The fromAccountId does not correspond to a valid account. [RFC 8620, Section 5.4, 6.3] fromAccountNotSupportedByMethod common IETF The fromAccountId given corresponds to a valid account, [RFC 8620, Section 5.4] but the account does not support this data type. invalidArguments common IETF One of the arguments is of the wrong type or otherwise [RFC 8620, Section 3.6.2] invalid, or a required argument is missing. invalidPatch common IETF The PatchObject given to update the record was not a [RFC 8620, Section 5.3] valid patch. invalidProperties common IETF The record given is invalid. [RFC 8620, Section 5.3] notFound common IETF The id given cannot be found. [RFC 8620, Section 5.3] notJSON common IETF The content type of the request was not application/json, [RFC 8620, Section 3.6.1] or the request did not parse as I-JSON. notRequest common IETF The request parsed as JSON but did not match the type [RFC 8620, Section 3.6.1] signature of the Request object. overQuota common IETF The create would exceed a server-defined limit on the [RFC 8620, Section 5.3] number or total size of objects of this type. Too many objects of this type have been created recently, rateLimit common IETF and a server-defined rate limit has been reached. It may [RFC 8620, Section 5.3] work if tried again later. requestTooLarge common IETF The total number of actions exceeds the maximum number [RFC 8620, Section 5.1, 5.3] the server is willing to process in a single method call. invalidResultReference common IETF The method used a result reference for one of its [RFC 8620, Section 3.6.2] arguments, but this failed to resolve. An unexpected or unknown error occurred during the serverFail common IETF processing of the call. The method call made no changes [RFC 8620, Section 3.6.2] to the server's state. Some, but not all, expected changes described by the serverPartialFail limited IETF method occurred. The client MUST resynchronise impacted [RFC 8620, Section 3.6.2] data to determine the server state. Some internal server resource was temporarily serverUnavailable common IETF unavailable. Attempting the same operation later (perhaps [RFC 8620, Section 3.6.2] after a backoff with a random factor) may succeed. singleton common IETF This is a singleton type, so you cannot create another [RFC 8620, Section 5.3] one or destroy the existing one. stateMismatch common IETF An ifInState argument was supplied, and it does not match [RFC 8620, Section 5.3] the current state. The action would result in an object that exceeds a tooLarge common IETF server-defined limit for the maximum size of a single [RFC 8620, Section 5.3] object of this type. tooManyChanges common IETF There are more changes than the client's maxChanges [RFC 8620, Section 5.6] argument. unknownCapability common IETF The client included a capability in the "using" property [RFC 8620, Section 3.6.1] of the request that the server does not support. unknownMethod common IETF The server does not recognise this method name. [RFC 8620, Section 3.6.2] unsupportedFilter common IETF The filter is syntactically valid, but the server cannot [RFC 8620, Section 5.5] process it. The sort is syntactically valid but includes a property unsupportedSort common IETF the server does not support sorting on or a collation [RFC 8620, Section 5.5] method it does not recognise. The client requested an object be both updated and willDestroy common IETF destroyed in the same /set request, and the server has [RFC 8620, Section 5.3] decided to therefore ignore the update. The Mailbox still has at least one child Mailbox. The mailboxHasChild common IETF client MUST remove these before it can delete the parent [RFC 8621, Section 2.5] Mailbox. mailboxHasEmail common IETF The Mailbox has at least one message assigned to it, and [RFC 8621, Section 2.5] the onDestroyRemoveEmails argument was false. blobNotFound common IETF At least one blob id referenced in the object doesn't [RFC 8621, Section 4.6] exist. tooManyKeywords common IETF The change to the Email's keywords would exceed a [RFC 8621, Section 4.6] server-defined maximum. tooManyMailboxes common IETF The change to the set of Mailboxes that this Email is in [RFC 8621, Section 4.6] would exceed a server-defined maximum. invalidEmail common IETF The Email to be sent is invalid in some way. [RFC 8621, Section 7.5] tooManyRecipients common IETF The envelope [RFC-ietf-emailcore-rfc5321bis-43] (supplied [RFC 8621, Section 7.5] or generated) has more recipients than the server allows. noRecipients common IETF The envelope [RFC-ietf-emailcore-rfc5321bis-43] (supplied [RFC 8621, Section 7.5] or generated) does not have any rcptTo email addresses. The rcptTo property of the envelope invalidRecipients common IETF [RFC-ietf-emailcore-rfc5321bis-43] (supplied or [RFC 8621, Section 7.5] generated) contains at least one rcptTo value that is not a valid email address for sending to. The server does not permit the user to send a message forbiddenMailFrom common IETF with this envelope From address [RFC 8621, Section 7.5] [RFC-ietf-emailcore-rfc5321bis-43]. The server does not permit the user to send a message forbiddenFrom common IETF with the From header field [RFC 8621, Section 6.3, 7.5] [RFC-ietf-emailcore-rfc5322bis-12] of the message to be sent. forbiddenToSend common IETF The user does not have permission to send at all right [RFC 8621, Section 7.5] now. The message has the "$mdnsent" keyword already set. The mdnAlreadySent common IETF client MUST NOT try again to send an MDN for this [RFC 9007, Section 2.1] message. The server does not recognise this data type, or the unknownDataType common IETF capability to enable it is not present in the current [RFC 9404] Request Object. The SieveScript violates the Sieve grammar [RFC 5228], invalidSieve common IETF and/or one or more extensions mentioned in the script's [RFC 9661, Section 2.4] "require" statement(s) are not supported by the Sieve interpreter. sieveIsActive common IETF The client tried to destroy the active SieveScript. [RFC 9661, Section 2.4] addressBookHasContents common IETF The AddressBook has at least one ContactCard assigned to [RFC 9610, Section 2.3] it, and the "onDestroyRemoveContents" argument was false. calendarHasEvent common IETF The Calendar has at least one CalendarEvent assigned to [RFC-ietf-jmap-calendars-22, Section it, and the "onDestroyRemoveEvents" argument was false. 4.3] The server was requested to send scheduling messages, but [RFC-ietf-jmap-calendars-22, Section noSupportedScheduleMethods common IETF does not support any of the methods available for at 5.8] least one of the recipients. cannotCalculateOccurrences common IETF The server cannot expand a recurrence required to return [RFC-ietf-jmap-calendars-22, Section the results for the requested query. 5.10] JMAP Data Types Registration Procedure(s) Specification Required Expert(s) Ken Murchison, Neil Jenkins, Arnt Gulbrandsen, Joris Baum Reference [RFC 9404] Available Formats [IMG] CSV Type Name Can Reference Blobs Can Use for State Change Capability Reference Core No No urn:ietf:params:jmap:core [RFC 8620] PushSubscription No No urn:ietf:params:jmap:core [RFC 8620] Mailbox Yes Yes urn:ietf:params:jmap:mail [RFC 8621] Thread Yes Yes urn:ietf:params:jmap:mail [RFC 8621] Email Yes Yes urn:ietf:params:jmap:mail [RFC 8621] EmailDelivery No Yes urn:ietf:params:jmap:mail [RFC 8621] SearchSnippet No No urn:ietf:params:jmap:mail [RFC 8621] Identity No Yes urn:ietf:params:jmap:submission [RFC 8621] EmailSubmission No Yes urn:ietf:params:jmap:submission [RFC 8621] VacationResponse No Yes urn:ietf:params:jmap:vacationresponse [RFC 8621] MDN No No urn:ietf:params:jmap:mdn [RFC 9007] Quota No Yes urn:ietf:params:jmap:quota [RFC 9425] SieveScript Yes Yes urn:ietf:params:jmap:sieve [RFC 9661] Principal No Yes urn:ietf:params:jmap:principals [RFC 9670] ShareNotification No Yes urn:ietf:params:jmap:principals [RFC 9670] AddressBook No Yes urn:ietf:params:jmap:contacts [RFC 9610] ContactCard Yes Yes urn:ietf:params:jmap:contacts [RFC 9610] Calendar No Yes urn:ietf:params:jmap:calendars [RFC-ietf-jmap-calendars-22] CalendarEvent Yes Yes urn:ietf:params:jmap:calendars [RFC-ietf-jmap-calendars-22] CalendarEventNotification No Yes urn:ietf:params:jmap:calendars [RFC-ietf-jmap-calendars-22] ParticipantIdentity No Yes urn:ietf:params:jmap:calendars [RFC-ietf-jmap-calendars-22] Licensing Terms