Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About IS-IS TLV Codepoints Created 2003-05-06 Last Updated 2026-05-20 Note For IS-IS registries and value ranges maintained via the "Expert Review" [RFC 8126] registration procedure, guidance for IESG-designated experts can be found in [RFC 7370]. Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • IS-IS Top-Level TLV Codepoints • IS-IS Authentication Type Codes • IS-IS Sub-TLVs for Reverse Metric TLV • IS-IS Sub-TLVs for TLVs Advertising Neighbor Information • IS-IS Neighbor Link-Attribute Bit Values • IS-IS Sub-TLVs for TLVs Advertising Prefix Reachability • IS-IS Bit Values for Prefix Attribute Flags Sub-TLV • IS-IS Group Address Type Codes for GADDR-TLV • IS-IS Sub-TLVs for MT-Port-Cap-TLV • IS-IS Sub-TLVs for MT-Capability TLV • IS-IS Sub-TLVs for IS-IS Router CAPABILITY TLV • IS-IS Sub-Sub-TLVs for SRv6 Capabilities Sub-TLV • IS-IS SRv6 Capabilities Sub-TLV Flags • IS-IS Application Identifiers for Generic Information TLV • IS-IS Sub-Sub-TLVs for BIER Info Sub-TLV • IS-IS Sub-TLVs for Segment Identifier/Label Binding TLVs • IS-IS Sub-Sub-TLV Codepoints for Application-Specific Link Attributes • IS-IS Sub-TLVs for Application-Specific SRLG TLV • IS-IS Sub-Sub-TLVs for SRv6 SID Sub-TLVs • IS-IS SRv6 Locator TLV Flags • IS-IS SRv6 End SID Sub-TLV Flags • IS-IS SRv6 Adjacency SID Sub-TLVs Flags • IS-IS Sub-Sub-TLVs for Flexible Algorithm Definition Sub-TLV • IS-IS Sub-Sub-TLVs for Flood Reflection Discovery Sub-TLV • IS-IS Sub-TLVs for the Area Proxy TLV • IS-IS Sub-TLVs for Flooding Parameters TLV • IS-IS Bit Values for Flooding Parameters Flags Sub-TLV IS-IS Top-Level TLV Codepoints Registration Procedure(s) Expert Review Expert(s) Chris Hopps, Hannes Gredler, Les Ginsberg Description Top-level TLVs for the IS-IS protocol Reference [RFC 3563][RFC 6233][RFC 7356][RFC 8918][RFC 9885] Note IETF SHALL keep JTC1/SC6 informed of TLV codepoint values allocated, and JTC1/SC6 SHALL refer allocation requests arising within JTC1 constituencies to the IANA registry process. Note Codepoints greater than 255 can only be used in PDUs designated to support extended TLVs. Available Formats [IMG] CSV Value Name IIH LSP SNP Purge MP Status/Reference 0 Reserved [ISO 10589, "Intermediate System to Intermediate System Intra- Domain 1 Area Addresses y y n n n Routeing Exchange Protocol for use in Conjunction with the Protocol for Providing the Connectionless-mode Network Service (ISO 8473)", International Standard 10589: 2002, Second Edition, 2002.] [ISO 10589, "Intermediate System to Intermediate System Intra- Domain 2 IIS Neighbors n y n n n Routeing Exchange Protocol for use in Conjunction with the Protocol for Providing the Connectionless-mode Network Service (ISO 8473)", International Standard 10589: 2002, Second Edition, 2002.] [ISO 10589, "Intermediate System to Intermediate System Intra- Domain 3 ES Neighbors n y n n n Routeing Exchange Protocol for use in Conjunction with the Protocol for Providing the Connectionless-mode Network Service (ISO 8473)", International Standard 10589: 2002, Second Edition, 2002.] [ISO 10589, "Intermediate System to Intermediate System Intra- Domain 4 Part. DIS n y n n n Routeing Exchange Protocol for use in Conjunction with the Protocol for Providing the Connectionless-mode Network Service (ISO 8473)", International Standard 10589: 2002, Second Edition, 2002.] [ISO 10589, "Intermediate System to Intermediate System Intra- Domain 5 Prefix Neighbors n y n n n Routeing Exchange Protocol for use in Conjunction with the Protocol for Providing the Connectionless-mode Network Service (ISO 8473)", International Standard 10589: 2002, Second Edition, 2002.] [ISO 10589, "Intermediate System to Intermediate System Intra- Domain 6 IIS Neighbors y n n n n Routeing Exchange Protocol for use in Conjunction with the Protocol for Providing the Connectionless-mode Network Service (ISO 8473)", International Standard 10589: 2002, Second Edition, 2002.] 7 Instance Identifier y y y y y [RFC 8202] [ISO 10589, "Intermediate System to Intermediate System Intra- Domain 8 Padding y n n n n Routeing Exchange Protocol for use in Conjunction with the Protocol for Providing the Connectionless-mode Network Service (ISO 8473)", International Standard 10589: 2002, Second Edition, 2002.] [ISO 10589, "Intermediate System to Intermediate System Intra- Domain 9 LSP Entries n n y n n Routeing Exchange Protocol for use in Conjunction with the Protocol for Providing the Connectionless-mode Network Service (ISO 8473)", International Standard 10589: 2002, Second Edition, 2002.] [ISO 10589, "Intermediate System to Intermediate System Intra- Domain 10 Authentication y y y y n Routeing Exchange Protocol for use in Conjunction with the Protocol for Providing the Connectionless-mode Network Service (ISO 8473)", International Standard 10589: 2002, Second Edition, 2002.]; [RFC 6233] 11 ESN TLV y n y n n [RFC 7602] 12 Opt. Checksum y n y n n [RFC 3358] 13 Purge Originator Identification n n n y n [RFC 6232]; [RFC 8918] [ISO 10589, "Intermediate System to Intermediate System Intra- Domain 14 LSPBufferSize n y n n n Routeing Exchange Protocol for use in Conjunction with the Protocol for Providing the Connectionless-mode Network Service (ISO 8473)", International Standard 10589: 2002, Second Edition, 2002.] 15 Router-Fingerprint y y n y n [RFC 8196] 16 Reverse Metric y n n n n [RFC 8500] 17 IS-IS Area Node IDs n y n n n [RFC 9667] 18 IS-IS Flooding Path n y n n n [RFC 9667] 19 IS-IS Flooding Request y n n n n [RFC 9667] 20 Area Proxy n y n n y [RFC 9666] 21 Flooding Parameters TLV y n y n y [RFC 9681] 22 Extended IS reachability n y n n y [RFC 5305] 23 IS Neighbor Attribute n y n n y [RFC 5311] 24 IS Alias ID n y n n n [RFC 5311] 25 L2 Bundle Member Attributes n y n n y [RFC 8668] 26 Unassigned 27 SRv6 Locator n y n n y [RFC 9352] 28 Zone ID (DEPRECATED - temporarily registered n y n n n [draft-ietf-lsr-isis-ttz-08] 2020-11-20, allowed to expire 2025-10-15) 29-41 Unassigned 42 DECnet Phase IV y n n n n DEC (ancient) 43-65 Unassigned 66 Lucent Proprietary n y n n n 67-125 Unassigned 126 IPv4 Algorithm Prefix Reachability n y n n n [RFC 9502, Section 6.1] 127 IPv6 Algorithm Prefix Reachability n y n n n [RFC 9502, Section 6.2] 128 IP Int. Reach n y n n n [RFC 1195]; [RFC 5302] 129 Prot. Supported y y n n n [RFC 1195] 130 IP Ext. Address n y n n n [RFC 1195]; [RFC 5302] 131 IDRPI n y y n n [RFC 1195] 132 IP Intf. Address y y n n n [RFC 1195] 133 Illegal n n n n n [RFC 1195] (not used) 134 Traffic Engineering router ID n y n n n [RFC 5305] 135 Extended IP reachability n y n n y [RFC 5305] 136 Unassigned 137 Dynamic Name n y n y n [RFC 5301]; [RFC 6233] 138 GMPLS-SRLG n y n n y [RFC 5307] 139 IPv6 SRLG n y n n n [RFC 6119] 140 IPv6 TE Router ID n y n n n [RFC 6119] 141 Inter-AS Reachability Information n y n n y [RFC 9346] 142 GADDR-TLV n y n n y [RFC 7176] 143 MT-Port-Cap-TLV y n n n y [RFC 6165] 144 MT-Capability TLV n y n n y [RFC 6329] 145 TRILL Neighbor TLV y n n n n [RFC 7176] 146 Unassigned 147 MAC-RI TLV n y n n y [RFC 6165] 148 BFD-Enabled TLV y n n n y [RFC 6213] 149 Segment Identifier / Label Binding n y n n y [RFC 8667] 150 Multi-Topology Segment Identifier / Label n y n n y [RFC 8667] Binding 151-160 Unassigned 161 Flood Reflection y n n n n [RFC 9377] 162-175 Unassigned 176 Nortel Proprietary n y n n n 177 Nortel Proprietary n y n n n 178-210 Unassigned 211 Restart TLV y n n n n [RFC 8706] 212-221 Unassigned 222 MT-ISN n y n n y [RFC 5120] 223 MT IS Neighbor Attribute n y n n y [RFC 5311] 224-228 Unassigned 229 M-Topologies y y n n n [RFC 5120] 230-231 Unassigned 232 IPv6 Intf. Addr. y y n n n [RFC 5308] 233 IPv6 Global Interface Address TLV y n n n n [RFC 6119] 234 Unassigned 235 MT IP. Reach n y n n y [RFC 5120] 236 IPv6 IP. Reach n y n n y [RFC 5308] 237 MT IPv6 IP. Reach n y n n y [RFC 5120] 238 Application-Specific SRLG n y n n y [RFC 9479] 239 Unassigned 240 P2P 3-Way Adj. State y n n n n [RFC 5303] 241 Unassigned 242 IS-IS Router CAPABILITY TLV n y n n y [RFC 7981] 243 Scope Flooding Support y n n n n [RFC 7356] 244-250 Unassigned 251 Generic Information n y n n y [RFC 6823] 252-65535 Unassigned IS-IS Authentication Type Codes Registration Procedure(s) Expert Review Expert(s) Chris Hopps, Hannes Gredler, Les Ginsberg Description Type Codes for Authentication TLV (10) Reference [RFC 5304] Available Formats [IMG] CSV Value Authentication Type Code Reference [ISO 10589, "Intermediate System to Intermediate System Intra- Domain Routeing Exchange Protocol 0 Reserved for use in Conjunction with the Protocol for Providing the Connectionless-mode Network Service (ISO 8473)", International Standard 10589: 2002, Second Edition, 2002.] [ISO 10589, "Intermediate System to Intermediate System Intra- Domain Routeing Exchange Protocol 1 Cleartext Password for use in Conjunction with the Protocol for Providing the Connectionless-mode Network Service (ISO 8473)", International Standard 10589: 2002, Second Edition, 2002.] [ISO 10589, "Intermediate System to Intermediate System Intra- Domain Routeing Exchange Protocol 2 ISO 10589 Reserved for use in Conjunction with the Protocol for Providing the Connectionless-mode Network Service (ISO 8473)", International Standard 10589: 2002, Second Edition, 2002.] 3 Cryptographic Authentication (CRYPTO_AUTH) [RFC 5310] 4-53 Unassigned 54 HMAC-MD5 Authentication [RFC 5304] 55-254 Unassigned [ISO 10589, "Intermediate System to Intermediate System Intra- Domain Routeing Exchange Protocol 255 Routing Domain private authentication method for use in Conjunction with the Protocol for Providing the Connectionless-mode Network Service (ISO 8473)", International Standard 10589: 2002, Second Edition, 2002.] IS-IS Sub-TLVs for Reverse Metric TLV Registration Procedure(s) Expert Review Expert(s) Chris Hopps, Hannes Gredler, Les Ginsberg Description Sub-TLVs for Reverse Metric TLV (16) Reference [RFC 8500][RFC 9885] Available Formats [IMG] CSV Type Description MP Reference 0 Reserved [RFC 8500] 1-17 Unassigned 18 Traffic Engineering Metric n [RFC 8500, Section 2] 19-255 Unassigned IS-IS Sub-TLVs for TLVs Advertising Neighbor Information Registration Procedure(s) Expert Review Expert(s) Chris Hopps, Hannes Gredler, Les Ginsberg Description This registry defines sub-TLVs for TLVs advertising neighbor information. The list of TLVs includes: * Extended IS reachability (22) * IS Neighbor Attribute (23) * L2 Bundle Member Attributes (25) * inter-AS reachability information (141) * MT-ISN (222) * MT IS Neighbor Attribute (223) Reference [RFC 5305][RFC 5316][RFC 7370][RFC 8668][RFC 9885] Note Allocations within this registry require documentation of the use of the allocated value and approval by the Designated Expert assigned by the IESG. Note The column for TLV 25 may be marked as follows: * y - sub-TLV may appear in TLV 25 but MUST NOT be shared by multiple L2 Bundle Members * y(s) - sub-TLV may appear in TLV 25 and MAY be shared by multiple L2 Bundle Members * n - sub-TLV MUST NOT appear in TLV 25 Available Formats [IMG] CSV Type Description 22 23 25 141 222 223 MP Reference 0-2 Unassigned 3 Administrative group (color) y y y(s) y y y n [RFC 5305] 4 Link Local/Remote Identifiers y y y(s) y y y n [RFC 5307] 5 Unassigned 6 IPv4 interface address y y y(s) y y y n [RFC 5305] 7 Unassigned 8 IPv4 neighbor address y y y(s) y y y n [RFC 5305] 9 Maximum link bandwidth y y y(s) y y y n [RFC 5305] 10 Maximum reservable link bandwidth y y y(s) y y y n [RFC 5305] 11 Unreserved bandwidth y y y(s) y y y n [RFC 5305] 12 IPv6 Interface Address y y y(s) y y y n [RFC 6119] 13 IPv6 Neighbor Address y y y(s) y y y n [RFC 6119] 14 Extended Administrative Group y y y(s) y y y n [RFC 7308] 15 Link MSD y y y y y y y [RFC 8491] 16 Application-Specific Link Attributes y y y(s) y y y y [RFC 9479] 17 Generic Metric y y y y y y n [RFC 9843, Section 2.1] 18 TE Default metric y y y(s) y y y n [RFC 5305] 19 Link-attributes y y y(s) y y y n [RFC 5029] 20 Link Protection Type y y y(s) y y y n [RFC 5307] 21 Interface Switching Capability Descriptor y y y(s) y y y y [RFC 5307] 22 Bandwidth Constraints y y y(s) y y y n [RFC 4124] 23 Unconstrained TE LSP Count (sub-)TLV y y y(s) y y y n [RFC 5330] 24 Remote AS Number n n n y n n n [RFC 9346] 25 IPv4 Remote ASBR Identifier n n n y n n n [RFC 9346] 26 IPv6 Remote ASBR Identifier n n n y n n n [RFC 9346] 27 Interface Adjustment Capability Descriptor (IACD) y y y(s) y y y y [RFC 6001] 28 MTU y y n n y y n [RFC 7176] 29 SPB-Metric y y y(s) n y y n [RFC 6329] 30 SPB-A-OALG y y y(s) n y y y [RFC 6329] 31 Adjacency Segment Identifier y y n y y y n [RFC 8667] 32 LAN Adjacency Segment Identifier y y n y y y n [RFC 8667] 33 Unidirectional Link Delay y y y y y y n [RFC 8570] 34 Min/Max Unidirectional Link Delay y y y y y y n [RFC 8570] 35 Unidirectional Delay Variation y y y y y y n [RFC 8570] 36 Unidirectional Link Loss y y y y y y n [RFC 8570] 37 Unidirectional Residual Bandwidth y y y y y y n [RFC 8570] 38 Unidirectional Available Bandwidth y y y y y y n [RFC 8570] 39 Unidirectional Utilized Bandwidth y y y y y y n [RFC 8570] 40 RTM Capability y y n n y y n [RFC 8169] 41 L2 Bundle Member Adj-SID n n y n n n y [RFC 8668] 42 L2 Bundle Member LAN Adj-SID n n y n n n y [RFC 8668] 43 SRv6 End.X SID y y y y y y y [RFC 9352, Section 8.1] 44 SRv6 LAN End.X SID y y y y y y y [RFC 9352, Section 8.2] 45 IPv6 Local ASBR Identifier n n n y n n n [RFC 9346] 46-160 Unassigned 161 Flood Reflector Adjacency y y n y y y n [RFC 9377] 162-249 Unassigned 250-254 Reserved for Cisco-specific extensions 255 Reserved for future expansion IS-IS Neighbor Link-Attribute Bit Values Registration Procedure(s) Expert Review Expert(s) Chris Hopps, Hannes Gredler, Les Ginsberg Description This registry defines bit values for the Link-attributes sub-TLV (19) advertised in TLVs advertising neighbor information. These TLVs are listed in the description of the “IS-IS Sub-TLVs for TLVs Advertising Neighbor Information” registry. Reference [RFC 5029][RFC 9667][RFC 9650] Note The "L2BM" column indicates applicability to the L2 Bundle Member Attributes TLV. The options for the "L2BM" column are: * Y - This bit MAY appear in the L2 Bundle Member Attributes TLV. * N - This bit MUST NOT appear in the L2 Bundle Member Attributes TLV. Available Formats [IMG] CSV Value Name L2BM Reference 0x1 Local Protection Available N [RFC 5029] 0x2 Link Excluded from Local Protection N [RFC 5029] 0x4 Local Edge Enabled for Flooding (LEEF) N [RFC 9667] IS-IS Sub-TLVs for TLVs Advertising Prefix Reachability Registration Procedure(s) Expert Review Expert(s) Chris Hopps, Hannes Gredler, Les Ginsberg Description This registry defines sub-TLVs for TLVs advertising prefix reachability. The list of TLVs includes: * SRv6 Locator (27) * IPv4 Algorithm Prefix Reachability (126) * IPv6 Algorithm Prefix Reachability (127) * Extended IP reachability (135) * MT IP Reach (235) * IPv6 IP Reach (236) * MT IPv6 IP Reach (237) Reference [RFC 5305][RFC 7370][RFC 9352][RFC 9885] Note Allocations within this registry require documentation of the use of the allocated value and approval by the Designated Expert assigned by the IESG. Available Formats [IMG] CSV Type Description 27 126 127 135 235 236 237 MP Reference 0 Unassigned 1 32-bit Administrative Tag Sub-TLV y y y y y y y y [RFC 5130] 2 64-bit Administrative Tag Sub-TLV y y y y y y y y [RFC 5130] 3 Prefix Segment Identifier n n n y y y y n [RFC 8667] 4 Prefix Attribute Flags y y y y y y y n [RFC 7794] 5 SRv6 End SID y n n n n n n y [RFC 9352, Section 7.2] 6 Flexible Algorithm Prefix Metric (FAPM) n n n y y y y n [RFC 9350, Section 8] 7-10 Unassigned 11 IPv4 Source Router ID y y y y y y y n [RFC 7794] 12 IPv6 Source Router ID y y y y y y y n [RFC 7794] 13-31 Unassigned 32 BIER Info n n n y y y y y [RFC 8401] 33-255 Unassigned IS-IS Bit Values for Prefix Attribute Flags Sub-TLV Registration Procedure(s) Expert Review Expert(s) Chris Hopps, Hannes Gredler, Les Ginsberg Description This registry defines bit values for the Prefix Attribute Flags (4) sub-TLV advertised in Prefix Reachability TLVs. These TLVs are listed in the description of the "IS-IS Sub-TLVs for TLVs Advertising Prefix Reachability” registry. Reference [RFC 7794] Available Formats [IMG] CSV Bit # Name Reference 0 External Prefix Flag (X-flag) [RFC 7794] 1 Re-advertisement Flag (R-flag) [RFC 7794] 2 Node Flag (N-flag) [RFC 7794] 3 ELC Flag (E-flag) [RFC 9088] 4 Anycast Flag (A-flag) [RFC 9352, Section 6] 5 U-Flag [RFC 9929, Section 3.2] 6 UP-Flag [RFC 9929, Section 3.2] IS-IS Group Address Type Codes for GADDR-TLV Registration Procedure(s) Expert Review Expert(s) Chris Hopps, Hannes Gredler, Les Ginsberg Description This registry defines Group Address Type Codes for the GADDR-TLV (142). Reference [RFC 7176] Available Formats [IMG] CSV Type Description Reference 0 Reserved [RFC 7176] 1 GMAC-ADDR [RFC 7176] 2 GIP-ADDR [RFC 7176] 3 GIPV6-ADDR [RFC 7176] 4 GLMAC-ADDR [RFC 7176] 5 GLIP-ADDR [RFC 7176] 6 GLIPV6-ADDR [RFC 7176] 7-254 Unassigned 255 Reserved [RFC 7176] IS-IS Sub-TLVs for MT-Port-Cap-TLV Registration Procedure(s) Expert Review Expert(s) Chris Hopps, Hannes Gredler, Les Ginsberg Description This registry defines sub-TLVs for the MT-Port-Cap-TLV (143). Reference [RFC 7176] Available Formats [IMG] CSV Value Group Address Type Code Reference 0 Reserved [RFC 7176] 1 VLAN-FLAGs [RFC 7176] 2 Enabled-VLANs [RFC 7176] 3 AppointedFwrdrs [RFC 7176] 4 SPB-MCID [RFC 6329] 5 SPB-Digest [RFC 6329] 6 SPB-B-VID [RFC 6329] 7 PORT-TRILL-VER [RFC 7176] 8 VLANs-Appointed [RFC 7176] 9-254 Unassigned 255 Reserved [RFC 7176] IS-IS Sub-TLVs for MT-Capability TLV Registration Procedure(s) Expert Review Expert(s) Chris Hopps, Hannes Gredler, Les Ginsberg Description This registry defines sub-TLVs for the MT-Capability TLV (144). Reference [RFC 6329][RFC 9885] Available Formats [IMG] CSV Value Group Address Type Code MP Reference 0 Reserved [RFC 6329] 1 SPB-Inst n [RFC 6329] 2 SPB-I-OALG y [RFC 6329] 3 SPBM-SI y [RFC 6329] 4 SPBV-ADDR y [RFC 6329] 5 Unassigned 6 NICKNAME y [RFC 7176] 7 TREES n [RFC 7176] 8 TREE-RT-IDs y [RFC 7176] 9 TREE-USE-IDs y [RFC 7176] 10 INT-VLAN y [RFC 7176] 11-12 Unassigned 13 TRILL-VER n [RFC 7176] 14 VLAN-GROUP y [RFC 7176] 15 INT-LABEL y [RFC 7176] 16 RBCHANNELS y [RFC 7176] 17 AFFINITY y [RFC 7176] 18 LABEL-GROUP y [RFC 7176] 19-20 Unassigned 21 Topology sub-TLV y [RFC 7813] 22 Hop sub-TLV n [RFC 7813] 23 Bandwidth Constraint sub-TLV n [RFC 7813] 24 Bandwidth Assignment sub-TLV n [RFC 7813] 25 Timestamp sub-TLV n [RFC 7813] 26-254 Unassigned 255 Reserved [RFC 6329] IS-IS Sub-TLVs for IS-IS Router CAPABILITY TLV Registration Procedure(s) Expert Review Expert(s) Chris Hopps, Hannes Gredler, Les Ginsberg Description This registry defines sub-TLVs for the IS-IS Router CAPABILITY TLV (242). Reference [RFC 7981][RFC 9885] Note Allocations within this registry require documentation of the use of the allocated value and approval by the Designated Expert assigned by the IESG. Available Formats [IMG] CSV Value Description MP Reference 0 Reserved 1 TE Node Capability Descriptor n [RFC 5073] 2 Segment Routing Capability n [RFC 8667] 3 TE-MESH-GROUP TLV (IPv4) y [RFC 4972] 4 TE-MESH-GROUP TLV (IPv6) y [RFC 4972] 5 PCED sub-TLV n [RFC 5089] 6 NICKNAME y [RFC 7176] 7 TREES n [RFC 7176] 8 TREE-RT-IDs y [RFC 7176] 9 TREE-USE-IDs y [RFC 7176] 10 INT-VLAN y [RFC 7176] 11 IPv4 TE Router ID n [RFC 9346] 12 IPv6 TE Router ID n [RFC 9346] 13 TRILL-VER n [RFC 7176] 14 VLAN-GROUP y [RFC 7176] 15 INT-LABEL y [RFC 7176] 16 RBCHANNELS y [RFC 7176] 17 AFFINITY y [RFC 7176] 18 LABEL-GROUP y [RFC 7176] 19 Segment Routing Algorithm n [RFC 8667] 20 S-BFD Discriminators n [RFC 7883] 21 Node-Admin-Tag n [RFC 7917] 22 Segment Routing Local Block (SRLB) n [RFC 8667] 23 Node MSD y [RFC 8491] 24 Segment Routing Mapping Server Preference (SRMS Preference) n [RFC 8667] 25 SRv6 Capabilities n [RFC 9352, Section 2] 26 Flexible Algorithm Definition (FAD) n [RFC 9350, Section 5.1] 27 IS-IS Area Leader n [RFC 9667] 28 IS-IS Dynamic Flooding n [RFC 9667] 29 IP Algorithm n [RFC 9502, Section 5.1] 30 MP-TLV Support for TLVs with Implicit Support n [RFC 9885, Section 7.2] 31-160 Unassigned 161 Flood Reflection Discovery y [RFC 9377] 162-249 Unassigned 250 Flood Reduction Algorithm (TEMPORARY - registered 2026-05-20, expires 2027-05-20) n [draft-ietf-lsr-flood-reduction-arch-01] 251-255 Unassigned IS-IS Sub-Sub-TLVs for SRv6 Capabilities Sub-TLV Registration Procedure(s) Expert Review Expert(s) Chris Hopps, Hannes Gredler, Les Ginsberg Description This registry defines sub-sub-TLVs for the SRv6 Capabilities sub-TLV (25) advertised in the IS-IS Router CAPABILITY TLV (242). Reference [RFC 9352][RFC 9885] Available Formats [IMG] CSV Value Description MP Reference 0 Reserved [RFC 9352] 1-255 Unassigned IS-IS SRv6 Capabilities Sub-TLV Flags Registration Procedure(s) Expert Review Expert(s) Chris Hopps, Hannes Gredler, Les Ginsberg Description This registry defines bit values advertised in the Flags field of the SRv6 Capabilities sub-TLV (25). This sub-TLV is advertised in the IS-IS Router CAPABILITY TLV (242). Reference [RFC 9352] Available Formats [IMG] CSV Type Description Reference 0 Unassigned 1 O-flag [RFC 9352, Section 2] 2-15 Unassigned IS-IS Application Identifiers for Generic Information TLV Registration Procedure(s) Expert Review Expert(s) Chris Hopps, Hannes Gredler, Les Ginsberg Description This registry defines Application Identifiers for the Generic Information TLV (251). Reference [RFC 6823] Available Formats [IMG] CSV ID Value Description Allowed in Instance zero (y/n) Reference 0 Reserved [RFC 6823] 1 TRILL n [RFC 7357] 2-65535 Unassigned IS-IS Sub-Sub-TLVs for BIER Info Sub-TLV Registration Procedure(s) Expert Review Expert(s) Chris Hopps, Hannes Gredler, Les Ginsberg Description This registry defines sub-sub-TLV codes which may be advertised in the BIER Info sub-TLV, which is advertised in Prefix Reachability TLVs. These TLVs are listed in the description of the "IS-IS Sub-TLVs for TLVs Advertising Prefix Reachability” registry. Reference [RFC 8401][RFC 9885] Available Formats [IMG] CSV Type Name MP Reference 0 Unassigned 1 BIER MPLS Encapsulation n [RFC 8401] 2 BIER PHP Request n [RFC-ietf-bier-php-16] 3-255 Unassigned IS-IS Sub-TLVs for Segment Identifier/Label Binding TLVs Registration Procedure(s) Expert Review Expert(s) Chris Hopps, Hannes Gredler, Les Ginsberg Description This registry defines sub-TLVs for Segment Identifier/Label Binding TLVs. The list of TLVs includes: Segment Identifier/Label Binding (149) Multi-Topology Segment Identifier/Label Binding (150) Reference [RFC 8667][RFC 9885] Available Formats [IMG] CSV Type Description MP Reference 0 Reserved [RFC 8667] 1 SID/Label n [RFC 8667] 2 Unassigned 3 Prefix Segment Identifier n [RFC 8667] 4-255 Unassigned IS-IS Sub-Sub-TLV Codepoints for Application-Specific Link Attributes Registration Procedure(s) Expert Review Expert(s) Chris Hopps, Hannes Gredler, Les Ginsberg Description This registry defines sub-sub-TLV codepoints for the Application-Specific Link Attributes sub-TLV, which is advertised in TLVs advertising neighbor information. These TLVs are listed in the description of the “IS-IS Sub-TLVs for TLVs Advertising Neighbor Information” registry. Reference [RFC 9479][RFC 9885] Note For future codepoints, in cases where the document that defines the encoding is different from the document that assigns the codepoint, the encoding reference MUST be to the document that defines the encoding. Note If a link attribute can be advertised both as a sub-TLV of TLVs advertising neighbor information and as a sub-sub-TLV of the Application-Specific Link Attributes sub-TLV defined in [RFC 9479], then the same numerical code should be assigned to the link attribute whenever possible. Available Formats [IMG] CSV Type Description MP Reference 0-2 Unassigned 3 Administrative group (color) n [RFC 5305] 4-8 Unassigned 9 Maximum link bandwidth n [RFC 5305] 10 Maximum reservable link bandwidth n [RFC 5305] 11 Unreserved bandwidth n [RFC 5305] 12-13 Unassigned 14 Extended Administrative Group n [RFC 7308] 15-16 Unassigned 17 Generic Metric y [RFC 9843, Section 2.1] 18 TE Default metric n [RFC 5305] 19-32 Unassigned 33 Unidirectional Link Delay n [RFC 8570] 34 Min/Max Unidirectional Link Delay n [RFC 8570] 35 Unidirectional Delay Variation n [RFC 8570] 36 Unidirectional Link Loss n [RFC 8570] 37 Unidirectional Residual Bandwidth n [RFC 8570] 38 Unidirectional Available Bandwidth n [RFC 8570] 39 Unidirectional Utilized Bandwidth n [RFC 8570] 40-255 Unassigned IS-IS Sub-TLVs for Application-Specific SRLG TLV Registration Procedure(s) Expert Review Expert(s) Chris Hopps, Hannes Gredler, Les Ginsberg Description This registry defines sub-TLVs for the Application-Specific SRLG TLV (TLV 238). Reference [RFC 9479][RFC 9885] Note For future codepoints, in cases where the document that defines the encoding is different from the document that assigns the codepoint, the encoding reference MUST be to the document that defines the encoding. Available Formats [IMG] CSV Value Description MP Reference 0-3 Unassigned 4 Link Local/Remote Identifiers n [RFC 5307] 5 Unassigned 6 IPv4 interface address n [RFC 5305] 7 Unassigned 8 IPv4 neighbor address n [RFC 5305] 9-11 Unassigned 12 IPv6 Interface Address n [RFC 6119] 13 IPv6 Neighbor Address n [RFC 6119] 14-255 Unassigned IS-IS Sub-Sub-TLVs for SRv6 SID Sub-TLVs Registration Procedure(s) Expert Review Expert(s) Chris Hopps, Hannes Gredler, Les Ginsberg Description This registry defines sub-sub-TLVs for SRv6 SID sub-TLVs. This includes the following sub-TLVs: * SRv6 End SID (5) (Advertised in SRv6 Locator TLV (27)) * SRv6 End.X SID (43) (Advertised in TLVs advertising neighbor information) * SRv6 LAN End.X SID (44) (Advertised in TLVs advertising neighbor information) Reference [RFC 9352][RFC 9885] Available Formats [IMG] CSV Type Description 5 43 44 MP Reference 0 Reserved [RFC 9352] 1 SRv6 SID Structure y y y n [RFC 9352] 2-255 Unassigned IS-IS SRv6 Locator TLV Flags Registration Procedure(s) Expert Review Expert(s) Chris Hopps, Hannes Gredler, Les Ginsberg Description This registry defines bit values advertised in the Flags field of the SRv6 Locator TLV (27). Reference [RFC 9352] Available Formats [IMG] CSV Value Description Reference 0 D-flag [RFC 9352, Section 7.1] 1-7 Unassigned IS-IS SRv6 End SID Sub-TLV Flags Registration Procedure(s) Expert Review Expert(s) Chris Hopps, Hannes Gredler, Les Ginsberg Description This registry defines bit values advertised in the Flags field of the SRv6 End SID sub-TLV (5), which is advertised in the SRv6 Locator TLV (27). Reference [RFC 9352] Available Formats [IMG] CSV Value Description Reference 0-7 Unassigned IS-IS SRv6 Adjacency SID Sub-TLVs Flags Registration Procedure(s) Expert Review Expert(s) Chris Hopps, Hannes Gredler, Les Ginsberg Description This registry defines bit values advertised in the Flags field of SRv6 SID sub-TLVs associated with adjacencies. These sub-TLVs are advertised in TLVs advertising neighbor information. The list of sub-TLVs includes: SRv6 End.X SID (43) SRv6 LAN End.X SID (44) Reference [RFC 9352] Available Formats [IMG] CSV Value Description Reference 0 B-flag [RFC 9352, Section 8.1] 1 S-flag [RFC 9352, Section 8.1] 2 P-flag [RFC 9352, Section 8.1] 3-7 Unassigned IS-IS Sub-Sub-TLVs for Flexible Algorithm Definition Sub-TLV Registration Procedure(s) Expert Review Expert(s) Chris Hopps, Hannes Gredler, Les Ginsberg Reference [RFC 9350][RFC 9885] Available Formats [IMG] CSV Type Description MP Reference 0 Reserved [RFC 9350] 1 Flexible Algorithm Exclude Admin Group n [RFC 9350, Section 6.1] 2 Flexible Algorithm Include-Any Admin Group n [RFC 9350, Section 6.2] 3 Flexible Algorithm Include-All Admin Group n [RFC 9350, Section 6.3] 4 Flexible Algorithm Definition Flags n [RFC 9350, Section 6.4] 5 Flexible Algorithm Exclude SRLG n [RFC 9350, Section 6.5] 6 IS-IS Exclude Minimum Bandwidth n [RFC 9843, Section 3.1.1] 7 IS-IS Exclude Maximum Delay n [RFC 9843, Section 3.1.2] 8 IS-IS Reference Bandwidth n [RFC 9843, Section 4.1.3.1] 9 IS-IS Bandwidth Threshold n [RFC 9843, Section 4.1.3.2] 10 Flexible Algorithm Exclude Reverse Admin Group n [RFC 9917, Section 5] 11 Flexible Algorithm Include-Any Reverse Admin Group n [RFC 9917, Section 6] 12 Flexible Algorithm Include-All Reverse Admin Group n [RFC 9917, Section 7] 13-255 Unassigned IS-IS Sub-Sub-TLVs for Flood Reflection Discovery Sub-TLV Registration Procedure(s) Expert Review Expert(s) Chris Hopps, Hannes Gredler, Les Ginsberg Description This registry contains assigned sub-sub-TLV identifiers for Flood Reflection Discovery purposes. Reference [RFC 9377][RFC 9885] Available Formats [IMG] CSV Type Description MP Reference 0-160 Unassigned 161 Flood Reflection Discovery Tunnel Encapsulation Attribute n [RFC 9377] 162-255 Unassigned IS-IS Sub-TLVs for the Area Proxy TLV Registration Procedure(s) Expert Review with RFC Required Expert(s) Chris Hopps, Hannes Gredler, Les Ginsberg Description This registry defines sub-TLVs for the Area Proxy TLV (TLV 20). Reference [RFC 9666] Available Formats [IMG] CSV Value Name Reference 0 Unassigned 1 Area Proxy System Identifier [RFC 9666] 2 Area SID [RFC 9666] 3-255 Unassigned IS-IS Sub-TLVs for Flooding Parameters TLV Registration Procedure(s) Expert Review Expert(s) Chris Hopps, Hannes Gredler, Les Ginsberg Description This registry defines sub-TLVs for the Flooding Parameters TLV(21). Reference [RFC 9681] Available Formats [IMG] CSV Type Description Reference 0 Reserved [RFC 9681] 1 LSP Burst Size [RFC 9681] 2 LSP Transmission Interval [RFC 9681] 3 LSPs per PSNP [RFC 9681] 4 Flags [RFC 9681] 5 PSNP Interval [RFC 9681] 6 Receive Window [RFC 9681] 7-255 Unassigned IS-IS Bit Values for Flooding Parameters Flags Sub-TLV Registration Procedure(s) Expert Review Expert(s) Chris Hopps, Hannes Gredler, Les Ginsberg Description This registry defines bit values for the Flags sub-TLV(4) advertised in the Flooding Parameters TLV(21). Reference [RFC 9681] Note In order to minimize encoding space, a new allocation should pick the smallest available value. Available Formats [IMG] CSV Bit # Description Reference 0 Ordered acknowledgment (O-flag) [RFC 9681] 1-63 Unassigned Licensing Terms