Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About IPv6 Address Space Last Updated 2025-10-23 Note The IPv6 address management function was formally delegated to IANA in December 1995 [RFC 1881]. The registration procedure was confirmed with the IETF Chair in March 2010. As stated in [RFC 3513], IANA should limit its allocation of IPv6-unicast address space to the range of addresses that start with binary value 001. The rest of the global unicast address space (approximately 85% of the IPv6 address space) is reserved for future definition and use, and is not to be assigned by IANA at this time. While [RFC 3513] was obsoleted by [RFC 4291], the guidance provided to IANA did not change regarding the allocation of IPv6 unicast addresses. Formerly known as Internet Protocol Version 6 Address Space (pursuant to [IESG decision]) Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registration Procedure(s) IETF Review Reference [RFC 9812] Available Formats [IMG] CSV IPv6 Prefix Allocation Reference Notes This range has been partially allocated. See [IPv6 Special-Purpose Address Space] for details. ::/8 Reserved by IETF [RFC 3513]; [RFC 4291] ::/96, formerly defined as the "IPv4-compatible IPv6 address" prefix, was deprecated by [RFC 4291]. 100::/8 Reserved by IETF [RFC 3513]; [RFC 4291] This range has been partially allocated. See [IPv6 Special-Purpose Address Space] for details. 200::/7 Reserved by IETF [RFC 4048] Deprecated as of December 2004 [RFC 4048]. Formerly an OSI NSAP-mapped prefix set [RFC 4548]. 400::/6 Reserved by IETF [RFC 3513]; [RFC 4291] 800::/5 Reserved by IETF [RFC 3513]; [RFC 4291] 1000::/4 Reserved by IETF [RFC 3513]; [RFC 4291] The IPv6 Unicast space encompasses the entire IPv6 address range with the exception of 2000::/3 Global Unicast [RFC 3513]; [RFC 4291] ff00::/8, per [RFC 4291]. IANA unicast address assignments are currently limited to the IPv6 unicast address range of 2000::/3. IANA assignments from this block are registered in [IPv6 Global Unicast Address Space]. This range has been partially allocated. See [IPv6 Special-Purpose Address Space] for details. 4000::/3 Reserved by IETF [RFC 3513]; [RFC 4291] 5f00::/8 (with 3ffe::/16, as noted at [IPv6 Global Unicast Address Space]) was used for the 6bone, but returned [RFC 5156]. 6000::/3 Reserved by IETF [RFC 3513]; [RFC 4291] 8000::/3 Reserved by IETF [RFC 3513]; [RFC 4291] a000::/3 Reserved by IETF [RFC 3513]; [RFC 4291] c000::/3 Reserved by IETF [RFC 3513]; [RFC 4291] e000::/4 Reserved by IETF [RFC 3513]; [RFC 4291] f000::/5 Reserved by IETF [RFC 3513]; [RFC 4291] f800::/6 Reserved by IETF [RFC 3513]; [RFC 4291] fc00::/7 Unique Local Unicast [RFC 4193] See [IPv6 Special-Purpose Address Space] for details. fe00::/9 Reserved by IETF [RFC 3513]; [RFC 4291] fe80::/10 Link-Scoped Unicast [RFC 3513]; [RFC 4291] See [IPv6 Special-Purpose Address Space] for details. fec0::/10 Reserved by IETF [RFC 3879] Deprecated by [RFC 3879] in September 2004. Formerly a Site-Local scoped address prefix. ff00::/8 Multicast [RFC 3513]; [RFC 4291] See [IPv6 Multicast Address Space] for details. Licensing Terms