Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About IPSECKEY Resource Record Parameters Created 2004-12-20 Last Updated 2023-03-15 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • Algorithm Type Field • Gateway Type Field Algorithm Type Field Registration Procedure(s) IETF Review Reference [RFC 4025][RFC 9373] Available Formats [IMG] CSV Bit Description Format Description Reference 0 No Public key is present [RFC 4025] 1 A DSA Public Key [RFC 2536, Section 2] [RFC 4025] 2 An RSA Public Key [RFC 3110, Section 2] [RFC 4025] 3 An ECDSA Public Key [RFC 6605, Section 4] [RFC 8005] 4 An EdDSA Public Key [RFC 8080, Section 3] [RFC 9373] 5-255 Unassigned Gateway Type Field Registration Procedure(s) Standards Action Reference [RFC 4025] Available Formats [IMG] CSV Value Description Reference 0 No gateway is present [RFC 4025] 1 A 4-byte IPv4 address is present [RFC 4025] 2 A 16-byte IPv6 address is present [RFC 4025] 3 A wire-encoded domain name is present [RFC 4025] 4-255 Unassigned Licensing Terms