Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About IMAP Response Codes Created 2009-03-24 Last Updated 2026-08-04 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registry Included Below • IMAP Response Codes IMAP Response Codes Registration Procedure(s) Expert Review Expert(s) Arnt Gulbrandsen, Dave Cridland Reference [RFC 5530] Available Formats [IMG] CSV Response Code Reference Status Description (Optional) NEWNAME [RFC 2060] obsolete REFERRAL [RFC 2221] ALERT [RFC 3501]; [RFC 9051] BADCHARSET [RFC 3501]; [RFC 9051] PARSE [RFC 3501]; [RFC 9051] PERMANENTFLAGS [RFC 3501]; [RFC 9051] READ-ONLY [RFC 3501]; [RFC 9051] READ-WRITE [RFC 3501]; [RFC 9051] TRYCREATE [RFC 3501]; [RFC 9051] UIDNEXT [RFC 3501]; [RFC 9051] UIDVALIDITY [RFC 3501]; [RFC 9051] UNSEEN [RFC 3501]; [RFC 9051] UNKNOWN-CTE [RFC 3516]; [RFC 9051] UIDNOTSTICKY [RFC 4315]; [RFC 9051] APPENDUID [RFC 4315]; [RFC 9051] COPYUID [RFC 4315]; [RFC 9051] URLMECH [RFC 4467] TOOBIG [RFC 4469] BADURL [RFC 4469] HIGHESTMODSEQ [RFC 4551] NOMODSEQ [RFC 4551] MODIFIED [RFC 4551] COMPRESSIONACTIVE [RFC 4978] CLOSED [RFC 5162]; [RFC 9051] NOTSAVED [RFC 5182] BADCOMPARATOR [RFC 5255] ANNOTATE [RFC 5257] ANNOTATIONS [RFC 5257] TEMPFAIL [RFC 5259] MAXCONVERTMESSAGES [RFC 5259] MAXCONVERTPARTS [RFC 5259] NOUPDATE [RFC 5267] NOTIFICATIONOVERFLOW [RFC 5465] BADEVENT [RFC 5465] UNDEFINED-FILTER [RFC 5466] METADATA [RFC 5464] UNAVAILABLE [RFC 5530]; [RFC 9051] AUTHENTICATIONFAILED [RFC 5530]; [RFC 9051] AUTHORIZATIONFAILED [RFC 5530]; [RFC 9051] EXPIRED [RFC 5530]; [RFC 9051] PRIVACYREQUIRED [RFC 5530]; [RFC 9051] CONTACTADMIN [RFC 5530]; [RFC 9051] NOPERM [RFC 5530]; [RFC 9051] INUSE [RFC 5530]; [RFC 9051] EXPUNGEISSUED [RFC 5530]; [RFC 9051] CORRUPTION [RFC 5530]; [RFC 9051] SERVERBUG [RFC 5530]; [RFC 9051] CLIENTBUG [RFC 5530]; [RFC 9051] CANNOT [RFC 5530]; [RFC 9051] LIMIT [RFC 5530]; [RFC 9051] OVERQUOTA [RFC 5530]; [RFC 9051] ALREADYEXISTS [RFC 5530]; [RFC 9051] NONEXISTENT [RFC 5530]; [RFC 9051] USEATTR [RFC 6154] DOWNGRADED [RFC 6858] MAILBOXID [RFC 8474] CAPABILITY [RFC 3501]; [RFC 9051] HASCHILDREN [RFC 9051] UIDREQUIRED [RFC 9586] INPROGRESS [RFC 9585] TOOMANY [RFC 10022] TOOFEW [RFC 10022] Licensing Terms