Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About IMAP Mailbox Name Attributes Created 2018-06-14 Last Updated 2026-06-01 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registry Included Below • IMAP Mailbox Name Attributes IMAP Mailbox Name Attributes Registration Procedure(s) IETF Review or Expert Review Expert(s) Barry Leiba, Bron Gondwana Reference [RFC 3501, Section 7.2.2][RFC 8457, Section 6][RFC 9051] Available Formats [IMG] CSV Attribute Name Description Reference Usage Notes All All messages [RFC 6154] Archive Archived messages [RFC 6154] Drafts Messages that are working drafts [RFC 6154] Flagged Messages with the \Flagged flag [RFC 6154] HasChildren Has accessible child mailboxes [RFC 5258] not used by JMAP HasNoChildren Has no accessible child mailboxes [RFC 5258] not used by JMAP Important Messages deemed important to user [RFC 8457] Inbox New mail is delivered here by default. [RFC 8621, Section 10.5.1] JMAP only Junk Messages identified as Spam/Junk [RFC 6154] Marked Server has marked the mailbox as "interesting" [RFC 3501]; [RFC 9051] not used by JMAP Memos Identifies the mailbox where user-created memo messages are stored. [RFC 9979] NoInferiors No hierarchy under this name [RFC 3501]; [RFC 9051] not used by JMAP NonExistent The mailbox name doesn't actually exist [RFC 5258] not used by JMAP Noselect The mailbox is not selectable [RFC 3501]; [RFC 9051] not used by JMAP Remote The mailbox exists on a remote server [RFC 5258] not used by JMAP Scheduled Identifies the mailbox where messages scheduled to be sent at a later time are stored. [RFC 9979] Sent Sent mail [RFC 6154] Snoozed Identifies the mailbox where temporarily snoozed messages are stored. [RFC 9979] Subscribed The mailbox is subscribed to [RFC 5258] Trash Messages the user has discarded [RFC 6154] Unmarked No new messages since last select [RFC 3501]; [RFC 9051] not used by JMAP Licensing Terms