Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About Internet Message Access Protocol (IMAP) LIST EXTENDED Registry Created 2006-10-19 Last Updated 2024-06-05 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • LIST-EXTENDED options • LIST-EXTENDED response LIST-EXTENDED options Registration Procedure(s) FCFS; IANA approval template in [RFC 5258, Section 9.3] Reference [RFC 5258] Available Formats [IMG] CSV Implied Person and email LIST-EXTENDED LIST-EXTENDED return LIST-EXTENDED option description Published Security Intended address to contact Owner/Change option name option type option(s) specification considerations usage for further controller information Causes the LIST command to list [RFC 5258, [RFC 5258, SUBSCRIBED SELECTION SUBSCRIBED subscribed mailboxes, rather than Section 3]. Section 8]. COMMON [Alexey_Melnikov] [IESG] the actual mailboxes. Causes the LIST command to return [RFC 5258, [RFC 5258, REMOTE SELECTION (none) remote mailboxes as well as local Section 3]. Section 8]. COMMON [Alexey_Melnikov] [IESG] ones, as described in RFC 2193. SUBSCRIBED RETURN Causes the LIST command to return [RFC 5258, [RFC 5258, COMMON [Alexey_Melnikov] [IESG] subscription state. Section 3]. Section 8]. Requests that CHILDINFO extended [RFC 5258, [RFC 5258, RECURSIVEMATCH SELECTION (none) data item (childinfo-extended-item) Section 3]. Section 8]. COMMON [Alexey_Melnikov] [IESG] is to be returned. CHILDREN RETURN Requests mailbox child information. [RFC 5258, [RFC 5258, COMMON [Alexey_Melnikov] [IESG] Section 3, 4]. Section 8]. Causes the LIST response to include [RFC 5738, [RFC 5738, see Authors' UTF8 SELECTION UTF8 mailboxes that mandate the UTF8 Section 3.4.1] Section 11] COMMON Addresses at the end [IESG] SELECT/EXAMINE parameter. of [RFC 5738] Causes the LIST response to include mailboxes that mandate the UTF8 [RFC 5738, [RFC 5738, see Authors' UTF8ONLY SELECTION UTF8 SELECT/EXAMINE parameter and exclude Section 3.4.1] Section 11] COMMON Addresses at the end [IESG] mailboxes that do not support the of [RFC 5738] UTF8 SELECT/EXAMINE parameter. Causes the LIST response to include [RFC 5738, [RFC 5738, see Authors' UTF8 RETURN none \NoUTF8 and \UTF8Only mailbox Section 3.4.2] Section 11] COMMON Addresses at the end [IESG] attributes. of [RFC 5738] Causes the LIST command to return STATUS RETURN STATUS responses in addition to LIST [RFC 5819] [RFC 5819] COMMON [Alexey_Melnikov] [IESG] responses. Limit the list to special-use Authors' Addresses SPECIAL-USE SELECTION SPECIAL-USE mailboxes only [RFC 6154] [none] COMMON at the end of [RFC [IESG] 6154] Request special-use mailbox Authors' Addresses SPECIAL-USE RETURN information [RFC 6154] [none] COMMON at the end of [RFC [IESG] 6154] Causes the LIST command to return [RFC 8440, [RFC 8440, MYRIGHTS RETURN MYRIGHTS responses in addition to Section 3] Section 6] COMMON [Kenneth_Murchison] [IESG] LIST responses. Causes the LIST command to return [RFC 9590, [RFC 9590, See Authors' METADATA RETURN METADATA responses in addition to Section 3] Section 6] COMMON Addresses at the end [IESG] LIST responses. of [RFC 9590] LIST-EXTENDED response Registration Procedure(s) IANA approval template in [RFC 5258, Section 9.3] Reference [RFC 5258] Available Formats [IMG] CSV Which LIST-EXTENDED Person and email LIST-EXTENDED LIST-EXTENDED extended data item option(s) (and their Published Security Intended address to contact Owner/Change extended data description types) causes this specification considerations usage for further controller item tag extended data item to information be returned (if any) The CHILDINFO extended data item describes the selection criteria that CHILDINFO has caused it to be returned and RECURSIVEMATCH [RFC 5258, [RFC 5258, Section COMMON [Alexey_Melnikov] [IESG] indicates that the mailbox has one or selection option Section 3.5] 8] more child mailboxes that match the selection criteria. The OLDNAME extended data item describes [RFC 5465, OLDNAME the old mailbox name for the mailbox none Section 5.4]; [none] COMMON [Alexey_Melnikov] [IESG] identified by the LIST response. [RFC 9051] Contact Information ID Name Contact URI Last Updated [Alexey_Melnikov] Alexey Melnikov mailto:Alexey.Melnikov&isode.com [Kenneth_Murchison] Kenneth Murchison mailto:murch&fastmailteam.com 2018-08-15 [IESG] IESG mailto:iesg&ietf.org Licensing Terms