Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About Internet Message Access Protocol (IMAP) Capabilities Registry Last Updated 2026-08-04 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • IMAP Capabilities • IMAP Quota Resource Types IMAP Capabilities Registration Procedure(s) IETF Review Reference [RFC 3501][RFC 9051] Note Client implementations compliant with [RFC 3501] SHOULD NOT require any capability name other than "IMAP4rev1". Client implementations compliant with [RFC 9051] SHOULD NOT require any capability name other than "IMAP4rev2", and possibly "STARTTLS" and "LOGINDISABLED" (on a cleartext port). All client implementations MUST ignore any unknown capability names. The prefix "QUOTA=RES-" is reserved per [RFC 9208, Section 9.1]. See [Section 9.2 of RFC 9208] for values that follow this prefix. All other capabilities starting with the "QUOTA=" prefix are reserved for future IETF Stream extensions to [RFC 9208]. Available Formats [IMG] CSV Capability Name Reference ACL [RFC 4314] ANNOTATE-EXPERIMENT-1 [RFC 5257] APPENDLIMIT [RFC 7889] AUTH= [RFC 3501]; [RFC 9051] BINARY [RFC 3516] CATENATE [RFC 4469] CHILDREN [RFC 3348] COMPRESS=DEFLATE [RFC 4978] CONDSTORE [RFC 7162] CONTEXT=SEARCH [RFC 5267] CONTEXT=SORT [RFC 5267] CONVERT [RFC 5259] CREATE-SPECIAL-USE [RFC 6154] ENABLE [RFC 5161] ESEARCH [RFC 4731] ESORT [RFC 5267] FILTERS [RFC 5466] I18NLEVEL=1 [RFC 5255] I18NLEVEL=2 [RFC 5255] ID [RFC 2971] IDLE [RFC 2177] IMAP4REV1 [RFC 3501] IMAP4REV2 [RFC 9051] IMAPSIEVE= [RFC 6785] INPROGRESS [RFC 9585] JMAPACCESS [RFC 9698] LANGUAGE [RFC 5255] LIST-EXTENDED [RFC 5258] LIST-METADATA [RFC 9590] LIST-MYRIGHTS [RFC 8440] LIST-STATUS [RFC 5819] LITERAL+ [RFC 7888] LITERAL- [RFC 7888] LOGIN-REFERRALS [RFC 2221] LOGINDISABLED [RFC 3501]; [RFC 9051] MAILBOX-REFERRALS [RFC 2193] MESSAGELIMIT= [RFC 9738] METADATA [RFC 5464] METADATA-SERVER [RFC 5464] MOVE [RFC 6851] MULTIAPPEND [RFC 3502] MULTISEARCH [RFC 7377] NAMESPACE [RFC 2342] NOTIFY [RFC 5465] OBJECTID [RFC 8474] PARTIAL [RFC 9394] PREVIEW [RFC 8970] QRESYNC [RFC 7162] QUOTA [RFC 9208] QUOTA= [RFC 9208] QUOTASET [RFC 9208] REPLACE [RFC 8508] RIGHTS= [RFC 4314] SASL-IR [RFC 4959] SAVEDATE [RFC 8514] SAVELIMIT= [RFC 9738] SEARCH=FUZZY [RFC 6203] SEARCHRES [RFC 5182] SORT [RFC 5256] SORT=DISPLAY [RFC 5957] SPECIAL-USE [RFC 6154] STARTTLS [RFC 3501]; [RFC 9051] STATUS=SIZE [RFC 8438] THREAD [RFC 5256] UIDBATCHES [RFC 10022] UIDONLY [RFC 9586] UIDPLUS [RFC 4315] UNAUTHENTICATE [RFC 8437] UNSELECT [RFC 3691] URL-PARTIAL [RFC 5550] URLAUTH [RFC 4467] URLAUTH=BINARY [RFC 5524]; [RFC Errata 6214] UTF8=ACCEPT [RFC 9755] UTF8=ALL (OBSOLETE) [RFC 5738]; [RFC 9755] UTF8=APPEND (OBSOLETE) [RFC 5738]; [RFC 9755] UTF8=ONLY [RFC 9755] UTF8=USER (OBSOLETE) [RFC 5738]; [RFC 9755] WITHIN [RFC 5032] IMAP Quota Resource Types Registration Procedure(s) Specification Required Expert(s) Alexey Melnikov, Ken Murchison Reference [RFC 9208] Available Formats [IMG] CSV Name of the Quota Description Extra required IMAP Extra optional IMAP Author Change Reference Resource Type commands/responses commands/responses Controller The physical space estimate, in units of 1024 DELETED-STORAGE STATUS [RFC 9208, STORAGE octets, of the mailboxes governed by the quota request data item and N/A [Alexey_Melnikov] [IESG] Section 5.1] root. response data item The number of messages stored within the DELETED STATUS request [RFC 9208, MESSAGE mailboxes governed by the quota root. data item and response N/A [Alexey_Melnikov] [IESG] Section 5.2] data item MAILBOX The number of mailboxes governed by the quota N/A N/A [Alexey_Melnikov] [IESG] [RFC 9208, root. Section 5.3] The maximum size of all annotations [RFC ANNOTATION-STORAGE 5257], in units of 1024 octets, associated N/A N/A [Alexey_Melnikov] [IESG] [RFC 9208, with all messages in the mailboxes governed by Section 5.4] the quota root. Contact Information ID Name Contact URI Last Updated [Alexey_Melnikov] Alexey Melnikov mailto:alexey.melnikov&isode.com 2021-12-09 [IESG] IESG mailto:iesg&ietf.org 2021-12-09 Licensing Terms