Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About Internet Key Exchange Version 2 (IKEv2) Parameters Created 2005-01-18 Last Updated 2026-10-20 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • IKEv2 Exchange Types • IKEv2 Payload Types • Transform Type Values • IKEv2 Transform Attribute Types • Transform Type 1 - Encryption Algorithm Transform IDs • Transform Type 2 - Pseudorandom Function Transform IDs • Transform Type 3 - Integrity Algorithm Transform IDs • Transform Type 4 - Key Exchange Method Transform IDs • Transform Type 5 - Sequence Numbers Transform IDs • Transform Type 13 - Key Wrap Algorithm Transform IDs • Transform Type 14 - Group Controller Authentication Method Transform IDs • IKEv2 Identification Payload ID Types • IKEv2 Certificate Encodings • IKEv2 Authentication Method • IKEv2 Notify Message Error Types • IKEv2 Notify Message Status Types • IKEv2 Notification IPCOMP Transform IDs (Value 16387) • IKEv2 Security Protocol Identifiers • IKEv2 Traffic Selector Types • IKEv2 Configuration Payload CFG Types • IKEv2 Configuration Payload Attribute Types • IKEv2 Gateway Identity Types • ROHC Attribute Types • IKEv2 Secure Password Methods • IKEv2 Hash Algorithms • IKEv2 Post-quantum Preshared Key ID Types • Group SA Attributes • Group-Wide Policy Attributes • Group Key Bag Attributes • Member Key Bag Attributes IKEv2 Exchange Types Registration Procedure(s) Expert Review Expert(s) Tero Kivinen, Valery Smyslov Reference [RFC 7296] Available Formats [IMG] CSV Value Exchange Type Reference 0-33 Reserved [RFC 7296] 34 IKE_SA_INIT [RFC 7296] 35 IKE_AUTH [RFC 7296] 36 CREATE_CHILD_SA [RFC 7296] 37 INFORMATIONAL [RFC 7296] 38 IKE_SESSION_RESUME [RFC 5723] 39 GSA_AUTH [RFC 9838] 40 GSA_REGISTRATION [RFC 9838] 41 GSA_REKEY [RFC 9838] 42 GSA_INBAND_REKEY [RFC 9838] 43 IKE_INTERMEDIATE [RFC 9242] 44 IKE_FOLLOWUP_KE [RFC 9370] 45-239 Unassigned 240-255 Reserved for Private Use [RFC 7296] IKEv2 Payload Types Registration Procedure(s) Expert Review Expert(s) Tero Kivinen, Valery Smyslov Reference [RFC 7296] Available Formats [IMG] CSV Value Next Payload Type Notation Reference 0 No Next Payload [RFC 7296] 1-32 Reserved [RFC 7296] 33 Security Association SA [RFC 7296] Security Association - GM Supported Transforms SAg [RFC 9838] 34 Key Exchange KE [RFC 7296] 35 Identification - Initiator IDi [RFC 7296] 36 Identification - Responder IDr [RFC 7296] 37 Certificate CERT [RFC 7296] 38 Certificate Request CERTREQ [RFC 7296] 39 Authentication AUTH [RFC 7296] 40 Nonce Ni, Nr [RFC 7296] 41 Notify N [RFC 7296] 42 Delete D [RFC 7296] 43 Vendor ID V [RFC 7296] 44 Traffic Selector - Initiator TSi [RFC 7296] 45 Traffic Selector - Responder TSr [RFC 7296] 46 Encrypted and Authenticated SK [RFC 7296] 47 Configuration CP [RFC 7296] 48 Extensible Authentication EAP [RFC 7296] 49 Generic Secure Password Method GSPM [RFC 6467] 50 Group Identification IDg [RFC 9838] 51 Group Security Association GSA [RFC 9838] 52 Key Download KD [RFC 9838] 53 Encrypted and Authenticated Fragment SKF [RFC 7383] 54 Puzzle Solution PS [RFC 8019] 55-127 Unassigned 128-255 Reserved for Private Use [RFC 7296] Transform Type Values Registration Procedure(s) Expert Review Expert(s) Tero Kivinen, Valery Smyslov Reference [RFC 7296][RFC 9370] Note "Key Exchange Method (KE)" transform type was originally named "Diffie-Hellman Group (D-H)" and was referenced by that name in a number of RFCs published prior to [RFC 9370], which gave it the current title. Note All "Additional Key Exchange (ADDKE)" entries use the same "Transform Type 4 - Key Exchange Method Transform IDs" registry as the "Key Exchange Method (KE)" entry. Note The "Sequence Numbers (SN)" Transform Type was originally named "Extended Sequence Numbers (ESN)" and was referenced by that name in a number of RFCs published prior to [RFC 9827], which gave it the current title. Available Formats [IMG] CSV Type Description Used In Reference 0 Reserved [RFC 7296] 1 Encryption Algorithm (ENCR) (IKE, GIKE_UPDATE, ESP) [RFC 7296]; [RFC 9838] 2 Pseudo-random Function (PRF) (IKE) [RFC 7296] 3 Integrity Algorithm (INTEG) (IKE, GIKE_UPDATE, AH, optional in ESP) [RFC 7296]; [RFC 9838] 4 Key Exchange Method (KE) (IKE, optional in AH, ESP) [RFC 7296]; [RFC 9370] 5 Sequence Numbers (SN) (AH, ESP) [RFC 7296]; [RFC 9827] 6 Additional Key Exchange 1 (ADDKE1) (optional in IKE, AH, ESP) [RFC 9370] 7 Additional Key Exchange 2 (ADDKE2) (optional in IKE, AH, ESP) [RFC 9370] 8 Additional Key Exchange 3 (ADDKE3) (optional in IKE, AH, ESP) [RFC 9370] 9 Additional Key Exchange 4 (ADDKE4) (optional in IKE, AH, ESP) [RFC 9370] 10 Additional Key Exchange 5 (ADDKE5) (optional in IKE, AH, ESP) [RFC 9370] 11 Additional Key Exchange 6 (ADDKE6) (optional in IKE, AH, ESP) [RFC 9370] 12 Additional Key Exchange 7 (ADDKE7) (optional in IKE, AH, ESP) [RFC 9370] 13 Key Wrap Algorithm (KWA) (IKE, GIKE_UPDATE) [RFC 9838] 14 Group Controller Authentication Method (GCAUTH) (GIKE_UPDATE) [RFC 9838] 15-240 Unassigned 241-255 Reserved for Private Use [RFC 7296] IKEv2 Transform Attribute Types Registration Procedure(s) Expert Review Expert(s) Tero Kivinen, Valery Smyslov Reference [RFC 7296] Available Formats [IMG] CSV Value Attribute Type Format Reference 0-13 Reserved [RFC 7296] 14 Key Length (in bits) TV [RFC 7296] 15-17 Reserved [RFC 7296] 18 Signature Algorithm Identifier TLV [RFC 9838] 19-16383 Unassigned 16384-32767 Reserved for Private Use [RFC 7296] Transform Type 1 - Encryption Algorithm Transform IDs Registration Procedure(s) Expert Review Expert(s) Tero Kivinen, Valery Smyslov Reference [RFC 7296][RFC 9395] Note To find out requirement levels for encryption algorithms for ESP, see [RFC 8221]. For IKEv2, see [RFC 8247]. Available Formats [IMG] CSV Number Name Status ESP Reference IKEv2 Reference 0 Reserved [RFC 7296] - 1 ENCR_DES_IV64 DEPRECATED [RFC 9395] UNSPECIFIED - 2 ENCR_DES DEPRECATED [RFC 8247] [RFC 2405] [RFC 7296] 3 ENCR_3DES [RFC 2451] [RFC 7296] 4 ENCR_RC5 DEPRECATED [RFC 9395] [RFC 2451] [RFC 7296] 5 ENCR_IDEA DEPRECATED [RFC 9395] [RFC 2451] [RFC 7296] 6 ENCR_CAST DEPRECATED [RFC 9395] [RFC 2451] [RFC 7296] 7 ENCR_BLOWFISH DEPRECATED [RFC 9395] [RFC 2451] [RFC 7296] 8 ENCR_3IDEA DEPRECATED [RFC 9395] UNSPECIFIED [RFC 7296] 9 ENCR_DES_IV32 DEPRECATED [RFC 9395] UNSPECIFIED - 10 Reserved [RFC 7296] - 11 ENCR_NULL [RFC 2410] Not allowed 12 ENCR_AES_CBC [RFC 3602] [RFC 7296] 13 ENCR_AES_CTR [RFC 3686] [RFC 5930] 14 ENCR_AES_CCM_8 [RFC 4309] [RFC 5282] 15 ENCR_AES_CCM_12 [RFC 4309] [RFC 5282] 16 ENCR_AES_CCM_16 [RFC 4309] [RFC 5282] 17 Unassigned 18 ENCR_AES_GCM_8 [RFC 4106]; [RFC 8247] [RFC 5282]; [RFC 8247] 19 ENCR_AES_GCM_12 [RFC 4106]; [RFC 8247] [RFC 5282]; [RFC 8247] 20 ENCR_AES_GCM_16 [RFC 4106]; [RFC 8247] [RFC 5282]; [RFC 8247] 21 ENCR_NULL_AUTH_AES_GMAC [RFC 4543] Not allowed 22 Reserved for IEEE P1619 XTS-AES [Matt_Ball] - 23 ENCR_CAMELLIA_CBC [RFC 5529] [RFC 7296] 24 ENCR_CAMELLIA_CTR [RFC 5529] - 25 ENCR_CAMELLIA_CCM_8 [RFC 5529]; [RFC 8247] - 26 ENCR_CAMELLIA_CCM_12 [RFC 5529]; [RFC 8247] - 27 ENCR_CAMELLIA_CCM_16 [RFC 5529]; [RFC 8247] - 28 ENCR_CHACHA20_POLY1305 [RFC 7634] [RFC 7634] 29 ENCR_AES_CCM_8_IIV [RFC 8750] Not allowed 30 ENCR_AES_GCM_16_IIV [RFC 8750] Not allowed 31 ENCR_CHACHA20_POLY1305_IIV [RFC 8750] Not allowed 32 ENCR_KUZNYECHIK_MGM_KTREE [RFC 9227] [RFC 9227] 33 ENCR_MAGMA_MGM_KTREE [RFC 9227] [RFC 9227] 34 ENCR_KUZNYECHIK_MGM_MAC_KTREE [RFC 9227] Not allowed 35 ENCR_MAGMA_MGM_MAC_KTREE [RFC 9227] Not allowed 36-1023 Unassigned 1024-65535 Reserved for Private Use [RFC 7296] [RFC 7296] Transform Type 2 - Pseudorandom Function Transform IDs Registration Procedure(s) Expert Review Expert(s) Tero Kivinen, Valery Smyslov Reference [RFC 7296][RFC 9395] Note To find out requirement levels for PRFs for IKEv2, see [RFC 8247]. Available Formats [IMG] CSV Number Name Status Reference 0 Reserved [RFC 7296] 1 PRF_HMAC_MD5 DEPRECATED [RFC 8247] [RFC 2104] 2 PRF_HMAC_SHA1 [RFC 2104] 3 PRF_HMAC_TIGER DEPRECATED [RFC 9395] [UNSPECIFIED] 4 PRF_AES128_XCBC [RFC 4434] 5 PRF_HMAC_SHA2_256 [RFC 4868] 6 PRF_HMAC_SHA2_384 [RFC 4868] 7 PRF_HMAC_SHA2_512 [RFC 4868] 8 PRF_AES128_CMAC [RFC 4615] 9 PRF_HMAC_STREEBOG_512 [RFC 9385] 10-1023 Unassigned 1024-65535 Reserved for Private Use [RFC 7296] Transform Type 3 - Integrity Algorithm Transform IDs Registration Procedure(s) Expert Review Expert(s) Tero Kivinen, Valery Smyslov Reference [RFC 7296][RFC 9395] Note To find out requirement levels for encryption algorithms for ESP/AH, see [RFC 8221]. For IKEv2, see [RFC 8247]. Available Formats [IMG] CSV Number Name Status Reference 0 NONE [RFC 7296] 1 AUTH_HMAC_MD5_96 DEPRECATED [RFC 8247] [RFC 2403]; [RFC 7296] 2 AUTH_HMAC_SHA1_96 [RFC 2404]; [RFC 7296] 3 AUTH_DES_MAC DEPRECATED [RFC 8247] [UNSPECIFIED] 4 AUTH_KPDK_MD5 DEPRECATED [RFC 8247] [UNSPECIFIED] 5 AUTH_AES_XCBC_96 [RFC 3566]; [RFC 7296] 6 AUTH_HMAC_MD5_128 DEPRECATED [RFC 9395] [RFC 4595] 7 AUTH_HMAC_SHA1_160 DEPRECATED [RFC 9395] [RFC 4595] 8 AUTH_AES_CMAC_96 [RFC 4494] 9 AUTH_AES_128_GMAC [RFC 4543] 10 AUTH_AES_192_GMAC [RFC 4543] 11 AUTH_AES_256_GMAC [RFC 4543] 12 AUTH_HMAC_SHA2_256_128 [RFC 4868] 13 AUTH_HMAC_SHA2_384_192 [RFC 4868] 14 AUTH_HMAC_SHA2_512_256 [RFC 4868] 15-1023 Unassigned 1024-65535 Reserved for Private Use [RFC 7296] Transform Type 4 - Key Exchange Method Transform IDs Registration Procedure(s) Expert Review Expert(s) Tero Kivinen, Valery Smyslov Reference [RFC 7296][RFC 6989][RFC 9370][RFC 9395] Note This registry was originally named "Transform Type 4 - Diffie-Hellman Group Transform IDs" and was referenced using that name in a number of RFCs published prior to [RFC 9370], which gave it its current title. Note This registry is used by the "Key Exchange Method (KE)" transform type and by all "Additional Key Exchange (ADDKE)" transform types. Note To find out requirement levels for key exchange methods for IKEv2, see [RFC 8247]. Note The instructions for the designated experts are described in [RFC 9370]. While adding new Key Exchange (KE) methods, the following considerations must be applied. A key exchange method must take exactly one round trip (one IKEv2 exchange) and at the end of this exchange, both peers must be able to derive the shared secret. In addition, any public value that peersexchanged during a key exchange method must fit into asingle IKEv2 payload. If these restrictions are not metfor a key exchange method, then there must be documentationon how this key exchange method is used in IKEv2. Available Formats [IMG] CSV Number Name Status Recipient Tests Reference 0 NONE [RFC 7296] 1 768-bit MODP Group DEPRECATED [RFC [RFC 6989, Section 2.1] [RFC 7296] 8247] 2 1024-bit MODP Group [RFC 6989, Section 2.1] [RFC 7296] 3-4 Reserved [RFC 7296] 5 1536-bit MODP Group [RFC 6989, Section 2.1] [RFC 3526] 6-13 Unassigned [RFC 7296] 14 2048-bit MODP Group [RFC 6989, Section 2.1] [RFC 3526] 15 3072-bit MODP Group [RFC 6989, Section 2.1] [RFC 3526] 16 4096-bit MODP Group [RFC 6989, Section 2.1] [RFC 3526] 17 6144-bit MODP Group [RFC 6989, Section 2.1] [RFC 3526] 18 8192-bit MODP Group [RFC 6989, Section 2.1] [RFC 3526] 19 256-bit random ECP group [RFC 6989, Section 2.3] [RFC 5903] 20 384-bit random ECP group [RFC 6989, Section 2.3] [RFC 5903] 21 521-bit random ECP group [RFC 6989, Section 2.3] [RFC 5903] 22 1024-bit MODP Group with 160-bit Prime DEPRECATED [RFC [RFC 6989, Section 2.2] [RFC 5114] Order Subgroup 8247] 23 2048-bit MODP Group with 224-bit Prime [RFC 6989, Section 2.2] [RFC 5114] Order Subgroup 24 2048-bit MODP Group with 256-bit Prime [RFC 6989, Section 2.2] [RFC 5114] Order Subgroup 25 192-bit Random ECP Group [RFC 6989, Section 2.3] [RFC 5114] 26 224-bit Random ECP Group [RFC 6989, Section 2.3] [RFC 5114] 27 brainpoolP224r1 [RFC 6989, Section 2.3] [RFC 6954] 28 brainpoolP256r1 [RFC 6989, Section 2.3] [RFC 6954] 29 brainpoolP384r1 [RFC 6989, Section 2.3] [RFC 6954] 30 brainpoolP512r1 [RFC 6989, Section 2.3] [RFC 6954] 31 Curve25519 [RFC 8031, Section 3.2] [RFC 8031] 32 Curve448 [RFC 8031, Section 3.2] [RFC 8031] 33 GOST3410_2012_256 [RFC 9385, Section 6.1] [RFC 9385] 34 GOST3410_2012_512 [RFC 9385, Section 6.1] [RFC 9385] 35 ml-kem-512 [RFC-ietf-ipsecme-ikev2-mlkem-09, Section 2.2] [RFC-ietf-ipsecme-ikev2-mlkem-09] 36 ml-kem-768 [RFC-ietf-ipsecme-ikev2-mlkem-09, Section 2.2] [RFC-ietf-ipsecme-ikev2-mlkem-09] 37 ml-kem-1024 [RFC-ietf-ipsecme-ikev2-mlkem-09, Section 2.2] [RFC-ietf-ipsecme-ikev2-mlkem-09] 38-1023 Unassigned 1024-65535 Reserved for Private Use [RFC 7296] Transform Type 5 - Sequence Numbers Transform IDs Registration Procedure(s) Expert Review Expert(s) Tero Kivinen, Valery Smyslov Reference [RFC 7296][RFC 9827] Note This registry was originally named "Transform Type 5 - Extended Sequence Numbers Transform IDs" and was referenced using that name in a number of RFCs published prior to [RFC 9827], which gave it the current title. Note The "32-bit Sequential Numbers" Transform ID was originally named "No Extended Sequence Numbers" and was referenced by that name in a number of RFCs published prior to [RFC 9827], which gave it the current title. Note The "Partially Transmitted 64-bit Sequential Numbers" Transform ID was originally named "Extended Sequence Numbers" and was referenced by that name in a number of RFCs published prior to [RFC 9827], which gave it the current title. Note Numbers in the range 2-65535 were originally marked as "Reserved" and were reclassified as "Unassigned" and "Reserved for Private Use" by [RFC 9827]. Available Formats [IMG] CSV Number Name Reference 0 32-bit Sequential Numbers [RFC 7296]; [RFC 9827] 1 Partially Transmitted 64-bit Sequential Numbers [RFC 7296]; [RFC 9827] 2 32-bit Unspecified Numbers [RFC 9838] 3-1023 Unassigned 1024-65535 Reserved for Private Use [RFC 9827] Transform Type 13 - Key Wrap Algorithm Transform IDs Registration Procedure(s) Expert Review Expert(s) Tero Kivinen, Valery Smyslov Reference [RFC 9838] Available Formats [IMG] CSV Value Key Wrap Algorithm Reference 0 Reserved [RFC 9838] 1 KW_5649_128 [RFC 9838] 2 KW_5649_192 [RFC 9838] 3 KW_5649_256 [RFC 9838] 4 KW_ARX [RFC 9838] 5-1023 Unassigned 1024-65535 Reserved for Private Use [RFC 9838] Transform Type 14 - Group Controller Authentication Method Transform IDs Registration Procedure(s) Expert Review Expert(s) Tero Kivinen, Valery Smyslov Reference [RFC 9838] Available Formats [IMG] CSV Value Group Controller Authentication Method Reference 0 Reserved [RFC 9838] 1 Implicit [RFC 9838] 2 Digital Signature [RFC 9838] 3-1023 Unassigned 1024-65535 Reserved for Private Use [RFC 9838] IKEv2 Identification Payload ID Types Registration Procedure(s) Expert Review Expert(s) Tero Kivinen, Valery Smyslov Reference [RFC 7296] Available Formats [IMG] CSV Value ID Type Reference 0 Reserved [RFC 7296] 1 ID_IPV4_ADDR [RFC 7296] 2 ID_FQDN [RFC 7296] 3 ID_RFC822_ADDR [RFC 7296] 4 Unassigned [RFC 7296] 5 ID_IPV6_ADDR [RFC 7296] 6-8 Unassigned [RFC 7296] 9 ID_DER_ASN1_DN [RFC 7296] 10 ID_DER_ASN1_GN [RFC 7296] 11 ID_KEY_ID [RFC 7296] 12 ID_FC_NAME [RFC 4595] 13 ID_NULL [RFC 7619] 14-200 Unassigned 201-255 Reserved for Private Use [RFC 7296] IKEv2 Certificate Encodings Registration Procedure(s) Expert Review Expert(s) Tero Kivinen, Valery Smyslov Reference [RFC 7296] Available Formats [IMG] CSV Value Certificate Encoding Reference 0 Reserved [RFC 7296] 1 PKCS #7 wrapped X.509 certificate [UNSPECIFIED] 2 PGP Certificate [UNSPECIFIED] 3 DNS Signed Key [UNSPECIFIED] 4 X.509 Certificate - Signature [RFC 7296] 5 Reserved [RFC 7296] 6 Kerberos Token [UNSPECIFIED] 7 Certificate Revocation List (CRL) [RFC 7296] 8 Authority Revocation List (ARL) [UNSPECIFIED] 9 SPKI Certificate [UNSPECIFIED] 10 X.509 Certificate - Attribute [UNSPECIFIED] 11 Raw RSA Key (DEPRECATED) [RFC 7296] 12 Hash and URL of X.509 certificate [RFC 7296] 13 Hash and URL of X.509 bundle [RFC 7296] 14 OCSP Content [RFC 4806] 15 Raw Public Key [RFC 7670] 16-200 Unassigned 201-255 Reserved for Private Use [RFC 7296] IKEv2 Authentication Method Registration Procedure(s) Expert Review Expert(s) Tero Kivinen, Valery Smyslov Reference [RFC 7296] Note To find out requirement levels for IKEv2 authentication methods, see [RFC 8247]. Available Formats [IMG] CSV Value Authentication Method Reference 0 Reserved [RFC 7296] 1 RSA Digital Signature [RFC 7296] 2 Shared Key Message Integrity Code [RFC 7296] 3 DSS Digital Signature [RFC 7296] 4-8 Unassigned [RFC 7296] 9 ECDSA with SHA-256 on the P-256 curve [RFC 4754] 10 ECDSA with SHA-384 on the P-384 curve [RFC 4754] 11 ECDSA with SHA-512 on the P-521 curve [RFC 4754] 12 Generic Secure Password Authentication Method [RFC 6467] 13 NULL Authentication [RFC 7619] 14 Digital Signature [RFC 7427] 15-200 Unassigned 201-255 Reserved for Private Use [RFC 7296] IKEv2 Notify Message Error Types Expert(s) Tero Kivinen, Valery Smyslov Reference [RFC 7296] Available Formats [IMG] CSV Range Registration Procedures 0-8191 Expert Review 8192-16383 Private Use Value Notify Message Error Type Reference 0 Reserved [RFC 7296] 1 UNSUPPORTED_CRITICAL_PAYLOAD [RFC 7296] 2-3 Reserved [RFC 7296] 4 INVALID_IKE_SPI [RFC 7296] 5 INVALID_MAJOR_VERSION [RFC 7296] 6 Reserved [RFC 7296] 7 INVALID_SYNTAX [RFC 7296] 8 Reserved [RFC 7296] 9 INVALID_MESSAGE_ID [RFC 7296] 10 Reserved [RFC 7296] 11 INVALID_SPI [RFC 7296] 12-13 Reserved [RFC 7296] 14 NO_PROPOSAL_CHOSEN [RFC 7296] 15-16 Reserved [RFC 7296] 17 INVALID_KE_PAYLOAD [RFC 7296] 18-23 Reserved [RFC 7296] 24 AUTHENTICATION_FAILED [RFC 7296] 25-33 RESERVED [RFC 7296] 34 SINGLE_PAIR_REQUIRED [RFC 7296] 35 NO_ADDITIONAL_SAS [RFC 7296] 36 INTERNAL_ADDRESS_FAILURE [RFC 7296] 37 FAILED_CP_REQUIRED [RFC 7296] 38 TS_UNACCEPTABLE [RFC 7296] 39 INVALID_SELECTORS [RFC 7296] 40 UNACCEPTABLE_ADDRESSES [RFC 4555] 41 UNEXPECTED_NAT_DETECTED [RFC 4555] 42 USE_ASSIGNED_HoA [RFC 5026] 43 TEMPORARY_FAILURE [RFC 7296] 44 CHILD_SA_NOT_FOUND [RFC 7296] 45 INVALID_GROUP_ID [RFC 9838] 46 AUTHORIZATION_FAILED [RFC 9838] 47 STATE_NOT_FOUND [RFC 9370] 48 TS_MAX_QUEUE [RFC 9611] 49 REGISTRATION_FAILED [RFC 9838] 50-8191 Unassigned 8192-16383 Reserved for Private Use [RFC 7296] IKEv2 Notify Message Status Types Expert(s) Tero Kivinen, Valery Smyslov Reference [RFC 7296] Available Formats [IMG] CSV Range Registration Procedures 16384-40959 Expert Review 40960-65535 Private Use Value Notify Message Status Type Reference 16384 INITIAL_CONTACT [RFC 7296] 16385 SET_WINDOW_SIZE [RFC 7296] 16386 ADDITIONAL_TS_POSSIBLE [RFC 7296] 16387 IPCOMP_SUPPORTED [RFC 7296] 16388 NAT_DETECTION_SOURCE_IP [RFC 7296] 16389 NAT_DETECTION_DESTINATION_IP [RFC 7296] 16390 COOKIE [RFC 7296] 16391 USE_TRANSPORT_MODE [RFC 7296] 16392 HTTP_CERT_LOOKUP_SUPPORTED [RFC 7296] 16393 REKEY_SA [RFC 7296] 16394 ESP_TFC_PADDING_NOT_SUPPORTED [RFC 7296] 16395 NON_FIRST_FRAGMENTS_ALSO [RFC 7296] 16396 MOBIKE_SUPPORTED [RFC 4555] 16397 ADDITIONAL_IP4_ADDRESS [RFC 4555] 16398 ADDITIONAL_IP6_ADDRESS [RFC 4555] 16399 NO_ADDITIONAL_ADDRESSES [RFC 4555] 16400 UPDATE_SA_ADDRESSES [RFC 4555] 16401 COOKIE2 [RFC 4555] 16402 NO_NATS_ALLOWED [RFC 4555] 16403 AUTH_LIFETIME [RFC 4478] 16404 MULTIPLE_AUTH_SUPPORTED [RFC 4739] 16405 ANOTHER_AUTH_FOLLOWS [RFC 4739] 16406 REDIRECT_SUPPORTED [RFC 5685] 16407 REDIRECT [RFC 5685] 16408 REDIRECTED_FROM [RFC 5685] 16409 TICKET_LT_OPAQUE [RFC 5723] 16410 TICKET_REQUEST [RFC 5723] 16411 TICKET_ACK [RFC 5723] 16412 TICKET_NACK [RFC 5723] 16413 TICKET_OPAQUE [RFC 5723] 16414 LINK_ID [RFC 5739] 16415 USE_WESP_MODE [RFC 5840] 16416 ROHC_SUPPORTED [RFC 5857] 16417 EAP_ONLY_AUTHENTICATION [RFC 5998] 16418 CHILDLESS_IKEV2_SUPPORTED [RFC 6023] 16419 QUICK_CRASH_DETECTION [RFC 6290] 16420 IKEV2_MESSAGE_ID_SYNC_SUPPORTED [RFC 6311] 16421 IPSEC_REPLAY_COUNTER_SYNC_SUPPORTED [RFC 6311] 16422 IKEV2_MESSAGE_ID_SYNC [RFC 6311] 16423 IPSEC_REPLAY_COUNTER_SYNC [RFC 6311] 16424 SECURE_PASSWORD_METHODS [RFC 6467] 16425 PSK_PERSIST [RFC 6631] 16426 PSK_CONFIRM [RFC 6631] 16427 ERX_SUPPORTED [RFC 6867] 16428 IFOM_CAPABILITY [Dongwook_Kim]; [3GPP TS 24.303 v10.6.0 annex B.2] 16429 GROUP_SENDER [RFC 9838] 16430 IKEV2_FRAGMENTATION_SUPPORTED [RFC 7383] 16431 SIGNATURE_HASH_ALGORITHMS [RFC 7427] 16432 CLONE_IKE_SA_SUPPORTED [RFC 7791] 16433 CLONE_IKE_SA [RFC 7791] 16434 PUZZLE [RFC 8019] 16435 USE_PPK [RFC 8784] 16436 PPK_IDENTITY [RFC 8784] 16437 NO_PPK_AUTH [RFC 8784] 16438 INTERMEDIATE_EXCHANGE_SUPPORTED [RFC 9242] 16439 IP4_ALLOWED [RFC 8983] 16440 IP6_ALLOWED [RFC 8983] 16441 ADDITIONAL_KEY_EXCHANGE [RFC 9370] 16442 USE_AGGFRAG [RFC 9347] 16443 SUPPORTED_AUTH_METHODS [RFC 9593] 16444 SA_RESOURCE_INFO [RFC 9611] 16445 USE_PPK_INT [RFC 9867] 16446 PPK_IDENTITY_KEY [RFC 9867] 16447 IKE_SA_INIT_FULL_TRANSCRIPT_AUTH [RFC-ietf-ipsecme-ikev2-downgrade-prevention-08] 16448-40959 Unassigned 40960-65535 Reserved for Private Use [RFC 7296] IKEv2 Notification IPCOMP Transform IDs (Value 16387) Registration Procedure(s) Expert Review Expert(s) Tero Kivinen, Valery Smyslov Reference [RFC 7296] Note To find out requirement levels for IPCOMP methods, see [RFC 8221]. Available Formats [IMG] CSV Value Compression Type Reference 0 Reserved [RFC 7296] 1 IPCOMP_OUI [UNSPECIFIED] 2 IPCOMP_DEFLATE [RFC 2394] 3 IPCOMP_LZS [RFC 2395] 4 IPCOMP_LZJH [RFC 3051] 5-240 Unassigned 241-255 Reserved for Private Use [RFC 7296] IKEv2 Security Protocol Identifiers Registration Procedure(s) Expert Review Expert(s) Tero Kivinen, Valery Smyslov Reference [RFC 7296] Available Formats [IMG] CSV Protocol ID Protocol Reference 0 Reserved [RFC 7296] 1 IKE [RFC 7296] 2 AH [RFC 7296] 3 ESP [RFC 7296] 4 FC_ESP_HEADER [RFC 4595] 5 FC_CT_AUTHENTICATION [RFC 4595] 6 GIKE_UPDATE [RFC 9838] 7-200 Unassigned 201-255 Reserved for Private Use [RFC 7296] IKEv2 Traffic Selector Types Registration Procedure(s) Expert Review Expert(s) Tero Kivinen, Valery Smyslov Reference [RFC 7296] Available Formats [IMG] CSV Value TS Type Reference 0-6 Reserved [RFC 7296] 7 TS_IPV4_ADDR_RANGE [RFC 7296] 8 TS_IPV6_ADDR_RANGE [RFC 7296] 9 TS_FC_ADDR_RANGE [RFC 4595] 10 TS_SECLABEL [RFC 9478] 11-240 Unassigned 241-255 Reserved for Private Use [RFC 7296] IKEv2 Configuration Payload CFG Types Registration Procedure(s) Expert Review Expert(s) Tero Kivinen, Valery Smyslov Reference [RFC 7296] Available Formats [IMG] CSV Value CFG Type Reference 0 Reserved [RFC 7296] 1 CFG_REQUEST [RFC 7296] 2 CFG_REPLY [RFC 7296] 3 CFG_SET [RFC 7296] 4 CFG_ACK [RFC 7296] 5-127 Unassigned 128-255 Reserved for Private Use [RFC 7296] IKEv2 Configuration Payload Attribute Types Registration Procedure(s) Expert Review Expert(s) Tero Kivinen, Valery Smyslov Reference [RFC 7296] Note Attribute Types with an "*" may be multi-valued on return only if multiple values were requested. Available Formats [IMG] CSV Value Attribute Type Multi-Valued Length Reference 0 Reserved [RFC 7296] 1 INTERNAL_IP4_ADDRESS YES* 0 or 4 octets [RFC 7296] 2 INTERNAL_IP4_NETMASK NO 0 or 4 octets [RFC 7296] 3 INTERNAL_IP4_DNS YES 0 or 4 octets [RFC 7296] 4 INTERNAL_IP4_NBNS YES 0 or 4 octets [RFC 7296] 5 Reserved [RFC 7296] 6 INTERNAL_IP4_DHCP YES 0 or 4 octets [RFC 7296] 7 APPLICATION_VERSION NO 0 or more [RFC 7296] 8 INTERNAL_IP6_ADDRESS YES* 0 or 17 octets [RFC 7296] 9 Reserved [RFC 7296] 10 INTERNAL_IP6_DNS YES 0 or 16 octets [RFC 7296] 11 Reserved [RFC 7296] 12 INTERNAL_IP6_DHCP YES 0 or 16 octets [RFC 7296] 13 INTERNAL_IP4_SUBNET YES 0 or 8 octets [RFC 7296] 14 SUPPORTED_ATTRIBUTES NO Multiple of 2 [RFC 7296] 15 INTERNAL_IP6_SUBNET YES 17 octets [RFC 7296] 16 MIP6_HOME_PREFIX YES 0 or 21 octets [RFC 5026] 17 INTERNAL_IP6_LINK NO 8 or more [RFC 5739] 18 INTERNAL_IP6_PREFIX YES 17 octets [RFC 5739] 19 HOME_AGENT_ADDRESS NO 16 or 20 [http://www.3gpp.org/ftp/Specs/html-info/24302.htm]; [Dongwook_Kim] 20 P_CSCF_IP4_ADDRESS YES 0 or 4 octets [RFC 7651] 21 P_CSCF_IP6_ADDRESS YES 0 or 16 octets [RFC 7651] 22 FTT_KAT NO 2 octets [TS 24.302 12.6.0] 23 EXTERNAL_SOURCE_IP4_NAT_INFO NO 0 or 6 [TS 29.139]; [Kimmo_Kymalainen] 24 TIMEOUT_PERIOD_FOR_LIVENESS_CHECK NO 0 or 4 octets [TS 24.302 13.4.0]; [Dongwook_Kim] 25 INTERNAL_DNS_DOMAIN YES 0 or more [RFC 8598] 26 INTERNAL_DNSSEC_TA YES 0 or more [RFC 8598] 27 ENCDNS_IP4 YES 0 or more [RFC 9464] 28 ENCDNS_IP6 YES 0 or more [RFC 9464] 29 ENCDNS_DIGEST_INFO YES 0 or more [RFC 9464] 30-16383 Unassigned 16384-32767 Reserved for Private Use [RFC 7296] IKEv2 Gateway Identity Types Registration Procedure(s) Expert Review Expert(s) Tero Kivinen, Valery Smyslov Reference [RFC 5685] Available Formats [IMG] CSV Value Description Reference 0 Reserved [RFC 5685] 1 IPv4 address of the VPN gateway [RFC 5685] 2 IPv6 address of the VPN gateway [RFC 5685] 3 FQDN of the VPN gateway [RFC 5685] 4-240 Unassigned 241-255 Reserved for Private Use [RFC 5685] ROHC Attribute Types Registration Procedure(s) Expert Review Expert(s) Tero Kivinen, Valery Smyslov Reference [RFC 5857] Available Formats [IMG] CSV Value ROHC Attribute Type Format Reference 0 Reserved [RFC 5857] 1 Maximum Context Identifier (MAX_CID) TV [RFC 5857] 2 ROHC Profile (ROHC_PROFILE) TV [RFC 5857] 3 ROHC Integrity Algorithm (ROHC_INTEG) TV [RFC 5857] 4 ROHC ICV Length in bytes (ROHC_ICV_LEN) TV [RFC 5857] 5 Maximum Reconstructed Reception Unit (MRRU) TV [RFC 5857] 6-16383 Unassigned 16384-32767 Reserved for Private Use [RFC 5857] IKEv2 Secure Password Methods Registration Procedure(s) Expert Review Expert(s) Tero Kivinen, Valery Smyslov Reference [RFC 6467] Available Formats [IMG] CSV Value Description Reference 0 Reserved [RFC 6467] 1 PACE [RFC 6631] 2 AugPAKE [RFC 6628] 3 Secure PSK Authentication [RFC 6617] 4-1023 Unassigned 1024-65535 Reserved for Private Use [RFC 6467] IKEv2 Hash Algorithms Registration Procedure(s) Expert Review Expert(s) Tero Kivinen, Valery Smyslov Reference [RFC 7427] Note To find out requirement levels for IKEv2 hash algorithms, see [RFC 8247]. Available Formats [IMG] CSV Value Hash Algorithm Reference 0 Reserved [RFC 7427] 1 SHA1 [RFC 7427] 2 SHA2-256 [RFC 7427] 3 SHA2-384 [RFC 7427] 4 SHA2-512 [RFC 7427] 5 Identity [RFC 8420] 6 STREEBOG_256 [RFC 9385] 7 STREEBOG_512 [RFC 9385] 8-1023 Unassigned 1024-65535 Reserved for Private Use [RFC 7427] IKEv2 Post-quantum Preshared Key ID Types Expert(s) Tero Kivinen, Valery Smyslov Reference [RFC 8784] Available Formats [IMG] CSV Range Registration Procedures 1-127 Expert Review 128-255 Private Use Value PPK_ID Type Reference 0 Reserved [RFC 8784] 1 PPK_ID_OPAQUE [RFC 8784] 2 PPK_ID_FIXED [RFC 8784] 3-127 Unassigned 128-255 Reserved for Private Use [RFC 8784] Group SA Attributes Registration Procedure(s) Expert Review Expert(s) Tero Kivinen, Valery Smyslov Reference [RFC 9838] Available Formats [IMG] CSV Value Group SA Attributes Format Multi-Valued Used in Protocol Reference 0 Reserved [RFC 9838] 1 GSA_KEY_LIFETIME TLV NO GIKE_UPDATE, AH, ESP [RFC 9838] 2 GSA_INITIAL_MESSAGE_ID TLV NO GIKE_UPDATE [RFC 9838] 3 GSA_NEXT_SPI TLV YES GIKE_UPDATE, AH, ESP [RFC 9838] 4-16383 Unassigned 16384-32767 Reserved for Private Use [RFC 9838] Group-Wide Policy Attributes Registration Procedure(s) Expert Review Expert(s) Tero Kivinen, Valery Smyslov Reference [RFC 9838] Available Formats [IMG] CSV Value GW Policy Attributes Format Multi-Valued Reference 0 Reserved [RFC 9838] 1 GWP_ATD TV NO [RFC 9838] 2 GWP_DTD TV NO [RFC 9838] 3 GWP_SENDER_ID_BITS TV NO [RFC 9838] 4-16383 Unassigned 16384-32767 Reserved for Private Use [RFC 9838] Group Key Bag Attributes Registration Procedure(s) Expert Review Expert(s) Tero Kivinen, Valery Smyslov Reference [RFC 9838] Available Formats [IMG] CSV Value Group Key Bag Attributes Format Multi-Valued Used in Protocol Reference 0 Reserved [RFC 9838] 1 SA_KEY TLV YES GIKE_UPDATE [RFC 9838] NO AH, ESP [RFC 9838] 2-16383 Unassigned 16384-32767 Reserved for Private Use [RFC 9838] Member Key Bag Attributes Registration Procedure(s) Expert Review Expert(s) Tero Kivinen, Valery Smyslov Reference [RFC 9838] Available Formats [IMG] CSV Value Member Key Bag Attributes Format Multi-Valued Reference 0 Reserved [RFC 9838] 1 WRAP_KEY TLV YES [RFC 9838] 2 AUTH_KEY TLV NO [RFC 9838] 3 GM_SENDER_ID TLV YES [RFC 9838] 4-16383 Unassigned 16384-32767 Reserved for Private Use [RFC 9838] Contact Information ID Name Contact URI Last Updated [Dongwook_Kim] Dongwook Kim mailto:info&3gpp.org 2026-10-20 [Kimmo_Kymalainen] Kimmo Kymalainen mailto:kimmo.kymalainen&etsi.org 2015-12-02 [Matt_Ball] Matt Ball mailto:matt.ball&ieee.org 2007-10-11 Licensing Terms