Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About Internet Control Message Protocol version 6 (ICMPv6) Parameters Last Updated 2026-06-09 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • ICMPv6 "type" Numbers • ICMPv6 "Code" Fields • Type 0 - Reserved • Type 1 - Destination Unreachable • Type 2 - Packet Too Big • Type 3 - Time Exceeded • Type 4 - Parameter Problem • Type 128 - Echo Request • Type 129 - Echo Reply • Type 130 - Multicast Listener Query • Type 131 - Multicast Listener Report • Type 132 - Multicast Listener Done • Type 133 - Router Solicitation • Type 134 - Router Advertisement • Type 135 - Neighbor Solicitation • Type 136 - Neighbor Advertisement • Type 137 - Redirect Message • Type 138 - Router Renumbering • Type 139 - ICMP Node Information Query • Type 140 - ICMP Node Information Response • Type 141 - Inverse Neighbor Discovery • Type 142 - Inverse Neighbor Discovery • Type 144 - Home Agent Address Discovery • Type 145 - Home Agent Address Discovery • Type 146 - Mobile Prefix Solicitation • Type 147 - Mobile Prefix Advertisement • Type 157 - Duplicate Address Request Code Suffix • Type 158 - Duplicate Address Confirmation Code Suffix • Type 160 - Extended Echo Request • Type 161 - Extended Echo Reply • FMIPv6 Message Types (Value 154) • IPv6 Neighbor Discovery Option Formats • Trust Anchor option (Type 15) Name Type field • Certificate option (Type 16) Cert Type field • Option-Code for Handover Assist Information Option (Type 29) • Option-Code for Mobile Node Identifier Option (Type 30) • Qtypes • IPv6 ND Router Advertisement Flags • Address Registration Option Status Values • 6LoWPAN Capability Bits • IPv6 Neighbor Discovery Prefix Information Option Flags • Address Registration Option Flags • Address Registration Option I-Field • PvD Option Flags • Crypto-Types • P-Field Values • EDAR Message Flags ICMPv6 "type" Numbers Reference [RFC 4443][RFC 9899] Note When this registry is modified, the YANG module "iana-icmpv6-types" [YANG Parameters] must be updated as defined in [RFC 9899]. Available Formats [IMG] CSV Range Registration Procedures 0-127 (Error messages) IETF Review 128-255 (Informational messages) IETF Review Type Name Reference 0 Reserved 1 Destination Unreachable [RFC 4443] 2 Packet Too Big [RFC 4443] 3 Time Exceeded [RFC 4443] 4 Parameter Problem [RFC 4443] 5-99 Unassigned 100 Private experimentation [RFC 4443] 101 Private experimentation [RFC 4443] 102-126 Unassigned 127 Reserved for expansion of ICMPv6 error messages [RFC 4443] 128 Echo Request [RFC 4443] 129 Echo Reply [RFC 4443] 130 Multicast Listener Query [RFC 2710] 131 Multicast Listener Report [RFC 2710] 132 Multicast Listener Done [RFC 2710] 133 Router Solicitation [RFC 4861] 134 Router Advertisement [RFC 4861] 135 Neighbor Solicitation [RFC 4861] 136 Neighbor Advertisement [RFC 4861] 137 Redirect Message [RFC 4861] 138 Router Renumbering [RFC 2894] 139 ICMP Node Information Query [RFC 4620] 140 ICMP Node Information Response [RFC 4620] 141 Inverse Neighbor Discovery Solicitation Message [RFC 3122] 142 Inverse Neighbor Discovery Advertisement Message [RFC 3122] 143 Version 2 Multicast Listener Report [RFC 9777] 144 Home Agent Address Discovery Request Message [RFC 6275] 145 Home Agent Address Discovery Reply Message [RFC 6275] 146 Mobile Prefix Solicitation [RFC 6275] 147 Mobile Prefix Advertisement [RFC 6275] 148 Certification Path Solicitation Message [RFC 3971] 149 Certification Path Advertisement Message [RFC 3971] 150 ICMP messages utilized by experimental mobility protocols such as Seamoby [RFC 4065] 151 Multicast Router Advertisement [RFC 4286] 152 Multicast Router Solicitation [RFC 4286] 153 Multicast Router Termination [RFC 4286] 154 FMIPv6 Messages [RFC 5568] 155 RPL Control Message [RFC 6550] 156 ILNPv6 Locator Update Message [RFC 6743] 157 Duplicate Address Request [RFC 6775] 158 Duplicate Address Confirmation [RFC 6775] 159 MPL Control Message [RFC 7731] 160 Extended Echo Request [RFC 8335] 161 Extended Echo Reply [RFC 8335] 162-199 Unassigned 200 Private experimentation [RFC 4443] 201 Private experimentation [RFC 4443] 202-254 Unassigned 255 Reserved for expansion of ICMPv6 informational messages [RFC 4443] ICMPv6 "Code" Fields Reference [RFC 4443] Note Code field subregistries that are not explicitly documented by the specification defining the associated Type value are not individually listed here. Nevertheless, the meaning of Code field values depend upon the Type value [RFC 4443, Section 2.1]. Any specification wishing to define a previously unspecified Code subregistry for a given Type should note the procedures in [RFC 4443, Section 6.1]. Type 0 - Reserved Code No registrations at this time. Type 1 - Destination Unreachable Registration Procedure(s) Standards Action or IESG Approval Reference [RFC 4443] Available Formats [IMG] CSV Code Name Reference 0 no route to destination 1 communication with destination administratively prohibited 2 beyond scope of source address [RFC 4443] 3 address unreachable 4 port unreachable 5 source address failed ingress/egress policy [RFC 4443] 6 reject route to destination [RFC 4443] 7 Error in Source Routing Header [RFC 6550]; [RFC 6554] 8 Headers too long [RFC 8883] 9 Error in P-Route [RFC 9914] Type 2 - Packet Too Big Registration Procedure(s) Standards Action or IESG Approval Reference [RFC 4443] Available Formats [IMG] CSV Code 0 Type 3 - Time Exceeded Registration Procedure(s) Standards Action or IESG Approval Reference [RFC 4443] Available Formats [IMG] CSV Code Name 0 hop limit exceeded in transit 1 fragment reassembly time exceeded Type 4 - Parameter Problem Registration Procedure(s) Standards Action or IESG Approval Reference [RFC 4443] Available Formats [IMG] CSV Code Name Reference 0 erroneous header field encountered 1 unrecognized Next Header type encountered 2 unrecognized IPv6 option encountered 3 IPv6 First Fragment has incomplete IPv6 Header Chain [RFC 7112] 4 SR Upper-layer Header Error [RFC 8754] 5 Unrecognized Next Header type encountered by intermediate node [RFC 8883] 6 Extension header too big [RFC 8883] 7 Extension header chain too long [RFC 8883] 8 Too many extension headers [RFC 8883] 9 Too many options in extension header [RFC 8883] 10 Option too big [RFC 8883] Type 128 - Echo Request Registration Procedure(s) Standards Action or IESG Approval Reference [RFC 4443] Available Formats [IMG] CSV Code 0 Type 129 - Echo Reply Registration Procedure(s) Standards Action or IESG Approval Reference [RFC 4443] Available Formats [IMG] CSV Code 0 Type 130 - Multicast Listener Query Registration Procedure(s) Standards Action or IESG Approval Reference [RFC 2710] Available Formats [IMG] CSV Code 0 Type 131 - Multicast Listener Report Registration Procedure(s) Standards Action or IESG Approval Reference [RFC 2710] Available Formats [IMG] CSV Code 0 Type 132 - Multicast Listener Done Registration Procedure(s) Standards Action or IESG Approval Reference [RFC 2710] Available Formats [IMG] CSV Code 0 Type 133 - Router Solicitation Registration Procedure(s) Standards Action or IESG Approval Reference [RFC 4861] Available Formats [IMG] CSV Code 0 Type 134 - Router Advertisement Registration Procedure(s) Standards Action or IESG Approval Reference [RFC 4861] Available Formats [IMG] CSV Code 0 Type 135 - Neighbor Solicitation Registration Procedure(s) Standards Action or IESG Approval Reference [RFC 4861] Available Formats [IMG] CSV Code 0 Type 136 - Neighbor Advertisement Registration Procedure(s) Standards Action or IESG Approval Reference [RFC 4861] Available Formats [IMG] CSV Code 0 Type 137 - Redirect Message Registration Procedure(s) Standards Action or IESG Approval Reference [RFC 4861] Available Formats [IMG] CSV Code 0 Type 138 - Router Renumbering Registration Procedure(s) IETF Review Reference [RFC 2894] Available Formats [IMG] CSV Code Name 0 Router Renumbering Command 1 Router Renumbering Result 255 Sequence Number Reset Type 139 - ICMP Node Information Query Registration Procedure(s) Specification Required Expert(s) Unassigned Reference [RFC 4620] Available Formats [IMG] CSV Code Name Reference 0 The Data field contains an IPv6 address which is the Subject of this Query. [RFC 4620] 1 The Data field contains a name which is the Subject of this Query, or is empty, as in the case of a NOOP. [RFC 4620] 2 The Data field contains an IPv4 address which is the Subject of this Query. [RFC 4620] Type 140 - ICMP Node Information Response Registration Procedure(s) Specification Required Expert(s) Unassigned Reference [RFC 4620] Available Formats [IMG] CSV Code Name Reference 0 A successful reply. The Reply Data field may or may not be empty. [RFC 4620] 1 The Responder refuses to supply the answer. The Reply Data field will be empty. [RFC 4620] 2 The Qtype of the Query is unknown to the Responder. The Reply Data field will be empty. [RFC 4620] Type 141 - Inverse Neighbor Discovery Registration Procedure(s) Standards Action Reference [RFC 3122] Available Formats [IMG] CSV Code 0 Type 142 - Inverse Neighbor Discovery Registration Procedure(s) Standards Action Reference [RFC 3122] Available Formats [IMG] CSV Code 0 Type 144 - Home Agent Address Discovery Registration Procedure(s) IESG Approval Reference [RFC 3775] Available Formats [IMG] CSV Code 0 Type 145 - Home Agent Address Discovery Registration Procedure(s) IESG Approval Reference [RFC 3775] Available Formats [IMG] CSV Code 0 Type 146 - Mobile Prefix Solicitation Registration Procedure(s) IESG Approval Reference [RFC 3775] Available Formats [IMG] CSV Code 0 Type 147 - Mobile Prefix Advertisement Registration Procedure(s) IESG Approval Reference [RFC 3775] Available Formats [IMG] CSV Code 0 Type 157 - Duplicate Address Request Code Suffix Registration Procedure(s) IETF Review or IESG Approval Reference [RFC 8505] Available Formats [IMG] CSV Code Suffix Meaning Reference 0 DAR message [RFC 6775] 1 EDAR message with 64-bit ROVR field [RFC 8505] 2 EDAR message with 128-bit ROVR field [RFC 8505] 3 EDAR message with 192-bit ROVR field [RFC 8505] 4 EDAR message with 256-bit ROVR field [RFC 8505] 5-15 Unassigned Type 158 - Duplicate Address Confirmation Code Suffix Registration Procedure(s) IETF Review or IESG Approval Reference [RFC 8505] Available Formats [IMG] CSV Code Suffix Meaning Reference 0 DAC message [RFC 6775] 1 EDAC message with 64-bit ROVR field [RFC 8505] 2 EDAC message with 128-bit ROVR field [RFC 8505] 3 EDAC message with 192-bit ROVR field [RFC 8505] 4 EDAC message with 256-bit ROVR field [RFC 8505] 5-15 Unassigned Type 160 - Extended Echo Request Registration Procedure(s) First Come First Served Reference [RFC 8335] Available Formats [IMG] CSV Code Name Reference 0 No Error [RFC 8335] 1-255 Unassigned Type 161 - Extended Echo Reply Registration Procedure(s) First Come First Served Reference [RFC 8335] Available Formats [IMG] CSV Code Name Reference 0 No Error [RFC 8335] 1 Malformed Query [RFC 8335] 2 No Such Interface [RFC 8335] 3 No Such Table Entry [RFC 8335] 4 Multiple Interfaces Satisfy Query [RFC 8335] 5-255 Unassigned FMIPv6 Message Types (Value 154) Registration Procedure(s) RFC Required Reference [RFC 5568] Available Formats [IMG] CSV Subtype Description Reference 0 Reserved [RFC 5568] 1 Reserved [RFC 5568] 2 RtSolPr [RFC 5568] 3 PrRtAdv [RFC 5568] 4 HI - Deprecated (Unavailable for Assignment) [RFC 5568] 5 HAck - Deprecated (Unavailable for Assignment) [RFC 5568] 6-255 Unassigned IPv6 Neighbor Discovery Option Formats Registration Procedure(s) RFC Required Reference [RFC 4861] Note IETF working groups with working group consensus and area director approval can request reclaimable Neighbor Discovery option type assignments from IANA. See [Section 13 of RFC 4861]. Available Formats [IMG] CSV Type Description Reference 1 Source Link-layer Address [RFC 4861] 2 Target Link-layer Address [RFC 4861] 3 Prefix Information [RFC 4861] 4 Redirected Header [RFC 4861] 5 MTU [RFC 4861] 6 NBMA Shortcut Limit Option [RFC 2491] 7 Advertisement Interval Option [RFC 6275] 8 Home Agent Information Option [RFC 6275] 9 Source Address List [RFC 3122] 10 Target Address List [RFC 3122] 11 CGA option [RFC 3971] 12 RSA Signature option [RFC 3971] 13 Timestamp option [RFC 3971] 14 Nonce option [RFC 3971] 15 Trust Anchor option [RFC 3971] 16 Certificate option [RFC 3971] 17 IP Address/Prefix Option [RFC 5568] 18 New Router Prefix Information Option [RFC 4068] 19 Link-layer Address Option [RFC 5568] 20 Neighbor Advertisement Acknowledgment Option [RFC 5568] 21 PvD ID Router Advertisement Option [RFC 8801] 22 Unassigned 23 MAP Option [RFC 4140] 24 Route Information Option [RFC 4191] 25 Recursive DNS Server Option [RFC 5006]; [RFC 8106] 26 RA Flags Extension Option [RFC 5175] 27 Handover Key Request Option [RFC 5269] 28 Handover Key Reply Option [RFC 5269] 29 Handover Assist Information Option [RFC 5271] 30 Mobile Node Identifier Option [RFC 5271] 31 DNS Search List Option [RFC 8106] 32 Proxy Signature (PS) [RFC 6496] 33 Address Registration Option [RFC 6775] 34 6LoWPAN Context Option [RFC 6775] 35 Authoritative Border Router Option [RFC 6775] 36 6LoWPAN Capability Indication Option (6CIO) [RFC 7400] 37 DHCP Captive-Portal [RFC 8910] 38 PREF64 option [RFC 8781] 39 Crypto-ID Parameters Option (CIPO) [RFC 8928] 40 NDP Signature Option (NDPSO) [RFC 8928] 41 Resource Directory Address Option [RFC 9176] 42 Consistent Uptime Option [RFC 9685] 43-137 Unassigned 138 CARD Request option [RFC 4065] 139 CARD Reply option [RFC 4065] 140-143 Unassigned 144 Encrypted DNS Option [RFC 9463] 145-252 Unassigned 253 RFC3692-style Experiment 1 [1] [RFC 4727] 254 RFC3692-style Experiment 2 [1] [RFC 4727] Trust Anchor option (Type 15) Name Type field Registration Procedure(s) Standards Action or IESG Approval Reference [RFC 3971][RFC 6495] Available Formats [IMG] CSV Value Description Reference 0 Reserved [RFC 6495] 1 DER Encoded X.501 Name [RFC 3971] 2 FQDN [RFC 3971] 3 SHA-1 Subject Key Identifier (SKI) [RFC 6495] 4 SHA-224 Subject Key Identifier (SKI) [RFC 6495] 5 SHA-256 Subject Key Identifier (SKI) [RFC 6495] 6 SHA-384 Subject Key Identifier (SKI) [RFC 6495] 7 SHA-512 Subject Key Identifier (SKI) [RFC 6495] 8-252 Unassigned 253-254 Reserved for Experimental Use [RFC 6495] 255 Reserved [RFC 6495] Certificate option (Type 16) Cert Type field Registration Procedure(s) Standards Action Reference [RFC 3971] Available Formats [IMG] CSV Value Description Reference 0 Reserved 1 X.509v3 Certificate [RFC 3971] 2-255 Unassigned Option-Code for Handover Assist Information Option (Type 29) Registration Procedure(s) Standards Action or IESG Approval Reference [RFC 5271] Available Formats [IMG] CSV Value Description Reference 0 Reserved [RFC 5271] 1 AN ID [RFC 5271] 2 Sector ID [RFC 5271] 3-255 Unassigned Option-Code for Mobile Node Identifier Option (Type 30) Registration Procedure(s) Standards Action or IESG Approval Reference [RFC 5271] Available Formats [IMG] CSV Value Description Reference 0 Reserved [RFC 5271] 1 NAI [RFC 5271] 2 IMSI [RFC 5271] 3-255 Unassigned Qtypes Registration Procedure(s) IETF Review Reference [RFC 4620] Available Formats [IMG] CSV Value Description Reference 0 NOOP [RFC 4620] 1 Unused [RFC 4620] 2 Node Name [RFC 4620] 3 Node Addresses [RFC 4620] 4 IPv4 Addresses [RFC 4620] 5-255 Unassigned IPv6 ND Router Advertisement Flags Registration Procedure(s) Standards Action or IESG Approval Reference [RFC 5175] Available Formats [IMG] CSV RA Option Bit Description Reference 0 M - Managed Address Configuration Flag [RFC 4861] 1 O - Other Configuration Flag [RFC 4861] 2 H - Mobile IPv6 Home Agent Flag [RFC 3775] 3 Prf - Router Selection Preferences [RFC 4191] 4 Prf - Router Selection Preferences [RFC 4191] 5 P - Neighbor Discovery Proxy Flag [RFC 4389] 6 S - SNAC Router Flag [RFC-ietf-6man-snac-router-ra-flag-08] 7-53 R - Reserved; Available for assignment [RFC 5175] 54-55 Private Experimentation [RFC 5175] Address Registration Option Status Values Registration Procedure(s) Standards Action Reference [RFC 6775][RFC 9010] Available Formats [IMG] CSV Value Description Reference 0 Success [RFC 6775] 1 Duplicate Address [RFC 6775] 2 Neighbor Cache Full [RFC 6775] 3 Moved [RFC 8505] 4 Removed [RFC 8505] 5 Validation Requested [RFC 8505] 6 Duplicate Source Address [RFC 8505] 7 Invalid Source Address [RFC 8505] 8 Registered Address Topologically Incorrect [RFC 8505] 9 6LBR Registry Saturated [RFC 8505] 10 Validation Failed [RFC 8505] 11 Registration Refresh Request [RFC 9685] 12 Invalid Registration [RFC 9685] 13-63 Unassigned [RFC 9010] 6LoWPAN Capability Bits Registration Procedure(s) IETF Review or IESG Approval Reference [RFC 7400] Available Formats [IMG] CSV Bit Description Reference 0-7 Reserved for Experimental Use [RFC 7400] 8 X flag: Registration for Unicast, Multicast, and Anycast Addresses Supported [RFC 9685] 9 AP-ND Enabled (A bit) [RFC 8928] 10 EDA Support (D bit) [RFC 8505] 11 6LR capable (L bit) [RFC 8505] 12 6LBR capable (B bit) [RFC 8505] 13 Routing Registrar (P bit) [RFC 8505] 14 EARO support (E bit) [RFC 8505] 15 GHC capable bit (G bit) [RFC 7400] 16 Registration for prefixes supported (F bit) [RFC 9926] 17-47 Unassigned IPv6 Neighbor Discovery Prefix Information Option Flags Registration Procedure(s) Standards Action Reference [RFC 8425] Available Formats [IMG] CSV PIO Option Bit Description Reference 0 L - On-link Flag [RFC 4861] 1 A - Autonomous Address Configuration Flag [RFC 4861] 2 R - Router Address Flag [RFC 6275] 3 P - DHCPv6-PD Preferred Flag [RFC 9762] 4-7 Reserved Address Registration Option Flags Registration Procedure(s) IETF Review or IESG Approval Reference [RFC 8505] Available Formats [IMG] CSV Bit Number Description Reference 0 Unassigned 1 C-Flag [RFC 9927]; [RFC 8928] 2-3 P-Field (2 bits) [RFC 9685, Section 14.1] 4-5 I-Field (2 bits) [RFC 8505, Section 4.1] 6 R Flag [RFC 8505] 7 T Flag [RFC 8505] Address Registration Option I-Field Registration Procedure(s) IETF Review or IESG Approval Reference [RFC 8505] Available Formats [IMG] CSV Value Meaning Reference 0 Abstract Index for Topology Selection [RFC 8505] 1-3 Unassigned PvD Option Flags Registration Procedure(s) Standards Action Reference [RFC 8801] Available Formats [IMG] CSV Bit Name Reference 0 H-flag [RFC 8801] 1 L-flag [RFC 8801] 2 R-flag [RFC 8801] 3-11 Unassigned Crypto-Types Registration Procedure(s) Specification Required or IESG Approval Expert(s) Mohit Sethi Reference [RFC 8928] Available Formats [IMG] CSV Crypto-Type Elliptic Hash Signature Representation Conventions Public Key Size Signature Reference Value Curve Function Algorithm Size 0 NIST P-256 SHA-256 ECDSA Weierstrass, (un)compressed, MSB/msb-order, [SEC1] 33/65 bytes 64 bytes [RFC 8928] [FIPS186-4] [RFC 6234] [FIPS186-4] (compressed/uncompressed) 1 Curve25519 SHA-512 Ed25519 [RFC Edwards, compressed, LSB/lsb-order, [RFC 8032] 32 bytes (compressed) 64 bytes [RFC 8928] [RFC 7748] [RFC 6234] 8032] 2 Curve25519 SHA-256 ECDSA Weierstrass, (un)compressed, MSB/msb-order, 33/65 bytes 64 bytes [RFC 8928] [RFC 7748] [RFC 6234] [FIPS186-4] [draft-ietf-lwig-curve-representations-13] (compressed/uncompressed) 3-255 P-Field Values Registration Procedure(s) Standards Action Reference [RFC 9685] Available Formats [IMG] CSV Value Registered Address Type Indicator Reference 0 Registration for a Unicast Address [RFC 9685] 1 Registration for a Multicast Address [RFC 9685] 2 Registration for an Anycast Address [RFC 9685] 3 Registration for a Unicast Prefix [RFC 9926] EDAR Message Flags Registration Procedure(s) IETF Review or IESG Approval Reference [RFC 9685] Available Formats [IMG] CSV Bit Number Meaning Reference 0-1 P-Field (2 bits) [RFC 9685, Section 14.1] 2-7 Unassigned Footnote [1] It is only appropriate to use these values in explicitly configured experiments; they MUST NOT be shipped as defaults in implementations. See [RFC 3692] for details. Licensing Terms