Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About IPv4 Special-Purpose Address Space Created 2009-08-19 Last Updated 2025-10-09 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registry Included Below • IPv4 Special-Purpose Address Space IPv4 Special-Purpose Address Space Registration Procedure(s) IETF Review Reference [RFC 5736][RFC 6890][RFC Errata 6404][RFC 8190] Note The IETF has reserved the address block of 192.0.0.0/24 for use for special purposes relating to protocol assignments. This registry contains the current assignments made by the IETF from this address block. Address prefixes listed in the Special-Purpose Address Registry are not guaranteed routability in any particular local or global context. The IPv4 and IPv6 Special-Purpose Address Registries maintain the following information regarding each entry: * Address Block - A block of IPv4 or IPv6 addresses that has been registered for a special purpose. * Name - A descriptive name for the special-purpose address block. * RFC - The RFC through which the special-purpose address block was requested. * Allocation Date - The date upon which the special-purpose address block was allocated. * Termination Date - The date upon which the allocation is to be terminated. This field is applicable for limited-use allocations only. * Source - A boolean value indicating whether an address from the allocated special-purpose address block is valid when used as the source address of an IP datagram that transits two devices. * Destination - A boolean value indicating whether an address from the allocated special-purpose address block is valid when used as the destination address of an IP datagram that transits two devices. * Forwardable - A boolean value indicating whether a router may forward an IP datagram whose destination address is drawn from the allocated special-purpose address block between external interfaces. * Globally Reachable - A boolean value indicating whether an IP datagram whose destination address is drawn from the allocated special-purpose address block is forwardable beyond a specified administrative domain. * Reserved-by-Protocol - A boolean value indicating whether the special-purpose address block is reserved by IP, itself. This value is "TRUE" if the RFC that created the special-purpose address block requires all compliant IP implementations to behave in a special way when processing packets either to or from addresses contained by the address block. If the value of "Destination" is FALSE, the values of "Forwardable" and "Globally Reachable" must also be false. Formerly known as IANA IPv4 Special-Purpose Address Registry (pursuant to [IESG decision]) Available Formats [IMG] CSV Address Block Name RFC Allocation Termination Source Destination Forwardable Globally Reserved-by-Protocol Date Date Reachable 0.0.0.0/8 "This network" [RFC 791, 1981-09 N/A True False False False True Section 3.2] [RFC 1122, 0.0.0.0/32 "This host on this network" Section 1981-09 N/A True False False False True 3.2.1.3] 10.0.0.0/8 Private-Use [RFC 1918] 1996-02 N/A True True True False False 100.64.0.0/10 Shared Address Space [RFC 6598] 2012-04 N/A True True True False False [RFC 1122, False 127.0.0.0/8 Loopback Section 1981-09 N/A [1] False [1] False [1] False [1] True 3.2.1.3] 169.254.0.0/16 Link Local [RFC 3927] 2005-05 N/A True True False False True 172.16.0.0/12 Private-Use [RFC 1918] 1996-02 N/A True True True False False 192.0.0.0/24 [2] IETF Protocol Assignments [RFC 6890, 2010-01 N/A False False False False False Section 2.1] 192.0.0.0/29 IPv4 Service Continuity Prefix [RFC 7335] 2011-06 N/A True True True False False 192.0.0.8/32 IPv4 dummy address [RFC 7600] 2015-03 N/A True False False False False 192.0.0.9/32 Port Control Protocol Anycast [RFC 7723] 2015-10 N/A True True True True False 192.0.0.10/32 Traversal Using Relays around NAT [RFC 8155] 2017-02 N/A True True True True False Anycast 192.0.0.170/32, [RFC 8880]; 192.0.0.171/32 NAT64/DNS64 Discovery [RFC 7050, 2013-02 N/A False False False False True Section 2.2] 192.0.2.0/24 Documentation (TEST-NET-1) [RFC 5737] 2010-01 N/A False False False False False 192.31.196.0/24 AS112-v4 [RFC 7535] 2014-12 N/A True True True True False 192.52.193.0/24 AMT [RFC 7450] 2014-12 N/A True True True True False 192.88.99.0/24 Deprecated (6to4 Relay Anycast) [RFC 7526] 2001-06 2015-03 192.88.99.2/32 6a44-relay anycast address [RFC 6751] 2012-10 N/A True True True False False 192.168.0.0/16 Private-Use [RFC 1918] 1996-02 N/A True True True False False 192.175.48.0/24 Direct Delegation AS112 Service [RFC 7534] 1996-01 N/A True True True True False 198.18.0.0/15 Benchmarking [RFC 2544] 1999-03 N/A True True True False False 198.51.100.0/24 Documentation (TEST-NET-2) [RFC 5737] 2010-01 N/A False False False False False 203.0.113.0/24 Documentation (TEST-NET-3) [RFC 5737] 2010-01 N/A False False False False False 240.0.0.0/4 Reserved [RFC 1112, 1989-08 N/A False False False False True Section 4] [RFC 8190]; 255.255.255.255/32 Limited Broadcast [RFC 919, 1984-10 N/A False True False False True Section 7] Footnotes [1] Several protocols have been granted exceptions to this rule. For examples, see [RFC 8029] and [RFC 5884]. [2] Not useable unless by virtue of a more specific reservation. Licensing Terms