Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About Hypertext Transfer Protocol (HTTP) Upgrade Token Registry Last Updated 2023-10-20 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registry Included Below • HTTP Upgrade Tokens HTTP Upgrade Tokens Registration Procedure(s) First Come First Served Reference [RFC 9110, Section 16.7] Note Please see [RFC 9110, Section 16.7] for details regarding token registrations. Available Formats [IMG] CSV Value Description Expected Version Tokens Reference HTTP Hypertext Transfer Protocol any DIGIT.DIGIT (e.g., "2.0") [RFC 9110, Section 2.5] TLS Transport Layer Security ANY DIGIT.DIGIT (e.g., "1.2") [RFC 2817] WebSocket The Web Socket Protocol [RFC 6455] websocket The Web Socket Protocol [RFC 6455]; [RFC 8441] h2c Hypertext Transfer Protocol version 2 (HTTP/2) (OBSOLETE) [RFC 9113, Section 3.1] connect-udp Proxying of UDP Payloads [RFC 9298] connect-ip Proxying of IP Payloads [RFC 9484] Licensing Terms