Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About Hypertext Transfer Protocol (HTTP) Parameters Last Updated 2025-10-02 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • HTTP Content Coding Registry • HTTP Transfer Coding Registry • HTTP Forwarded Parameters • HTTP Preferences • HTTP Range Unit Registry HTTP Content Coding Registry Registration Procedure(s) IETF Review Reference [RFC 9110, Section 16.6.1] Available Formats [IMG] CSV Name Description Reference Notes aes128gcm AES-GCM encryption with a 128-bit content encryption key [RFC 8188] br Brotli Compressed Data Format [RFC 7932] compress UNIX "compress" data format [Welch, T., "A Technique for High [RFC 9110] Section 8.4.1.1 Performance Data Compression", IEEE Computer 17(6), June 1984.] dcb "Dictionary-Compressed Brotli" data format. [RFC 9842] Section 4 dcz "Dictionary-Compressed Zstandard" data format. [RFC 9842] Section 5 deflate "deflate" compressed data ([RFC 1951]) inside the "zlib" data format [RFC 9110] Section 8.4.1.2 ([RFC 1950]) exi W3C Efficient XML Interchange [W3C Recommendation: Efficient XML Interchange (EXI) Format] gzip GZIP file format [RFC 1952] [RFC 9110] Section 8.4.1.3 identity Reserved [RFC 9110] Section 12.5.3 pack200-gzip Network Transfer Format for Java Archives [JSR 200: Network Transfer Format for Java]; [Kumar_Srinivasan]; [John_Rose] x-compress Deprecated (alias for compress) [RFC 9110] Section 8.4.1.1 x-gzip Deprecated (alias for gzip) [RFC 9110] Section 8.4.1.3 zstd A stream of bytes compressed using the Zstandard protocol with a [RFC 9659]; [RFC 8878] Window_Size of not more than 8 MB. HTTP Transfer Coding Registry Registration Procedure(s) IETF Review Reference [RFC 9112, Section 7.3] Available Formats [IMG] CSV Name Description Reference Notes chunked Transfer in a series of chunks [RFC 9112] Section 7.1 compress UNIX "compress" data format [Welch, T., "A Technique for High Performance Data Compression", IEEE Computer 17(6), [RFC 9112] Section 7.2 June 1984.] deflate "deflate" compressed data ([RFC 1951]) inside the "zlib" data format ([RFC 1950]) [RFC 9112] Section 7.2 gzip GZIP file format [RFC 1952] [RFC 9112] Section 7.2 identity (withdrawn in errata to [RFC 2616]) [RFC 2616] Section 3.6 trailers (reserved) [RFC 9112] Section 12.3 x-compress Deprecated (alias for compress) [RFC 9112] Section 7.2 x-gzip Deprecated (alias for gzip) [RFC 9112] Section 7.2 HTTP Forwarded Parameters Registration Procedure(s) IETF Review Reference [RFC 7239] Available Formats [IMG] CSV Name Description Reference Notes by IP-address of incoming interface of a proxy [RFC 7239] Section 5.1 for IP-address of client making a request through a proxy [RFC 7239] Section 5.2 host Host header field of the incoming request [RFC 7239] Section 5.3 proto Application protocol used for incoming request [RFC 7239] Section 5.4 HTTP Preferences Registration Procedure(s) Specification Required Expert(s) Julian Reschke Reference [RFC 7240] Note Registration requests should be sent to the mailing list described in [RFC 7240]. If approved, designated experts should notify IANA within two weeks. For assistance, please contact iana@iana.org. Available Formats [IMG] CSV Preference Value Description Reference respond-async Indicates that the client prefers that the server [RFC 7240, Section respond asynchronously to a request. 4.1] When the value is "minimal", it indicates that the client prefers that the server return a minimal response to a request. When the value is [RFC 7240, Section return One of either "minimal" or "representation" "representation", it indicates that the client prefers 4.2] that the server include a representation of the current state of the resource in response to a request. Indicates an upper bound to the length of time the [RFC 7240, Section wait client expects it will take the server to process the 4.3] request once it has been received. When value is "strict", it indicates that the client wishes the server to apply strict validation and error handling One of either "strict" or "lenient" handling to the processing of a request. When the [RFC 7240, Section value is "lenient", it indicates that the client 4.4] wishes the server to apply lenient validation and error handling to the processing of the request. The "depth-noroot" preference indicates that the client wishes for the server to exclude the target (root) resource from processing by the HTTP method and only apply the HTTP method to the target resource's subordinate resources. This preference is only depth-noroot intended to be used with HTTP methods whose [RFC 8144, Section 4] definitions explicitly provide support for the Depth [RFC 4918] header field. Furthermore, this preference only applies when the Depth header field has a value of "1" or "infinity" (either implicitly or explicitly). safe Indicates that safe (i.e., unobjectionable) content is [RFC 8674] preferred. Indicates that the service is allowed to return odata.allow-entityreferences references in place of resources that have previously [OData Version 4.01 been returned, with at least the properties requested, Part 1: Protocol] in the same response. Requests that the service invoke the specified URL to signal some service state, such as the completion of [OData Version 4.01 odata.callback an asynchronous result or availability of new or Part 1: Protocol] modified information. The service state that triggers the change is dependent upon the request. Requests that the service attempt to continue processing a request that encounters non-fatal errors, [OData Version 4.01 odata.continue-on-error for example in a multi-part request. The response Part 1: Protocol] SHOULD indicate what portions of the request were and were not able to be successfully handled. Comma-separated list of terms to include or, when prefixed with a minus sign (-), exclude from the response. Terms MUST be Specifies the set of annotations the client requests [OData Version 4.01 odata.include-annotations namespace-qualified and MAY specify just a to be included, where applicable, or excluded in the Part 1: Protocol] namespace to include or exclude all terms response. within that namespace. The special value "*" matches all annotations. A positive integer that represents the Requests that each collection within the response [OData Version 4.01 odata.maxpagesize maximum number of items each collection in a contain no more than the number of items specified as Part 1: Protocol] response SHOULD contain. the positive integer value of this preference. One of nulls - properties containing null values may be omitted from the response Specifies whether a server can omit properties with a [OData Version 4.01 omit-values defaults - properties containing the null value or properties set to their default value Part 1: Protocol] property default value may be omitted from from a response. the response. Requests that the service initiate change tracking on [OData Version 4.01 odata.track-changes the result of this request, according to the Part 1: Protocol] underlying protocol. HTTP Range Unit Registry Registration Procedure(s) IETF Review Reference [RFC 9110, Section 16.5.1] Available Formats [IMG] CSV Name Description Reference Notes bytes a range of octets [RFC 9110] Section 14.1.2 none reserved as keyword to indicate range requests are not supported [RFC 9110] Section 14.3 Contact Information ID Name Contact URI Last Updated [Kumar_Srinivasan] Kumar Srinivasan mailto:Kumar.Srinivasan&Sun.COM 2006-10-27 [John_Rose] John Rose mailto:John.Rose&Sun.COM 2006-10-27 Licensing Terms