Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About Hash Algorithms for HTTP Digest Fields Created 2023-07-27 Last Updated 2024-05-22 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registry Included Below • Hash Algorithms for HTTP Digest Fields Hash Algorithms for HTTP Digest Fields Registration Procedure(s) Specification Required Expert(s) Roberto Polli (primary), Lucas Pardue (secondary) Reference [RFC 9530] Available Formats [IMG] CSV Algorithm Key Status Description Reference sha-512 Active The SHA-512 algorithm. [RFC 6234]; [RFC 4648]; [RFC 9530] sha-256 Active The SHA-256 algorithm. [RFC 6234]; [RFC 4648]; [RFC 9530] md5 Deprecated The MD5 algorithm. It is vulnerable to collision attacks; see [NO-MD5] and [RFC 1321]; [RFC 4648]; [RFC 9530] [CMU-836068] sha Deprecated The SHA-1 algorithm. It is vulnerable to collision attacks; see [NO-SHA] and [RFC 3174]; [RFC 4648]; [RFC 6234]; [RFC 9530] [IACR-2020-014] unixsum Deprecated The algorithm used by the UNIX "sum" command. [RFC 4648]; [RFC 6234]; [UNIX]; [RFC 9530] unixcksum Deprecated The algorithm used by the UNIX "cksum" command. [RFC 4648]; [RFC 6234]; [UNIX]; [RFC 9530] adler Deprecated The ADLER32 algorithm. [RFC 1950]; [RFC 9530] crc32c Deprecated The CRC32c algorithm. [RFC 9260, Appendix A]; [RFC 9530] Licensing Terms