Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About Hypertext Transfer Protocol (HTTP) Digest Algorithm Values Created 2002-01-03 Last Updated 2024-02-16 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • HTTP Digest Algorithm Values • Hash Algorithms for HTTP Digest Authentication HTTP Digest Algorithm Values Registration Procedure(s) RFC Required or Specification Required Expert(s) James Manger Reference [RFC 3230] Note This registry is deprecated since it lists the algorithms that can be used with the Digest and Want-Digest fields defined in [RFC 3230], which has been obsoleted by [RFC 9530]. While registration is not closed, new registrations are encouraged to use the [Hash Algorithms for HTTP Digest Fields] registry instead. Available Formats [IMG] CSV Digest Algorithm Description Reference The ADLER32 algorithm is a checksum specified in [RFC 1950] "ZLIB Compressed Data Format". The 32-bit output is encoded in hexadecimal ADLER32 (using between 1 and 8 ASCII characters from 0-9, A-F, and a-f; [RFC 1950]; [RFC 3309]; [Paul_Millar] leading 0's are allowed). For example, ADLER32=03da0195 and ADLER32=3DA0195 are both valid checksums for the 4-byte message "Wiki". The CRC32c algorithm is a 32-bit cyclic redundancy check. It achieves a better hamming distance (for better error-detection performance) than many other 32-bit CRC functions. Other places it is used include CRC32c iSCSI and SCTP. The 32-bit output is encoded in hexadecimal (using [RFC 9260, Appendix A] between 1 and 8 ASCII characters from 0-9, A-F, and a-f; leading 0's are allowed). For example, CRC32c=0a72a4df and crc32c=A72A4DF are both valid checksums for the 3-byte message "dog". MD5 The MD5 algorithm, as specified in [RFC 1321]. The output of this [RFC 1321]; [RFC 4648]; [RFC 5843] algorithm is encoded using the base64 encoding [RFC 4648]. The SHA-1 algorithm [http://csrc.nist.gov/publications/PubsFIPS.html]; [National [http://csrc.nist.gov/publications/PubsFIPS.html]; [National Institute of Standards and Technology. Secure Hash Standard SHA Institute of Standards and Technology. Secure Hash Standard (SHS). (SHS). FEDERAL INFORMATION PROCESSING STANDARDS PUBLICATION FEDERAL INFORMATION PROCESSING STANDARDS PUBLICATION 180-3, U.S. 180-3, U.S. Department of Commerce, October 2008.]; [RFC 4648]; Department of Commerce, October 2008.]. The output of this algorithm [RFC 5843] is encoded using the base64 encoding [RFC 4648]. The SHA-256 algorithm [http://csrc.nist.gov/publications/PubsFIPS.html]; [National [http://csrc.nist.gov/publications/PubsFIPS.html]; [National Institute of Standards and Technology. Secure Hash Standard SHA-256 Institute of Standards and Technology. Secure Hash Standard (SHS). (SHS). FEDERAL INFORMATION PROCESSING STANDARDS PUBLICATION FEDERAL INFORMATION PROCESSING STANDARDS PUBLICATION 180-3, U.S. 180-3, U.S. Department of Commerce, October 2008.]; [RFC 4648]; Department of Commerce, October 2008.]. The output of this algorithm [RFC 5843] is encoded using the base64 encoding [RFC 4648]. The SHA-512 algorithm [http://csrc.nist.gov/publications/PubsFIPS.html]; [National [http://csrc.nist.gov/publications/PubsFIPS.html]; [National Institute of Standards and Technology. Secure Hash Standard SHA-512 Institute of Standards and Technology. Secure Hash Standard (SHS). (SHS). FEDERAL INFORMATION PROCESSING STANDARDS PUBLICATION FEDERAL INFORMATION PROCESSING STANDARDS PUBLICATION 180-3, U.S. 180-3, U.S. Department of Commerce, October 2008.]; [RFC 4648]; Department of Commerce, October 2008.]. The output of this algorithm [RFC 5843] is encoded using the base64 encoding [RFC 4648]. The algorithm computed by the UNIX ``sum'' command, as defined by the Single UNIX Specification, Version 2 [The Open Group. The Single UNIX [The Open Group. The Single UNIX Specification, Version 2 - 6 UNIXsum Specification, Version 2 - 6 Vol Set for UNIX 98. Document number Vol Set for UNIX 98. Document number T912, The Open Group, T912, The Open Group, February 1997.]. The output of this algorithm February 1997.] is an ASCII decimal-digit string representing the 16-bit checksum, which is the first word of the output of the UNIX ``sum'' command. The algorithm computed by the UNIX ``cksum'' command, as defined by the Single UNIX Specification, Version 2 [The Open Group. The Single [The Open Group. The Single UNIX Specification, Version 2 - 6 UNIXcksum UNIX Specification, Version 2 - 6 Vol Set for UNIX 98. Document Vol Set for UNIX 98. Document number T912, The Open Group, number T912, The Open Group, February 1997.]. The output of this February 1997.] algorithm is an ASCII digit string representing the 32-bit CRC, which is the first word of the output of the UNIX ``cksum'' command. Hash Algorithms for HTTP Digest Authentication Registration Procedure(s) Specification Required Expert(s) Unassigned Reference [RFC 7616] Available Formats [IMG] CSV Hash Algorithm Digest Size Reference MD5 128 [RFC 7616] SHA-512-256 256 [RFC 7616] SHA-256 256 [RFC 7616] Contact Information ID Name Contact URI Last Updated [Paul_Millar] Paul Millar mailto:paul.millar&desy.de 2012-11-06 Licensing Terms