Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About Hypertext Transfer Protocol (HTTP) Cache-Status Created 2021-08-19 Last Updated 2022-06-21 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registry Included Below • HTTP Cache-Status HTTP Cache-Status Registration Procedure(s) Expert Review Expert(s) Mark Nottingham Reference [RFC 9211] Available Formats [IMG] CSV Name Type Description Reference hit Boolean When true, indicates that the request was satisfied by the cache; that is, it was not forwarded, and the [RFC 9211] response was obtained from the cache. fwd Token When present, indicates that the request went forward towards the origin; its value indicates why. [RFC 9211] fwd-status Integer Indicates which status code (see [RFC 9110, Section 15]) the next-hop server returned in response to the [RFC 9211] forwarded request. Indicates the response’s remaining freshness lifetime (see [RFC 9111, Section 4.2.1]) as calculated by the ttl Integer cache, as an integer number of seconds, measured as closely as possible to when the response header section is [RFC 9211] sent by the cache. stored Boolean Indicates whether the cache stored the response (see [RFC 9111, Section 3]); a true value indicates that it did. [RFC 9211] collapsed Boolean Indicates whether this request was collapsed together with one or more other forward requests (see [RFC 9111, [RFC 9211] Section 4]); If true, the response was successfully reused; if not, a new request had to be made. key String Conveys a representation of the cache key (see [RFC 9111, Section 2]) used for the response. [RFC 9211] detail String or Token Allows implementations to convey additional information not captured in other parameters, such as [RFC 9211] implementation-specific states or other caching-related metrics. Licensing Terms