Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About IANA OUI Ethernet Numbers Last Updated 2026-10-13 Note This page has assignments by IANA as specified in [RFC 9542] to be under the IANA OUI. For some information on IEEE 802 number assignments by the IEEE Registration Authority and how to contact that authority, see the [IEEE 802 Numbers]. Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • IANA MAC ADDRESS BLOCK • IANA Unicast 48-bit MAC Addresses • IANA Multicast 48-bit MAC Addresses • IANA 64-bit MAC Addresses • The CFxxxx Series • SNAP Protocol Numbers • IANA Link Layer Discovery Protocol (LLDP) TLV Subtypes • IANA PTP TLV Subtypes IANA MAC ADDRESS BLOCK Registration Procedure(s) See [RFC 9542]. Expert(s) Donald Eastlake (primary), Juan Carlos Zuniga (secondary) Reference [RFC 9542] Note IANA allocates addresses under the IANA OUI (00-00-5E) as explained in [RFC 9542]. Unicast addresses under the IANA OUI start with 00-00-5E, while multicast addresses under the IANA OUI start with 01-00-5E. In the lists below, these initial 3 bytes are omitted for brevity. As described in [RFC 9542], 48-bit MAC addresses in the range 33-33-00-00-00-00 to 33-33-FF-FF-FF-FF are used for IPv6 multicast. When the available space for either multicast or unicast EUI-48 identifiers under OUI 00-00-5E has been 90% or more exhausted, IANA should request an additional OUI from the IEEE Registration Authority for further IANA assignment use. The appointed Expert(s) should monitor for this condition and notify IANA. IANA Unicast 48-bit MAC Addresses Note These values are prefixed with 00-00-5E. See [Section 2.1.3 of RFC 9542]. Available Formats [IMG] CSV Range Registration Procedures Small to medium assignments of up to 65536 identifiers Expert Review Large assignments of 131072 or more identifiers IESG Ratification, as defined in [RFC 9542, Section 5.1] Assignment(s) in the 00-00-00 to 00-00-FF range IESG Ratification, as defined in [RFC 9542, Section 5.1] Addresses Usage Reference 00-00-00 to 00-00-FF Reserved [RFC 9542] 00-01-00 to 00-01-FF VRRP (Virtual Router Redundancy Protocol) [RFC 9568] 00-02-00 to 00-02-FF VRRP IPv6 (Virtual Router Redundancy Protocol IPv6) [RFC 9568] 00-03-00 to 00-51-FF Unassigned 00-52-00 PacketPWEthA [RFC 6658] 00-52-01 PacketPWEthB [RFC 6658] 00-52-02 BFD for VXLAN [RFC 8971] 00-52-03 to 00-52-12 Unassigned (small allocations) 00-52-13 Proxy Mobile IPv6 [RFC 6543] 00-52-14 to 00-52-FF Unassigned (small allocations) 00-53-00 to 00-53-FF Documentation [RFC 9542] 00-54-00 to 90-00-FF Unassigned 90-01-00 TRILL OAM [RFC 7455] 90-01-01 to 90-01-FF Unassigned (small allocations requiring both unicast and multicast) 90-02-00 to FF-FF-FF Unassigned IANA Multicast 48-bit MAC Addresses Note These values are prefixed with 01-00-5E. See [Section 2.1.3 of RFC 9542]. Available Formats [IMG] CSV Range Registration Procedures Small to medium assignments of up to 65536 identifiers Expert Review Large assignments of 131072 or more identifiers IESG Ratification, as defined in [RFC 9542, Section 5.1] Addresses Usage Reference 00-00-00 to 7F-FF-FF IPv4 Multicast [RFC 1112] 80-00-00 to 8F-FF-FF MPLS Multicast [RFC 5332] 90-00-00 MPLS-TP p2p [RFC 7213] 90-00-01 Bidirectional Forwarding Detection (BFD) on Link Aggregation Group (LAG) Interfaces [RFC 7130] 90-00-02 AllL1MI-ISs [RFC 8202] 90-00-03 AllL2MI-ISs [RFC 8202] 90-00-04 to 90-00-FF Unassigned (small allocations) 90-01-00 TRILL OAM [RFC 7455] 90-01-01 to 90-01-FF Unassigned (small allocations requiring both unicast and multicast) 90-02-00 to 90-0F-FF Unassigned 90-10-00 to 90-10-FF Documentation [RFC 9542] 90-11-00 to FF-FF-FF Unassigned IANA 64-bit MAC Addresses Note These values are prefixed with 00-00-5E to form unicast MAC addresses, with 01-00-5E to form multicast MAC addresses, with 02-00-5E to form unicast modified EUI-64 addresses, and with 03-00-5E to form multicast modified EUI-64 addresses. See [RFC 9542], particularly Section 2.2.2, for more details. Available Formats [IMG] CSV Range Registration Procedures Small to medium assignments of up to 268435456 identifiers Expert Review Assignments of any size, including blocks of 536870912 or more IESG Ratification, as defined in [RFC 9542, Section 5.1] Assignments from Reserved ranges IESG Ratification, as defined in [RFC 9542, Section 5.1] Addresses Usage Reference 00-00-00-00-00 to 0F-FF-FF-FF-FF Reserved [RFC 9542] 10-00-00-00-00 to 10-00-00-00-FF Documentation [RFC 9542] 10-00-00-01-00 to EF-FF-FF-FF-FF Unassigned FD-00-00-00-00 to FD-FF-FF-FF-FF Reserved [RFC 9542] FE-00-00-00-00 to FE-FF-FF-FF-FF IPv4 Addr Holders [RFC 9542] FF-00-00-00-00 to FF-FD-FF-FF-FF Reserved [RFC 9542] FF-FE-00-00-00 to FF-FE-FF-FF-FF IANA EUI-48 Holders [RFC 9542] FF-FF-00-00-00 to FF-FF-FF-FF-FF Reserved [RFC 9542] The CFxxxx Series Note [RFC 2153] described a method of using a "pseudo OUI" for certain purposes when there is no appropriate regular OUI assigned. The registry for these is on the PPP Parameters IANA web page. The CF series registry has been closed by [RFC 5342]. Please see [Point-to-Point (PPP) Protocol Field Assignments]. Value Description Reference No registrations at this time. SNAP Protocol Numbers Registration Procedure(s) Expert Review Expert(s) Donald Eastlake (primary), Juan Carlos Zuniga (secondary) Reference [RFC 9542] Note The SNAP protocol number assignments use the IANA OUI. Values 0000 and FFFF require IESG Ratification as described in [Section 5.1 of RFC 9542]. Available Formats [IMG] CSV Protocol Number (decimal) Protocol Number (hex) Description References 0000 0000 reserved [RFC 9542] 0001 0001 MARS Data Messages (short form) [RFC 2022] 0002 0002 reserved for future NHRP use [RFC 2332] 0003 0003 MARS/NHRP Control Messages [RFC 2022]; [RFC 2332] 0004 0004 MARS Data Messages (long form) [RFC 2022] 0005 0005 SCSP - Server Cache Sync Protocol [RFC 2334] 0006 0006 VRID - Virtual Router MAC Address [S_Knight] 0007 0007 L2TP [RFC 3070] 0008 0008 Virtual Private Network ID [RFC 2684] 0009-0065 0009-0041 Unassigned 0066 0042 Documentation Use [RFC 9542] 0067-65534 0043-FFFE Unassigned 65535 FFFF Reserved [RFC 9542] IANA Link Layer Discovery Protocol (LLDP) TLV Subtypes Registration Procedure(s) Expert Review Expert(s) Eliot Lear, Dan Romascanu Reference [RFC 8520][RFC 9542] Available Formats [IMG] CSV Value Description Reference 0 Reserved [RFC 9542] 1 the Manufacturer Usage Description (MUD) Uniform Resource Locator (URL) [RFC 8520] 2-41 Unassigned 42 Example for use in documentation [RFC 9542] 43-254 Unassigned 255 Reserved [RFC 9542] IANA PTP TLV Subtypes Expert(s) Miroslav Lichvar, Karen O'Donoghue Reference [RFC 10030] Note IEEE 1588-2019 (PTP version 2.1) defines several organization-specific TLVs. These values are the organizationSubType of TLVs having the IANA OUI (00-00-5E) as the organizationId. Available Formats [IMG] CSV Range Registration Procedures 0-0xFFFF IETF Review 0x10000-0x7FFFFF Specification Required 0x800000-0xFFFFFE Experimental and Private Use Subtype Description Reference 0x0 Reserved [RFC 10030] 0x1 Network Time Protocol Message [RFC 10030] 0x2-0x7FFFFF Unassigned 0x800000-0xFFFFFE Reserved for Experimental and Private Use [RFC 10030] 0xFFFFFF Reserved [RFC 10030] Contact Information ID Name Contact URI Last Updated [S_Knight] S. Knight mailto:steven.knight&ascend.com 1997-11 Licensing Terms