Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About Extended Master Session Key (EMSK) Parameters Created 2008-06-24 Last Updated 2026-03-05 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • User Specific Root Keys (USRK) Key Labels • EMSK PRF Numbers User Specific Root Keys (USRK) Key Labels Registration Procedure(s) Specification Required Expert(s) Unassigned Reference [RFC 5295] Available Formats [IMG] CSV Label Description Reference experimental1 Reserved for Experimental Use [RFC 5295] experimental2 Reserved for Experimental Use [RFC 5295] private1 Reserved for Private Use [RFC 5295] private2 Reserved for Private Use [RFC 5295] EMSK Extended Master Session Key (EMSK) [RFC 5295] dsrk@ietf.org Domain Specific Root Key (DSRK) [RFC 5295] EAP Re-authentication Root Key@ietf.org Re-auth usage label [RFC 6696] DSRK Delivery Authorized Key@ietf.org DSRK authorized delivery key [RFC 6696] EAP Early-Authentication Root Key@ietf.org Early authentication usage [RFC 6630] TEAPbindkey@ietf.org TEAP binding usage label [RFC 9930] EMSK PRF Numbers Reference [RFC 5295] Available Formats [IMG] CSV Range Registration Procedures 0-220 IETF Review 221-255 Reserved for Private Use Value Description Reference 0 Reserved [RFC 5295] 1 HMAC-SHA-256 PRF+ (Default) [RFC 5295] 2-220 Unassigned 221-255 Reserved for Private Use [RFC 5295] Licensing Terms