Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About EAP-pwd Parameters Created 2010-01-06 Last Updated 2017-04-24 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • PWD-Exch Messages • Random Function Registry • PRF Registry • Password Preprocessing Methods PWD-Exch Messages Registration Procedure(s) IETF Review Reference [RFC 5931] Available Formats [IMG] CSV Value Name Reference 0x00 Reserved [RFC 5931] 0x01 EAP-pwd-ID exchange [RFC 5931] 0x02 EAP-pwd-Commit exchange [RFC 5931] 0x03 EAP-pwd-Confirm exchange [RFC 5931] 0x04-0x63 Unassigned Random Function Registry Registration Procedure(s) Specification Required Expert(s) Joseph Salowey Reference [RFC 5931] Available Formats [IMG] CSV Value Name Reference 0x00 Private Use [RFC 5931] 0x01 Function defined in RFC, Section 2.4 [RFC 5931] 0x02-0xFF Unassigned PRF Registry Registration Procedure(s) IETF Review Reference [RFC 5931] Available Formats [IMG] CSV Value Name Reference 0x00 Private Use [RFC 5931] 0x01 HMAC-SHA256 as defined in RFC4634 [RFC 5931]; [RFC 4634] 0x02-0xFF Unassigned Password Preprocessing Methods Registration Procedure(s) Specification Required Expert(s) Joseph Salowey Reference [RFC 5931] Available Formats [IMG] CSV Value Name Reference 0x00 None [RFC 5931] 0x01 RFC2759 [RFC 5931]; [RFC 2759] 0x02 SASLprep [RFC 5931] 0x03 a random salt with SHA-1 [RFC 8146] 0x04 a random salt with SHA-256 [RFC 8146] 0x05 a random salt with SHA-512 [RFC 8146] 0x06 UNIX crypt() [RFC 8146] 0x07 scrypt [RFC 8146] 0x08 PBKDF2 with SHA-256 [RFC 8146] 0x09 PBKDF2 with SHA-512 [RFC 8146] 0x0A SASLprep then a random salt with SHA-1 [RFC 8146] 0x0B SASLprep then a random salt with SHA-256 [RFC 8146] 0x0C SASLprep then a random salt with SHA-512 [RFC 8146] 0x0D SASLprep then UNIX crypt() [RFC 8146] 0x0E OpaqueString then scrypt [RFC 8146] 0x0F OpaqueString then PBKDF2 with SHA-256 [RFC 8146] 0x10 OpaqueString then PBKDF2 with SHA-512 [RFC 8146] 0x11-0xFF Unassigned Licensing Terms