Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About Flexible Authentication via Secure Tunneling Extensible Authentication Protocol (EAP-FAST) Parameters Created 2008-12-12 Last Updated 2013-07-26 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • EAP-FAST TLV Types (Value 43) • EAP-FAST (value 43) Error-TLV (value 5) Error-Codes • EAP-FAST (value 43) Request-Action TLV (value 19) Action Codes • EAP-FAST PAC Attribute Types • EAP-FAST PAC Types • EAP-FAST Server-Trusted-Root Credential Format Types • EAP-FAST GTC Error Codes EAP-FAST TLV Types (Value 43) Registration Procedure(s) Specification Required Expert(s) Joseph Salowey Reference [RFC 4851] Available Formats [IMG] CSV Value Description Reference 0 Reserved [RFC 4851] 1 Reserved [RFC 4851] 2 Reserved [RFC 4851] 3 Result TLV [RFC 4851] 4 NAK TLV [RFC 4851] 5 Error TLV [RFC 4851] 6 Unassigned 7 Vendor-Specific TLV [RFC 4851] 8 Unassigned 9 EAP-Payload TLV [RFC 4851] 10 Intermediate-Result TLV [RFC 4851] 11 PAC TLV [RFC 5422] 12 Crypto-Binding TLV [RFC 4851] 13-17 Unassigned 18 Server-Trusted-Root TLV [RFC 5422] 19 Request-Action TLV [RFC 4851] 20 PKCS#7 TLV [RFC 5422] EAP-FAST (value 43) Error-TLV (value 5) Error-Codes Registration Procedure(s) Specification Required Expert(s) Joseph Salowey Reference [RFC 4851] Available Formats [IMG] CSV Value Description Reference 2001 Tunnel_Compromise_Error [RFC 4851] 2002 Unexpected_TLVs_Exchanged [RFC 4851] EAP-FAST (value 43) Request-Action TLV (value 19) Action Codes Registration Procedure(s) Specification Required Expert(s) Joseph Salowey Reference [RFC 4851] Available Formats [IMG] CSV Value Description Reference 1 Process-TLV [RFC 4851] 2 Negotiate-EAP [RFC 4851] EAP-FAST PAC Attribute Types Registration Procedure(s) Specification Required Expert(s) Joseph Salowey Reference [RFC 5422] Available Formats [IMG] CSV Value Description Reference 0 Reserved [RFC 5422] 1 PAC-Key [RFC 5422] 2 PAC-Opaque [RFC 5422] 3 PAC-Lifetime [RFC 5422] 4 A-ID [RFC 5422] 5 I-ID [RFC 5422] 6 Reserved [RFC 5422] 7 A-ID-Info [RFC 5422] 8 PAC-Acknowledgement [RFC 5422] 9 PAC-Info [RFC 5422] 10 PAC-Type [RFC 5422] 11-63 Allocated for management by Cisco [RFC 5422] 64-255 Unassigned EAP-FAST PAC Types Registration Procedure(s) Specification Required Expert(s) Joseph Salowey Reference [RFC 5422] Available Formats [IMG] CSV Value Description Reference 0 Reserved [RFC 5422] 1 Tunnel PAC [RFC 5422] 2 Machine Authentication PAC [RFC 5422] 3 User Authorization PAC [RFC 5422] 4-63 Allocated for management by Cisco [RFC 5422] 64-255 Unassigned EAP-FAST Server-Trusted-Root Credential Format Types Registration Procedure(s) Specification Required Expert(s) Joseph Salowey Reference [RFC 5422] Available Formats [IMG] CSV Value Description Reference 0 Reserved [RFC 5422] 1 PKCS#7-Server-Certificate-Root [RFC 5422] 2-63 Allocated for management by Cisco [RFC 5422] 64-255 Unassigned EAP-FAST GTC Error Codes Registration Procedure(s) Specification Required Expert(s) Joseph Salowey Reference [RFC 5421] Available Formats [IMG] CSV Code Error Name Reference 0-645 Unassigned 646 ERROR_RESTRICTED_LOGON_HOURS [RFC 5421] 647 ERROR_ACCT_DISABLED [RFC 5421] 648 ERROR_PASSWD_EXPIRED [RFC 5421] 649 ERROR_NO_DIALIN_PERMISSION [RFC 5421] 650-690 Unassigned 691 ERROR_AUTHENTICATION_FAILURE [RFC 5421] 692-708 Unassigned 709 ERROR_CHANGING_PASSWORD [RFC 5421] 710-754 Unassigned 755 ERROR_PAC_I-ID_NO_MATCH [RFC 5421] 756-9999999999 Unassigned Licensing Terms