Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About Dynamic Symmetric Key Provisioning Protocol (DSKPP) Created 2010-09-21 Last Updated 2015-06-08 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • Status Codes • DSKPP Version Registry • PRF Algorithm ID Registry • Key Container Registry Status Codes Registration Procedure(s) Specification Required Expert(s) Unassigned Reference [RFC 6063] Available Formats [IMG] CSV Status Code Reference Continue [RFC 6063] Success [RFC 6063] Abort [RFC 6063] AccessDenied [RFC 6063] MalformedRequest [RFC 6063] UnknownRequest [RFC 6063] UnknownCriticalExtension [RFC 6063] UnsupportedVersion [RFC 6063] NoSupportedKeyTypes [RFC 6063] NoSupportedEncryptionAlgorithms [RFC 6063] NoSupportedMacAlgorithms [RFC 6063] NoProtocolVariants [RFC 6063] NoSupportedKeyPackages [RFC 6063] AuthenticationDataMissing [RFC 6063] AuthenticationDataInvalid [RFC 6063] InitializationFailed [RFC 6063] ProvisioningPeriodExpired [RFC 6063] DSKPP Version Registry Registration Procedure(s) Standards Action Reference [RFC 6063] Available Formats [IMG] CSV DSKPP Version Reference 1.0 [RFC 6063] PRF Algorithm ID Registry Registration Procedure(s) Specification Required Expert(s) Unassigned Reference [RFC 6063] Available Formats [IMG] CSV Common Name URI Reference DSKPP-PRF-AES urn:ietf:params:xml:ns:keyprov:dskpp:prf-aes-128 [RFC 6063] DSKPP-PRF-SHA256 urn:ietf:params:xml:ns:keyprov:dskpp:prf-sha256 [RFC 6063] Key Container Registry Registration Procedure(s) Specification Required Expert(s) Unassigned Reference [RFC 6063] Available Formats [IMG] CSV Name URI Deprecated Reference PSKC Key urn:ietf:params:xml:ns:keyprov:dskpp:pskc-key-container FALSE [RFC 6030]; [RFC 6063] Container SKPC Key urn:ietf:params:xml:ns:keyprov:dskpp:skpc-key-container FALSE [RFC 6031]; [RFC 6063] Container PKCS12 Key ['Personal Information Exchange Syntax Standard', PKCS 12 Version Container urn:ietf:params:xml:ns:keyprov:dskpp:pkcs12-key-container FALSE 1.0]; [ftp://ftp.rsasecurity.com/pub/pkcs/pkcs-12/pkcs-12v1.pdf]; [RFC 6063] PKCS5-XML ['XML Schema for PKCS 5 Version 2.0', PKCS 5 Version 2.0 Amd.1 Key urn:ietf:params:xml:ns:keyprov:dskpp:pkcs5-xml-key-container FALSE (FINAL DRAFT), October 2006]; Container [http://www.rsasecurity.com/rsalabs/pkcs/]; [RFC 6063] Licensing Terms