Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About DNSKEY FLAGS Created 2004-02-04 Last Updated 2026-07-20 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registry Included Below • DNSKEY RR Flags DNSKEY RR Flags Registration Procedure(s) Standards Action Reference [RFC 3755][RFC 4034] Note The DNSKEY RR contains a 16-bit flags field. The KEY RR may have different flag assignments -- those assignments are not recorded in this registry. Available Formats [IMG] CSV Number Description Reference 0-6 Unassigned [RFC 3755]; [RFC 4034] 7 ZONE [RFC 3755]; [RFC 4034] 8 REVOKE [RFC 5011] 9-13 Unassigned [RFC 3755]; [RFC 4034] 14 Authoritative Delegation Types (TEMPORARY - registered 2026-07-20, expires 2027-07-20) [draft-ietf-dnsop-delext-08] 15 Secure Entry Point (SEP) [RFC 3757]; [RFC 4034] Licensing Terms