Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About Dynamic Link Exchange Protocol (DLEP) Parameters Created 2017-04-03 Last Updated 2026-07-02 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • Signal Type Values • Message Type Values • Data Item Type Values • Status Code Values • Extension Type Values • IPv4 Connection Point Flags • IPv6 Connection Point Flags • Peer Type Flags • IPv4 Address Flags • IPv6 Address Flags • IPv4 Attached Subnet Flags • IPv6 Attached Subnet Flags • Hop Control Actions Values • Queue Parameter Sub-Data Item Type Values • Traffic Classification Sub-Data Item Type Values Signal Type Values Expert(s) Rick Taylor Reference [RFC 8175] Available Formats [IMG] CSV Range Registration Procedures 3-65519 Specification Required 65520-65534 Private Use Type Code Description Reference 0 Reserved [RFC 8175] 1 Peer Discovery Signal [RFC 8175] 2 Peer Offer Signal [RFC 8175] 3-65519 Unassigned 65520-65534 Reserved for Private Use [RFC 8175] 65535 Reserved [RFC 8175] Message Type Values Expert(s) Rick Taylor Reference [RFC 8175] Available Formats [IMG] CSV Range Registration Procedures 17-65519 Specification Required 65520-65534 Private Use Type Code Description Reference 0 Reserved [RFC 8175] 1 Session Initialization Message [RFC 8175] 2 Session Initialization Response Message [RFC 8175] 3 Session Update Message [RFC 8175] 4 Session Update Response Message [RFC 8175] 5 Session Termination Message [RFC 8175] 6 Session Termination Response Message [RFC 8175] 7 Destination Up Message [RFC 8175] 8 Destination Up Response Message [RFC 8175] 9 Destination Announce Message [RFC 8175] 10 Destination Announce Response Message [RFC 8175] 11 Destination Down Message [RFC 8175] 12 Destination Down Response Message [RFC 8175] 13 Destination Update Message [RFC 8175] 14 Link Characteristics Request Message [RFC 8175] 15 Link Characteristics Response Message [RFC 8175] 16 Heartbeat Message [RFC 8175] 17 Credit Control [RFC 9893] 18 Credit Control Response [RFC 9893] 19-65519 Unassigned 65520-65534 Reserved for Private Use [RFC 8175] 65535 Reserved [RFC 8175] Data Item Type Values Expert(s) Rick Taylor Reference [RFC 8175] Available Formats [IMG] CSV Range Registration Procedures 26-65407 Specification Required 65408-65534 Private Use Type Code Description Reference 0 Reserved [RFC 8175] 1 Status [RFC 8175] 2 IPv4 Connection Point [RFC 8175] 3 IPv6 Connection Point [RFC 8175] 4 Peer Type [RFC 8175] 5 Heartbeat Interval [RFC 8175] 6 Extensions Supported [RFC 8175] 7 MAC Address [RFC 8175] 8 IPv4 Address [RFC 8175] 9 IPv6 Address [RFC 8175] 10 IPv4 Attached Subnet [RFC 8175] 11 IPv6 Attached Subnet [RFC 8175] 12 Maximum Data Rate (Receive) (MDRR) [RFC 8175] 13 Maximum Data Rate (Transmit) (MDRT) [RFC 8175] 14 Current Data Rate (Receive) (CDRR) [RFC 8175] 15 Current Data Rate (Transmit) (CDRT) [RFC 8175] 16 Latency [RFC 8175] 17 Resources (RES) [RFC 8175] 18 Relative Link Quality (Receive) (RLQR) [RFC 8175] 19 Relative Link Quality (Transmit) (RLQT) [RFC 8175] 20 Maximum Transmission Unit (MTU) [RFC 8175] 21 Hop Count [RFC 8629] 22 Hop Control [RFC 8629] 23 Queue Parameters [RFC 8651] 24 Pause [RFC 8651] 25 Restart [RFC 8651] 26 Link Identifier Length [RFC 8703] 27 Link Identifier [RFC 8703] 28 Latency Range [RFC 8757] 29 Traffic Classification [RFC 9892] 30 Credit Window Initialization [RFC 9893] 31 Credit Window Association [RFC 9893] 32 Credit Window Grant [RFC 9893] 33 Credit Window Status [RFC 9893] 34 Credit Window Request [RFC 9893] 35-65407 Unassigned 65408-65534 Reserved for Private Use [RFC 8175] 65535 Reserved [RFC 8175] Status Code Values Expert(s) Rick Taylor Reference [RFC 8175] Available Formats [IMG] CSV Range Registration Procedures 4-111 Specification Required 112-127 Private Use 133-239 Specification Required 240-254 Private Use Status Code Failure Mode Description Reference 0 Continue Success [RFC 8175] 1 Continue Not Interested [RFC 8175] 2 Continue Request Denied [RFC 8175] 3 Continue Inconsistent Data [RFC 8175] 4-111 Continue Unassigned 112-127 Continue Reserved for Private Use [RFC 8175] 128 Terminate Unknown Message [RFC 8175] 129 Terminate Unexpected Message [RFC 8175] 130 Terminate Invalid Data [RFC 8175] 131 Terminate Invalid Destination [RFC 8175] 132 Terminate Timed Out [RFC 8175] 133-239 Terminate Unassigned 240-254 Terminate Reserved for Private Use [RFC 8175] 255 Terminate Shutting Down [RFC 8175] Extension Type Values Expert(s) Rick Taylor Reference [RFC 8175] Available Formats [IMG] CSV Range Registration Procedures 2-65519 Specification Required 65520-65534 Private Use Code Description Reference 0 Reserved [RFC 8175] 1 Multi-Hop Forwarding [RFC 8629] 2 Control-Plane-Based Pause [RFC 8651] 3 Link Identifiers [RFC 8703] 4 Latency Range [RFC 8757] 5 IEEE 802.1Q Aware Credit Window [RFC 9895] 6 Diffserv Aware Credit Window [RFC 9894] 7-65519 Unassigned 65520-65534 Reserved for Private Use [RFC 8175] 65535 Reserved [RFC 8175] IPv4 Connection Point Flags Registration Procedure(s) Specification Required Expert(s) Rick Taylor Reference [RFC 8175] Available Formats [IMG] CSV Bit Description Reference 0-6 Unassigned 7 Use TLS [RFC 5246] indicator [RFC 8175] IPv6 Connection Point Flags Registration Procedure(s) Specification Required Expert(s) Rick Taylor Reference [RFC 8175] Available Formats [IMG] CSV Bit Description Reference 0-6 Unassigned 7 Use TLS [RFC 5246] indicator [RFC 8175] Peer Type Flags Registration Procedure(s) Specification Required Expert(s) Rick Taylor Reference [RFC 8175] Available Formats [IMG] CSV Bit Description Reference 0-6 Unassigned 7 Secured Medium indicator [RFC 8175] IPv4 Address Flags Registration Procedure(s) Specification Required Expert(s) Rick Taylor Reference [RFC 8175] Available Formats [IMG] CSV Bit Description Reference 0-6 Unassigned 7 Add/Drop indicator [RFC 8175] IPv6 Address Flags Registration Procedure(s) Specification Required Expert(s) Rick Taylor Reference [RFC 8175] Available Formats [IMG] CSV Bit Description Reference 0-6 Unassigned 7 Add/Drop indicator [RFC 8175] IPv4 Attached Subnet Flags Registration Procedure(s) Specification Required Expert(s) Rick Taylor Reference [RFC 8175] Available Formats [IMG] CSV Bit Description Reference 0-6 Unassigned 7 Add/Drop indicator [RFC 8175] IPv6 Attached Subnet Flags Registration Procedure(s) Specification Required Expert(s) Rick Taylor Reference [RFC 8175] Available Formats [IMG] CSV Bit Description Reference 0-6 Unassigned 7 Add/Drop indicator [RFC 8175] Hop Control Actions Values Expert(s) Rick Taylor Reference [RFC 8629] Available Formats [IMG] CSV Range Registration Procedures 4-65519 Specification Required 65520-65534 Private Use Value Action Reference 0 Reset [RFC 8629] 1 Terminate [RFC 8629] 2 Direct Connection [RFC 8629] 3 Suppress Forwarding [RFC 8629] 4-65519 Unassigned 65520-65534 Reserved for Private Use [RFC 8629] 65535 Reserved [RFC 8629] Queue Parameter Sub-Data Item Type Values Expert(s) Ronald in 't Velt, Lou Berger Reference [RFC 8651] Available Formats [IMG] CSV Range Registration Procedures 2-65407 Specification Required 65408-65534 Private Use Type Code Description/Policy Reference 0 Reserved [RFC 8651] 1 Queue Parameter [RFC 8651] 2-65407 Unassigned 65408-65534 Reserved for Private Use [RFC 8651] 65535 Reserved [RFC 8651] Traffic Classification Sub-Data Item Type Values Expert(s) Ronald in 't Velt, Lou Berger Reference [RFC 9892] Available Formats [IMG] CSV Range Registration Procedures 1-65407 Specification Required 65408-65534 Private Use Type Code Description Reference 0 Reserved [RFC 9892] 1 Diffserv Traffic Classification [RFC 2474] 2 Ethernet Traffic Classification [IEEE 802.1Q] 3-65407 Unassigned 65408-65534 Reserved for Private Use [RFC 9892] 65535 Reserved [RFC 9892] Licensing Terms