Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About DomainKeys Identified Mail (DKIM) Parameters Created 2007-03-08 Last Updated 2018-07-06 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • DKIM Signature Tag Specifications • DKIM-Signature Query Method • DKIM-Signature Canonicalization Header • DKIM-Signature Canonicalization Body • _domainkey DNS TXT Record Tag Specifications • DKIM Key Type • DKIM Hash Algorithms • DKIM Service Types • DKIM Selector Flags • Authorized Third-Party Signature (ATPS) Tag Registry • DKIM Reporting Tag Registry DKIM Signature Tag Specifications Registration Procedure(s) IETF Review Reference [RFC 6376] Available Formats [IMG] CSV Type Reference Status v [RFC 6376] active a [RFC 6376] active b [RFC 6376] active bh [RFC 6376] active c [RFC 6376] active d [RFC 6376] active h [RFC 6376] active i [RFC 6376] active l [RFC 6376] active q [RFC 6376] active s [RFC 6376] active t [RFC 6376] active x [RFC 6376] active z [RFC 6376] active atps [RFC 6541] active atpsh [RFC 6541] active r [RFC 6651] active DKIM-Signature Query Method Registration Procedure(s) IETF Review Reference [RFC 6376] Available Formats [IMG] CSV Type Option Reference Status dns txt [RFC 6376] active DKIM-Signature Canonicalization Header Registration Procedure(s) IETF Review Reference [RFC 6376] Available Formats [IMG] CSV Type Reference Status simple [RFC 6376] active relaxed [RFC 6376] active DKIM-Signature Canonicalization Body Registration Procedure(s) IETF Review Reference [RFC 6376] Available Formats [IMG] CSV Type Reference Status simple [RFC 6376] active relaxed [RFC 6376] active _domainkey DNS TXT Record Tag Specifications Registration Procedure(s) IETF Review Reference [RFC 6376] Available Formats [IMG] CSV Type Reference Status v [RFC 6376] active g [RFC 4871] historic h [RFC 6376] active k [RFC 6376] active n [RFC 6376] active p [RFC 6376] active s [RFC 6376] active t [RFC 6376] active DKIM Key Type Registration Procedure(s) IETF Review Reference [RFC 6376] Available Formats [IMG] CSV Type Reference Status rsa [RFC 8017] active ed25519 [RFC 8032] active DKIM Hash Algorithms Registration Procedure(s) IETF Review Reference [RFC 6376] Available Formats [IMG] CSV Type Reference Status sha1 [RFC 6376]; [RFC 8301] historic sha256 [FIPS-180-3-2008] active DKIM Service Types Registration Procedure(s) IETF Review Reference [RFC 6376] Available Formats [IMG] CSV Type Reference Status email [RFC 6376] active * [RFC 6376] active DKIM Selector Flags Registration Procedure(s) IETF Review Reference [RFC 6376] Available Formats [IMG] CSV Type Reference Status y [RFC 6376] active s [RFC 6376] active Authorized Third-Party Signature (ATPS) Tag Registry Registration Procedure(s) Specification Required Expert(s) Unassigned Reference [RFC 6541] Available Formats [IMG] CSV Tag Reference Status d [RFC 6541] active v [RFC 6541] active DKIM Reporting Tag Registry Registration Procedure(s) Specification Required Expert(s) Unassigned Reference [RFC 6651] Available Formats [IMG] CSV Tag Reference Status ra [RFC 6651] active rp [RFC 6651] active rr [RFC 6651] active rs [RFC 6651] active Licensing Terms