Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About Content Delivery Network Interconnection (CDNI) Parameters Created 2015-10-22 Last Updated 2026-04-02 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • CDNI Payload Types • CDNI CI/T Trigger Types • CDNI CI/T Error Codes • CDNI Capabilities Redirection Modes • CDNI Logging Directive Names • CDNI Logging File Version • CDNI Logging Record-Types • CDNI Logging Field Names • CDNI RI Error Response Code • CDNI Metadata Footprint Types • CDNI Metadata Protocol Types • CDNI URI Signing Verification Codes • CDNI URI Signing Signed Token Transport • CDNI Telemetry Source Types • CDNI Capacity Limit Types CDNI Payload Types Registration Procedure(s) Specification Required Expert(s) Kevin Ma, Sanjay Mishra Reference [RFC 7736] Available Formats [IMG] CSV Payload Type Reference ci-trigger-command [RFC 8007] ci-trigger-status [RFC 8007] ci-trigger-collection [RFC 8007] FCI.DeliveryProtocol [RFC 8008] FCI.AcquisitionProtocol [RFC 8008] FCI.RedirectionMode [RFC 8008] FCI.Logging [RFC 8008] FCI.Metadata [RFC 8008] logging-file [RFC 7937] redirection-request [RFC 7975] redirection-response [RFC 7975] MI.HostIndex [RFC 8006] MI.HostMatch [RFC 8006] MI.HostMetadata [RFC 8006] MI.PathMatch [RFC 8006] MI.PatternMatch [RFC 8006] MI.PathMetadata [RFC 8006] MI.SourceMetadata [RFC 8006] MI.Source [RFC 8006] MI.LocationACL [RFC 8006] MI.LocationRule [RFC 8006] MI.Footprint [RFC 8006] MI.TimeWindowACL [RFC 8006] MI.TimeWindowRule [RFC 8006] MI.TimeWindow [RFC 8006] MI.ProtocolACL [RFC 8006] MI.ProtocolRule [RFC 8006] MI.DeliveryAuthorization [RFC 8006] MI.Cache [RFC 8006] MI.Auth [RFC 8006] MI.Grouping [RFC 8006] FCI.RedirectTarget [RFC 8804] MI.FallbackTarget [RFC 8804] MI.UriSigning [RFC 9246] MI.ACMEDelegationMethod [RFC 9538] MI.DelegatedCredentials [RFC 9677] FCI.DelegatedCredentials [RFC 9677] FCI.Telemetry [RFC 9808] FCI.CapacityLimits [RFC 9808] CDNI CI/T Trigger Types Registration Procedure(s) RFC Required Reference [RFC 8007] Available Formats [IMG] CSV JSON String Description Reference preposition A request for the dCDN to acquire metadata or content. [RFC 8007] A request for the dCDN to invalidate metadata or content. After servicing this request the dCDN will not use the specified data invalidate without first re-validating it using, for example, an "If-None-Match" HTTP request. The dCDN need not erase the associated [RFC 8007] data. purge A request for the dCDN to erase metadata or content. After servicing the request, the specified data MUST NOT be held on the [RFC 8007] dCDN (the dCDN should re-acquire the metadata or content from uCDN if it needs it). CDNI CI/T Error Codes Registration Procedure(s) Specification Required Expert(s) Kevin Ma, Sanjay Mishra Reference [RFC 8007] Available Formats [IMG] CSV Error Code Description Reference emeta The dCDN was unable to acquire metadata required to fulfil the request. [RFC 8007] econtent The dCDN was unable to acquire content (CT/T preposition commands only). [RFC 8007] eperm The uCDN does not have permission to issue the CI/T Command (for example, the data is owned by another CDN). [RFC 8007] ereject The dCDN is not willing to fulfil the CI/T Command (for example, a preposition request for content at a time when the dCDN [RFC 8007] would not accept Request Routing requests from the uCDN). ecdn An internal error in the dCDN or one of its downstream CDNs. [RFC 8007] ecancelled The uCDN cancelled the request. [RFC 8007] eunsupported The Trigger Specification contained a "type" that is not supported by the dCDN. No action was taken by the dCDN other than to [RFC 8007] create a Trigger Status Resource in state "failed". CDNI Capabilities Redirection Modes Registration Procedure(s) IETF Review Reference [RFC 8008] Available Formats [IMG] CSV Redirection Mode Description Reference DNS-I Iterative DNS-based Redirection [RFC 8008] DNS-R Recursive DNS-based Redirection [RFC 8008] HTTP-I Iterative HTTP-based Redirection [RFC 8008] HTTP-R Recursive HTTP-based Redirection [RFC 8008] CDNI Logging Directive Names Registration Procedure(s) Specification Required Expert(s) Kevin Ma Reference [RFC 7937] Note Directive names are to be allocated with a format of NAMEFORMAT (see [Section 3.1 of RFC 7937]). All directive names defined in the logging file are case-insensitive as per the basic ABNF ([RFC 5234]). Each specification that defines a new CDNI Logging directive needs to contain a description for the new directive with the same set of information as provided in [Section 3.3 of RFC 7937] (i.e., format, directive value and occurrence). Available Formats [IMG] CSV Directive Name Reference version [RFC 7937] UUID [RFC 7937] claimed-origin [RFC 7937] established-origin [RFC 7937] remark [RFC 7937] record-type [RFC 7937] fields [RFC 7937] SHA256-hash [RFC 7937] CDNI Logging File Version Registration Procedure(s) Specification Required Expert(s) Kevin Ma Reference [RFC 7937] Note Version values are to be allocated with a format of NAMEFORMAT (see [Section 3.1 of RFC 7937]). All version values defined in the logging file are case-insensitive as per the basic ABNF ([RFC 5234]). Available Formats [IMG] CSV version Description Reference cdni/1.0 CDNI Logging File version 1.0 as specified in [RFC 7937] [RFC 7937] CDNI Logging Record-Types Registration Procedure(s) Specification Required Expert(s) Kevin Ma Reference [RFC 7937] Note Record-types are to be allocated with a format of NAMEFORMAT (see [Section 3.1 of RFC 7937]). All record-types defined in the logging file are case-insensitive as per the basic ABNF ([RFC 5234]). Each specification that defines a new record-type needs to contain a description for the new record-type with the same set of information as provided in [Section 3.4.1 of RFC 7937]. This includes: o a list of all the CDNI Logging fields that can appear in a CDNI Logging Record of the new record-type o for all these fields: a specification of the occurrence for each Field in the new record-type o for every newly defined Field, i.e., for every Field that results in a registration in the CDNI Logging Field Names Registry: a specification of the field name, format and field value. Available Formats [IMG] CSV record-types Description Reference cdni_http_request_v1 CDNI Logging Record version 1 for content delivery using HTTP [RFC 7937] cdni_http_request_v2 Extension to CDNI Logging Record version 1 for content delivery using HTTP, to include URI Signing Logging fields [RFC 9246] CDNI Logging Field Names Registration Procedure(s) Specification Required Expert(s) Kevin Ma Reference [RFC 7937] Note Field names are to be allocated with a format of NHTABSTRING (see [Section 3.1 of RFC 7937]). All field names defined in the logging file are case-insensitive as per the basic ABNF ([RFC 5234]). Available Formats [IMG] CSV Field Name Reference date [RFC 7937] time [RFC 7937] time-taken [RFC 7937] c-groupid [RFC 7937] s-ip [RFC 7937] s-hostname [RFC 7937] s-port [RFC 7937] cs-method [RFC 7937] cs-uri [RFC 7937] u-uri [RFC 7937] protocol [RFC 7937] sc-status [RFC 7937] sc-total-bytes [RFC 7937] sc-entity-bytes [RFC 7937] cs(insert_HTTP_header_name_here) [RFC 7937] sc(insert_HTTP_header_name_here) [RFC 7937] s-ccid [RFC 7937] s-sid [RFC 7937] s-cached [RFC 7937] s-uri-signing [RFC 9246] s-uri-signing-deny-reason [RFC 9246] CDNI RI Error Response Code Registration Procedure(s) Specification Required Expert(s) Kevin Ma, Sanjay Mishra Reference [RFC 7975] Available Formats [IMG] CSV Code Reason Description Reference 100 (see Description) Generic informational error-code meant for carrying a human-readable string [RFC 7975] Generic error-code for uCDN errors where the dCDN cannot or will not process the request due to 400 (see Description) something that is perceived to be a uCDN error. The reason field may be used to provide more [RFC 7975] details about the source of the error. Generic error-code for dCDN errors where the dCDN is aware that it has erred or is incapable of 500 (see Description) satisfying the RI request for some reason. The reason field may be used to provide more details [RFC 7975] about the source of the error. 501 Unable to retrieve metadata The dCDN is unable to retrieve the metadata associated with the content requested by the UA. This [RFC 7975] may indicate a configuration error or that the content requested by the UA does not exist. 502 Loop detected The dCDN detected a redirection loop (see [Section 4.8 of RFC 7975]). [RFC 7975] 503 Maximum hops exceeded The dCDN detected the maximum number of redirection hops exceeding max-hops (see [Section 4.8 of [RFC 7975] RFC 7975]). 504 Out of capacity The dCDN does not currently have sufficient capacity to handle the UA request. [RFC 7975] 505 Delivery protocol not supported The dCDN does not support the (set of) delivery protocols indicated in the CDNI Metadata of the [RFC 7975] content requested by the UA. The dCDN does not support the requested redirection protocol. This error-code is also used when the 506 Redirection protocol not supported RI request has the dns-only flag set to True and the dCDN is not supported or is not prepared to [RFC 7975] return an RT of a surrogate directly. CDNI Metadata Footprint Types Registration Procedure(s) Specification Required Expert(s) Kevin Ma Reference [RFC 8006] Available Formats [IMG] CSV Footprint Type Description Reference ipv4cidr IPv4 CIDR address block [RFC 8006] ipv6cidr IPv6 CIDR address block [RFC 8006] asn Autonomous System Number (ASN) [RFC 8006] countrycode ISO 3166-1 alpha-2 code [RFC 8006] altopid A list of PID names [RFC 9241, Section 4] subdivisioncode ISO 3166-2 country subdivision code: alpha-2 country code, followed by a hyphen-minus and up to 3 characters [RFC 9388] from A-Z;0-9 as a code within the country footprintunion A combination of other footprint objects [RFC 9388] CDNI Metadata Protocol Types Registration Procedure(s) Specification Required Expert(s) Kevin Ma Reference [RFC 8006] Available Formats [IMG] CSV Protocol Type Description Type Specification Protocol Specification http/1.1 Hypertext Transfer Protocol -- HTTP/1.1 [RFC 8006] [RFC 7230] https/1.1 HTTP/1.1 over TLS [RFC 8006] [RFC 7230]; [RFC 2818] CDNI URI Signing Verification Codes Registration Procedure(s) Specification Required Expert(s) Phil Sorber Reference [RFC 9246] Available Formats [IMG] CSV Value Description Reference 000 No signed JWT verification performed [RFC 9246] 200 Signed JWT verification performed and verified [RFC 9246] 400 Signed JWT verification performed and rejected because of incorrect signature [RFC 9246] 401 Signed JWT verification performed and rejected because of Issuer enforcement [RFC 9246] 402 Signed JWT verification performed and rejected because of Subject enforcement [RFC 9246] 403 Signed JWT verification performed and rejected because of Audience enforcement [RFC 9246] 404 Signed JWT verification performed and rejected because of Expiration Time enforcement [RFC 9246] 405 Signed JWT verification performed and rejected because of Not Before enforcement [RFC 9246] 406 Signed JWT verification performed and rejected because only one of CDNI Signed Token Transport or CDNI Expiration Time Setting [RFC 9246] present 407 Signed JWT verification performed and rejected because of JWT ID enforcement [RFC 9246] 408 Signed JWT verification performed and rejected because of Version enforcement [RFC 9246] 409 Signed JWT verification performed and rejected because of Critical Extension enforcement [RFC 9246] 410 Signed JWT verification performed and rejected because of Client IP enforcement [RFC 9246] 411 Signed JWT verification performed and rejected because of URI Container enforcement [RFC 9246] 500 Unable to perform signed JWT verification because of malformed URI [RFC 9246] CDNI URI Signing Signed Token Transport Registration Procedure(s) Specification Required Expert(s) Phil Sorber Reference [RFC 9246] Available Formats [IMG] CSV Value Description Reference 0 Designates token transport is not enabled [RFC 9246] 1 Designates token transport via cookie [RFC 9246] 2 Designates token transport via query string [RFC 9246] CDNI Telemetry Source Types Registration Procedure(s) Specification Required Expert(s) Ben Rosenblum, Sanjay Mishra Reference [RFC 9808] Available Formats [IMG] CSV Source Type Description Reference generic An object that allows for advertisement of generic data sources [RFC 9808] CDNI Capacity Limit Types Registration Procedure(s) Specification Required Expert(s) Ben Rosenblum, Sanjay Mishra Reference [RFC 9808] Available Formats [IMG] CSV Capacity Limit Type Units Reference egress Bits per second [RFC 9808] requests Requests per second [RFC 9808] storage-size Total bytes [RFC 9808] storage-objects Count [RFC 9808] sessions Count [RFC 9808] cache-size Total bytes [RFC 9808] Licensing Terms