Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About Bundle Protocol Created 2011-03-24 Last Updated 2026-09-15 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • Bundle Block Types • Primary Bundle Protocol Version • Bundle Processing Control Flags • Block Processing Control Flags • Bundle Status Report Flags • Bundle Status Report Reason Codes • Bundle Custody Signal Reason Codes • Bundle Metadata Type Codes • Ciphersuite Numbers • Ciphersuite Flags • Ciphersuite Parameters and Results Type Registry • Bundle Administrative Record Types • CBHE Node Numbers • CBHE Service Numbers • Bundle Protocol TCP Convergence-Layer Version Numbers • Bundle Protocol TCP Convergence-Layer Message Types • Bundle Protocol TCP Convergence-Layer REFUSE_BUNDLE Reason Codes • Bundle Protocol TCP Convergence-Layer SHUTDOWN Reason Codes • Bundle Protocol TCP Convergence-Layer Version 4 Session Extension Types • Bundle Protocol TCP Convergence-Layer Version 4 Transfer Extension Types • Bundle Protocol TCP Convergence-Layer Version 4 Message Types • Bundle Protocol TCP Convergence-Layer Version 4 XFER_REFUSE Reason Codes • Bundle Protocol TCP Convergence-Layer Version 4 SESS_TERM Reason Codes • Bundle Protocol TCP Convergence-Layer Version 4 MSG_REJECT Reason Codes • Bundle Protocol URI Scheme Types • BPSec Security Context Identifiers • BPSec BIB-HMAC-SHA2 Integrity Scope Flags • BPSec BCB-AES-GCM AAD Scope Flags Bundle Block Types Registration Procedure(s) Specification Required Expert(s) Scott Burleigh, Fred Templin Reference [RFC 6255][RFC 9171] Available Formats [IMG] CSV Bundle Protocol Version Value Description Reference none 0 Reserved [RFC 6255] 6,7 1 Bundle Payload Block [RFC 5050]; [RFC 9171] 6 2 Bundle Authentication Block [RFC 6257] 6 3 Payload Integrity Block [RFC 6257] 6 4 Payload Confidentiality Block [RFC 6257] 6 5 Previous-Hop Insertion Block [RFC 6259] 7 6 Previous node (proximate sender) [RFC 9171] 7 7 Bundle age (in milliseconds) [RFC 9171] 6 8 Metadata Extension Block [RFC 6258] 6 9 Extension Security Block [RFC 6257] 7 10 Hop count (#prior xmit attempts) [RFC 9171] 7 11 Block Integrity [RFC 9172] 7 12 Block Confidentiality [RFC 9172] 7 13 Custody Transfer Extension Block [CCSDS 734.6-O-1] 7 14 Compressed Status Reporting Extension Block [CCSDS 734.6-O-1] 7 15 Quality of Service Extension Block [CCSDS 734.4-O-1] 7 16-191 Unassigned 6,7 192-255 Reserved for Private and/or Experimental Use [RFC 5050]; [RFC 9171] Primary Bundle Protocol Version Registration Procedure(s) RFC Required Reference [RFC 6255] Available Formats [IMG] CSV Value Description Reference 0-5 Reserved [RFC 6255] 6 Assigned [RFC 5050] 7 Assigned [RFC 9171] 8-255 Unassigned Bundle Processing Control Flags Registration Procedure(s) Specification Required Expert(s) Scott Burleigh, Fred Templin Reference [RFC 6255][RFC 9171] Available Formats [IMG] CSV Bundle Protocol Version Bit Position (right to left) Description Reference 6,7 0 Bundle is a fragment [RFC 5050]; [RFC 9171] 6,7 1 ADU is an administrative record [RFC 5050]; [RFC 9171] 6,7 2 Bundle must not be fragmented [RFC 5050]; [RFC 9171] 6 3 Custody transfer is requested [RFC 5050] 6 4 Destination endpoint is a singleton [RFC 5050] 6,7 5 Acknowledgement by application is requested [RFC 5050]; [RFC 9171] 7 6 Status time requested in reports [RFC 9171] 6 7-8 Class of service: priority [RFC 5050] 6 9-13 Class of service: reserved [RFC 5050] 6,7 14 Request reporting of bundle reception [RFC 5050]; [RFC 9171] 6 15 Request reporting of custody acceptance [RFC 5050] 6,7 16 Request reporting of bundle forwarding [RFC 5050]; [RFC 9171] 6,7 17 Request reporting of bundle delivery [RFC 5050]; [RFC 9171] 6,7 18 Request reporting of bundle deletion [RFC 5050]; [RFC 9171] 6,7 19 Reserved [RFC 5050]; [RFC 9171] 6,7 20 Reserved [RFC 5050]; [RFC 9171] 21-63 Unassigned Block Processing Control Flags Registration Procedure(s) Specification Required Expert(s) Scott Burleigh, Fred Templin Reference [RFC 6255][RFC 9171] Available Formats [IMG] CSV Bundle Protocol Version Bit Position (right to left) Description Reference 6,7 0 Block must be replicated in every fragment [RFC 5050]; [RFC 9171] 6,7 1 Transmit status report if block can't be processed [RFC 5050]; [RFC 9171] 6,7 2 Delete bundle if block can't be processed [RFC 5050]; [RFC 9171] 6 3 Last block [RFC 5050] 6,7 4 Discard block if it can't be processed [RFC 5050]; [RFC 9171] 6 5 Block was forwarded without being processed [RFC 5050] 6 6 Block contains an EID-reference field [RFC 5050] 7-63 Unassigned Bundle Status Report Flags Registration Procedure(s) RFC Required Reference [RFC 6255] Available Formats [IMG] CSV Value Description Reference 00000000 Reserved [RFC 6255] 00000001 Reporting node received bundle [RFC 5050] 00000010 Reporting node accepted custody of bundle [RFC 5050] 00000100 Reporting node forwarded the bundle [RFC 5050] 00001000 Reporting node delivered the bundle [RFC 5050] 00010000 Reporting node deleted the bundle [RFC 5050] 00100000 Unassigned 01000000 Unassigned 10000000 Unassigned Bundle Status Report Reason Codes Registration Procedure(s) Specification Required Expert(s) Scott Burleigh, Fred Templin Reference [RFC 6255][RFC 9171] Available Formats [IMG] CSV Bundle Protocol Version Value Description Reference 6,7 0 No additional information [RFC 5050]; [RFC 9171] 6,7 1 Lifetime expired [RFC 5050]; [RFC 9171] 6,7 2 Forwarded over unidirectional link [RFC 5050]; [RFC 9171] 6,7 3 Transmission canceled [RFC 5050]; [RFC 9171] 6,7 4 Depleted storage [RFC 5050]; [RFC 9171] 6,7 5 Destination endpoint ID unavailable [RFC 5050]; [RFC 9171] 6,7 6 No known route to destination from here [RFC 5050]; [RFC 9171] 6,7 7 No timely contact with next node on route [RFC 5050]; [RFC 9171] 6,7 8 Block unintelligible [RFC 5050]; [RFC 9171] 7 9 Hop limit exceeded [RFC 9171] 7 10 Traffic pared [RFC 9171] 7 11 Block unsupported [RFC 9171] 7 12 Missing security operation [RFC 9172] 7 13 Unknown security operation [RFC 9172] 7 14 Unexpected security operation [RFC 9172] 7 15 Failed security operation [RFC 9172] 7 16 Conflicting security operation [RFC 9172] 17-254 Unassigned 6,7 255 Reserved [RFC 6255]; [RFC 9171] Bundle Custody Signal Reason Codes Registration Procedure(s) Specification Required Expert(s) Scott Burleigh, Fred Templin Reference [RFC 6255] Available Formats [IMG] CSV Value Description Reference 0 No additional information [RFC 5050] 1-2 Unassigned 3 Redundant reception (reception by a node that is a custodial node for this bundle) [RFC 5050] 4 Depleted storage [RFC 5050] 5 Destination endpoint ID unintelligible [RFC 5050] 6 No known route to destination from here [RFC 5050] 7 No timely contact with next node on route [RFC 5050] 8 Block unintelligible [RFC 5050] 9-126 Unassigned 127 Reserved [RFC 6255] Bundle Metadata Type Codes Registration Procedure(s) Specification Required Expert(s) Rick Taylor Reference [RFC 6258] Available Formats [IMG] CSV Value Description Reference 0 Reserved [RFC 6258] 1 URI [RFC 6258] 2-191 Unassigned 192-255 Private and/or Experimental Use [RFC 6258] Ciphersuite Numbers Registration Procedure(s) Specification Required Expert(s) Stephen Farrell, Edward Birrane Reference [RFC 6257] Available Formats [IMG] CSV Value Description Reference 0 Unassigned 1 BAB-HMAC [RFC 6257] 2 PIB-RSA-SHA256 [RFC 6257] 3 PCB-RSA-AES128-PAYLOAD-PIB-PCB [RFC 6257] 4 ESB-RSA-AES128-EXT [RFC 6257] values greater than 4 Reserved [RFC 6257] Ciphersuite Flags Registration Procedure(s) Specification Required Expert(s) Stephen Farrell, Edward Birrane Reference [RFC 6257] Available Formats [IMG] CSV Bit Position (right to left) Description Reference 0 Block contains results [RFC 6257] 1 Block contains correlator [RFC 6257] 2 Block contains parameters [RFC 6257] 3 Destination EIDref present [RFC 6257] 4 Source EIDref present [RFC 6257] values greater than 4 Reserved [RFC 6257] Ciphersuite Parameters and Results Type Registry Registration Procedure(s) Specification Required Expert(s) Stephen Farrell, Edward Birrane Reference [RFC 6257] Available Formats [IMG] CSV Value Description Reference 0 Reserved [RFC 6257] 1 initialization vector (IV) [RFC 6257] 2 reserved [RFC 6257] 3 key-information [RFC 6257] 4 fragment-range (pair of SDNVs) [RFC 6257] 5 integrity signature [RFC 6257] 6 unassigned 7 salt [RFC 6257] 8 PCB integrity check value (ICV) [RFC 6257] 9 reserved [RFC 6257] 10 encapsulated block [RFC 6257] 11 block type of encapsulated block [RFC 6257] 12-191 reserved [RFC 6257] 192-250 private use [RFC 6257] 251-255 reserved [RFC 6257] Bundle Administrative Record Types Registration Procedure(s) Specification Required Expert(s) Marc Blanchet, Keith Scott Reference [RFC 7116][RFC 9713] Available Formats [IMG] CSV Bundle Protocol Version Value Description Reference 6,7 0 Reserved [RFC 7116]; [RFC 9713] 6,7 1 Bundle status report [RFC 5050]; [RFC 9171] 6 2 Custody signal [RFC 5050] 3 Unassigned 6 4 Aggregate Custody Signal [CCSDS-BP] 5-12 Unassigned 7 13 Compressed Custody Signal [CCSDS-734.6-O-1] 7 14 Compressed Reporting Signal [CCSDS-734.6-O-1] 15 Unassigned 7 16-254 Unassigned 7 255 ACME Node ID Validation [RFC 9891] 7 256-64383 Unassigned 7 64384-64511 Reserved for Experimental Use [RFC 9713] 7 64512-65535 Reserved for Private Use [RFC 9713] CBHE Node Numbers Reference [RFC 7116][RFC 9758] Note Renamed "'ipn' Scheme URI Default Allocator Node Numbers" and moved to [Uniform Resource Identifier (URI) Schemes] per [RFC 9758]. CBHE Service Numbers Expert(s) Marc Blanchet, Keith Scott Reference [RFC 7116] Available Formats [IMG] CSV Range Registration Procedures 0-63 Specification Required 1024-65535 Specification Required Value Description Reference 0 Bundle Protocol Administrative Record [RFC 6260] 1 CCSDS File Delivery Service [CCSDS 727.0-B-4] 2 Reserved [RFC 7116] 3-63 Unassigned 64-1023 Allocated to the Space Assigned Numbers Authority (SANA) for use by Consultative Committee for Space Data Systems (CCSDS) [RFC 7116] missions. 1024-65535 Unassigned >=65535 Reserved for Private or Experimental Use [RFC 7116] Bundle Protocol TCP Convergence-Layer Version Numbers Registration Procedure(s) RFC Required Reference [RFC 7242] Available Formats [IMG] CSV Value Description Reference 0 Reserved [RFC 7242] 1 Reserved [RFC 7242] 2 Reserved [RFC 7242] 3 TCPCL [RFC 7242] 4 TCPCLv4 [RFC 9174] 5-255 Unassigned Bundle Protocol TCP Convergence-Layer Message Types Registration Procedure(s) RFC Required Reference [RFC 7242] Available Formats [IMG] CSV Type Code Description Reference 0x0 Reserved [RFC 7242] DATA_SEGMENT 0x1 Indicates the transmission of a segment of bundle data, as described in Section 5.2. [RFC 7242] ACK_SEGMENT 0x2 Acknowledges reception of a data segment, as described in Section 5.3. [RFC 7242] REFUSE_BUNDLE 0x3 Indicates that the transmission of the current bundle shall be stopped, as described in Section 5.4. [RFC 7242] KEEPALIVE 0x4 KEEPALIVE message for the connection, as described in Section 5.6. [RFC 7242] SHUTDOWN 0x5 Indicates that one of the nodes participating in the connection wishes to cleanly terminate the connection, as [RFC 7242] described in Section 6. LENGTH 0x6 Contains the length (in bytes) of the next bundle, as described in Section 5.5. [RFC 7242] 0x7-0xf Unassigned Bundle Protocol TCP Convergence-Layer REFUSE_BUNDLE Reason Codes Registration Procedure(s) RFC Required Reference [RFC 7242] Available Formats [IMG] CSV RCode Semantics Reference 0x0 Reason for refusal is unknown or not specified. [RFC 7242] 0x1 The receiver now has the complete bundle. The sender may now consider the bundle as completely received. [RFC 7242] 0x2 The receiver's resources are exhausted. The sender SHOULD apply reactive bundle fragmentation before retrying. [RFC 7242] 0x3 The receiver has encountered a problem that requires the bundle to be retransmitted in its entirety. [RFC 7242] 0x4-0x7 Unassigned 0x8-0xf Reserved for future usage. [RFC 7242] Bundle Protocol TCP Convergence-Layer SHUTDOWN Reason Codes Registration Procedure(s) RFC Required Reference [RFC 7242] Available Formats [IMG] CSV Code Meaning Description Reference 0x00 Idle timeout The connection is being closed due to idleness. [RFC 7242] 0x01 Version mismatch The node cannot conform to the specified TCPCL protocol version. [RFC 7242] 0x02 Busy The node is too busy to handle the current connection. [RFC 7242] 0x03-0xff Unassigned Bundle Protocol TCP Convergence-Layer Version 4 Session Extension Types Registration Procedure(s) Expert Review Expert(s) Brian Sipos, Rick Taylor Reference [RFC 9174] Available Formats [IMG] CSV Code Session Extension Type Reference 0x0000 Reserved [RFC 9174] 0x0001-0x7FFF Unassigned 0x8000-0xFFFF Reserved for Private or Experimental Use [RFC 9174] Bundle Protocol TCP Convergence-Layer Version 4 Transfer Extension Types Registration Procedure(s) Expert Review Expert(s) Brian Sipos, Rick Taylor Reference [RFC 9174] Available Formats [IMG] CSV Code Transfer Extension Type Reference 0x0000 Reserved [RFC 9174] 0x0001 Transfer Length Extension [RFC 9174] 0x0002-0x7FFF Unassigned 0x8000-0xFFFF Reserved for Private or Experimental Use [RFC 9174] Bundle Protocol TCP Convergence-Layer Version 4 Message Types Registration Procedure(s) RFC Required Reference [RFC 9174] Available Formats [IMG] CSV Code Message Type Reference 0x00 Reserved [RFC 9174] 0x01 XFER_SEGMENT [RFC 9174] 0x02 XFER_ACK [RFC 9174] 0x03 XFER_REFUSE [RFC 9174] 0x04 KEEPALIVE [RFC 9174] 0x05 SESS_TERM [RFC 9174] 0x06 MSG_REJECT [RFC 9174] 0x07 SESS_INIT [RFC 9174] 0x08-0xEF Unassigned 0xF0-0xFF Reserved for Private or Experimental Use [RFC 9174] Bundle Protocol TCP Convergence-Layer Version 4 XFER_REFUSE Reason Codes Registration Procedure(s) Specification Required Expert(s) Brian Sipos, Rick Taylor Reference [RFC 9174] Available Formats [IMG] CSV Code Refusal Reason Reference 0x00 Unknown [RFC 9174] 0x01 Completed [RFC 9174] 0x02 No Resources [RFC 9174] 0x03 Retransmit [RFC 9174] 0x04 Not Acceptable [RFC 9174] 0x05 Extension Failure [RFC 9174] 0x06 Session Terminating [RFC 9174] 0x07-0xEF Unassigned 0xF0-0xFF Reserved for Private or Experimental Use [RFC 9174] Bundle Protocol TCP Convergence-Layer Version 4 SESS_TERM Reason Codes Registration Procedure(s) Specification Required Expert(s) Brian Sipos, Rick Taylor Reference [RFC 9174] Available Formats [IMG] CSV Code Termination Reason Reference 0x00 Unknown [RFC 9174] 0x01 Idle timeout [RFC 9174] 0x02 Version mismatch [RFC 9174] 0x03 Busy [RFC 9174] 0x04 Contact Failure [RFC 9174] 0x05 Resource Exhaustion [RFC 9174] 0x06-0xEF Unassigned 0xF0-0xFF Reserved for Private or Experimental Use [RFC 9174] Bundle Protocol TCP Convergence-Layer Version 4 MSG_REJECT Reason Codes Registration Procedure(s) Specification Required Expert(s) Brian Sipos, Rick Taylor Reference [RFC 9174] Available Formats [IMG] CSV Code Rejection Reason Reference 0x00 Reserved [RFC 9174] 0x01 Message Type Unknown [RFC 9174] 0x02 Message Unsupported [RFC 9174] 0x03 Message Unexpected [RFC 9174] 0x04-0xEF Unassigned 0xF0-0xFF Reserved for Private or Experimental Use [RFC 9174] Bundle Protocol URI Scheme Types Registration Procedure(s) Standards Action Reference [RFC 9171] Available Formats [IMG] CSV Value Description BP Utilization Reference URI Definition Reference 0 Reserved n/a 1 dtn [RFC 9171] [RFC 9171] 2 ipn [RFC 9171] [RFC 6260]; [RFC 9171] 3-254 Unassigned n/a 255-65535 Reserved n/a >65535 Reserved for Private Use n/a BPSec Security Context Identifiers Registration Procedure(s) Specification Required Expert(s) Ken McKeever, Edward Birrane Reference [RFC 9172] Available Formats [IMG] CSV Value Description Reference -32768 to -1 Reserved [RFC 9172] 0 Reserved [RFC 9172] 1 BIB-HMAC-SHA2 [RFC 9173] 2 BCB-AES-GCM [RFC 9173] 3 COSE (TEMPORARY - registered 2024-11-12, publication requested 2026-08-24) [draft-ietf-dtn-bpsec-cose-09] 4-32767 Unassigned BPSec BIB-HMAC-SHA2 Integrity Scope Flags Registration Procedure(s) Specification Required Expert(s) Ken McKeever, Edward Birrane Reference [RFC 9173] Available Formats [IMG] CSV Bit Position (right to left) Description Reference 0 Include primary block flag [RFC 9173] 1 Include target header flag [RFC 9173] 2 Include security header flag [RFC 9173] 3-7 Reserved [RFC 9173] 8-15 Unassigned BPSec BCB-AES-GCM AAD Scope Flags Registration Procedure(s) Specification Required Expert(s) Ken McKeever, Edward Birrane Reference [RFC 9173] Available Formats [IMG] CSV Bit Position (right to left) Description Reference 0 Include primary block flag [RFC 9173] 1 Include target header flag [RFC 9173] 2 Include security header flag [RFC 9173] 3-7 Reserved [RFC 9173] 8-15 Unassigned Licensing Terms