Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About BGP Monitoring Protocol (BMP) Parameters Created 2016-04-14 Last Updated 2026-05-22 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • BMP Message Types • BMP Peer Types • BMP Peer Flags for Peer Types 0 through 2 • BMP Peer Flags for Loc-RIB Instance Peer Type 3 • BMP Statistics Types • BMP Initiation Information TLVs • BMP Termination Message TLVs • BMP Termination Message Reason Codes • BMP Peer Down Reason Codes • BMP Route Mirroring TLVs • BMP Route Mirroring Information Codes • BMP Peer Up Message TLVs BMP Message Types Expert(s) John G. Scudder, Rex Fernando (rex), Paolo Lucente Reference [RFC 7854] Available Formats [IMG] CSV Range Registration Procedures 0-127 Standards Action 128-250 Specification Required 251-254 Experimental Use Type Description Reference 0 Route Monitoring [RFC 7854] 1 Statistics Report [RFC 7854] 2 Peer Down Notification [RFC 7854] 3 Peer Up Notification [RFC 7854] 4 Initiation [RFC 7854] 5 Termination [RFC 7854] 6 Route Mirroring [RFC 7854] 7-250 Unassigned 251-254 Experimental [RFC 7854] 255 Reserved [RFC 7854] BMP Peer Types Expert(s) John G. Scudder, Rex Fernando (rex), Paolo Lucente Reference [RFC 7854] Available Formats [IMG] CSV Range Registration Procedures 0-127 Standards Action 128-250 Specification Required 251-254 Experimental Use Peer Type Description Reference 0 Global Instance Peer [RFC 7854] 1 RD Instance Peer [RFC 7854] 2 Local Instance Peer [RFC 7854] 3 Loc-RIB Instance Peer [RFC 9069] 4-250 Unassigned 251-254 Experimental [RFC 7854] 255 Reserved [RFC 7854] BMP Peer Flags for Peer Types 0 through 2 Registration Procedure(s) Standards Action Reference [RFC 7854][RFC 9069] Available Formats [IMG] CSV Flag Description Reference 0 V flag [RFC 7854] 1 L flag [RFC 7854]; [RFC Errata 7703] 2 A flag [RFC 7854] 3 O flag [RFC 8671] 4 F flag (DEPRECATED) [RFC 9069] 5-7 Unassigned BMP Peer Flags for Loc-RIB Instance Peer Type 3 Registration Procedure(s) Standards Action Reference [RFC 9069] Available Formats [IMG] CSV Flag Description Reference 0 F flag [RFC 9069] 1-7 Unassigned BMP Statistics Types Reference [RFC 7854][RFC 9515] Available Formats [IMG] CSV Range Registration Procedures 0-32767 Standards Action 32768-65530 First Come First Served 65531-65534 Experimental Use Stat Type Description Reference 0 Number of prefixes rejected by inbound policy [RFC 7854] 1 Number of (known) duplicate prefix advertisements [RFC 7854] 2 Number of (known) duplicate withdraws [RFC 7854] 3 Number of updates invalidated due to CLUSTER_LIST loop [RFC 7854] 4 Number of updates invalidated due to AS_PATH loop [RFC 7854] 5 Number of updates invalidated due to ORIGINATOR_ID [RFC 7854] 6 Number of updates invalidated due to a loop found in AS_CONFED_SEQUENCE or AS_CONFED_SET [RFC 7854] 7 Number of routes in Adj-RIBs-In [RFC 7854] 8 Number of routes in Loc-RIB [RFC 7854] 9 Number of routes in per-AFI/SAFI Adj-RIB-In [RFC 7854] 10 Number of routes in per-AFI/SAFI Loc-RIB [RFC 7854] 11 Number of updates subjected to treat-as-withdraw [RFC 7854] 12 Number of prefixes subjected to treat-as-withdraw [RFC 7854] 13 Number of duplicate update messages received [RFC 7854] 14 Number of routes in pre-policy Adj-RIB-Out [RFC 8671] 15 Number of routes in post-policy Adj-RIB-Outy [RFC 8671] 16 Number of routes in per-AFI/SAFI pre-policy Adj-RIB-Out [RFC 8671] 17 Number of routes in per-AFI/SAFI post-policy Adj-RIB-Out [RFC 8671] 18 Number of routes currently in the pre-policy Adj-RIB-In. [RFC 9972] 19 Number of routes currently in the per-AFI/SAFI pre-policy Adj-RIB-In. [RFC 9972] 20 Number of routes currently in the post-policy Adj-RIB-In. [RFC 9972] 21 Number of routes currently in the per-AFI/SAFI post-policy Adj-RIB-In. [RFC 9972] 22 Number of routes currently in the per-AFI/SAFI pre-policy Adj-RIB-In rejected by an inbound policy. [RFC 9972] 23 Number of routes currently in the per-AFI/SAFI post-policy Adj-RIB-In accepted by an inbound [RFC 9972] policy. 24 Number of routes currently in per-AFI/SAFI selected as primary route. (TEMPORARY - registered [draft-ietf-grow-bmp-bgp-rib-stats-16] 2024-10-18, extension registered 2025-09-23, expires 2026-10-18) 25 Number of routes currently in per-AFI/SAFI selected as a backup route. (TEMPORARY - registered [draft-ietf-grow-bmp-bgp-rib-stats-16] 2024-10-18, extension registered 2025-09-23, expires 2026-10-18) 26 Number of routes currently in the per-AFI/SAFI post-policy Adj-RIB-In or Loc-RIB suppressed by a [RFC 9972] configured route-damping policy. 27 Number of routes currently in the per-AFI/SAFI post-policy Adj-RIB-In or Loc-RIB marked as stale by [RFC 9972] GR events. 28 Number of routes currently in the per-AFI/SAFI post-policy Adj-RIB-In or Loc-RIB marked as stale by [RFC 9972] LLGR. 29 Number of routes currently in the post-policy Adj-RIB-In left before exceeding the received-route [RFC 9972] threshold. 30 Number of routes currently in the per-AFI/SAFI post-policy Adj-RIB-In left before exceeding the [RFC 9972] received-route threshold. 31 Number of routes currently in the post-policy Adj-RIB-In or Loc-RIB left before exceeding a [RFC 9972] license-customized route threshold. 32 Number of routes currently in the per-AFI/SAFI post-policy Adj-RIB-In or Loc-RIB left before [RFC 9972] exceeding a license-customized route threshold. 33 Number of routes currently in the pre-policy Adj-RIB-In rejected due to exceeding the locally [RFC 9972] configured maximum AS_PATH length. 34 Number of routes currently in the per-AFI/SAFI pre-policy Adj-RIB-In rejected due to exceeding the [RFC 9972] locally configured maximum AS_PATH length. 35 Number of routes currently in the per-AFI/SAFI post-policy Adj-RIB-In invalidated after verifying [RFC 9972] the route origin ASN through the ROA of the RPKI and mismatch of prefix length. 36 Number of routes currently in the per-AFI/SAFI post-policy Adj-RIB-In validated after verifying the [RFC 9972] route origin ASN through the ROA of the RPKI. 37 Number of routes currently in the per-AFI/SAFI post-policy Adj-RIB-In whose RPKI route origin [RFC 9972] validation state is NotFound. 38 Number of routes currently in the per-AFI/SAFI pre-policy Adj-RIB-Out rejected by an outbound [RFC 9972] policy. 39 Number of routes currently in the pre-policy Adj-RIB-Out filtered due to AS_PATH length exceeding [RFC 9972] the locally configured maximum. 40 Number of routes currently in the per-AFI/SAFI pre-policy Adj-RIB-Out filtered due to AS_PATH [RFC 9972] length exceeding the locally configured maximum. 41 Number of routes currently in the per-AFI/SAFI post-policy Adj-RIB-Out invalidated after verifying [RFC 9972] the route origin ASN through the ROA of the RPKI and mismatch of prefix length. 42 Number of routes currently in the per-AFI/SAFI post-policy Adj-RIB-Out validated after verifying [RFC 9972] the route origin ASN through the ROA of the RPKI. 43 Number of routes currently in the per-AFI/SAFI post-policy Adj-RIB-Out whose RPKI route origin [RFC 9972] validation state is NotFound. 44-65530 Unassigned 65531-65534 Experimental [RFC 7854] 65535 Reserved [RFC 7854] BMP Initiation Information TLVs Reference [RFC 7854][RFC 9069][RFC 9515][RFC 9736] Available Formats [IMG] CSV Range Registration Procedures 0-32767 Standards Action 32768-65530 First Come First Served 65531-65534 Experimental Use Type Description Reference 0 String [RFC 9736] 1 sysDescr [RFC 9736] 2 sysName [RFC 9736] 3 Reserved [RFC 9736] 4 Reserved [RFC 9736] 5-65530 Unassigned 65531-65534 Experimental [RFC 7854] 65535 Reserved [RFC 9736] BMP Termination Message TLVs Reference [RFC 7854][RFC 9515] Available Formats [IMG] CSV Range Registration Procedures 0-32767 Standards Action 32768-65530 First Come First Served 65531-65534 Experimental Use Type Description Reference 0 String [RFC 7854] 1 Reason [RFC 7854] 2-65530 Unassigned 65531-65534 Experimental [RFC 7854] 65535 Reserved [RFC 7854] BMP Termination Message Reason Codes Reference [RFC 7854][RFC 9515] Available Formats [IMG] CSV Range Registration Procedures 0-32767 Standards Action 32768-65530 First Come First Served 65531-65534 Experimental Use Type Description Reference 0 Administratively closed [RFC 7854] 1 Unspecified reason [RFC 7854] 2 Out of resources [RFC 7854] 3 Redundant connection [RFC 7854] 4 Permanently administratively closed [RFC 7854] 5-65530 Unassigned 65531-65534 Experimental [RFC 7854] 65535 Reserved [RFC 7854] BMP Peer Down Reason Codes Expert(s) John G. Scudder, Rex Fernando (rex), Paolo Lucente Reference [RFC 7854][RFC Errata 7194] Available Formats [IMG] CSV Range Registration Procedures 0-127 Standards Action 128-250 Specification Required 251-254 Experimental Use Type Description Reference 0 Reserved [RFC 7854] 1 Local system closed, NOTIFICATION PDU follows [RFC 7854] 2 Local system closed, FSM Event follows [RFC 7854] 3 Remote system closed, NOTIFICATION PDU follows [RFC 7854] 4 Remote system closed, no data [RFC 7854] 5 Peer de-configured [RFC 7854] 6 Local system closed, TLV data follows [RFC 9069] 7-250 Unassigned 251-254 Experimental [RFC 7854]; [RFC Errata 7194] 255 Reserved [RFC 7854]; [RFC Errata 7194] BMP Route Mirroring TLVs Reference [RFC 7854][RFC 9515] Available Formats [IMG] CSV Range Registration Procedures 0-32767 Standards Action 32768-65530 First Come First Served 65531-65534 Experimental Use Type Description Reference 0 BGP Message [RFC 7854] 1 Information [RFC 7854] 2-65530 Unassigned 65531-65534 Experimental [RFC 7854] 65535 Reserved [RFC 7854] BMP Route Mirroring Information Codes Reference [RFC 7854][RFC 9515] Available Formats [IMG] CSV Range Registration Procedures 0-32767 Standards Action 32768-65530 First Come First Served 65531-65534 Experimental Use Type Description Reference 0 Errored PDU [RFC 7854] 1 Messages Lost [RFC 7854] 2-65530 Unassigned 65531-65534 Experimental [RFC 7854] 65535 Reserved [RFC 7854] BMP Peer Up Message TLVs Reference [RFC 9736] Available Formats [IMG] CSV Range Registration Procedures 0, 3-32767 Standards Action 32768-65530 First Come First Served 65531-65534 Experimental Use Type Description Reference 0 String [RFC 9736] 1 Reserved [RFC 9736] 2 Reserved [RFC 9736] 3 VRF/Table Name [RFC 9736] 4 Admin Label [RFC 9736] 5-65530 Unassigned 65531-65534 Experimental [RFC 9736] 65535 Reserved [RFC 9736] Licensing Terms